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CHAPTER 1

과정 소개

1.1 서문

1.1.1 배경

2008 년 우리는 특수 용어나 전문 용어 때문에 곤란을 겪는 일 없이 GIS 를 배우고자 하는 사람들을 위해,
무료공개콘텐츠자원인 Gentle Introduction to GIS를시작했습니다. 남아프리카공화국정부의지원으로
시작된 이 프로그램은, 전세계에서 우리에게 어떻게 이를 이용해 대학 교육 과정을 운영하고 있는지, 또
어떻게 GIS 를 독학하고 있는지 등을 전해오면서 대단한 성공을 거두고 있습니다. 이 Gentle Introduction
은 소프트웨어 예제가 아니라 (모든 예시에 QGIS 를 이용하긴 하지만) GIS 를 배우는 사람들을 위한 일반
문서를 지향하고 있습니다. 또 QGIS 응용 프로그램의 기능적 개요를 자세히 설명하는 QGIS 매뉴얼도
있습니다. 그러나 이 문서들은 예제가 아니라 참고 지침 정도의 내용으로 구성돼 있습니다. 우리는 Linfiniti
Consulting 을 통해 많은 교육 과정을 운영해 왔으며, 결국 세 번째 문서가 필요하다는 점을 깨달았습니다.
그리하여 우리는 독자가 QGIS 의 중요한 기능들을 순차적으로 배워나갈 수 있는 강의 형식 문서를 만들게
된 것입니다.

이 교육 교재는 QGIS, PostgreSQL, PostGIS 에 대한 5 일 과정을 운영하는 데 필요한 모든 내용을 담고자
합니다. 이 과정은 초급, 중급, 고급 사용자 모두에게 적합한 내용으로 구성됐으며, 문서 전반에 걸쳐 많은
예제들과 그에 대한 주석 달린 답변들을 갖추고 있습니다.

1.1.2 라이선스

The Free Quantum GIS Training Manual by Linfiniti Consulting CC. is licensed under a Cre-
ative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License. Based on a work at
https://github.com/qgis/QGIS-Training-Manual. Permissions beyond the scope of this license may be
available at https://github.com/qgis/QGIS-Training-Manual/blob/master/index.rst.

우리는 독자가 자유롭게 복사하고, 수정하고, 재배포할 수 있는 자유로운 라이선스 (liberal license) 에 따라
이 QGIS 교육 교재를 발행합니다. 이 문서 마지막 부분에서 전체 라이선스의 내용을 확인할 수 있습니다.
이 문서의 사용 지침을 간단히 말하자면 다음과 같습니다.

• 독자가 스스로 만든 문서인 척하거나, 이 문서에서 저작권 표시나 작성자 목록 등을 삭제해서는 안
됩니다.

• 독자가 제공받은 라이선스보다 더 엄격한 라이선스를 따라 재배포할 수 없습니다.

• 독자가 이 문서에 실질적인 분량 (적어도 완전한 모듈 하나 이상) 을 추가하고 이를 프로젝트에 반영할
경우 이 문서의 (첫 페이지에 표시될) 저자 목록의 마지막에 자신의 이름을 추가할 수 있습니다.

• 독자가 작은 변경이나 수정을 제공할 경우 그 다음 공헌자 목록에 자신의 이름을 추가할 수 있습니다.

• 이 문서 전체를 번역한 경우 “Translated by Joe Bloggs” 형식으로 저자 목록에 자신의 이름을 추가할
수 있습니다.

1
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• 어떤 모듈이나 강의를 후원하고 있다면 후원하는 각 강의 시작 부분에 다음과 같은 형식으로 감사의
말을 삽입하도록 저자에게 요청할 수 있습니다.

주석: 이 강의는 MegaCorp 이 후원했습니다.

• 현재 라이선스 아래 독자가 어떤 일을 할 수 있는지 불확실한 경우, office@linfiniti.com 으로
연락주십시오. 독자가 하려는 일이 라이선스에 부합하는지 알려드리겠습니다.

• 독자가 http:://lulu.com 같은 자가 출판 사이트에 이 문서를 올리는 경우 QGIS 프로젝트에그 수익을
기부하도록 요청합니다.

• 저자들의문서화된허가가없다면이문서를상용화해서는안됩니다. 상용화라는말을정확히하자면,
수익을 위해 이 문서를 판매하거나, 파생 문서 (예를 들어 잡지에 이 문서의 내용을 기사로 판매하는
경우) 를 생성해서도 안 됩니다. 모든 수익을 QGIS 프로젝트에 기부할 경우 이 조항은 적용되지
않습니다. 교육 과정 자체가 상업적이라 하더라도 이 문서를 교재로 사용할 수 있습니다 (이렇게 하는
것을권장합니다). 다시말하자면이문서를교재로사용하는교육과정을운영하여돈을벌수있지만,
문서 자체를 판매해서 돈을 벌 수는 없습니다. 그런 수익은 모두 QGIS 프로젝트에 기부돼야 합니다.

1.1.3 공헌 조항

이 문서는 QGIS 로 할 수 있는 모든 일을 다루는 완벽한 문서가 절대 아닙니다. 우리는 누구에게나 부족한
부분을 채울 새로운 내용을 추가하도록 권장합니다. 또 Linfiniti Consulting CC. 는 추가적인 내용을 상용
서비스로 생성할 수도 있는데, 이 경우에도 생성된 모든 문서를 핵심 콘텐츠에 추가하고 동일한 라이선스에
따라 출판해야 합니다.

1.1.4 저자

• Rüdiger Thiede (rudi@linfiniti.com) - QGIS 교육용 내용 및 PostGIS 내용의 일부를 작성했습니다.

• Tim Sutton (tim@linfiniti.com) - PostgreSQL 및 PostGIS 부분을 공동 작성하고 이 프로젝트를
관리했습니다. 또 이 교재를 위해 특별한 스핑크스 테마 (sphinx theme) 를 작성하기도 했습니다.

• Horst Düster (horst.duester@kappasys.ch) - PostgreSQL 및 PostGIS 부분을 공동 작성했습니다.

• Marcelle Sutton (marcelle@linfiniti.com) - 이 문서를 생성하는 과정에서 교정 및 편집을
담당했습니다.

1.1.5 개인 공헌자

권용찬 (unitave@gmail.com) - 이 교육 교재를 번역했습니다. 장병진 (bjjang@gaia3d.com) - 번역 작업 및
검토를 총괄했습니다.

1.1.6 후원자

• 케이프 페닌슐라 기술 대학교 한국오픈소스 GIS 포럼

1.1.7 데이터

주석: 이교재전반에쓰이는샘플데이터를 http://qgis.org/downloads/data/training_manual_exercise_data.zip
주소에서 다운로드할 수 있습니다.

이 문서에 포함된 샘플 데이터는 무료로 이용할 수 있으며, 출처는 다음과 같습니다.

• OpenStreetMap 의 Streets and Places 데이터셋 (http://www.openstreetmap.org/)

• NGI 의 Property boundaries(도심/교외), water bodies (http://www.ngi.gov.za/)

2 Chapter 1. 과정 소개
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• CGIAR-CGI 의 SRTM DEM (http://srtm.csi.cgiar.org/)

1.1.8 최신 버전

http://readthedocs.org 에서 호스팅해주고 있는 홈페이지 를 방문하면 언제라도 이 문서의 최신 버전을
구할 수 있습니다.

주석: 앞에 언급한 홈페이지의 우하단에 이 문서의 PDF 및 EPUB 버전을 다운로드할 수 있는 링크가
있습니다.

2012 년 5 월, 팀 서튼

1.2 예제 데이터 준비

교육 교재와 함께 제공되는 샘플 데이터는 Swellendam 마을 및 그 주변에 대한 자료입니다. Swellendam 은
남아프리카공화국의웨스턴케이프에있는케이프타운에서동쪽으로 2시간거리에있습니다. 이데이터셋의
피처명은 영어와 아프리칸스어 두 가지로 되어 있습니다.

누구나이데이터셋을어려움없이이용할수있습니다. 그러나사용자자국또는고향의데이터를이용하고자
할 경우, 모듈 3 에서 모듈 7.2 까지의 모든 강의에 사용자의 데이터를 쓸 수 있습니다. 이후 강의에는 좀더
복잡한 데이터 소스를 사용하게 되는데, 사용자의 지역에 따라 이런 데이터가 존재하지 않을 수도 있습니다.

주석: 강의담당자나숙련된 QGIS사용자가강의에로컬샘플데이터를이용하고자할경우이준비과정이
필요합니다. 교육 교재와 함께 기본 데이터셋이 제공되지만, 기본 데이터셋을 로컬 데이터로 대체하고자
한다면 다음 지침을 따라야 합니다.

주석: 이교육교재전반에쓰이는샘플데이터를 http://qgis.org/downloads/data/training_manual_exercise_data.zip
에서 다운로드할 수 있습니다.

1.2.1 Try Yourself

주석: 이 지침은 사용자가 QGIS 를 잘 알고 있다고 가정하며, 강의 교재로 쓰이도록 작성된 것은 아닙니다.

사용자의 강의에 기본 데이터셋 대신 로컬 데이터를 사용하고자 할 경우 QGIS 에 내장된 도구로 간단히
데이터를 준비할 수 있습니다. 이때 사용자가 선택한 지역은 도심과 교외가 균형 있게 분포하며, 서로 다른
종류의 도로와 (자연보호구역 또는 농장 같은) 지역 경계, 그리고 하천 같은 지표수를 포함해야 합니다.

• 새 QGIS 프로젝트 열기

• Vector 드롭다운 메뉴에서 OpenStreetMap -> Download Data 메뉴를 선택합니다. 그 다음 사용자가
원하는 지역의 좌표를 직접 입력하거나 기존 레이어를 이용해서 좌표를 설정할 수 있습니다.

• 반환되는 .osm 파일을 저장하려면 위치를 선택하고 OK 를 클릭합니다.
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• 그 다음 Add Vector Layer 버튼을 클릭해서 .osm 파일을 열 수 있습니다. 브라우저 창에서 All files
를 선택해야 할 수도 있습니다. 아니면 파일을 QGIS 창으로 드래그 & 드롭 할 수도 있습니다.

• 대화 창이 열리면 other_relations 및 multilinestrings 레이어를 제외한 모든 레이어를
선택합니다.

4 Chapter 1. 과정 소개
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OSM의명명규칙을따르는 4개레이어가사용자맵에로드됩니다. (벡터데이터를보려면줌인/줌아웃해야
할 수도 있습니다.)

이 레이어들에서 쓸 만한 데이터를 추출해서 다시 명명해, 해당하는 shapefile 을 생성해야 합니다.

• 먼저 multipolygons 레이어를 더블클릭해서 Layer properties 대화 창을 엽니다.

• General 탭을 선택하고 Query Builder 를 클릭해서 Query builder 창을 엽니다.

이제 이 레이어에서 교육 교재 전반에 걸쳐 사용하게 될 다음 세 가지 항목의 데이터를 추출해야 합니다.

• building

• natural (특히 지표수)

• landuse

사용자 지역이 담고 있는 데이터를 샘플링해서 사용자의 지역이 어떤 결과를 내놓을지 볼 수도 있습니다.
“landuse” 항목에 아무것도 없다면 제외해도 됩니다.

1.2. 예제 데이터 준비 5
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필요한 데이터를 추출하려면 각 항목에 대해 필터 표현식을 작성해야 합니다. “building” 항목을 예로
들어보겠습니다.

• 다음 표현식 building != "NULL" 을 텍스트 영역에 입력하고 Test 를 클릭해서 이 쿼리가 얼마나
많은 결과를 반환하는지 확인합니다. 결과가 적을 경우 레이어의 Attribute Table 을 보면 OSM 이
사용자 지역에 대해 어떤 데이터를 반환했는지 확인할 수 있습니다.

• OK 를 클릭하십시오. 맵에서 “building” 이 아닌 레이어 요소가 전부 삭제됩니다.

이제 사용자의 강의에 사용하기 위해 남은 데이터를 shapefile 로 저장해야 합니다.

• multipolygons 레이어를 오른쪽 클릭한 다음 Save As... 를 선택합니다.

• 파일 형식이 ESRI Shapefile 인지 확인한 후 새 exercise_data 디렉터리 아래 “epsg4326”
디렉터리에 저장합니다.

• No Symbology 가 선택되어 있는지 확인하십시오. (심볼에 대한 강좌는 차후 추가 예정입니다.)

• Add saved file to map 도 선택할 수 있습니다.

맵에 buildings 레이어가 추가되면 다음 표현식을 써서 natural 및 landuse 항목에 대해 같은 과정을
반복합니다.

주석: 다음 필터 표현식을 진행하기 전에 (Layer properties 대화 창을 통해) multipolygons 레이어에서
이전 필터를 지워줘야 합니다!

6 Chapter 1. 과정 소개
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• natural: “natural = ‘water”’

• landuse: “landuse != ‘NULL”’

결과로나온데이터를각각새 exercise_data디렉터리 (예를들자면 “water”, “landuse”)아래 “epsg4326”
디렉터리에 저장해야 합니다.

그 다음 lines 와 points 레이어에서 다음 항목들을 추출해서 상응하는 디렉터리에 저장해야 합니다.

• lines: “highway != ‘NULL”’ 을 써서 roads 로, “waterway != ‘NULL”’ 을 써서 rivers 로

• points: “place != ‘NULL”’ 을 써서 places 로

이렇게 데이터 추출이 완료되면 multipolygons, lines, points 레이어를 삭제해도 됩니다.

이제 사용자 맵이 이와 비슷하게 보일 것입니다. (심볼은 매우 다를 수 있습니다.)

중요한 것은 앞에 보이는 6 개 레이어에 대응하는 레이어가 있으며, 모든 레이어가 데이터를 담고 있어야
한다는 점입니다.

마지막으로 landuse 레이어에서 강의에 쓰일 spatiallite 파일을 생성합니다.

• landuse 레이어를 오른쪽 클릭한 다음 Save as... 를 선택합니다.

• 파일 형식으로 SpatialLite 를 선택한 다음 “epsg4326” 디렉터리 아래 landuse 파일로 저장합니다.

• OK 를 클릭합니다.

• landuse.shp 및 (생성되었다면) 관련 파일을 삭제합니다.

1.2.2 Try Yourself SRTM DEM tiff 파일 생성

모듈 6(벡터 데이터 생성) 및 모듈 8(래스터) 에 사용자 강의에 쓰일 지역의 래스터 이미지 (SRTM DEM)
가 필요합니다.

CGIAR-CGI: http://srtm.csi.cgiar.org/ 에서 SRTM DEM 을 다운로드할 수 있습니다.

사용자가 선택한 지역 전체를 포함하는 이미지가 필요합니다.

필수 파일 (들) 을 다운로드한 다음 “exercise_data” 디렉터리 아래 “raster/SRTM/” 디렉터리에
저장합니다.

1.2. 예제 데이터 준비 7
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모듈 6 의 강의 1.2 를 보면 수강생이 디지타이즈해야 하는 학교 운동장 3 개의 근접 이미지가 있습니다.
따라서 사용자의 새로운 SRTM DEM tiff 파일 (들) 을 이용해 이 이미지들을 재생성해야 합니다. 꼭 학교
운동장일필요는없습니다. 동일한학교토지이용유형 3개면됩니다. (예를들어학교건물,운동장,주차장
등)

참고로 예제 데이터에 포함된 이미지는 다음과 같습니다.
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1.2.3 Try Yourself 표식 교체

사용자 로컬 데이터를 생성한 다음, 마지막으로 conf.py 안에 있는 표식 (token) 을 교체해서 사용자 로컬
버전에 상응하는 명칭들이 교육 교재에 나오도록 해야 합니다.

교체해야 할 표식들은 다음과 같습니다.

• majorUrbanName: 기본값은 “Swellendam” 입니다. 사용자 지역의 중심 도시의 명칭으로 바꾸십시오.

• schoolAreaType1: 기본값은 “athletics field” 입니다. 사용자 지역에서 가장 큰 학교 지역 유형의
명칭으로 바꾸십시오.

• largeLandUseArea: 기본값은 “Bontebok National Park”입니다. 사용자지역에서가장큰토지이용
폴리곤의 명칭으로 바꾸십시오.

• srtmFileName: 기본값은 srtm_41_19.tif 입니다. 사용자의 SRTM DEM 파일명으로 바꾸십시오.

• localCRS: 기본값은 WGS 84 / UTM 34S 입니다. 사용자 지역의 정확한 CRS 로 바꿔야 합니다.

1.2. 예제 데이터 준비 9
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CHAPTER 2

Module: 인터페이스

2.1 Lesson: 간략한 소개

우리 교육 과정에 온 것을 환영합니다! 다음 며칠 동안 여러분께 QGIS 를 쉽고 효율적으로 사용하는
방법을 알려드리겠습니다. GIS 를 처음 접하신다면, 어떻게 시작하면 되는지 말씀드리겠습니다. 숙련된
사용자라면, QGIS 가 어떻게 GIS 프로그램에서 기대할 수 있는 모든 기능과 그 이상까지 만족시키는지
알게 될 것입니다!

이번 모듈에서는 QGIS 프로젝트 자체를 소개하면서 사용자 인터페이스도 설명합니다.

이 강의가 끝나면 QGIS 화면의 주요 요소들을 정확히 판별하고, 각 요소들의 기능을 숙지하고, QGIS 에
shapefile 을 로드할 수 있게 될 것입니다.

경고: 이강의는 GIS데이터셋을추가,삭제,수정하는지침을포함합니다. 이를위해교육용데이터셋을
제공합니다. 이 강의에서 설명하는 기술을 여러분의 데이터에 직접 적용해보기 전에 항상 백업을
확인하세요!

2.1.1 이 교육 교재를 보는 방법

이렇게 보이는 모든 텍스트는 화면상에서 사용자가 클릭할 수 있다는 뜻입니다.

이렇게 → 보이는 → 텍스트 는 메뉴의 단계를 뜻합니다.

이런 텍스트 는 명령어, 경로, 파일명처럼 사용자가 입력할 수 있다는 뜻입니다.

2.1.2 단계별 강의 목표

이 강의는 사용자 경험 수준에 따라 달라집니다. 여러분이 스스로를 어느 카테고리에 넣느냐에 따라 각각
다른 결과를 기대할 수 있습니다. 각 카테고리는 다음 단계에 대한 필수적인 정보를 담고 있으므로 사용자의
경험 수준 또는 그 이상 단계에 있는 모든 예제를 실제로 해보는 것이 중요합니다.

초급

이카테고리의사용자는이론적인 GIS지식이나 GIS프로그램실행경험이없거나아주적다고가정합니다.

사용자가 프로그램을 실행하는 목적을 설명하기 위해 제한된 이론적 배경을 설명하지만, 이론보다는 실제
실행 경험을 더 중시합니다.

이 강의를 마치면 GIS 의 가능성에 대한 개념 및 QGIS 를 통해 그 가능성을 현실로 바꿀 수 있는 방법을
알게 될 것입니다.

11
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중급

이 카테고리의 사용자는 평소 GIS 를 사용하며 실제적인 지식 및 경험을 가지고 있다고 가정합니다.

초급 레벨을 위한 지침을 따라가다 보면 QGIS 가 사용자에게 익숙한 다른 소프트웨어와 조금 다르지만,
얼마나 비슷한지에 대해 알게 될 것입니다. 또 QGIS 의 분석 기능을 사용하는 방법에 대해서도 배우게 될
것입니다.

이 강의를 마치면 평소 GIS 를 사용하며 필요했던 모든 기능을 QGIS 를 통해 손쉽게 이용하게 될 것입니다.

고급

이 카테고리의 사용자는 GIS 에 익숙하며 공간 데이터베이스, 원격 서버에서 데이터 사용, 분석 목적의
스크립트 작성 등의 지식과 경험을 가지고 있다고 가정합니다.

다른 두 레벨을 위한 지침을 따라가다 보면 QGIS 인터페이스가 따르는 접근법에 익숙해져 사용자가 필요로
하는 기본 기능에 어떻게 접근하면 되는지 알게 될 것입니다. 또 QGIS 의 플러그인 시스템 및 데이터베이스
접속 시스템 등을 이용하는 방법에 대해서도 설명합니다.

이 강의를 마치면 일상적인 QGIS 운영은 물론 고급 기능들에 대해서도 잘 알게 될 것입니다.

2.1.3 QGIS 의 장점

공간정보의중요성이점점널리알려지면서흔히쓰이는 GIS기능의일부또는전부를지원하는도구는계속
개발되고있습니다. 그렇다면다른 GIS소프트웨어패키지말고 QGIS를사용해야하는이유는무엇일까요?

여기 몇 가지 이유를 소개합니다.

• 무료입니다. QGIS 를 설치하고 이용하는 데 한 푼도 들지 않습니다. 초기 비용도, 유지 비용도
없습니다.

• 자유 소프트웨어입니다. QGIS 를 사용하는 데 추가 기능이 필요한 경우, 다음 버전이 나올 때까지
기다릴 필요가 없습니다. 해당 기능의 개발을 후원할 수도, 프로그래밍을 할 줄 안다면 직접 추가할
수도 있습니다.

• 지속적으로 개발됩니다. 누구나 새로운 기능을 추가하거나 기존 기능을 개선할 수 있기 때문에, QGIS
는 절대 멈추지 않습니다. 사용자가 어떤 기능을 필요로 한다면, 그 기능이 이미 개발 중일 가능성이
높습니다.

• 광범위한 문서 및 도움을 받을 수 있습니다. 어떤 문제가 생긴다면 광범위한 문서를 참조할 수도,
QGIS 사용자들의 도움을 받을 수도, 개발자들에게 연락을 취할 수도 있습니다.

• 크로스 플랫폼입니다. QGIS 를 맥 OS, 윈도우, 리눅스에 설치할 수 있습니다.

이제 QGIS 를 사용할 이유를 알려드렸으니, 사용법도 알려드려야죠. 첫 강의에서 사용자의 첫 QGIS 맵을
생성하는 방법을 설명합니다.

2.2 Lesson: 첫 레이어 추가

응용 프로그램을 시작하고 예제 및 연습에 쓰일 기본 맵을 생성하겠습니다.

이 강의의 목표: 예제 맵으로 시작하기.

주석: 이 예제를 시작하기 전에 사용자 컴퓨터에 QGIS 를 설치해야 합니다. 또 QGIS data downloads
area 에서 “training_manual_exercise_data.zip” 파일을 다운로드해야 합니다.

사용자의 설치 설정에 따라 데스크탑 바로가기 또는 메뉴 항목에서 QGIS 를 실행합니다.

12 Chapter 2. Module: 인터페이스
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주석: 이 강의에 쓰일 스크린샷은 맥 OS 에서 실행되는 QGIS 2.0 버전을 캡처한 것입니다. 사용자 설정에
따라실제화면이조금씩다를수도있습니다. 그러나동일한버튼들을모두사용할수있고,어떤 OS에서도
동일하게 실행될 것입니다. 이 강의를 따라하려면 (교재 작성 당시 최신 버전인) QGIS 2.0 이 필요합니다.

그럼 바로 시작해볼까요!

2.2.1 Follow Along: 맵 준비

• QGIS 를 시작합니다. 텅 빈 새 맵이 나타날 것입니다.

• Add Vector Layer 버튼 을 찾아보십시오.

• 버튼을 클릭해서 다음 대화 창을 엽니다.

• Browse 버튼을 클릭하고 (사용자 강의 디렉터리에 있는) exercise_data/epsg4326/roads.shp
파일을 찾습니다. 이 파일을 선택한 다음 Open 을 클릭해서 앞의 대화 창으로 돌아옵니다. 파일
경로가 입력되어 있을 것입니다. 대화 창의 Open 을 클릭합니다. 사용자가 선택한 데이터가 로드될
것입니다.

축하합니다! 이제 기본 맵을 사용할 수 있습니다. 이제 사용자의 작업을 저장하도록 합시다.

• Save As 버튼 을 클릭합니다.

• 맵을 exercise_data/ 디렉터리 아래에 basic_map.qgs 라는 파일명으로 저장합니다.

결과 확인

2.2.2 In Conclusion

레이어 추가 및 기본 맵 생성 방법을 배웠습니다!

2.2. Lesson: 첫 레이어 추가 13
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2.2.3 What’s Next?

이제 Add Vector Layer 버튼의 기능을 배웠습니다만, 다른 버튼들은 어떻습니까? 이 인터페이스는 어떻게
동작할까요? 더 깊이 들어가기 전에, QGIS 인터페이스의 일반적인 레이아웃을 살펴봅시다. 이것이 다음
강의의 주제입니다.

2.3 Lesson: 인터페이스 개요

QGIS 사용자 인터페이스를 살펴보고, 인터페이스의 기본 구조를 형성하는 메뉴, 툴바, 맵 캔버스, 레이어
목록에 대해 알아봅니다.

이 강의의 목표: QGIS 사용자 인터페이스의 기본을 이해하기.

2.3.1 Try Yourself: 기본

앞의 그림에 나타난 요소들은 다음과 같습니다.

1. 레이어 목록 / 브라우저 패널

2. 툴바

3. 맵 캔버스

4. 상태 바

5. 사이드 툴바

레이어 목록

레이어 목록에서 사용자가 사용할 수 있는 모든 레이어들의 목록을 언제나 볼 수 있습니다.

14 Chapter 2. Module: 인터페이스
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접혀 있는 항목을 (항목 옆의 화살표나 더하기 심볼을 클릭해서) 확장시키면 해당 레이어의 현재 모양에
대한 상세 정보를 알 수 있습니다.

레이어를 오른쪽 클릭하면 많은 추가 옵션 메뉴를 사용할 수 있습니다. 이제 곧 그 일부를 사용하게 될 테니
잘 살펴보세요!

QGIS일부버전은레이어목록바로아래에 Control rendering order 체크박스가분리되어있습니다. 보이지
않아도 괜찮습니다. 체크박스가 보일 경우 체크돼 있는지 확인하십시오.

주석: 벡터 레이어는 보통 도로, 나무 등과 같은 특정 유형의 오브젝트로 이루어진 데이터셋입니다. 벡터
레이어는 포인트, 라인, 폴리곤으로 구성됩니다.

브라우저 패널

QGIS 브라우저는 QGIS 에 내장된 패널로, 사용자 데이터베이스를 쉽게 탐색할 수 있습니다. (ESRI
shapefile 또는 MapInfo 파일 같은) 일반 벡터 파일, (PostGIS, Oracle, Spatialite, MSSQL Spatial 같은)
데이터베이스, 그리고 WMS/WFS 연결에 접속할 수 있습니다. 또 사용자의 GRASS 데이터도 볼 수
있습니다.

툴바

기본적인 접근성을 위해 사용자가 가장 자주 사용하는 도구 모음을 툴바로 만들 수 있습니다. 예를 들어
파일 툴바에서 새 프로젝트를 시작하고 저장, 불러오기, 인쇄할 수 있습니다. 사용자가 가장 자주 사용하는
도구들만 보이도록 View → Toolbars 메뉴를 통해 툴바를 추가 혹은 제거하여 쉽게 인터페이스를 사용자
지정할 수 있습니다.

툴바에 없다고 해도, 메뉴를 통해 모든 도구를 사용할 수 있습니다. 예를 들면 (Save 버튼이 포함된) File
툴바를 제거하더라도 File → Save 메뉴를 클릭해서 사용자 맵을 저장할 수 있습니다.

맵 캔버스

맵 자체가 표출되는 곳입니다.

상태 바

현재 맵에 관련된 정보를 보여줍니다. 맵 축척을 조정하거나 현재 맵 상에서 마우스 위치의 좌표를 볼 수도
있습니다.

2.3.2 Try Yourself 1

앞에 나열된 이 네 가지 요소를 앞의 그림을 보지 않고 사용자의 화면에서 식별해보십시오. 명칭 및 기능을
식별할 수 있습니까? 앞으로 며칠 동안 이 요소들을 사용하면서 더 익숙해질 수 있을 것입니다.

결과 확인

2.3.3 Try Yourself 2

다음 도구들을 사용자 화면에서 찾아보십시오. 각각 어떤 기능입니까?

2.3. Lesson: 인터페이스 개요 15
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1.

2.

3.

4.

5.

주석: 이 도구들 가운데 화면에 보이지 않는 것이 있다면 현재 숨겨져 있는 상황이니 툴바들을
활성화시켜보십시오. 또화면해상도가낮을경우툴바가짧아지면서일부도구가보이지않게됐을가능성도
있습니다. 이렇게 접혀 있는 툴바의 경우 오른쪽 이중 화살표를 클릭하면 숨겨져 있던 도구들을 볼 수
있습니다. 각 도구 아이콘 위에 마우스를 가져다 대면 해당 도구의 명칭 및 간단한 설명을 볼 수 있습니다.

결과 확인

2.3.4 What’s Next?

이제 QGIS 인터페이스가 어떻게 작동하는지 알았으니, 도구들을 사용해서 사용자 맵을 향상시킬 수
있습니다! 이것이 다음 강의의 주제입니다.
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CHAPTER 3

Module: 기본 맵 생성

이 모듈에서 향후 QGIS 의 기능성을 더욱 잘 보여주는 데 쓰일 기본 맵을 생성할 것입니다.

3.1 Lesson: 벡터 데이터 작업

이견이 있을 수도 있지만 보통 GIS 를 사용할 때 가장 흔히 볼 수 있는 데이터가 벡터 데이터입니다. 벡터
데이터는 포인트로 지리 데이터를 묘사하며, 이러한 포인트는 연결되어 라인이나 폴리곤이 될 수 있습니다.
벡터 데이터셋에 포함된 모든 오브젝트를 피처 라고 하며, 이 피처를 묘사하는 데이터와 연결되어 있습니다.

이 강의의 목표: 벡터 데이터의 구조와 맵에 벡터 데이터셋을 로드하는 방법을 배우기.

3.1.1 Follow Along: 레이어 속성 뷰

여러분이 작업할 데이터가 오브젝트가 어디에 위치하는지 나타낼 뿐만 아니라 어떤 오브젝트인지도
나타낸다는 사실을 알아야 합니다.

이전 예제를 실행했다면 사용자 맵에 roads 레이어가 로드돼 있을 것입니다. 현재 사용자는 단순히 도로의
위치밖에 알 수 없습니다.

사용할 수 있는 모든 데이터를 보려면 레이어 목록에서 roads 레이어를 선택한 다음,

• 이 버튼을 클릭하십시오.

roads 레이어에 대한 더 많은 데이터가 담긴 테이블이 나타납니다. 이 추가 데이터를 속성 데이터 (attribute
data) 라고 합니다. 사용자 맵에 보이는 라인은 도로가 어디로 뻗어 있는지 나타냅니다. 이것을 공간 데이터
(spatial data) 라고 합니다.

GIS 에서 이 정의는 흔히 사용되므로, 잘 기억해두는 편이 좋습니다!

• 이제 속성 테이블을 닫으십시오.

벡터 데이터는 좌표 평면 상에서 포인트, 라인, 폴리곤으로 피처를 나타냅니다. 보통 도로나 도시 블럭 같은
개별 피처를 저장하는 데 쓰입니다.

3.1.2 Follow Along: Shapefile 에서 벡터 데이터 로드

Shapefile 은 GIS 데이터를 관련 파일 그룹으로 저장할 수 있는 특정한 파일 형식입니다. 각 레이어는
확장자는 다르지만 파일명이 동일한 몇 개 파일들로 이루어집니다. 손쉽게 shapefile 을 주고받을 수 있어
대부분의 GIS 소프트웨어가 지원합니다.

이전 강의에서 기초 예제로 설명했던 벡터 레이어를 추가하는 방법을 떠올려 보십시오.

동일한 방법으로 사용자 맵에 데이터셋을 로드합니다.

17
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• “places”

• “water”

• “rivers”

• “buildings”

결과 확인

3.1.3 Follow Along: 데이터베이스에서 벡터 데이터 로드

데이터베이스는 대용량의 관련 데이터를 하나의 파일로 저장할 수 있습니다. 여러분은 벌써 Microsoft
Access같은 DBMS(database management system)를잘알고있을지도모르겠군요. GIS응용프로그램도
데이터베이스를 활용할 수 있습니다. 공간 데이터를 다뤄야 하기 때문에 GIS 에 특화된 (PostGIS 같은)
DBMS 들은 추가 기능들을 갖추고 있습니다.

• 이 아이콘을 클릭하십시오.

(이 아이콘이 보이지 않는다면, Manage Layers 툴바가 활성화돼 있는지 확인하십시오.)

새 대화 창이 나타날 것입니다. 이 대화 창에서,

• New 버튼을 클릭합니다.

• 다른 데이터가 담긴 동일 폴더에서 landuse.sqlite 파일을 찾을 수 있을 것입니다. 해당 파일을 선택한
다음 Open 을 클릭합니다.

이제 처음 대화 창이 다시 보일 것입니다. 세 버튼 위에 있는 드롭다운 선택 메뉴가 사용자 컴퓨터에 있는
데이터베이스 파일의 경로 “land_use.db@...” 으로 변한 것이 보이십니까?

• Connect 버튼을 클릭합니다. 이전까지 비어 있단 창에 다음과 같은 내용이 나타날 것입니다.
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• landuse 레이어를 클릭해서 선택한 다음, Add 를 클릭합니다.

주석: 맵을 자주 저장해야 합니다! 맵 파일은 어떤 데이터도 직접 담고 있지 않지만, 어떤 레이어를
로드했는지 저장합니다.

결과 확인

3.1.4 Follow Along: 레이어 재배열

사용자레이어목록에있는레이어들은맵상에특정순서대로그려집니다. 목록맨아래에있는레이어를첫
번째로그리고,맨위에있는레이어를마지막에그립니다. 목록에서레이어순서를바꾸면맵상에그려지는
순서도 바꿀 수 있습니다.

주석: 사용자의 QGIS 버전에 따라 레이어 목록 아래쪽에 Control rendering order 라는 체크박스가 있을
수도 있습니다. 이것을 체크 (활성화) 해야만 레이어 목록에서 레이어를 위아래로 이동할 때 맵 상에서도
앞뒤로 움직입니다. 사용자의 QGIS 버전에 이 옵션이 없을 경우, 기본적으로 활성화된 상태이므로 걱정할
필요는 없습니다.

현재 맵 상에 레이어가 로드되는 순서가 전혀 논리적이지 않을 수도 있습니다. 다른 레이어들이 road
레이어를 덮어 완전히 가려져 있을 수도 있습니다.

예를 들어 레이어 순서를 이렇게 하면...
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... “roads” 및 “places” 레이어가 “urban areas” 레이어 아래로 가기 때문에 보이지 않게 됩니다.

이 문제를 해결하려면,

• 레이어 목록에서 레이어를 클릭 & 드래그하십시오.

• 다음처럼 순서를 재배열하십시오.

이제 도로와 건물이 토지이용구역 위에 나타나는, 시각적으로 더 논리적인 맵을 볼 수 있습니다.

3.1.5 In Conclusion

이제 몇 가지 다른 소스들로부터 필요한 모든 레이어를 추가했습니다.

3.1.6 What’s Next?

레이어를 로드할 때 랜덤한 색상이 자동적으로 적용되므로, 현재 사용자 맵을 읽기 힘들 수도 있습니다.
사용자가 직접 색상 및 심볼을 적용하는 편이 좋습니다. 다음 강의에서 그 방법을 배울 것입니다.
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3.2 Lesson: 심볼

심볼은 맵 상에 레이어를 시각적으로 표현하는 방법입니다. 공간 성격을 가지는 데이터를 표현하는 다른
방법들에 비해, GIS 의 강점은 사용자가 작업하는 데이터의 역동적인 시각적 표현을 할 수 있다는 것입니다.

따라서 맵의 (개별 레이어의 심볼에 의존하는) 시각적 표현이 매우 중요합니다. 여러분이 생산한 맵의 최종
이용자는 맵이 나타내는 내용을 쉽게 알아볼 수 있어야 합니다. 마찬가지로 여러분이 작업할 때 데이터를
탐색할 수 있어야 하는데, 훌륭한 심볼이 큰 도움이 됩니다.

즉 적절한 심볼을 갖추는 일은 그냥 그러면 좋다 정도의 일이 아니라는 겁니다. 여러분이 GIS 를 제대로
사용하려면, 사람들이 이용할 수 있는 맵과 정보를 생산하려면, 심볼이 필수적입니다.

이 강의의 목표: 벡터 레이어에 대해 사용자가 원하는 심볼을 생성하기.

3.2.1 Follow Along: 색상 변경

레이어의 심볼을 변경하려면 해당 레이어의 Layer Properties 를 여십시오. 먼저 landuse 레이어의 색상을
바꿔봅시다.

• 레이어 목록에서 landuse 레이어를 오른쪽 클릭합니다.

• 메뉴에서 Properties 항목을 선택합니다.

주석: 레이어 목록에서 레이어를 더블 클릭해도 레이어 속성에 접근할 수 있습니다.

Properties 창에서,

• 가장 왼쪽에 있는 Style 탭을 선택하십시오.
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• Color 레이블 옆에 있는 색상 선택 버튼을 클릭하십시오.

표준 색상 대화 창이 나타납니다.

• 회색을 선택한 다음 OK 를 클릭합니다.

• 다시 Layer Properties 창의 OK 를 클릭하면 레이어의 색상이 변경되는 것을 볼 수 있습니다.

3.2.2 Try Yourself

water 레이어를 연한 파랑으로 바꿔보십시오.

결과 확인

3.2.3 Follow Along: 심볼 구조 변경

색상만 제대로 바꿔도 맵이 괜찮아지지만, 레이어의 심볼에는 색상만 있는 것이 아닙니다. 이제 서로 다른
토지이용구역 사이의 라인을 제거해서 맵이 너무 조밀하게 보이지 않도록 해보겠습니다.

• landuse 레이어의 Layer Properties 창을 엽니다.
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Style 탭을 선택하면 이전과 같은 대화 창이 보일 것입니다. 하지만 이번에는 색상 변경 이상의 작업을
해보겠습니다.

• Symbol Layers 패널에서 (필요하다면) Fill 드롭다운 메뉴를 펼친 다음 Simple fill 옵션을
선택하십시오.

• Border style 드롭다운 메뉴를 클릭하십시오. 지금은 짧은 라인과 Solid Line 이라는 텍스트가 보일
겁니다.

• 이것을 No Pen 으로 바꾸십시오.

• OK 를 클릭합니다.

이제 landuse 레이어의 구역 사이에 있던 라인들이 사라질 것입니다.

3.2.4 Try Yourself

• 이제 water 레이어의 심볼을 변경해서 진한 파란색 외곽선이 보이도록 해보십시오.

• rivers 레이어의 심볼을 변경해서 수로를 합리적으로 표현해보십시오.

결과 확인
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3.2.5 Follow Along: 축척 기반 가시성

가끔레이어가특정축척에서잘맞지않는다고느껴질때가있습니다. 예를들면전대륙을담은데이터셋은
상세함이 부족해서 마을 수준에서는 정확하지 않을 수도 있습니다. 이런 경우 부적절한 축척에서 해당
데이터셋을 숨기는 편이 좋습니다.

강의로 돌아와서, 소축척에서 건물을 보이지 않게 하려 한다고 가정합시다. 예를 들면 이 맵은...

... 별로 쓸모가 없습니다. 이 축척에서 건물을 식별하기란 거의 불가능합니다.

축척 기반 렌더링을 활성화하려면,

• buildings 레이어의 Layer Properties 대화 창을 엽니다.

• General 탭을 선택합니다.

• Scale dependent visibility 라는 체크박스를 클릭해서 축척 기반 렌더링을 활성화합니다.
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• Maximum 값을 1:10,000 로 수정합니다.

• OK 를 클릭합니다.

그 결과 맵이 어떻게 변하는지 줌인/줌아웃해보십시오. buildings 레이어가 언제 사라지고 언제 나타나는지
아시겠습니까?

주석: 마우스 휠을 써서 줌인/줌아웃할 수 있습니다. 또 줌 도구를 써서 창 크기에 맞게 줌인/줌아웃할
수도 있습니다.

3.2.6 Follow Along: 심볼 레이어 추가

이제 레이어에서 단순한 심볼을 변경하는 방법을 알았으니, 다음으로 좀 더 복잡한 심볼을 생성해볼
차례입니다. QGIS 에서는 심볼 레이어를 이용합니다.

• Go back to the landuse layer’s symbol properties panel (by clicking

Simple fill in the Symbol layers panel).

이 예제의 현재 심볼에는 윤곽선이 없습니다. (즉 No Pen 경계선 스타일을 사용하고 있습니다.)
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Symbol layers 패널에 있는 Fill 을 선택합니다. 그 다음 Add symbol layer 버튼을 클릭합니다.

• 대화 창이 다음과 같이 변할 것입니다.

26 Chapter 3. Module: 기본 맵 생성



QGIS Training Manual, 출시 2.2

(색상 등이 조금 다르게 나타날 수도 있지만 여러분이 곧 바꾸게 될 것입니다.)

이제 두 번째 심볼 레이어가 나타납니다. 단색이기 때문에, 당연히 이전 심볼 유형을 완전히 가리게 됩니다.
또 이 레이어는 Solid Line 경계선 스타일을 사용하는데, 당연히 이 심볼을 바꿔야 합니다.

주석: 맵 레이어와 심볼 레이어를 착각하지 않는 것이 중요합니다. 맵 레이어는 맵에 로드된 벡터 (또는
래스터)입니다. 심볼레이어는맵레이어를표현하는데쓰이는심볼의일부입니다. 이강의에서는착각하지
않도록 맵 레이어를 보통 그냥 레이어로 부르지만, 심볼 레이어는 언제나 심볼 레이어라고 부릅니다.

새 Simple Fill 레이어를 선택한 다음,

• 이전처럼 경계선 스타일을 No Pen 으로 설정합니다.

• 면 스타일을 다음과 같이 Solid 또는 No brush 이외의 것으로 변경합니다.
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• OK 를 클릭합니다. 이제 그 결과를 보고 필요한 대로 수정할 수 있습니다.

복수의심볼레이어를추가한다음같은방법으로사용자레이어에필요한텍스처유형을생성할수있습니다.
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재미있죠! 그러나 실제 맵에 사용하기에는 색상이 너무 많을지도 모르겠군요...

3.2.7 Try Yourself

• 필요한 경우 줌인해서, 앞에서 설명한 방업으로 buildings 레이어에 간단하지만 보기 쉬운 텍스처를
생성하는 작업을 잊지 마십시오.

결과 확인

3.2.8 Follow Along: 심볼 수준 순서 배열

서로 다른 맵 레이어를 렌더링할 때와 마찬가지로 심볼 레이어도 순차적으로 렌더링됩니다. 즉 하나의
심볼에 많은 심볼 레이어를 사용할 경우 기대하지 않은 결과가 나올 수도 있다는 이야기입니다.

• (앞에서 설명한 방법대로) roads 레이어에 심볼 레이어를 추가합니다.

• 기본라인의 Pen width 를 0.3으로, 색상을흰색으로설정하고, Pen Style 드롭다운메뉴에서 Dashed
Line 을 선택합니다.

• 이 새로운, 맨 위의 레이어의 두께를 1.3 으로 설정하고, Solid Line 인지 확인합니다.

그러면 이렇게 보입니다.
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이러려는 게 아니었는데 말이죠!

이런일이일어나지않게하려면, 심볼레이어의순서를바꿔서로다른심볼레이어들이렌더링되는순서를
조정해야 합니다.

심볼 레이어의 순서를 바꾸려면 Symbol layers 패널에서 Line 레이어를 선택한 다음 창의 우하단에 있는
Advanced → Symbol levels... 를 클릭합니다. 다음과 같은 대화 창이 열릴 것입니다.
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Enable symbol levels 를 선택하면, 수준 수자를 입력해서 해당하는 각 심볼 레이어의 순서를 설정할 수
있습니다. 0 은 맨 아래 레이어를 의미합니다.

이 경우 다음과 같이 순서를 반대로 조정합니다.
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이렇게 하면 굵고 검은 선 위에 흰 점선이 렌더링됩니다.

• OK 를 두 번 클릭해서 맵으로 돌아갑니다.

이제 맵이 다음과 같이 보이게 됩니다.
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또 이제 도로들이 만나는 지점이 “합쳐져”, 어떤 도로가 다른 도로 위로 렌더링되지 않는다는 점도
살펴보십시오.

작업이 끝난 후 향후 다시 심볼을 변경하더라도 여러분의 작업을 잃어버리는 일이 없도록 심볼 자체를
저장하는 것도 잊지 마십시오. Layer Properties 대화 창의 Style 탭에 있는 Save Style ... 버튼을 클릭하면
현재 심볼 스타일을 저장할 수 있습니다. 보통 QGIS Layer Style File 형식으로 저장해야 합니다.

exercise_data/styles 디렉터리에 사용자 스타일을 저장하십시오. Load Style ... 버튼을 클릭하면
언제라도이전에저장했던스타일을로드할수있습니다. 저장하지않은스타일을변경할경우해당스타일을
잃어버리게 된다는 점을 기억하십시오.

3.2.9 Try Yourself

• roads 레이어의 모양을 다시 바꿔봅시다.

이번에는 도로가 중간 정도의 회색에 엷은 노란색 윤곽선을 갖춘 가는 라인이어야 합니다. Advanced →
Symbol levels... 대화 창에서 레이어 렌더링 순서를 바꿔야 할지도 모른다는 점을 기억하십시오.
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결과 확인

3.2.10 Try Yourself

심볼 수준을 (복수의 심볼을 갖춘 레이어 같은) 범주화된 레이어에도 적용할 수 있습니다. 아직 범주화에
대해서는 배우지 않았기 때문에, 지금은 범주화하지 않은 기본적인 데이터를 작업할 것입니다.

• 새 맵을 생성하고 roads 데이터셋만 추가하십시오.

• exercise_data/styles 디렉터리에 있는 advanced_levels_demo.qml 스타일을 적용합니다.

• Swellendam 지역으로 줌인합니다.

• 심볼 레이어를 이용해서 다음 그림처럼 레이어의 윤곽선이 서로 이어지도록 만드십시오.
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결과 확인

3.2.11 Follow Along: 심볼 레이어 유형

면 색을 설정하거나 미리 정의된 패턴을 사용하는 것을 넘어, 완전히 다른 심볼 레이어 유형을 사용할 수
있습니다. 지금까지 사용했던 유형은 모두 단순한 채우기 유형이었습니다. 더 고급의 심볼 레이어 유형을
사용하면 사용자의 심볼을 마음대로 지정할 수 있습니다.

벡터의 각 (포인트, 라인, 폴리곤) 유형은 각각 고유한 심볼 레이어 유형 그룹을 갖추고 있습니다. 먼저
포인트에 사용할 수 있는 유형들을 살펴보겠습니다.

포인트 심볼 레이어 유형

• basic_map 프로젝트를 여십시오.

• places 레이어의 심볼 속성을 변경합니다.
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• You can access the various symbol layer types by selecting the

Simple marker layer in the Symbol layers panel, then click the Symbol layer type dropdown:
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• 사용할 수 있는 다양한 옵션들을 살펴보고, 사용자가 적합하다고 생각하는 스타일의 심볼을
선택하십시오.

• 고르기 힘든 경우, 둥근 Simple marker 를 선택한 다음 경계선은 흰색, 면색은 엷은 녹색, size 는 3,00
으로, Outline width 는 0.5 로 설정하십시오.

라인 심볼 레이어 유형

라인 데이터에 쓸 수 있는 다양한 옵션들을 보려면,

• roads 레이어의 최상위 심볼 레이어 유형을 Marker line 으로 바꿉니다.

• Symbol layers 패널에 있는 Simple marker 레이어를 선택합니다. 심볼 속성을 다음 대화 창과
일치하도록 변경합니다.
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• 간격을 1,00 으로 바꿉니다.
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• Ensure that the symbol levels are correct (via the

Advanced -> Symbol levels dialog we used earlier) before applying the style.

스타일을 적용한 다음, 맵 상에 스타일이 어떻게 표현되는지 살펴보십시오. 이 심볼들은 도로를 따라
기울기가 바뀌지만, 언제나 그런 것은 아닙니다. 이는 어떤 목적에는 부합하지만, 다른 목적에는 아닐 수도
있습니다. 원한다면 해당 심볼 레이어를 원래대로 다시 바꿀 수 있습니다.

폴리곤 심볼 레이어 유형

폴리곤 레이어에 쓸 수 있는 다양한 옵션들을 보려면,

• 이전과 마찬가지로 water 레이어의 심볼 레이어 유형을 바꿉니다.

• 목록에 있는 서로 다른 옵션들이 각각 어떤 작용을 하는지 살펴보십시오.

• 여러분이 어울린다고 생각하는 옵션을 하나 선택하십시오.

• 고르기 힘든 경우, Point pattern fill 을 선택하고, 다음 옵션을 적용합니다.
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• 일반적인 Simple fill 로 새 심볼 레이어를 추가합니다.

• 아두운 파란색 경계선을 가진 동일한 밝은 파란색으로 변경합니다.

• Move down 버튼을 이용해 Point pattern 심볼 레이어 아래로 이동시킵니다.
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이제 water 레이어에 텍스처 심볼이 적용됐습니다. 이렇게 하면 사용자가 텍스처를 구성하는 개별 점들의
크기, 형태, 밀도를 마음대로 설정할 수 있습니다.

3.2.12 Follow Along: 사용자 지정 SVG 채우기 생성

주석: 이 예제를 실행하려면 무료 벡터 편집 소프트웨어인 Inkscape 를 설치해야 합니다.

• Inkscape 프로그램을 실행하십시오.

다음 인터페이스를 보게 될 것입니다.
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Corel 같은 다른 벡터 이미지 편집 프로그램을 사용해본 적이 있다면 이 화면이 익숙할 것입니다.

먼저 캔버스 크기를 작은 텍스처에 적당하도록 변경합니다.

• 메뉴에서 File → Document Properties항목을클릭하십시오. Document Properties대화창이나타날
것입니다.

• Units 를 px 로 바꿉니다.

• Width 와 Height 을 100 으로 바꿉니다.

• 변경이 끝났으면 대화 창을 닫습니다.

• 메뉴에서 View → Zoom → Page 항목을 클릭해서 여러분이 작업할 페이지를 보십시오.

• Circle 도구를 선택한 다음,
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• 페이지 상에서 클릭 & 드래그로 타원체를 그립니다. 타원을 원으로 만들려면, 키보드의 ctrl 자판을
누른 채 클릭 & 드래그하십시오.

• 방금 생성한 원을 오른쪽 클릭해서 Fill and Stroke 항목을 선택합니다.

• Stroke paint 를 엷은 청회색으로 바꾸고 Stroke style 을 가는 획의 어두운 색상으로 바꿉니다.
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• Line 도구로 선분을 그리십시오.

• 선분을 시작하려면 한 번 클릭합니다. 선이 15 도 간격으로 꺾이도록 하려면 키보드의 ctrl 자판을
누르고 있어야 합니다.

• 선분을 끝내려면 다시 한 번 클릭하고, 선 그리기를 끝내려면 오른쪽 클릭하십시오.

• 원의 획과 일치하도록 라인의 색상 및 굵기를 변경하고, 필요한 경우 위치를 바꿔 다음과 같은 심볼이
되도록 만드십시오.
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• 이 강의용 디렉터리인 exercise_data/symbols 아래 landuse_symbol 디렉터리에 SVG 파일로
저장하십시오.

QGIS 로 돌아와서,

• landuse 레이어의 Layer Properties 를 엽니다.

• 심볼 구조를 다음과 같이 변경한 다음 Browse 버튼을 클릭해서 사용자의 SVG 이미지를 찾습니다.
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또 SVG 레이어의 경계선을 업데이트해야 할지도 모릅니다.
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이제 사용자의 landuse 레이어에 다음 맵에 보이는 것과 동일한 텍스처가 적용돼 있어야 합니다.
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3.2.13 In Conclusion

서로 다른 레이어에 대한 심볼들을 변경하는 작업이 한 무리의 벡터 파일로 저장되었고, 맵도 판독
가능해졌습니다. 여러분이 작업에 익숙해진 것은 물론, 보기 좋은 맵이 되기까지 했군요!

3.2.14 Further Reading

아름다운 맵의 예시

3.2.15 What’s Next?

전체레이어의심볼을변경하는작업은유용하지만, 이맵을읽는사람이각레이어안에담긴정보에접근할
수는 없습니다. 거리명은 무엇인가? 특정 지역이 속한 행정구역은 어디인가? 이 농장의 상대표면적은
얼마나 되나? 이 모든 정보가 아직 숨겨져 있습니다. 다음 강의에서 여러분이 만든 맵에 이런 데이터를
어떻게 표현하는지에 대해 설명하겠습니다.

주석: 지금 여러분의 맵을 저장해야 할 때라는 건 잊지 않으셨죠?
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CHAPTER 4

Module: 벡터 데이터 범주화

벡터 데이터를 범주화하면 피처들 (동일 레이어의 서로 다른 오브젝트들) 의 속성에 따라 서로 다른 심볼을
할당할 수 있습니다. 이렇게 하면 맵 사용자가 다양한 피처의 속성들을 쉽게 볼 수 있습니다.

4.1 Lesson: 속성 데이터

지금까지 우리가 맵 상에서 변경했던 것들은 맵 상에 보이는 오브젝트들의 영향을 받지 않았습니다. 다시
말해 모든 토지이용구역들은 똑같이 보였고, 모든 도로들도 똑같이 보였습니다. 맵을 보는 사람들은 특정
지역에 특정 형태의 도로가 있다는 것 외에는 자기가 보고 있는 도로에 대해 아무것도 알 수 없었습니다.

그러나 GIS 의 최대 강점은 맵 상에 보이는 모든 오브젝트들이 속성을 가지고 있다는 것입니다. GIS 에서
맵은 단순한 그림이 아닙니다. 맵은 오브젝트들의 위치만이 아니라 그 오브젝트들에 대한 정보도 담고
있습니다.

이 강의의 목표: 오브젝트의 속성 데이터를 살펴보고, 그 다양한 데이터를 어떻게 쓸 수 있는지 이해하기.

4.1.1 Follow Along: 속성 데이터

places레이어의속성테이블을여십시오. (필요한경우 “벡터데이터작업” 강의부분을다시참조하십시오.)
라벨 서식에 가장 쓸모 있는 항목이 무엇이겠습니까?

결과 확인

4.1.2 In Conclusion

이제 여러분이 사용하는 데이터 안에 실제로 뭐가 들어 있는지 보기 위해 속성 테이블을 이용하는 방법을
알게됐습니다. 여러분에게필요한속성이없다면어떤데이터셋이라도쓸모없는데이터입니다. 어떤속성이
필요한지 알고 있다면 어떤 데이터셋을 사용할 수 있는지, 또는 필요한 속성 데이터를 가진 다른 데이터셋을
찾아야 하는지 빨리 결정할 수 있습니다.

4.1.3 What’s Next?

목적이 다르다면 쓸모 있는 속성도 달라집니다. 속성 중 일부는 맵 사용자가 볼 수 있도록 텍스트로 직접
나타낼 수 있습니다. 다음 강의에서는 그 방법을 배워보겠습니다.

4.2 Lesson: 라벨 도구

어떤 오브젝트에 대한 어떤 정보를 보이기 위해 맵에 라벨을 추가할 수 있습니다. 라벨은 어떤 벡터
레이어와도 연계될 수 있습니다. 이때 라벨의 내용은 해당 레이어의 속성 데이터를 따릅니다.
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주석: Layer Properties 대화 창에도 동일한 기능을 제공하는 Labels 탭이 있지만, 이번 예제에서는 툴바
버튼으로 실행할 수 있는 Label tool 을 사용하겠습니다.

이 강의의 목표: 레이어에 유용하고 보기 좋은 라벨을 추가하기.

4.2.1 Follow Along: 라벨 이용

라벨 도구에 접근하려면 먼저 해당 기능이 활성화돼 있는지 확인해야 합니다.

• 메뉴의 View → Toolbars 항목을 선택하십시오.

• Label 항목 옆에 체크 표시가 돼 있는지 확인하십시오. 표시가 안 돼 있다면 Label 항목을 클릭해서
활성화하십시오.

• Layers list 에 있는 places 레이어를 클릭해서 선택합니다.

• 다음 툴바 버튼 을 클릭합니다.

Layer labeling settings 대화 창이 나타날 것입니다.

• Label this layer with... 옆에 있는 체크박스에 체크합니다.

이제 라벨에 쓰일 속성 항목을 선택해야 합니다. 이전 강의에서 여러분은 이 목적에 NAME 항목이 가장
적합하다는 사실을 배웠습니다.

• 목록에서 NAME 을 선택한 다음,
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• OK 를 클릭하십시오.

이제 맵 상에 다음과 같은 라벨이 보일 것입니다.
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4.2.2 Follow Along: 라벨 옵션 변경

이전 강의에서 사용자 맵을 위해 선택한 스타일에 따라, 서로 겹치거나 위치 표식에서 너무 떨어져 있는 등
라벨 서식이 어울리지 않을 수도 있습니다.

• 이전과 마찬가지로 Label tool 버튼을 클릭해서 실행하십시오.

• Make sure Text is selected in the left-hand options list, then

update the text formatting options to match those shown here:
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폰트문제를해결했습니다! 이제라벨이겹치는문제를살펴봅시다. 다만그전에 Buffer 옵션을보겠습니다.

• Label tool 대화 창을 엽니다.

• 왼쪽 옵션 목록에서 Buffer 를 선택합니다.

• Select the checkbox next to Draw text buffer, then choose options

to match those shown here:
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• Apply 버튼을 클릭합니다.

places 라벨에 색상 버퍼 또는 윤곽선이 추가되어 맵 상에서 더 잘 보이는 것을 알 수 있습니다.
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이제 라벨의 위치를 상응하는 위치 표식에 맞춰보겠습니다.

• Label tool 대화 창에서 Placement 탭을 선택합니다.

• Change the value of Distance to 2mm and make sure that

Around point is selected:

4.2. Lesson: 라벨 도구 57



QGIS Training Manual, 출시 2.2

• Apply 버튼을 클릭합니다.

이제 라벨이 위치 표식을 가리지 않는다는 사실을 알 수 있습니다.

4.2.3 Follow Along: 레이어 심볼 대신 라벨 사용

많은경우포인트의위치가매우정확할필요는없습니다. 예를들어 places레이어의포인트들대부분은도시
또는 교외 전체를 나타내며, 이런 피처와 연결되는 특정 포인트는 대축척에서 그다지 정확하지는 않습니다.
사실을 말하자면 포인트의 위치를 너무 정확히 설정하면 맵을 읽을 때 혼란해지기 쉽습니다.

다음과 같은 예를 들어봅시다. 세계 지도 상에서 유럽 연합을 나타내는 포인트가 폴란드 근처에 위치할 수도
있습니다. 이런 맵을 읽을 때 유럽 연합 이라는 라벨을 가진 포인트가 폴란드에 있다면 유럽 연합의 수도가
폴란드라고 착각할 수 있습니다.

따라서 이런 종류의 오해를 피하기 위해 포인트 심볼을 비활성화하고 대신 라벨만을 표출시키는 작업도
유용합니다.

QGIS 에서는 라벨의 위치를 상응하는 포인트 바로 위로 변경해서 렌더링하는 방법을 쓸 수 있습니다.

• places 레이어의 Layer labeling settings 대화창을 엽니다.

• 옵션 목록에서 Placement 옵션을 선택합니다.

• Offset from point 버튼을 클릭합니다.
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위치 표식을 기준으로 라벨의 위치를 설정할 수 있는 Quadrant 옵션이 나타날 것입니다. 이 예제의 경우,
라벨의 중심을 위치 표식에 맞추고자 하기 때문에 center quadrant 를 선택합니다.

• 마찬가지로 레이어 스타일을 편집해서 포인트 심볼을 감추십시오. Ellipse marker 의 너비와 높이를
0 으로 설정합니다.
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• OK 를 클릭하면 다음과 같은 결과를 볼 수 있습니다.
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맵을줌아웃하는경우, 라벨가운데일부가대축척에서서로겹쳐지는것을막기위해사라지는것을볼수도
있습니다. 많은 포인트를 가진 데이터셋으로 작업하는 경우 이런 현상을 원할 수도 있지만, 그렇지 않다면
유용한 정보를 잃어버리게 됩니다. 이런 일들을 다룰 수 있는 다른 가능성도 있습니다. 이 강의의 후반부
예제에서 이를 다시 설명하겠습니다.

4.2.4 Try Yourself 사용자 지정 라벨

• 라벨 및 심볼 설정을 위치 표식을 드러내고 라벨 오프셋을 2.00mm 로 되돌리십시오. 이 단계에서 위치
표식이나 라벨의 스타일을 조정하는 편이 좋습니다.

결과 확인

• 맵의 축척을 1:100000 으로 설정하십시오. Status Bar 에 있는 Scale 박스에 직접 입력하면 됩니다.

• 이 축척에서 잘 보이도록 라벨을 조정해보십시오.

결과 확인

4.2. Lesson: 라벨 도구 61



QGIS Training Manual, 출시 2.2

4.2.5 Follow Along: 라인 라벨 작업

이제 라벨 작업을 어떻게 하는지 알게 됐지만, 또 다른 문제가 있습니다. 포인트와 폴리곤의 라벨 작업은
쉽습니다. 하지만 라인은 어떨까요? 라인 라벨을 포인트의 경우와 똑같이 작업하면, 다음과 같은 결과를
얻게 됩니다.

이제 roads 레이어의 라벨 서식을 알기 쉽도록 재설정해보겠습니다.

• 여러분이 혼란스럽지 않도록 Places 레이어를 숨깁니다.

• 이전 예제에서 했던 것처럼 streets 레이어의 라벨을 활성화합니다.

• 더 많은 라벨을 볼 수 있도록 폰트 Size 를 10 으로 설정합니다.

• Swellendam 도시 지역으로 줌인합니다.

• Label tool 대화 창의 Advanced 탭에서 다음과 같이 설정합니다.
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텍스트 스타일에 기본값을 사용했기 때문에 라벨을 읽기 힘들다는 사실을 알아차리셨습니까? 라벨 텍스트
서식의 Color 를 진회색 또는 검은색으로, buffer 를 연노랑색으로 설정합니다.

축척에 따라 다르지만, 사용자 맵이 다음처럼 보일 것입니다.
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도로명 일부가 반복적으로 나타나는데, 반드시 필요하지는 않습니다. 이렇게 반복되지 않게 하려면,

• Label labelling settings 대화 창에서 Rendering 옵션을 클릭한 다음 Merge connected lines to avoid
duplicate labels 를 선택합니다.
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• OK 를 클릭합니다.

알아차리기에는 너무 짧은 피처에 라벨이 붙는 일을 막기 위한 유용한 기능도 있습니다.

• 마찬가지로 Rendering 패널에서 Suppress labeling of features smaller than ... 의 값을 5mm 로
설정합니다. Apply 를 클릭하면 어떤 결과가 나오는지 살펴보십시오.

다른 Placement 설정도 시험해봅시다. 이전에도 봤듯이 이런 경우 horizontal 옵션은 적절하지 않습니다.
대신 curved 옵션을 시험해보겠습니다.

• Layer labeling settings 대화 창의 Placement 패널에 있는 Curved 옵션을 선택합니다.

결과는 다음과 같습니다.
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이전에는 보였던 라벨들 가운데 다수가 사라졌다는 것을 알 수 있습니다. 이리 저리 꼬인 도로 라인을
따라가면서 읽을 수도 있도록 만드는 일이 어렵기 때문입니다. 어느 쪽이 더 쓸모가 있는지 혹은 더 보기
좋은지를 따져 여러분이 어떤 옵션을 사용할 것인지 결정할 수 있습니다.

4.2.6 Follow Along: 데이터 정의 설정

• Streets 레이어의 라벨을 비활성화합니다.

• Places 레이어의 라벨을 비활성화합니다.

• 버튼을 클릭해서 Places 레이어의 속성 테이블을 엽니다.

지금 여러분이 관심을 가져야 할 항목은 각 오브젝트의 도시 구역 유형을 정의하는 place 하나뿐입니다. 이
데이터를 이용해서 라벨 스타일을 바꿀 수 있습니다.

• places Labels 패널에 있는 Text 패널을 찾으십시오.

• Italic 드롭다운 메뉴에 있는 Edit... 을 선택해서 Expression string builder 를 엽니다.
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텍스트 입력란에 "place" = 'town' 을 입력하고 OK 를 두 번 클릭합니다.

4.2. Lesson: 라벨 도구 67



QGIS Training Manual, 출시 2.2

결과는 다음과 같습니다.
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4.2.7 Try Yourself 데이터 정의 설정 사용

주석: 고급 라벨 작업 설정의 일부를 보여드리기 위해 조금 앞으로 뛰어넘겠습니다. 고급 수준에서는
여러분이 다음 내용을 이해한다고 가정합니다. 이해가 안 된다면 이 부분을 건너뛰어도 좋습니다. 필요한
내용을 학습한 후에 다시 시도해보십시오.

• places 레이어의 속성 테이블을 엽니다.

• 버튼을 클릭해서 편집 모드로 들어갑니다.

• 새 열을 추가하고,

• 다음과 같이 설정합니다.
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• 각각 다른 places 유형 (예를 들어 PLACE 항목의 각 키 값) 에 사용자 지정 폰트 크기를 설정하는 데 이
열을 사용합니다.

결과 확인

4.2.8 라벨 작업의 더 많은 가능성들

이 강의에서 모든 옵션을 다룰 수는 없지만, Label tool 에는 유용한 다른 기능들이 많이 있다는 것을
기억하십시오. 렌더링을축척기반으로설정하거나,레이어의라벨들에대한렌더링우선순위를조정하거나,
모든 라벨 옵션을 레이어 속성을 이용해 설정할 수 있습니다. 라벨의 기울기, XY 좌표, 그리고 다른
속성들까지도 (해당 목적을 위해 할당된 속성 항목이 있다면) 설정할 수 있습니다. 그리고 이런 속성들을
Label tool 에 인접한 도구들을 이용해서 편집할 수도 있습니다.

(필요한 속성 항목이 존재하고 사용자가 편집 모드일 경우 이 도구들이 활성화될 것입니다.)

여러분 마음대로 라벨 작업 시스템의 가능성을 탐색해보십시오.

4.2.9 In Conclusion

이제레이어속성을이용해서동적인라벨을생성하는방법을배웠으니,여러분의맵을더욱유익하고멋지게
만들 수 있게 됐습니다!
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4.2.10 What’s Next?

이제 속성이 여러분의 맵에 어떻게 시각적인 변화를 줄 수 있는지 알게 됐으니, 오브젝트 그 자체의 심볼을
바꾸는 데 이용해보는 건 어떨까요? 이것이 바로 다음 강의의 주제입니다!

4.3 Lesson: 범주화

개별 장소의 명칭 같은 정보를 전달하는 데 라벨이 유용하긴 하지만, 모든 정보를 전달할 수는 없습니다.
예를 들어 각 landuse 구역이 어떻게 이용되는지 알고 싶다고 합시다. 라벨을 사용할 경우 이런 결과가
나옵니다.

라벨을 읽기 어려울 뿐만 아니라 맵 상에 수많은 토지이용구역이 있을 경우 혼잡하기까지 합니다.

이 강의의 목표: 벡터 데이터를 효율적으로 범주화하는 방법 배우기.

4.3.1 Follow Along: 명칭 데이터 범주화

• landuse 레이어의 Layer Properties 대화 창을 엽니다.

• Style 탭을 선택합니다.

• Click on the dropdown that says Single Symbol and change it to

Categorized:
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• 새 패널에 있는 Column 을 landuse 로, Color ramp 를 Greens 로 바꿉니다.

• Classify 버튼을 클릭하십시오.
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• OK 를 클릭합니다.

결과는 다음과 같습니다.
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• Layer list 의 landuse 옆에 있는 화살표 (또는 더하기표) 를 클릭합니다.

이제 토지이용 폴리곤들이 동일한 토지이용 유형일 경우 동일한 색상을 가지도록 적절하게 범주화됐습니다.
landuse 레이어에서 검은색 경계선을 없애는 편이 좋을 수도 있습니다.
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• Layer Properties 를 열고, Style 탭에서 Symbol 을 선택하십시오.

• Simple Fill 레이어에서 경계선을 제거하여 심볼을 변경한 다음 OK 를 클릭합니다.

이제 토지이용 폴리곤의 윤곽선이 제거되어, 각 카테고리별로 면 색만 남은 것을 볼 수 있을 것입니다.

• 원한다면 연관된 색상 블럭을 더블클릭해서 각 토지이용구역의 면 색을 바꿀 수도 있습니다.

비어 있는 카테고리가 하나 있는 게 보이십니까?
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이 빈 카테고리는 토지이용 값이 정의되지 않았거나, NULL 값을 가지고 있는 오브젝트를 칠하는 데
쓰입니다. 맵상에서 NULL값을가진구역을표현하기위해이카테고리를그대로두어야합니다. 정의되지
않은 값이나 NULL 값을 좀 더 확실히 표현하기 위해 색상을 바꾸는 편이 좋을 수도 있습니다.

여러분이 힘들게 바꾼 변경 사항을 잃지 않도록 지금 맵을 저장하세요!

4.3.2 Try Yourself 고급 범주화

사용자가 초급 수준 내용만을 따라가고 있는 경우, 앞에서 얻은 지식을 이용해서 buildings 레이어를
범주화해보십시오. building 열에 대해 카테고리를 설정하고 Spectral 색상표를 이용하십시오.

주석: 결과를 보려면 도심 지역으로 줌인해야 합니다.

4.3.3 Follow Along: 비율 범주화

범주화에는 명칭, 순서, 간격, 그리고 비율, 네 가지 유형이 있습니다.
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명칭 범주화에서는 오브젝트의 명칭을 기준으로 카테고리를 범주화합니다. 예를 들면 도시명, 우편번호
등에는 어떤 순서도 없습니다.

순서범주화에서는특정순서로카테고리를배열합니다. 예를들면세계무역,관광,문화등에대한중요도를
기준으로 세계 도시들의 순위를 매기는 경우입니다.

간격 범주화에서는 양수, 음수, 0 값을 기준으로 숫자를 나누게 됩니다. 해수면 위/아래 높이, 빙결 온도
(섭씨 0 도) 위/아래 기온 등이 그 예입니다.

비율 범주화에서는 양수 및 0 값만을 기준으로 숫자를 나눕니다. 절대 영도 (켈빈 0 도) 이상의 온도, 어떤
포인트로부터의 거리, 특정 거리의 월별 평균 교통량 등이 그 예입니다.

앞의 예제에서 우리는 각 농장을 해당 지자체에 할당하는 명칭 범주화를 사용했습니다. 이제 농장을 면적을
기준으로 범주화하는 비율 범주화를 사용해보겠습니다.

• (간직하고싶을경우) Style대화창에있는 Save Style ... 버튼을클릭해서토지이용심볼을저장합니다.

저장하지 않은 채로 레이어를 재범주화하면 기존 심볼을 잃게 됩니다.

• Style 대화 창을 닫습니다.

• landuse 레이어의 속성 테이블을 여십시오.

토지이용구역을 면적을 기준으로 범주화하고자 하지만 문제가 있습니다. 속성에 면적 항목이 없기 때문에
새로 만들어야 합니다.

• 다음 버튼을 클릭해서 편집 모드로 들어갑니다.

:align: center

• 다음 버튼을 클릭해서 새 열을 추가합니다.

• 새로 나타나는 대화 창을 다음과 같이 설정해줍니다.
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• OK 를 클릭합니다.

새 항목이 추가될 것입니다. (테이블의 맨 오른쪽에 추가되므로 수평 방향으로 스크롤해야 보일 수도
있습니다.) 그러나 현재 아무 값도 없이 NULL 값으로만 채워져 있습니다.

이 문제를 해결하려면 면적을 계산해야만 합니다.

• 항목 계산기를 실행하십시오.

align center

다음 대화 창이 나타날 것입니다.
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• 대화 창의 맨 위에 있는 값을 다음과 같이 변경합니다.

• Function List 에서 Geometry → $area 를 선택한 다음,
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• 더블클릭하면 Expression 항목에 $area 가 나타납니다.

• OK 를 클릭합니다.

이제 AREA열에값이채워졌을것입니다. (데이터를다시불러오려면열제목을클릭하십시오.) 편집내용을
저장한 다음 OK 를 클릭합니다.

주석: 면적이 도 단위로 돼 있습니다. 나중에 평방미터 단위로 다시 계산할 것입니다.

• Layer properties 대화창을 열고 Style 탭을 선택합니다.

• 범주화 스타일을 Categorized 에서 Graduated 로 변경합니다.

• Column 을 AREA 로 변경한 다음,

• Color ramp 아래에 있는 New color ramp... 옵션을 선택하면 다음 대화 창이 나타납니다.
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• Gradient 를 (벌써선택되어있지않다면)선택하고 OK 를클릭합니다. 다음과같은창이나타납니다.
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이 창을 이용해서, 적은 면적을 Color 1 로, 큰 면적을 Color 2 로 나타낼 것입니다.

• 적합한 색상을 선택하십시오.

이 예제에서는 다음과 비슷한 결과가 나옵니다.
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• OK 를 클릭합니다.

• 새 색상표에 어울리는 명칭을 선택하십시오.

• 명칭을 입력한 다음 OK 를 클릭합니다.

이제 다음과 같은 화면을 보게 됩니다.

4.3. Lesson: 범주화 83



QGIS Training Manual, 출시 2.2

다른 항목은 그대로 놔둡니다.

• OK 를 클릭합니다.
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4.3.4 Try Yourself 범주화 개선

• 각 단계 사이의 라인을 제거하겠습니다.

• 여러분의 범주화를 이해하기 쉽도록 Mode 및 Classes 의 값을 변경해보십시오.

결과 확인

4.3.5 Follow Along: 규칙 기반 범주화

범주화에 복수의 기준을 결합하는 것이 유용할 경우가 많지만, 아쉽게도 일반 범주화에서는 단일 기준만
적용됩니다. 이런 경우 규칙 기반 범주화를 쓸 수 있습니다.

• landuse 레이어의 Layer Properties 대화 창을 엽니다.

• Style 탭을 선택합니다.

• 범주화 스타일을 Rule-based 로 바꾸면 다음 화면을 보게 됩니다.
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• Click the Add rule 버튼 을 클릭하십시오.

• 그러면 새 대화 창이 나타납니다.

• Filter 텍스트 공간 옆에 있는 생략부호 ... 버튼을 클릭합니다.

• 이때 나타나는 쿼리 빌더를 이용해서, 기준이 될 표현식 "landuse" = 'residential' AND "name"
!= ' |majorUrbanName| ' 을 입력한 후 OK 를 클릭하고, 엷은 청회색을 선택한 다음 경계선을
제거합니다.
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• 새로운 기준인 "landuse" != 'residential' AND AREA >= 0.00005 를 추가하고 중간 정도의
녹색을 선택합니다.

• 다른 기준 "name" = ' |majorUrbanName| ' 을 추가하고 해당 지역에서 도시의 중요성을 강조하기
위해 짙은 청회색을 할당합니다.

• 이 기준을 목록 맨 위로 클릭 & 드래그합니다.

이필터들은배제적으로,다함께작용하여 (면적이 0.00005미만이거나,주거지역이아니거나, ‘Swellendam‘
에 포함되지 않을 경우) 맵 상의 일부 지역을 제외하게 됩니다. 이렇게 제외된 폴리곤들은 기본적인 (no
filter) 카테고리의 스타일을 적용받습니다.

맵 상에서 제외된 폴리곤들은 주거지역이 아니므로 기본 카테고리에 어울리는 엷은 청회색을 할당하도록
합시다.

이제 사용자의 대화 창이 이렇게 보여야 합니다.
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• 이 심볼을 적용하십시오.

사용자 맵이 다음과 비슷하게 보일 것입니다.

4.3. Lesson: 범주화 89



QGIS Training Manual, 출시 2.2

이제 Swellendam 이 가장 두드러진 주거지역으로 나타나고 다른 비주거지역은 면적에 따라 다른 색상을
보여주는 맵이 되었습니다.

4.3.6 In Conclusion

심볼을 이용하면 레이어의 속성들을 읽기 쉬운 방법으로 나타낼 수 있습니다. 우리가 선택한 연관 속성을
이용해서 피처의 중요성을 이해하도록 만들 수 있습니다. 여러분이 당면한 문제가 무엇이냐에 따라 다른
범주화 기술을 적용해서 문제를 해결하십시오.

4.3.7 What’s Next?

이제 멋진 맵을 만들었습니다만, 이것을 어떻게 QGIS 에서 분리시켜 인쇄할 수 있는 파일 형식이나 이미지
또는 PDF 로 만들 수 있을까요? 이것이 다음 강의의 주제입니다!
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CHAPTER 5

Module: 맵 생성

이 모듈에서 QGIS 맵 작성자 (Map Composer) 를 이용해 필수적인 맵 구성요소를 모두 갖춘 우수한 맵을
생산하는 방법을 배우게 됩니다.

5.1 Lesson: 맵 작성자 사용

이제맵을만들었으니인쇄하거나문서로내보내야합니다. 왜냐하면 GIS맵은이미지가아니기때문입니다.
오히려 모든 레이어, 라벨, 색상 등의 참조 정보를 담고 있는 GIS 프로그램의 현재 상태를 저장하는
것에 가깝습니다. 따라서 동일한 데이터나 (QGIS 같은) GIS 프로그램이 없는 사람에게 맵 파일은
무용지물입니다. 다행히도 QGIS 는 맵 파일을 어느 컴퓨터에서도 읽을 수 있는 포맷으로 내보낼 수 있고,
프린터가 연결돼 있다면 맵을 인쇄할 수도 있습니다. 이런 내보내기 및 인쇄는 모두 맵 작성자를 통해
이루어집니다.

이 강의의 목표: QGIS 맵 작성자를 사용해 필요한 모든 설정을 만족하는 기초 맵 생성하기.

5.1.1 Follow Along: 작성자 관리자

QGIS를사용하면동일한맵파일을이용해서복수의맵을생성할수있습니다. 이를위한도구를 Composer
Manager 라고 합니다.

• 메뉴의 Project → Composer Manager 항목을 클릭해서 이 도구를 실행합니다. 비어 있는 Composer
manager 대화 창이 나타날 것입니다.

• Add 버튼을 클릭하고 새 작성자에 Swellendam 의 명칭을 부여합니다.

• OK 를 클릭하십시오.

• Show 버튼을 클릭하십시오.

(대화 창을 닫은 후, 다음 그림처럼 File → Print Composers 메뉴를 통해 작성자에 접근할 수 있습니다.)
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어떤 방법을 택하든지 이제 Print Composer 창이 보일 것입니다.
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5.1.2 Follow Along: 기초 맵 작성

이 예제에서 맵은 이미 원하는 대로 작성돼 있습니다. 사용자 맵도 마찬가지인지 확인하십시오.

• Print Composer 창에서 Composition → Paper and Quality 아래의 값이 다음처럼 설정돼 있는지
확인하십시오.

• Size: A4 (210x297mm)

• Orientation: Landscape

• Quality: 300dpi

이제 원하는 대로 페이지 레이아웃을 설정했지만, 이 페이지는 맵을 담고 있지 않습니다. 맵을 불러봅시다!

• Add New Map 버튼 을 클릭합니다.

이 도구를 활성화하면 사용자가 페이지 위에 맵을 불러올 수 있습니다.

• 빈 페이지 상에서 클릭 & 드래그로 사각형을 그립니다.

페이지 상에 맵이 나타날 것입니다.

• 클릭 & 드래그로 맵을 이리저리 옮겨보십시오.
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• 사각형의 꼭지점 부분을 클릭 & 드래그해서 크기를 조정해보십시오.

주석: 물론 사용자 맵은 예제와 달라보일 겁니다! 사용자 자신의 프로젝트 설정에 따라 달라집니다.
하지만걱정하지마세요! 이것은일반적인지침이므로맵자체가어떻게보이던지상관없이동일하게작용할
것입니다.

• 페이지 주변을 따라 여백을 남기고, 위쪽에 제목을 위한 공간을 남겨두십시오.

• 다음 버튼을 사용해서 (맵이 아니라) 페이지를 줌인/줌아웃해보십시오.
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• QGIS 메인 창에서 맵을 줌 & 이동해보십시오. Move item content 도구 를 사용해서도 맵을
이동할 수 있습니다.

줌인할 경우, 맵 스스로 리프레시되지는 않습니다. 사용자가 원하는 곳으로 페이지를 줌인/줌아웃하는 동안
맵을 다시 그리는 시간을 절약하기 위한 것이지만, 반대로 줌인/줌아웃하는 동안 잘못된 해상도 때문에
이상해 보이거나 판독할 수 없게 되기도 합니다.

• 다음 버튼을 클릭해서 맵이 강제로 리프레시되도록 합니다.

여러분이맵에부여한크기와위치가최종이아니라는점을기억하십시오. 만족스럽지않다면향후언제라도
다시 바꿀 수 있습니다. 지금 이 시점에서는 이 맵에 대한 작업을 저장해야 할 필요가 있습니다. QGIS 의
Composer 가 메인 맵 파일의 일부이기 때문에, 여러분은 자신의 메인 프로젝트를 저장할 필요가 있습니다.
QGIS의메인창으로 (Layers list 및여러분이 이전에작업했던다른친숙한요소들이있는창으로)간다음
평소와 마찬가지로 프로젝트를 저장하십시오.

5.1.3 Follow Along: 제목 추가

페이지 상에 여러분의 맵을 보기 좋게 불러오긴 했지만, 판독자/사용자들에게 그 내용을 알려주고 있지는
않습니다. 일정한 문맥이 필요합니다. 맵 요소들을 추가해서 문맥을 부여할 수 있습니다. 먼저, 제목을
추가해봅시다.

• 이 버튼 을 클릭하십시오.

• 페이지에서 맵 윗 부분을 클릭하면 맵 위에 라벨이 나타날 것입니다.

• 페이지의상단한가운데로오도록크기와위치를조정합니다. 맵의크기와위치를조정한방법그대로
제목을 조정할 수 있습니다.

제목을 이동하면 페이지 한 가운데 맞출 수 있도록 지시선이 나타나는 것을 알 수 있습니다.

그런데 (페이지가 아니라) 맵을 기준으로 제목의 위치를 맞출 수 있는 도구도 있습니다.

• 맵을 클릭해서 선택하십시오.

• 키보드의 shift 자판을 누른 채로 라벨을 클릭해서 맵과 라벨을 모두 선택합니다.

• Align 버튼 을 찾아서 그 옆의 드롭다운 화살표를 클릭합니다. 위치 조정 옵션이 나타나면 Align
center 를 클릭합니다.
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이제 요소들의 위치를 맞췄으니 실수로 움직이는 일이 없도록 해야 합니다.

• 맵과 라벨을 모두 오른쪽 클릭합니다.

한 쪽에 작은 자물쇠 아이콘이 나타나 해당 요소를 드래그할 수 없다는 사실을 알려줍니다. 하지만 언제라도
다시 오른쪽 클릭으로 잠금을 풀 수 있습니다.

이제 맵을 기준으로 라벨을 중심에 오도록 했지만 그 내용까지는 아닙니다. 라벨의 내용을 가운데
정렬하려면,

• 라벨을 클릭해서 선택합니다.

• Composer 창의 사이드 패널에 있는 Item Properties 탭을 클릭합니다.

• 라벨 텍스트를 “Swellendam” 로 변경합니다.

• 이 인터페이스를 사용해서 폰트 및 정렬 옵션을 설정합니다.

• 크지만 식별할 수 있을 정도의 폰트를 (이 예제에서는 36 크기의 기본 폰트를 쓸 것입니다) 선택한
다음, Horizontal Alignment 를 Center 로 설정합니다.
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폰트 색상도 바꿀 수 있지만, 기본 설정인 검은색을 유지하는 것이 최선일 것입니다.

제목의 텍스트 상자에 테를 두르지 않는 것이 기본 설정입니다. 그러나 테를 두르고 싶다면 그렇게 할 수
있습니다.

• Item Properties 탭에서 아래 방향으로 스크롤해서 Frame 옵션을 찾으십시오.

• Frame 체크박스를 클릭해서 테를 활성화합니다. 또 테의 색상 및 굵기도 바꿀 수 있습니다.

이 예제에서는 테를 활성화하지 않을 것이기 때문에, 페이지가 다음과 같이 보입니다.

5.1.4 Follow Along: 범례 추가

맵을 읽는 사람이 맵 상의 다양한 오브젝트들이 정확히 무엇을 의미하는지 볼 수 있어야 합니다. 지명 같은
경우에는 한 눈에 알 수 있습니다. 그러나 농장의 색상 같은 알기 어려운 경우도 있습니다. 새 범례를
추가해봅시다.

• 버튼을 클릭합니다.

• 범례의 위치를 정하려면 페이지를 클릭한 다음 원하는 곳으로 이동시키십시오.
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5.1.5 Follow Along: 범례 항목 지정

범례에 보이는 모든 것이 꼭 필요한 것은 아닙니다. 따라서 필요하지 않은 일부 항목을 제거해보겠습니다.

• Item Properties 탭에서 Legend items 패널을 찾으십시오.

• buildings 항목을 선택한 다음,

• minus 버튼 을 클릭해서 범례에서 삭제합니다.

항목의 명칭을 바꿀 수도 있습니다.

• 동일한 목록에서 레이어를 선택한 다음,

• Edit 버튼 을 클릭합니다.

• 레이어들의 명칭을 Places, Roads and Streets, Surafce Water, Rivers 로 바꾸십시오.

• landuse 를 Hidden 으로 설정한 다음, 아래 방향 화살표를 클릭하고 각 카테고리를 범례에 나타낼
명칭으로 편집하십시오. 또 각 항목의 순서를 바꿀 수도 있습니다.
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이때 범례가 새 레이어명 때문에 넓어질 수 있으므로, 범례 또는 맵을 이동하거나 크기를 조정해야 할 수도
있습니다. 그 결과는 다음과 같습니다.

5.1.6 Follow Along: 사용자 맵 내보내기

주석: 여러분의 작업을 자주 저장해야 한다는 사실을 기억하시나요?

겨우 맵을 내보낼 준비가 끝났습니다! Composer 창의 좌상단에서 내보내기 버튼을 볼 수 있을 겁니다.
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가장 왼쪽에 있는 버튼은 Print 버튼으로, 프린터 인터페이스를 실행합니다. 사용자가 가지고 있는 프린터
모델에 따라 프린터 옵션이 달라지기 때문에, 인쇄에 대한 자세한 정보를 원한다면 프린터 매뉴얼이나
일반적인 지침을 살펴보는 편이 낫습니다.

다른 세 버튼으로 맵 페이지를 파일로 내보낼 수 있습니다. 다음 세 가지 파일 포맷을 선택할 수 있습니다.

• Export as Image

• Export as SVG

• Export as PDF

이미지로 내보내기는 여러분이 선택할 수 있는 다양한 일반 이미지 포맷들을 제공합니다. 가장 간단한
옵션일 테지만, 생성된 이미지는 “고정” 돼 있어 편집하기가 어렵습니다.

다른 두 가지 옵션이 더 자주 쓰입니다.

(출판을 위해 맵을 편집하기를 바라는) 지도제작자에게 맵을 보낼 경우, SVG 로 내보내는 것이 최선입니다.
SVG 는 “Scalable Vector Graphic” 의 약자로, Inkscape 나 다음 벡터 이미지 편집 소프트웨어 같은
프로그램이 불러들일 수 있습니다.

고객에게맵을보내야하는경우, 인쇄옵션설정이편하다는이유에서일반적으로 PDF포맷을사용합니다.
지도제작자가 이 포맷을 불러들이고 편집할 수 있는 프로그램을 가지고 있다면 PDF 포맷을 선호할 수도
있습니다.

이 예제에서는 PDF 포맷을 사용하겠습니다.

• Export as PDF 버튼 을 클릭하십시오.

• 평소와 마찬가지로 저장 위치 및 파일명을 선택하십시오.

• Save 를 클릭합니다.

5.1.7 In Conclusion

• Composer 창을 닫습니다.

• 사용자 맵을 저장합니다.

• 사용자 OS 의 파일관리자를 통해 내보낸 PDF 파일을 찾으십시오.

• PDF 파일을 엽니다.

• 성취감에 젖어보십시오.

여러분의 첫 번째 QGIS 맵 프로젝트를 종료한 것을 축하합니다!

5.1.8 What’s Next?

다음 강의에서 여러분은 완수해야 할 숙제를 받게 될 것입니다. 이제까지 배웠던 모든 기술들을 실제로
활용해볼 기회입니다.

5.2 과제 1

사용자의 기존 맵 프로젝트를 열어서 철저히 점검해보십시오. 자잘한 실수나 이전에 고치고 싶었던 것들이
있다면 지금 고쳐보십시오.

여러분의 맵을 사용자 지정하는 과정에서 계속 자문해보십시오. 이 데이터를 잘 모르는 사람이라도 이 맵을
쉽게 읽고 이해할 수 있을까? 인터넷이나 포스터, 혹은 잡지에서 이 맵을 봤다면 내 관심을 끌었을까? 내가
만든 지도가 아니었더라도 이 맵을 판독하고 싶었을까?
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여러분이 이 강의를 초급 또는 중급 수준에서 듣고 있다면 고급 부분에서 말하고 있는 기술들을
읽어보십시오. 여러분의 맵에 적용해보고 싶은 내용이 있다면, 지금 시행해보는 것은 어떨까요?

여러분이강의실에서이강의를받고있다면,강사가평가를위해여러분의맵최종버전을 PDF로내보내서
제출하도록 할 수도 있습니다. 여러분이 혼자 이 강의를 따라오고 있다면, 동일한 기준을 적용해서 자신의
맵을 평가해보도록 하십시오. 맵 자체의 전체적인 모양과 심볼 사용 방법은 물론 맵 페이지의 모양과
레이아웃, 구성요소 등에 따라 여러분의 맵을 평가하십시오. 맵의 모양을 평가하는 가장 중요한 기준은
사용하기 편한가 라는 점을 기억하시기 바랍니다. 보기 편할 수록, 한 눈에 이해하기 쉬울 수록 더 좋은
맵입니다.

사용자 마음대로 조정해보세요!

5.2.1 In Conclusion

처음 네 모듈에서 벡터 맵을 생성하고 스타일을 적용하는 방법에 대해 배웠습니다. 다음 네 모듈에서는
완전한 GIS 분석을 위해 QGIS 를 이용하는 방법에 대해 배우게 될 것입니다. 벡터 데이터의 생성 및 편집,
벡터 데이터 분석, 래스터 데이터의 이용 및 분석, 그리고 래스터 및 벡터 데이터소스를 이용해서 처음부터
끝까지 GIS 를 통해 문제를 해결하기 등을 배우게 됩니다.
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CHAPTER 6

Module: 벡터 데이터 생성

기존데이터를이용해서맵을생성하는것은시작에불과합니다. 이모듈에서는기존벡터데이터를수정하고
새 데이터베이스를 처음부터 만드는 방법에 대해 배울 것입니다.

6.1 Lesson: 새 벡터 데이터셋 생성

여러분이 사용하는 데이터는 출처가 있어야 합니다. 가장 일반적인 응용 작업의 경우, 이미 존재하는
데이터를 사용합니다. 그러나 특별하고 전문적인 프로젝트일수록, 사용할 수 있는 데이터가 이미 존재할
가능성은 적어집니다. 이런 경우 여러분 자신의 새 데이터를 생성해야 합니다.

이 강의의 목표: 새 벡터 데이터셋 생성하기.

6.1.1 Follow Along: 레이어 생성 대화 창

새 벡터 데이터를 추가하려면 먼저 데이터를 추가할 벡터 데이터셋이 필요합니다. 이 예제에서는 기존
데이터셋을편집하기보다완전히새로운데이터를생성해보려합니다. 따라서사용자자신의새데이터셋을
먼저 정의해야 합니다.

새 레이어를 정의할 수 있는 New Vector Layer 대화창을 열어야 합니다.

• 메뉴에서 Layer → New → New Shapefile Layer 항목을 찾아 클릭하십시오.

다음 대화 창이 나타날 것입니다.
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이 단계에서 어떤 유형의 데이터셋을 생성할지 결정하는 것이 중요합니다. 서로 다른 벡터 레이어 유형은
백그라운드에서 “서로다르게”구성되기때문에레이어를생성한후에는유형을변경할수없기때문입니다.

다음 예제에서 지역을 나타내는 새 피처들을 생성할 예정입니다. 이런 피처의 경우, 폴리곤 데이터셋을
생성해야 합니다.

• Polygon 라디오 버튼을 클릭하십시오.
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대화 창의 다른 항목에 아무런 영향도 미치지 않지만, 벡터 데이터셋을 생성했을 때 정확한 도형 유형을
사용하게 해줍니다.

다음항목을통해좌표계,또는 CRS를설정할수있습니다. CRS는지구상의한점을좌표형태로표현하는
방법을 설정하는데, 아주 많은 방법이 있기 때문에 아주 많은 CRS 들이 있습니다. 이 프로젝트의 CRS 는
WGS84 로, 기본값을 그대로 쓰면 됩니다.

다음으로 New attribute 아래 모여 있는 항목 집합이 있습니다. 기본적으로 새 레이어는 단일 속성, 즉 다음
그림에 보이는 (Attributes list 에서 볼 수 있는) id 항목만을 가집니다. 그러나 여러분이 생성하는 데이터를
유용하게 만들려면 이 새 레이어 안에 생성할 피처에 대해 뭔가 정보를 부여할 필요가 있습니다. 이 예제의
목표에 따라, name 이라는 항목 하나를 추가하는 것으로 충분할 것입니다.

• 아래 설정을 그대로 따라한 다음 Add to attributes list 버튼을 클릭하십시오.

• 대화 창이 다음 그림처럼 보이는지 확인하십시오.
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• OK 를 클릭합니다. 저장 대화 창이 나타납니다.

• exercise_data 디렉터리를 찾아갑니다.

• 사용자가 만든 새 레이어를 school_property.shp 으로 저장합니다.

새 레이어가 Layers list 에 추가됐을 것입니다.
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6.1.2 Follow Along: 데이터소스

새 데이터를 생성하는 작업은 당연히 지표면에 실재하는 오브젝트에 관련된 것이어야 합니다. 따라서
어딘가에서 해당 정보를 구해야 합니다.

오브젝트 관련 데이터를 구할 수 있는 방법은 많습니다. 예를 들어 GPS 를 이용해서 실재 세계에 있는
포인트들을 데이터화한 다음 QGIS 로 불러들일 수 있습니다. 또는 경위의 측량계를 통해 포인트를 측정한
다음 좌표를 직접 입력해서 새 피처를 생성할 수도 있습니다. 아니면 위성영상이나 항공사진 같은 원격탐사
데이터로부터 오브젝트를 따오는 디지털라이즈 작업을 할 수도 있습니다.

이 예제에서는 디지털라이즈 작업을 이용합니다. 래스터 데이터셋 샘플을 갖추고 있으므로, 필요한 대로
불러들여야 합니다.

• Add Raster Layer 버튼 을 클릭합니다.

• exercise_data/raster/ 디렉터리를 찾아가십시오.

• 3420C_2010_327_RGB_LATLNG.tif 파일을 선택합니다.

• Open 을 클릭합니다. 사용자 맵에 이미지가 로드될 것입니다.

• Layers list 에서 이 새 이미지를 찾아보십시오.

• 목록 맨 아래로 이미지를 클릭 & 드래그해서 사용자의 다른 레이어를 볼 수 있도록 합니다.

• 다음 지역을 찾아 줌인/줌아웃하십시오.

주석: buildings 레이어 심볼이 래스터 레이어의 일부 또는 전체를 덮고 있다면, Layers panel 에서 해당
레이어를 선택 해제해서 일시적으로 비활성화시킬 수 있습니다. 또 roads 심볼이 방해가 된다면 마찬가지로
숨길 수도 있습니다.

다음 세 군데 학교 부지를 디지타이즈할 것입니다.
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디지타이즈를 시작하려면 편집 모드 로 들어가야 합니다. GIS 소프트웨어는 우연히 중요한 데이터를
편집하거나 삭제하는 일을 막기 위해 일반적으로 이런 단계를 거치게 합니다. 각 레이어에 대해 개별적으로
편집 모드를 켜거나 끌 수 있습니다.

school_property 레이어에 대해 편집 모드로 들어가려면,

• Layer list 에있는해당레이어를클릭해서선택하십시오. (정확한레이어를선택했는지확인하십시오.
다른 레이어를 편집하게 될 수도 있습니다!)

• Toggle Editing 버튼 을 클릭합니다.

이 버튼을 찾을 수 없을 경우, Digitizing 툴바가 활성화돼 있는지 확인해보십시오. View → Toolbars →
Digitizing 메뉴 항목 옆에 체크 표시가 있어야 합니다.

편집 모드로 들어간 순간 디지타이즈 작업 도구가 활성화되는 것을 볼 수 있습니다.

다른 관련 버튼 네 개가 아직 활성화되지 않았지만, 새 데이터와 상호작용을 시작하면 활성화될 것입니다.

툴바의 왼쪽에서 오른쪽 방향으로 각각 다음과 같습니다.

• Save Edits: 레이어의 변경 사항을 저장합니다.
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• Add Feature: 새 피처의 디지타이즈 작업을 시작합니다.

• Move Feature(s): 피처 전체를 이동합니다.

• Node Tool: 피처의 일부만을 이동합니다.

• Delete Selected: 선택한 피처를 삭제합니다.

• Cut Features: 선택한 피처를 잘라냅니다.

• Copy Features: 선택한 피처를 복사합니다.

• Paste Features: 잘라낸 또는 복사한 피처를 다시 맵에 붙여넣습니다.

새 피처를 추가할 차례입니다.

• Add Feature 버튼을 클릭해서 학교 운동장을 디지타이즈하는 작업을 시작하겠습니다.

마우스 커서가 십자 모양으로 변한 것을 눈치채셨습니까? 여러분이 좀 더 정확하게 포인트의 위치를
디지타이즈할 수 있도록 해줍니다. 디지타이즈 작업 도중이라도 마우스 휠을 돌려 맵을 줌인/줌아웃할
수 있고, 마우스 휠을 누른 채 드래그해서 맵을 이동할 수 있다는 것을 기억하십시오.

여러분이 디지타이즈할 첫 번째 피처는 다음 athletics field 입니다.

• 운동장의 경계 어딘가의 포인트를 클릭해서 디지타이즈 작업을 시작합니다.

• 여러분이 그리는 도형이 운동장을 완전히 가릴 때까지 경계를 따라 계속 포인트를 클릭합니다.

• 마지막 포인트의 위치를 디지타이즈한 다음, 오른쪽 클릭 으로 폴리곤 그리기를 완료합니다. 피처가
완성되고 Attributes 대화 창이 나타날 것입니다.

• 다음과 같이 값을 입력하십시오.
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• OK 를 클릭하면 새 피처가 생성됩니다!

피처를 디지타이즈할 때 실수를 했을 경우, 피처 생성 후에 언제라도 편집/수정할 수 있다는 사실을
기억하십시오. 실수를 했다 하더라도 앞의 지침대로 피처를 완성할 때까지 디지타이즈 작업을 계속한 다음,

• Select Single Feature 도구로 해당 피처를 선택합니다.

다음 도구를 사용할 수 있습니다.

• Move Feature(s) 도구로 전체 피처를 이동할 수 있고,

• Node Tool 도구로 여러분이 잘못 클릭한 단일 포인트를 이동시킬 수 있으며,

• Delete Selected 도구로 피처를 완전히 삭제하고 다시 디지타이즈 작업을 시작하거나,
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• Edit → Undo 메뉴 항목이나 ctrl + z 단축키로 실수한 부분을 되돌릴 수도 있습니다.

6.1.3 Try Yourself

• 이제 학교와 그 위에 있는 운동장을 디지타이즈해보겠습니다. 다음 이미지를 참고하십시오.

새 피처에 각각 유일한 id 값을 부여해야 한다는 점을 기억하십시오!

주석: 레이어에 피처를 추가하는 작업이 끝나면, 편집한 내용을 저장하고 편집 모드에서 나와야 한다는
사실을 잊지 마십시오.

주석: 이전 강의에서 배운 기술을 이용해서 school_property 의 면, 윤곽선, 라벨 위치 및 서식에 스타일을
적용할 수 있습니다. 이 예제에서는 투명한 면에 밝은 보라색 점선의 윤곽선을 적용해봅시다.
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6.1.4 Try Yourself

• routes.shp 라는 파일명으로 id 와 type 속성을 가진 새 라인 피처를 생성합니다. (앞에 나왔던
지침을 따르십시오.)

• 현재도로레이어에표시되지않은경로두개를디지타이즈해보겠습니다. 하나는길이고,다른하나는
산길입니다.

이 길은 Railton 의 교외 남쪽 경계를 따라, 표시된 두 도로에서 시작하고 끝납니다.

산길은 좀 더 남쪽에 있습니다.
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routes 레이어에 이 길과 산길을 차례로 디지타이즈해보십시오. 갈림길이나 굽이마다 (왼쪽 클릭으로)
포인트를 찍으며 이 경로들을 최대한 정확히 따라가보십시오.

각 경로를 생성한 다음, path 와 track 이라는 type 속성값을 부여하십시오.

아마도 포인트만 표시되었을 수도 있습니다. Layer Properties 대화 창을 통해 경로에 스타일을
적용하십시오. 사용자 마음대로 길과 산길에 각각 다른 스타일을 적용해보십시오.

편집 내용을 저장하고 편집 모드를 끕니다.

결과 확인

6.1.5 In Conclusion

이제 피처를 생성하는 법을 배웠습니다! 이 강의에서는 포인트 피처를 추가하는 법을 다루지 않았는데,
여러분이 (라인이나 폴리곤 같은) 좀 더 복잡한 피처를 다루는 법을 안다면 포인트 피처도 쉽게 생성할 수
있기때문입니다. 포인트위치를딱한번클릭하는것만제외하면,속성을부여하고피처를생성하는방법은
똑같습니다.

디지타이즈는 GIS 프로그램을 사용하면서 매우 일상적인 작업이기 때문에 그 방법을 아는 것은 매우
중요합니다.

6.1.6 What’s Next?

GIS 레이어 안의 피처는 그냥 그림이 아니라 공간에 있는 오브젝트입니다. 예를 들어 인접한 폴리곤들은
서로의 상대적인 위치를 알고 있습니다. 이것을 위상 (topology) 이라고 합니다. 다음 강의에서 이 위상이
어떻게 유용한지에 대한 예제를 배울 것입니다.

6.2 Lesson: 피처의 위상

위상은 벡터 데이터 레이어의 유용한 성질입니다. 겹침이나 틈과 같은 오류를 최소화해주기 때문입니다.
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예를 들면, 피처 두 개가 경계선을 공유하는데 위상을 이용해서 경계선을 편집하는 경우, 먼저 첫 번째
피처를 편집한 다음 두 번째 피처를 편집하고 경계선을 정교하게 맞출 필요가 없습니다. 공유하는 경계선을
편집해서 두 피처를 동시에 변경할 수 있습니다.

이 강의의 목표: 예제를 통해 위상을 이해하기.

6.2.1 Follow Along: 맞추기

위상적 편집을 더 쉽게 하려면 맞추기 기능을 활성화하는 것이 최선입니다. 이렇게 하면 디지타이즈 작업
동안 마우스 커서가 다른 오브젝트에 자동으로 맞춰집니다. 맞추기 옵션을 설정하려면,

• Settings → Snapping Options... 메뉴 항목을 찾아보십시오.

• Snapping options 대화 창을 다음과 같이 설정하십시오.

• Avoid Int. 열에 있는 체크박스를 체크하십시오. (참으로 설정합니다.)

• OK 를 클릭해서 변경 사항을 저장하고 대화 창을 닫습니다.

• landuse 레이어를 선택하고 편집 모드로 들어갑니다.

• View → Toolbars 메뉴에서 Advanced Digitizing 툴바가 활성화돼 있는지 확인하십시오.

• 다음 지역으로 줌인/줌아웃합니다. (필요한 경우 레이어와 라벨을 활성화하십시오.)
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• 새 (가공의) Bontebok National Part 지역을 디지타이즈합니다.

• 대화 창이 나타나면 OGC_FID 값을 999 로 설정하십시오. 다른 값들은 그대로 놔둬도 됩니다.

세심하게 디지타이즈 작업을 했고, 인접한 농장들의 꼭지점에 커서가 자동으로 맞춰지도록 했다면 사용자가
새로 만든 농장과 기존 인접 농장들 사이에 틈이 생기지 않았다는 사실을 알 수 있을 것입니다.

• Advanced Digitizing 툴바에 되돌리기/다시 실행 도구가 있습니다.
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6.2.2 Follow Along: 올바른 위상적 피처

때로 위상 피처를 업데이트해야 할 수도 있습니다. 이 예제에서는, landuse 레이어에 최근 합쳐져 하나의
구역을 형성한 몇몇 복잡한 산림 구역이 있습니다.

산림 구역을 합치기 위해 새 폴리곤을 생성하기 보다, Node Tool 을 이용해서 기존 폴리곤을 편집하고
합쳐보도록 하겠습니다.

• 편집 모드에서 이미 나왔다면 다시 활성화합니다.

• Node Tool 을 선택하십시오.

• 산림 구역 하나를 골라, 모서리를 선택하고 인접한 모서리로 이동해서 두 산림 구역이 만나도록
해보겠습니다.

116 Chapter 6. Module: 벡터 데이터 생성



QGIS Training Manual, 출시 2.2

• 노드들을 서로 맞춰질 때까지 클릭 & 드래그하십시오.

위상적으로 올바른 경계선은 다음과 같이 보입니다.
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다시 Node Tool 을 이용해서 몇 개 구역을 더 합쳐보십시오. 적합한 경우라면 Add Feature 도구를 사용할
수도 있습니다. 공식 예제 데이터를 사용하고 있다면 다음과 같은 산림 구역을 얻게 될 것입니다.

산림 구역을 그림보다 더, 혹은 적게, 아니면 다른 구역들을 합쳤다고 해도 괜찮습니다.
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6.2.3 Follow Along: Tool: 피처 단순화

다음은 Simplify Feature 도구입니다.

• 클릭해서 실행하십시오.

• Node Tool 또는 Add Feature도구를사용해합친구역들가운데하나를클릭하십시오. 다음대화창이
나타날 것입니다.

• 슬라이더를 좌우로 움직이면서 맵이 어떻게 변하는지 살펴보십시오.
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이렇게 복잡한 피처가 가지고 있는 노드의 개수를 줄일 수 있습니다.

• OK 를 클릭하십시오.

이 도구가 위상에 어떤 영향을 미쳤는지 보십시오. 단순화된 폴리곤은 맞닿아 있어야 할 인접 폴리곤과
맞닿아 있지 않습니다. 즉 이 도구는 홀로 떨어져 있는 피처를 단순화하는 데 더 어울립니다. 이 도구의
장점은 단순화 작업을 위해 간단하고 직관적인 인터페이스를 제공하는 데 있습니다.

다음 단계를 시작하기 전에 마지막 변경 사항을 되돌려 원래 폴리곤 상태로 설정하십시오.

6.2.4 Try Yourself 고리 추가 도구

다음은 Add Ring 도구입니다.

이 도구를 사용하면 피처에 구멍을 - 피처가 구멍을 완전히 둘러싸고 있을 경우에만 - 낼 수 있습니다. 예를
들자면 남아프리카 공화국의 국경선을 디지타이즈한 다음 레소토 왕국 자리에 구멍을 내고 싶을 경우 이
도구를 이용하면 됩니다.

이 도구를 사용해본다면, 지금처럼 맞추기 옵션이 켜져 있는 경우 폴리곤 가운데에 고리를 생성할 수 없다는
사실을 알게 될 것입니다. 제외하려는 지역이 폴리곤 경계선과 연결돼 있다면 이 사실은 아무런 문제도 안
됩니다.

• 이전 단계에서 사용했던 대화 창을 통해 landuse 레이어에 대한 맞추기 옵션을 비활성화합니다.

• Now try using the Add Ring tool tool to create a gap in the middle of the Bontebok National Part.

• 다음 Delete Ring 도구를 써서 새 피처를 삭제하십시오.

주석: 고리를 삭제하려면 모서리를 선택해야 합니다.

결과 확인

6.2.5 Try Yourself 부분 추가 도구

다음은 Add Part 도구입니다.

이도구를이용하면주피처에직접연결되지않은부분피처를생성할수있습니다. 예를들자면남아프리카
공화국의 국경선을 디지타이즈했지만 프린스에드워드아일랜드 주를 빼먹었을 때, 이 도구를 써서 섬을
추가할 수 있습니다.

• 이 도구를 사용하려면 먼저 다음 Select Single Feature 도구를 써서 부분을 추가하고자 하는 폴리곤을
선택해야 합니다.

• 이제 Add Part 도구를 써서 Bontebok National Part 바깥에 구역을 추가해보십시오.

• 다음 Delete Part 도구로 새로 만든 피처를 삭제합니다.
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주석: 부분을 삭제하려면 모서리를 선택해야 합니다.

결과 확인

6.2.6 Follow Along: Tool: 피처 형태 수정

다음은 Reshape Features 도구입니다.

이 도구를 이용해 기존 피처에 요철을 추가할 수 있습니다. 이 도구를 선택한 다음,

• Bontebok National Part 안쪽을 클릭해서 폴리곤을 그리십시오.

• 세 번 클릭해서 폴리곤을 그리십시오. 마지막 클릭 위치를 기존 폴리곤 안쪽으로 해서, 한 변이 열린
사각형 모양으로 만드십시오.

• 오른쪽 클릭으로 폴리곤 그리기를 마칩니다.

다음과 비슷한 결과를 보게 될 것입니다.
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반대로 작업할 수도 있습니다.

• 폴리곤 바깥을 클릭하십시오.

• 폴리곤 안쪽으로 사각형을 그리십시오.

• 폴리곤 바깥에서 다시 오른쪽 클릭합니다.

다음과 비슷한 결과를 보게 될 것입니다.
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6.2.7 Try Yourself 피처 쪼개기 도구

다음 Split Features 도구는 바로 앞에서 했던 폴리곤의 일정 부분을 없애는 기능과 비슷하지만, 두 부분
가운데 하나를 삭제하는 게 아니라 두 부분을 모두 유지시킵니다.

• 먼저 landuse 레이어에 대한 맞추기 옵션을 다시 활성화하십시오.

이 도구를 이용해서 Bontebok National Part 로부터 한 모서리를 쪼개보겠습니다.

• Split Features 도구를 선택한 다음 꼭지점 하나를 클릭해서 라인을 그리십시오. 쪼개기를 바라는
반대편의 아무 꼭지점이나 클릭하고 오른쪽 클릭으로 라인을 완성합니다.
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• 이 단계에서는 아무 일도 일어나지 않은 것처럼 보일 겁니다. 그러나 landuse 레이어에는 경계선
심볼이 없으므로, 새 쪼개기 라인도 보이지 않는 것입니다.

• Select Single Feature 도구로 방금 쪼갠 모서리를 선택해보십시오. 새 피처가 다음과 같이
하이라이트될 것입니다.
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6.2.8 Try Yourself 피처 합치기 도구

방금 기존 폴리곤에서 쪼갠 피처를 다시 합쳐보도록 합시다.

• Merge Selected Features 및 Merge Attributes of Selected Features 도구를 사용해보십시오.

• 달라진 점을 확인해보십시오.

결과 확인

6.2.9 In Conclusion

위상 편집은 오브젝트를 빠르고 쉽게 생성하고 변경하면서도 위상적으로 올바르게 유지할 수 있는 강력한
도구입니다.

6.2.10 What’s Next?

이제 오브젝트의 형태를 쉽게 디지타이즈하는 방법을 배웠습니다. 그러나 속성을 추가하는 작업은 아직
조금 어렵습니다! 다음 강의에서 서식을 이용해서 속성을 더 간단하고 효과적으로 할 수 있는 방법을
배워보겠습니다.

6.3 Lesson: 서식

디지타이즈 작업으로 새 데이터를 추가할 때, 피처에 대한 속성을 입력할 수 있는 대화 창이 나타납니다.
그러나이기본대화창은한눈에파악하기어렵습니다. 특히여러분이대용량데이터셋을생성하거나,다른
사람들에게 디지타이즈 작업을 부탁했는데 기본 서식을 이해하기 어려워 할 경우 유용성 문제가 제기될 수
있습니다.

QGIS 를 사용하면, 다행히도 레이어에 대한 사용자 지정 대화 창을 생성할 수 있습니다. 이 강의에서 그
방법을 배워보겠습니다.

이 강의의 목표: 레이어에 대한 서식을 생성하기.

6.3.1 Follow Along: QGIS 서식 디자인 기능 이용

• Layers list 에서 roads 레이어를 선택하십시오.

• 이전과 마찬가지로 Edit Mode 로 들어갑니다.

• 레이어의 Attribute Table 을 엽니다.

• 테이블의 아무 셀이나 오른쪽 클릭하십시오. Open form 항목만 있는 간략한 메뉴가 나타납니다.

• 이 항목을 클릭해서 QGIS 가 이 레이어를 위해 생성한 서식을 살펴보십시오.

물론 항상 Attribute Table 에서 특정 거리를 찾아봐야 하는 것보다 맵을 보면서 이 작업을 할 수 있다면
좋겠죠.

• 메뉴의 Settings → Options 항목을 선택합니다.

• 새로 나타난 대화 창에서 Map Tools 탭을 선택합니다.

• Open feature form ... 체크박스를 체크합니다.
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• OK 를 클릭합니다.

• Layers list 에서 roads 레이어를 선택하십시오.

• 다음 Identify 도구를 사용해서 맵에 있는 아무 거리나 클릭해보십시오.

일반적인 Identify 대화 창 대신 이제 익숙한 서식이 보일 것입니다.
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6.3.2 Try Yourself 서식을 이용해서 값 편집

편집 모드에 들어온 상태라면, 이 서식을 사용해서 피처의 속성을 편집할 수 있습니다.

• (편집 모드가 아니라면) 편집 모드를 활성화하십시오.

• Identify 도구를 써서 Swellendam 을 가로지르는 중심가를 클릭하십시오.
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• 중심가의 highway 값을 secondary 로 편집합니다.

• 편집 내용을 저장하십시오.

• 편집 모드에서 나오십시오.

• Attribute Table 을 열고 속성 테이블에 있는 값이 업데이트된 것을 확인해보십시오. 따라서 소스
데이터의 값도 업데이트되었습니다.

주석: 기본 데이터셋을 쓰고 있다면, 이 맵에 Voortrek Street 이라는 도로가 하나 이상 있다는 사실을
알 수 있을 겁니다.

6.3.3 Follow Along: 서식 항목 유형 설정

서식을 사용해서 편집하는 것도 좋지만, 모든 것을 직접 입력해야 하기도 합니다. 다행스럽게도, 서식에는
서로 다른 다양한 방법으로 데이터를 편집할 수 있도록 해주는, 소위 말하는 *위젯 * 이 여러 종류 있습니다.

• roads 레이어의 Layer Properties 를 엽니다.

• Fields 탭을 선택하십시오. 다음과 같은 창을 볼 수 있습니다.
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• man_made 와 동일한 행에 있는 Line edit 버튼을 클릭하면 새로운 대화 창이 나타납니다.

• 옵션 목록에서 Checkbox 를 선택합니다.
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• OK 를 클릭합니다.

• (roads 레이어의 편집 모드를 활성화하지 않은 경우) 편집 모드로 들어갑니다.

• Identify 도구를 클릭합니다.

• 이전과 동일한 중심가를 클릭합니다.

이제 man_made 속성 옆에 True (체크함) 또는 False (체크 안 함) 를 나타내는 체크박스가 보일 것입니다.

6.3.4 Try Yourself

highway 항목에 더 적합한 위젯을 설정해보십시오.

결과 확인

6.3.5 Try Yourself 테스트 데이터 생성

완전히 새로운 여러분만의 사용자 지정 서식을 디자인할 수도 있습니다.

• 다음 두 속성을 가진 test-data 라는 단순한 포인트 레이어를 생성하십시오.

– Name (텍스트)

– Age (텍스트)
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• 이 새 레이어에 디지타이즈 작업 도구로 포인트 몇 개를 찍어 간단한 데이터를 준비하십시오. 새
포인트를 만들 때마다 QGIS 의 기본 속성 부여 서식이 나타날 것입니다.

주석: 이전 단계에서 맞추기 옵션을 활성화시킨 채라면 비활성화시켜야 할 수도 있습니다.
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6.3.6 Follow Along: 새 서식 생성

이제 속성 데이터 부여 단계를 위해 사용자 지정 서식을 생성해야 합니다. 이를 위해 Qt4 Designer 를
설치해야 합니다. (이 프로그램은 서식을 생성하기 위해서만 필요합니다.) 윈도우를 사용하고 있다면 기본
강의 자료에 포함돼 있을 것입니다. 다른 OS 를 사용하는 경우 직접 검색해서 찾아야 합니다. 우분투를
사용하고 있다면 터미널에서 다음 내용을 실행하면...

주석: 이 강의를 작성하는 현재 최신 버전은 Qt5 입니다. 그러나 이 과정에서 필요한 것은 Qt4 로, 꼭 Qt5
와 호환되는 것은 아닙니다.

sudo apt-get install qt4-designer

... 자동적으로 설치될 것입니다. 설치가 안 된다면 소프트웨어 센터 에서 찾아보십시오.

• 윈도우의 시작 메뉴 에서 (아니면 사용자의 OS 에 적합한 실행 방법으로) Qt4 Designer 를
실행하십시오.

• 새 대화 창을 생성할 수 있는 다음 대화 창이 나타납니다.
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• 창의 (기본적으로) 왼쪽에 있는 Widget Box 를 찾아보십시오. Line Edit 라는 항목을 담고 있습니다.

• 이 항목을 여러분의 서식으로 클릭 & 드래그합니다. 서식에 새로운 Line Edit 이 생성될 것입니다.

• 이 새로운 라인 편집 요소를 선택하면 (기본적으로 창의 오른쪽에 있는) 요소의 속성 창을 볼 수
있습니다.
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• Name 이라고 명명합니다.

• 동일한 방법으로, 새 스핀박스를 생성하고 Age 라고 명명합니다.

• 굵은 폰트의 Add a New Person 라는 텍스트를 가진 Label 을 추가합니다. (폰트를 설정하려면
오브젝트의 속성 창을 살펴보십시오.) 아니면 (라벨을 추가하기보다) 대화 창 자체의 제목으로 설정할
수도 있습니다.

• 사용자의 대화 창 아무 곳이나 클릭하십시오.

• (기본적으로 창의 맨 위에 있는 툴바에 있는) Lay Out Vertically 버튼을 찾아 클릭하십시오. 사용자의
대화창 내용을 자동으로 정렬합니다.

• (속성 창에서) 대화 창의 최대 크기를 200 (너비) x 100 (높이) 로 설정합니다.

• exercise_data/forms/add_people.ui 경로와 파일명으로 새 서식을 저장하십시오.

• 저장이 완료되면 Qt4 Designer 프로그램을 닫아도 됩니다.

6.3.7 Follow Along: 서식과 사용자 레이어의 연계

• QGIS 로 다시 돌아갑니다.

• 레이어 목록의 test-data 레이어를 더블클릭해서 속성 테이블을 엽니다.

• Layer Properties 대화 창의 Fields 탭을 클릭합니다.

• Attribute editor layout 드롭다운 메뉴에서 Provide ui-file 을 선택합니다.

• 생략부호 버튼을 클릭한 다음 방금 생성한 add_people.ui 파일을 선택합니다.
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• Layer Properties 대화 창의 OK 를 클릭합니다.

• 편집 모드로 들어가 새 포인트를 찍어보십시오.

• 이제 (QGIS 가 보통 생성하는 기본 대화 창 대신) 사용자 지정 대화창이 나타날 것입니다.

• Identify도구를사용해사용자의포인트하나를클릭할경우,식별결과창을오른쪽클릭하고콘텍스트
메뉴에서 View Feature Form 을 선택하면 사용자 지정 서식을 불러올 수 있습니다.

• 이 레이어에 대해 편집 모드로 들어가 있다면, 콘텍스트 메뉴에 Edit Feature Form 이 대신 보일
것입니다. 이제 포인트를 찍은 직후라 할지라도 새 서식에서 속성을 조정할 수 있습니다.

6.3.8 In Conclusion

데이터 편집이나 생성 시 서식을 이용하면 훨씬 편하게 작업할 수 있습니다. 위젯 유형을 편집하거나 완전히
새로운 서식을 생성해서 해당 레이어를 위해 새 데이터를 디지타이즈하는 사람의 경험을 향상시켜 오해 및
불필요한 오류를 최소화할 수 있습니다.

6.3.9 Further Reading

앞의 고급 내용을 완료했고 파이썬을 알고 있을 경우, 파이썬 로직으로 사용자 지정 피처를 생성하는 내용을
담고 있는 이 블로그 포스트 를 참고해보십시오. 파이썬 로직을 이용하면 데이터 유효성 확인, 자동 완성 등
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고급 기능을 사용할 수 있습니다.

6.3.10 What’s Next?

QGIS 의 표준 액션 가운데 하나가 피처를 식별하는 작업과 동시에 서식을 여는 것입니다. 그러나 사용자가
정의한 사용자 지정 액션을 실행하도록 할 수 있습니다. 이것이 다음 강의의 내용입니다.

6.4 Lesson: 액션

이전 강의에서 기본 액션에 대해 알았으니, 이제 여러분 자신의 액션을 정의해볼 차례입니다. 액션이란
피처를 클릭했을 때 일어나는 어떤 일을 말합니다. 액션으로 사용자 맵에 수많은 기능성을 추가할 수
있습니다. 예를 들자면 오브젝트에 대한 추가적인 정보를 얻을 수 있습니다. 액션을 할당함으로써 여러분의
맵에 완전히 새로운 차원을 추가할 수 있습니다!

이 강의의 목표: 사용자 지정 액션을 추가하는 방법을 배우기.

6.4.1 Follow Along: 이미지 열기

이전강의에서생성한 school_property레이어를사용합니다. 강의자료에여러분이디지타이즈한세부지의
사진이 포함돼 있습니다. 다음 단계는 각 부지에 해당 이미지를 연계시키는 것입니다. 그 다음, 부지를
클릭하면 해당 부지의 사진을 나타내는 액션을 생성할 것입니다.

6.4.2 Follow Along: 이미지 용 항목 추가

school_property 레이어의 속성에 이미지를 연계시킬 방법이 아직 없습니다. 먼저 이를 위한 항목을
생성하겠습니다.

• Layer Properties 대화 창을 엽니다.

• Fields 탭을 클릭합니다.

• 편집 모드를 엽니다.
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• 다음 새 열을 추가합니다.
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• 다음 값을 입력합니다.
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• 항목을 생성한 다음, 새 항목 옆에 있는 Line edit 버튼을 클릭합니다.

• 다음과 같이 File name 에 대해 설정합니다.
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• Layer Properties 대화 창의 OK 를 클릭합니다.

• Identify 도구를 사용해 school_property 레이어에 있는 세 피처 가운데 하나를 클릭합니다.

아직 편집 모드이므로, 다음과 같은 대화 창이 나타날 것입니다.
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• image 항목 옆의 ... 탐색 버튼을 클릭하십시오.

• 사용자이미지가있는경로를선택하십시오. 이미지들은 exercise_data/school_property_photos/
경로에 있으며, 각각 연계되어야 할 피처와 동일한 명칭을 가지고 있습니다.

• OK 를 클릭합니다.

• 이런 방법으로 모든 이미지들을 올바른 피처와 연계하십시오.

• 편집 내용을 저장하고 편집 모드를 끕니다.

6.4.3 Follow Along: 액션 생성

• school_property 레이어에 대한 Actions 서식을 엽니다.

• Action properties 패널에 있는 Name 항목에 Show Image 라는 텍스트를 입력합니다.
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다음 단계는 사용자의 OS 에 따라 달라지므로, 다음 가운데 적합한 지침을 선택하십시오.

윈도우

• Type 드롭다운 메뉴를 클릭하고 Open 을 선택합니다.

우분투 리눅스

• Action 아래에 Gnome Image Viewer 를 위해 eog 를 입력하거나, ImageMagick 를 사용하려면
display 를 입력합니다. 명령어 뒤에 공백을 입력해야 한다는 점을 기억하십시오!

MacOS

• Type 드롭다운 메뉴를 클릭하고 Mac 을 선택합니다.

• Under Action, write :kbd:‘open ‘. Remember to put a space after the command!
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명령어 입력 계속

우리는 이미지를 열기를 원하고, QGIS 는 이미지의 경로를 알고 있습니다. 이제 남은 것은 Action 에
이미지의 경로를 알려주는 일뿐입니다.

• 다음 목록에서 image 를 선택하십시오.

• Insert field 항목을 클릭하십시오. QGIS 가 Action 항목에 [% "image" %] 라는 문구를 추가할
것입니다.

• Add to action list 버튼을 클릭합니다.

• Layer Properties 대화 창의 OK 를 클릭합니다.

이제 새로 만든 액션을 테스트해봅시다.

• Layers list 에 있는 school_property 레이어를 클릭해서 하이라이트시킵니다.

• (Open Attribute Table 버튼이 있는 툴바에서) 다음 Run feature action 버튼을 찾아보십시오.

• 이 버튼의 오른쪽에 있는 아래 방향 화살표를 클릭해보십시오. 지금 현재 이 레이어에 정의된 액션은
여러분이 방금 생성한 하나뿐입니다.

• 버튼을 클릭해서 도구를 활성화합니다.

• 이 도구를 이용해서, 학교 부지 세 곳 가운데 하나를 클릭합니다.

• 해당 부지의 사진이 열릴 것입니다.

6.4.4 Follow Along: 인터넷 검색

맵을 보고 있다가 어떤 농장이 있는 지역에 대해 더 알고 싶어졌다고 해봅시다. 해당 지역에 대해 아무것도
모르고 있고, 그 지역에 대한 일반적인 정보를 찾고 싶다고 가정합시다. 지금 컴퓨터 앞에 앉아 있다는 점을
생각해보면 여러분이 처음 취할 행동은 아마도 해당 지역의 명칭을 구글해보는 것일 겁니다. 그러면 QGIS
가 자동으로 그 액션을 취하도록 만들어볼까요!

• landuse 레이어의 속성 테이블을 엽니다.

각 토지이용구역의 name 항목을 이용해서 구글 검색을 해보겠습니다.

• 속성 테이블을 닫습니다.

• Layer Properties 의 Actions 로 돌아갑니다.

• Action Properties → Name 메뉴 항목에 Google Search 를 입력합니다.

다음 단계는 사용자의 OS 에 따라 달라지므로, 다음 가운데 적합한 지침을 선택하십시오.
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윈도우

• Type 아래에 있는 Open 을 선택하면, 윈도우에 인터넷 익스플로러 같은 기본 브라우저에서 인터넷
주소를 열도록 명령합니다.

우분투 리눅스

• Action 아래에 xdg-open을입력하면, 우분투에크롬이나파이어폭스같은기본브라우저에서인터넷
주소를 열도록 명령합니다.

MacOS

• Action 아래에 open 을 입력하면, MacOS 에 사파리 같은 기본 브라우저에서 인터넷 주소를 열도록
명령합니다.

명령어 입력 계속

앞에 나열한 명령어 가운데 어떤 것을 이용하든, 이제 어떤 인터넷 주소를 열 것인지 알려줘야 합니다. 즉
구글 사이트로 가서 자동으로 지역명을 검색해야 합니다.

구글을 이용할 때는 보통 구글 검색란에 검색 문구를 입력합니다. 그러나 이 경우에는 컴퓨터가 자동으로
검색해야 합니다. 구글에 뭔가를 검색하라고 명령하는 방법은 (검색란을 직접 이용하지 않으려면) 인터넷
브라우저에 다음 http://www.google.com/search?q=SEARCH_PHRASE 라는 주소를 부여하는 것입니다.
이때 SEARCH_PHRASE 가 여러분이 검색하길 바라는 구문입니다. 아직 어떤 구문을 검색해야 하는지 모르기
때문에, (검색 구문 없이) 주소의 전반부만 입력하겠습니다.

• Action 항목에 http://www.google.com/search?q= 라고 입력하십시오. 기존 명령어 뒤에 공백을
삽입한 다음 이 주소를 입력해야 합니다!

이제여러분이어떤피처를클릭하더라도 QGIS가해당피처의 name값을구글에서검색하도록브라우저에
명령해야 합니다.

• name 항목을 선택합니다.

• Insert field 를 클릭하면,
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QGIS 가 다음과 같이 구문을 추가할 것입니다.

다시 말해 QGIS 가 브라우저를 열고 http://www.google.com/search?q=[% "name" %] 라는 주소를
전송하는 액션입니다. 그런데 [% "name" %] 라는 부분을 통해 QGIS 가 검색 구문으로 name 항목의 내용을
보내게 하는 것입니다.

따라서 예를 들자면, 사용자가 클릭한 토지이용구역의 명칭이 Marloth Nature Reserve 라고 할 때 QGIS
는 브라우저에 http://www.google.com/search?q=Marloth%20Nature%20Reserve 라는 주소를 보내게
되고, 그러면 브라우저는 구글 사이트로 가서 “Marloth Nature Reserve” 에 대한 검색 결과를 반환할
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것입니다.

• 아직 이 예제를 실행하지 않았다면, 앞에 설명한 모든 것을 따라해보십시오.

• Add to action list 버튼을 클릭합니다. 위 목록에 새 액션이 나타날 것입니다.

• Layer Properties 대화 창의 OK 를 클릭합니다.

이제 새로운 액션을 테스트해봅시다.

• Layers list 에서 landuse 레이어를 활성화한 다음, Run feature action 버튼을 클릭하십시오.

• 맵상에보이는토지이용구역가운데 아무곳이나클릭해보십시오. 여러분의브라우저가열리고, 해당
구역의 name 값으로 저장된 도시를 자동으로 구글 검색할 것입니다.

주석: 액션이 제대로 실행되지 않을 경우, 모든 명령어를 제대로 입력했는지 확인해보십시오. 이런 작업
시 오타가 흔하게 날 수 있습니다!

6.4.5 Follow Along: QGIS 안에서 직접 웹페이지 열기

앞 단계에서 외부 브라우저에서 웹페이지를 여는 방법을 배웠습니다. 그런데 이 방식은 예측할 수 없는
의존성이라는 문제를 제기합니다. 최종 사용자의 시스템에 이 액션을 실행하는 데 필요한 소프트웨어가
반드시 있을까요? 여러분이 배운 대로, 최종 사용자가 사용하는 OS 가 무엇인지 모른다면 동일한 액션에
대해 어떤 종류의 기초 명령어를 써야 하는지 확실하지 않을 수도 있습니다. 또 OS 의 버전에 따라 앞에
나온 브라우저를 여는 명령어가 먹히지 않을 수도 있는데, 이 문제를 해결하지 못 할 수도 있습니다.

그러나 QGIS 는 매우 강력하고 다용도인 Qt4 라이브러리를 사용하고 있습니다. 또 QGIS 의 액션은
임의적이고 표식화된 (예를 들어 속성 항목의 내용에 기반한 다양한 정보를 이용하는) 파이썬 명령어일
수도 있습니다!

이제 웹페이지를 보여주는 파이썬 액션을 이용하는 방법을 배워보겠습니다. 외부 브라우저에서 웹사이트를
여는 것과 동일한 보편적인 아이디어이지만, 팝업 창에 웹사이트를 표출하는 (html 위젯에 기반한 웹킷인)
Qt4 QWebView 클래스를 이용하기 때문에 사용자 시스템의 브라우저를 필요로 하지 않습니다.

이번에는 구글 대신 위키피디아를 사용해봅시다. 여러분이 요청할 URL 은 다음과 같을 것입니다.

http://wikipedia.org/wiki/SEARCH_PHRASE

레이어 액션을 생성하려면,

• Layer Properties 대화 창을 열고 Actions 탭을 선택합니다.

• Set up a new action using the following properties for the action: * Type: Python * Name:
Wikipedia * Action (all on one line):

from PyQt4.QtCore import QUrl; from PyQt4.QtWebKit import QWebView; myWV =
QWebView(None); myWV.load(QUrl('http://wikipedia.org/wiki/[% "name" %]'));
myWV.show()
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이 명령어에 대해 설명하겠습니다.

• 모든 파이썬 코드는 한 줄로, 쌍반점으로 구분되는 명령어들로 이루어집니다. (일반적인 파이썬
명령어들처럼 행갈이를 하지 않습니다.)

• [% "name" %] 은 액션을 실행할 때 (이전과 마찬가지로) 실제 속성 값으로 대체될 것입니다.

• 이코드는단순하게새 QWebView인스턴스를생성하고, URL을설정하고, show()를호출해서사용자
데스크탑에 창으로 표출되도록 합니다.

이예제가조금부자연스럽다는점을알아야합니다. 파이썬은의미론적으로특별한들여쓰기를사용합니다.
따라서 쌍반점으로 명령어를 구분하는 것은 파이썬을 사용하는 최적의 방식이 아닙니다. 그러므로 실제
상황에서는 파이썬 모듈에서 사용자 로직을 불러들여, 속성 항목을 파라미터로 쓰는 함수를 호출하는 일이
더 많을 것입니다.

마찬가지로 사용자 시스템의 특정 이미지 뷰어 없이도 이미지를 표출하는 방식을 쓸 수 있습니다.

• 앞에 설명한 방법을 사용해서, 방금 생성한 위키피디아 액션을 통해 위키피디아 페이지를
불러와보십시오.

6.4.6 In Conclusion

액션을 사용하면 사용자 맵에 추가적인 기능성을 부여해서, QGIS 에서 동일한 맵을 보는 최종 사용자에게
도움을 줄 수 있습니다. 어떤 OS 에서도 셸 명령어는 물론 파이썬을 사용할 수 있으므로, 여러분이 생성할
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수 있는 기능에 제한이란 없습니다!

6.4.7 What’s Next?

벡터 데이터 생성에 대해 모두 배웠으니, 이제 문제를 해결하기 위해 이 데이터를 분석하는 방법을 배울
차례입니다. 이것이 다음 모듈의 주제입니다.
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Module: 벡터 분석

이제 몇몇 피처들을 편집해봤으니, 달리 어떤 작업이 가능한지 알고 싶을 것입니다. 속성을 가진 피처도
쓸모가 있지만, 결국 평범한, GIS 가 아닌 맵이 알려줄 수 있는 것 이상을 알려주지는 못 합니다.

GIS 의 중요한 장점은, GIS 는 질문에 답할 수 있다 는 것입니다.

다음 세 모듈에서, 우리는 GIS 를 이용해서 연구 목적의 질문 에 답하고자 할 것입니다. 예를 들어 여러분이
부동산 업자인데 다음 기준을 가진 고객을 위해 Swellendam 에 있는 거주지를 찾고 있다고 해봅시다.

1. Swellendam 에 있어야 한다.

2. 학교와 적정한 거리 (1km 정도) 안에 있어야 한다.

3. 면적은 100 평방미터 이상이어야 한다.

4. 주 도로에서 50 미터 이상 떨어져서는 안 된다.

5. 500 미터 반경 안에 식당이 있어야 한다.

다음 세 모듈을 통해, 이 새로운 거주지 개발에 적합한 농장 부지를 찾는 데 GIS 분석 도구의 능력을
활용해보겠습니다.

7.1 Lesson: 데이터 재투영 및 변환

좌표계 (CRS) 얘기를 다시 해봅시다. 이전에 간략하게 언급했지만, 실제로 어떤 의미를 가지고 있는지에
대해서는 설명하지 않았습니다.

이 강의의 목표: 벡터 데이터를 재투영하고 변환하기.

7.1.1 Follow Along: 투영

맵자체는물론모든데이터는현재WGS84라는 CRS를사용하고있습니다. WGS84는데이터를표현하는
데 쓰이는 매우 흔한 지리좌표계 (GCS) 입니다. 그러나 이제 곧 설명할 문제점도 가지고 있습니다.

• 현재 맵을 저장하십시오.

• 그 다음 exercise_data/world/world.qgs 경로에 있는 세계 지도를 여십시오.

• Zoom In 도구를 사용해서 남아프리카 공화국으로 줌인하십시오.

• 창 맨 아래의 Status Bar 에 있는 Scale 항목으로 통해 축척을 설정해보십시오. 남아프리카 공화국이
보이는 상태에서 1:5000000 (5 백만 분의 1) 로 값을 설정합니다.

• Scale 항목에 주의를 기울이면서 맵을 이리저리 이동해보십시오.

축척이 변하는 것을 보셨습니까? 여러분이 1:5000000 축척으로 줌인한, 화면 정중앙에 있던 포인트를
벗어났기 때문입니다. 그 포인트를 벗어나면 축척이 달라집니다.
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그 이유를 이해하려면, 지구의를 생각해보십시오. 남북 방향으로 선이 뻗어 있습니다. 이 경도 선들은
적도에서는 멀리 떨어져 있지만 남극/북극에서 만납니다.

GCS 는 이 구체 상에서 정의되지만, 여러분의 모니터는 평면입니다. 평면에서 구체를 표현하려 할 때, 마치
테니스 공을 잘라서 평평하게 펼치려고 할 때처럼, 왜곡이 발생합니다. 즉 맵 상에서는 경도 선들이 (서로
만나야할)극지방에서도평행하게떨어져있습니다. 다시말해맵상에서적도로부터멀어질수록, 여러분이
보는 오브젝트의 축척이 점점 커진다는 뜻입니다. 한 마디로 말하자면 맵 상의 위치에 따라 축척이 계속
변한다는 말이지요!

이 문제를 해결하기 위해 투영좌표계 (PCS) 를 대신 사용해봅시다. PCS 는 축척 변화를 감안하여 바로잡는
방식으로 데이터를 “투영” 하거나 변환합니다. 따라서 축척을 일정하게 유지하려면 PCS 를 이용해서
데이터를 재투영해야 합니다.

7.1.2 Follow Along: “실시간” 재투영

QGIS는 “실시간 (on the fly)”으로데이터를재투영할수있습니다. 데이터자체가다른좌표계를이용하고
있더라도, 사용자가 바라는 좌표계로 데이터를 투영할 수 있다는 뜻입니다.

• 이 “실시간” 투영을 활성화하려면, QGIS 창의 맨 아래의 Status Bar 에 있는 CRS Status 버튼을
클릭하십시오.

• 대화 창이 나타나면, Enable ‘on the fly’ CRS transformation 옆에 있는 체크박스를 체크합니다.

• Filter 입력란에 global 이라는 텍스트를 입력합니다. 아래쪽의 목록에 좌표계 (NSIDC EASE-Grid
Global) 가 하나 나타날 것입니다.

• NSIDC EASE-Grid Global 을 클릭해서 선택한 다음, OK 를 클릭하십시오.

• 남아프리카 공화국의 형태가 어떻게 변하는지 보셨습니까? 투영체를 바꾸면 지구 상의 오브젝트의
형태가 바뀝니다.

• 이전과 마찬가지로 1:5000000 축척으로 줌인하십시오.

• 맵을 이리저리 이동해보십시오.

• 축척이 일정하게 유지됩니다!

서로 다른 CRS 를 이용하는 데이터셋을 결합하는 데에도 “실시간” 재투영을 사용할 수 있습니다.

• 다음과 같이 “실시간” 재투영을 비활성화합니다.

– CRS Status 버튼을 다시 클릭하십시오.

– Enable ‘on the fly’ CRS transformation 체크박스를 해제합니다.

– OK 를 클릭합니다.

• In QGIS 2.0, the ‘on the fly’ reprojection is automatically activated when

layers with different CRSs are loaded in the map. To understand what ‘on the fly’ reprojection does,
deactivate this automatic setting:

• 메뉴에서 Settings → Options... 를 선택합니다.

• 대화 창의 왼쪽 패널에서 CRS 를 선택하십시오.

• Un-check :guilabel:‘Automatically enable ‘on the fly’ reprojection if layers

have different CRS‘. * Click OK.

• 남아프리카 공화국의 데이터만을 가지고 있는 다른 벡터 레이어를 맵에 추가해보십시오.
exercise_data/world/RSA.shp 경로에서 찾을 수 있습니다.
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보이십니까?

레이어가 보이지 않습니다! 그래도 이 문제는 쉽게 해결할 수 있죠?

• Layers list 에서 RSA 레이어를 오른쪽 클릭합니다.

• Zoom to Layer Extent 를 선택합니다.

네, 이제 남아프리카 공화국이 보이는군요... 그런데 세계 지도는 어디로 갔을까요?

이 두 레이어를 하나씩 볼 수는 있지만, 동시에 볼 수는 없습니다. 두 레이어가 이용하는 좌표계가 서로
너무나 다르기 때문입니다. continents 데이터셋은 도 (degrees) 단위로 돼 있지만, RSA 데이터셋은 미터
(meters) 단위로 돼 있습니다. 그러니까, RSA 데이터셋에 있는 케이프타운의 어떤 지점이 적도로부터 약
4,100,000미터떨어져있다고해봅시다. 그런데 continents데이터셋의동일한지점은적도로부터약 33.9
도 떨어져 있습니다.

이 거리는 똑같습니다. 하지만 QGIS 는 그걸 모르죠. 데이터를 재투영하라고 하지 않았으니까요. 즉 QGIS
입장에서는, RSA 데이터셋이 담고 있는 남아프리카 공화국 버전의 케이프타운이 적도에서 4,100,000
미터라는 정확한 거리에 있습니다. 그러나 continents 데이터셋에서는 적도에서 33.9 미터 거리에 있는
겁니다! 이제 문제가 뭔지 아시겠습니까?

QGIS 는 케이프타운이 있어야 할 곳을 모릅니다. 데이터가 그걸 알려줘야 하는 것이죠. 데이터가 QGIS 에
케이프타운이 적도에서 34 미터 떨어져 있고 남아프리카 공화국의 남북 길이가 12 미터라고 한다면, QGIS
는 그렇게 그릴 것입니다.

이 문제를 해결하려면,

• Click on the CRS Status button again and switch

Enable ‘on the fly’ CRS transformation on again as before. * Zoom to the extents of the RSA dataset.

이제 동일한 CRS 를 이용해 재투영되고 있기 때문에 다음과 같이 두 데이터셋이 딱 맞춰집니다.

서로 다른 데이터셋들로부터 데이터를 결합하는 경우, 동일한 CRS 를 이용하지 않을 수도 있다는 점을
기억해야 합니다. “실시간” 재투영 기능으로 두 데이터셋을 함께 표출할 수 있습니다.

다음 단계로 넘어가기 전에 서로 다른 CRS 를 이용하는 데이터셋들을 열 때마다 ‘실시간’ 재투영이
자동적으로 활성화되도록 만드는 편이 좋겠죠?

• 메뉴에서 Settings → Options... 를 다시 클릭한 다음 CRS 를 선택합니다.
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• Automatically enable ‘on the fly’ reprojection if layers have different CRS 를 활성화합니다.

7.1.3 Follow Along: 다른 CRS 로 데이터셋 저장

‘범주화’ 강의에서 건물들의 면적을 계산했던 일을 기억하십니까? 면적을 기준으로 건물들을 범주화하기
위한 작업이었습니다.

• (Swellendam 데이터를 담고 있는) 기본 맵을 다시 여십시오.

• buildings 레이어의 속성 테이블을 여십시오.

• AREA 열이 보일 때까지 오른쪽으로 스크롤합니다.

면적 값들이 얼마나 작은지 보이십니까? 0 값도 있을 겁니다. 면적을 도 (degree) 로 계산했기 때문입니다.
데이터가투영좌표계를이용하고있지않은겁니다. 농장들의면적을평방미터로계산하려면데이터도미터
단위를 이용해야 합니다. 따라서 재투영해야 할 필요가 있습니다.

그러나 ‘실시간’ 재투영만으로는 안 됩니다. ‘실시간’ 라는 말 그대로 데이터를 변경하지 않은 채 맵 상에
나타나는 레이어를 재투영하는 기능이기 때문입니다. 데이터 자체를 진짜로 재투영하려면, 새 투영체를
이용하는 새 파일로 내보내야 합니다.

• Layers list 의 buildings 레이어를 오른쪽 클릭합니다.

• 콘텍스트 메뉴의 Save As... 를 선택하십시오. Save vector layer as... 대화 창이 나타날 것입니다.

• Save as 항목 옆에 있는 Browse 버튼을 클릭하십시오.

• exercise_data/ 경로를 찾아가서 새 레이어의 파일명을 buildings_reprojected.shp 로
설정합니다.

• Encoding 은 그대로 두십시오.

• Layer CRS 드롭다운 메뉴의 값을 Selected CRS 로 변경합니다.

• 드롭다운 메뉴 아래에 있는 Browse 버튼을 클릭합니다.

• CRS Selector 대화 창이 나타날 것입니다.

• Filter 란에서 34S 를 찾으십시오.

• 목록에서 WGS 84 / UTM zone 34S 를 선택합니다.

• Symbology export 는 그대로 두십시오.

이제 Save vector layer as... 대화 창이 다음처럼 보일 것입니다.
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• OK 를 클릭합니다.

• 새 맵을 시작해서 방금 생성한 재투영된 레이어를 불러옵니다.

‘범주화’ 강의에서 어떻게 면적을 계산했는지 떠올려보십시오.

• 이전과 동일한 표현식을 실행해서 AREA 항목을 업데이트 (또는 추가) 합니다.
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각 건물의 면적이 평방미터 단위로 AREA 열에 추가될 것입니다.

• 다른 계산 단위로, 예를 들어 헥타르로 면적을 계산하려면 다음과 같이 AREA 열을 사용해서 두 번째
열을 생성해야 합니다.
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Look at the new values in your attribute table. This is much more useful, as people actually quote
building size in metres, not in degrees. This is why it’s a good idea to reproject your data, if necessary,
before calculating areas, distances, and other values that are dependent on the spatial properties of the
layer.

7.1.4 Follow Along: 사용자 지정 투영체 생성

QGIS 에 기본으로 포함된 투영체 외에도 많은 투영체가 있습니다. 여러분 자신만의 투영체를 생성할 수도
있습니다.

• 새 맵을 시작하십시오.

• world/oceans.shp 데이터셋을 로드합니다.

• 메뉴에서 Settings → Custom CRS... 를 선택하면 다음 대화 창이 나타날 것입니다.
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• 새 투영체를 생성하려면 Add new CRS 버튼을 클릭하십시오.

Van der Grinten I 라는 투영체를 사용해볼 만합니다.

• Name 란에 이 명칭을 입력하십시오.

이 투영체는 다른 대부분 투영체와는 달리 사각 면이 아니라 원형 면에 지구를 표현합니다.

• 투영체의 파라미터로 다음 문자열을 입력하십시오.

+proj=vandg +lon_0=0 +x_0=0 +y_0=0 +R_A +a=6371000 +b=6371000 +units=m +no_defs
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• OK 를 클릭합니다.

• “실시간” 재투영을 활성화하십시오.

• 새로 정의한 투영체를 (Filter 항목에서 명칭을 찾아서) 선택하십시오.

• 이 투영체를 적용하면 맵이 다음과 같이 재투영될 것입니다.
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7.1.5 In Conclusion

목적에 따라 유용한 투영체도 달라집니다. 올바른 투영체를 선택함으로써 사용자 맵 상에 피처를 정확하게
표현할 수 있게 됩니다.

7.1.6 Further Reading

이 강의의 고급 내용을 위한 자료는 다음 포스팅 에서 빌려온 것입니다.

좌표계에 대한 자세한 정보는 이 곳 을 참조하십시오.

7.1.7 What’s Next?

다음 강의에서는 QGIS 의 다양한 벡터 분석 도구들을 이용해 벡터 데이터를 분석하는 방법에 대해
배워보겠습니다.

7.2 Lesson: 벡터 분석

벡터 데이터를 분석해서 서로 다른 피처들이 공간 안에서 어떻게 상호작용하는지 밝힐 수 있습니다. GIS
에는 서로 다른 많은 분석 관련 기능들이 있는데, 모든 기능을 다 살펴보지는 않을 것입니다. 그보다는
문제를 제시하고 QGIS 가 제공하는 도구들을 써서 그 문제를 해결하는 방식을 사용할 것입니다.

이 강의의 목표: 문제를 제시하고, 분석 도구를 써서 해결하기
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7.2.1 GIS 처리 과정

시작하기 전 GIS 문제를 해결하는 데 사용할 수 있는 처리 과정을 간략히 살펴보는 것이 좋을 것입니다.
다음과 같은 처리 과정을 거칩니다.

1. 문제를 정의

2. 데이터 획득

3. 문제를 분석

4. 결과를 표출

7.2.2 문제

해결해야 할 문제를 결정하는 것으로 처리 과정을 시작합시다. 예를 들어 여러분이 부동산 업자인데 다음
기준을 가진 고객을 위해 Swellendam 에 있는 거주지를 찾고 있다고 해봅시다.

1. Swellendam 에 있어야 한다.

2. 학교와 적정한 거리 (1km 정도) 안에 있어야 한다.

3. 면적은 100 평방미터 이상이어야 한다.

4. 주 도로에서 50 미터 이상 떨어져서는 안 된다.

5. 500 미터 반경 안에 식당이 있어야 한다.

7.2.3 데이터

이 문제들을 해결하려면 다음 데이터들이 필요합니다.

1. 지역 내에 있는 거주지 (건물)

2. 도시 내부 및 주변의 도로

3. 학교와 식당의 위치

4. 건물 면적

이모든데이터들을 OpenStreetMap을통해찾을수있고, 이교재를공부하면서사용해온데이터셋도이번
강의에 사용할 수 있을 것입니다. 그러나 완전한 데이터를 갖추고 있다고 확신하기 위해, QGIS 에 내장된
OSM 다운로드 도구로 OSM 에서 데이터를 다시 다운로드하겠습니다.

주석: OSM 다운로드는 일관된 데이터 항목을 가지고 있지만, 커버리지 및 세부 내용은 다를 수 있습니다.
예를 들어 여러분이 선택한 지역에 식당 정보가 없다면, 다른 지역을 선택해야 할 수도 있습니다.

7.2.4 Follow Along: 프로젝트 시작

• 새 QGIS 프로젝트를 시작하십시오.

• Use the OpenStreetMap data download tool found in the Vector -> OpenStreeMap menu to down-
load the data for your chosen region.

• exercise_data 디렉터리에 osm_data.osm 이라는 파일명으로 데이터를 저장하십시오.

• Note that the osm format is a type of vector data. Add this data as a vector layer as usually Layer
-> Add vector layer..., browse to the new osm_data.osm file you just downloaded. You may need
to
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select Show All Files as the file format.

• osm_data.osm 파일을 선택하고 Open 을 클릭합니다.

• 이때나타나는대화창에서 other_relations와 multilinestrings레이어를제외한모든레이어를
선택하십시오.

여러분의 맵에 OSM 데이터를 개별 레이어로 불러들일 것입니다.

OSM 에서 방금 다운로드한 데이터는 이전 강의에서 배운 바와 같이 위도와 경도 좌표를 사용하는 WGS84
지리좌표계를 사용합니다. 그런데 길이를 미터 단위로 계산하려면 투영좌표계로 작업해야 한다는 사실도
배웠습니다. 사용자의 프로젝트의 좌표계를 사용자 데이터에 적합한 CRS 로 설정해봅시다. Swellendam
에서는 다음과 같이 WGS 84 / UTM zone 34S 를 선택하십시오.

• Project Properties 대화 창을 열고, CRS 를 선택한 다음 목록에서 WGS 84 / UTM zone 34S 를
찾습니다.

• OK 를 클릭합니다.

이제 OSM 데이터셋에서 필요한 정보를 추출해야 합니다. 이 지역에 있는 모든 집, 학교, 식당, 도로를
나타내는 레이어들이 필요합니다. multipolygons 레이어가 이 정보를 담고 있으며, 해당 레이어의 Attribute
Table 에 있는 정보를 이용해서 추출할 수 있습니다. 먼저 schools 레이어부터 시작해봅시다.

• Layers list 에 있는 multipolygons 레이어를 오른쪽 클릭해서 Layer Properties 를 여십시오.

• General 메뉴를 선택합니다.

• Feature subset 아래에 있는 [Query Builder] 버튼을 클릭해서 Query builder 대화 창을 엽니다.

• 이 대화 창의 왼쪽에 있는 Fields 목록에서 amenity 항목이 보일 때까지 스크롤하십시오.

• 해당 항목을 한 번 클릭합니다.

• Values 목록 아래에 있는 All 버튼을 클릭합니다.

이제 amenity 값이 school 인 폴리곤들만 보이도록 QGIS 에 명령해야 합니다.

• Fields 목록의 amenity 항목을 더블클릭합니다.

• Watch what happens in the Provider specific filter expression

field below:
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"amenity" 라는 텍스트가 나타났습니다. 이제 쿼리를 완성해봅시다.

• Operators 아래에 있는 = 버튼을 클릭하십시오.

• Values 목록의 school 값을 더블클릭합니다.

• OK 를 두 번 클릭합니다.

This will filter OSM’s multipolygon layer to only show the schools in your region. You can now either:

• 필터링된 OSM 레이어를 schools 이라는 명칭으로 바꾼 다음 osm_data.osm 파일에서
multipolygons 레이어를 다시 불러들이거나, 아니면

• 필터링된 레이어를 복제하고 복사본의 명칭을 바꾼 다음 Query Builder 의 쿼리 내용을 지우고 새
쿼리를 생성할 수도 있습니다.

7.2.5 Try Yourself OSM 에서 필요한 레이어 추출

앞에서 설명한 기술을 써서, Query Builder 도구를 이용, OSM 에서 나머지 데이터를 추출해서 다음과
같은 레이어들을 생성하십시오.

• roads (OSM 의 lines 레이어에서)

• restaurants (OSM 의 multipolygons 레이어에서)
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• houses (OSM 의 multipolygons 레이어에서)

이전 강의에서 생성했던 roads.shp 레이어를 다시 사용할 수도 있습니다.

결과 확인

• Save your map under exercise_data, as analysis.qgs.

• 사용자 OS 의 파일관리자에서 exercise_data 디렉터리 아래 새 폴더를 생성하고
residential_development 라고 명명합니다. 분석 기능의 결과물인 데이터셋을 이 폴더에
저장할 것입니다.

7.2.6 Try Yourself 중요한 도로 찾기

OSM 데이터셋의 도로 가운데 일부는 unclassified, tracks, path 그리고 footway 로 분류돼 있습니다.
여러분의 도로 데이터셋에서 이런 도로들을 제외해야 합니다.

• roads 레이어에서 Query Builder 를 열고 Clear 를 클릭한 다음, 다음 쿼리를 작성합니다.

"highway" != 'NULL' AND "highway" != 'unclassified' AND "highway" != 'track' AND
"highway" != 'path' AND "highway" != 'footway'

여러분은값을더블클릭하고버튼들을클릭해서쿼리를작성할수도있고,앞의텍스트를복사 &붙여넣기할
수도 있습니다.

이제 여러분의 맵에서 도로 상당수가 줄어들 것입니다.

7.2.7 Try Yourself 레이어 CRS 변환

레이어안에서거리를측정할것이기때문에,레이어의 CRS를변경해야합니다. 그렇게하려면,각레이어를
차례대로 선택해서 새 CRS 를 사용하는 새 shapefile 로 레이어를 저장한 다음 새 레이어를 맵에 불러들여야
합니다.

주석: 이예제에서는WGS 84 / UTM zone 34S CRS를사용할것이지만,여러분이다른지역을선택했다면
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해당 지역에 더 적합한 UTM CRS 를 사용할 수도 있습니다.

• Layers 패널에서 roads 레이어를 오른쪽 클릭하십시오.

• Save as... 를 클릭합니다.

• Save Vector As 대화 창을 다음과 같이 설정한 다음 (Add saved file to map 을 선택했는지
확인하고) OK 를 클릭합니다.

새 shapefile 이 생성되고, 해당 레이어가 사용자 맵에 추가됩니다.
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주석: If you don’t have activated Enable ‘on the fly’ CRS transformation or the Automatically enable
‘on the fly’ reprojection if layers have different CRS settings (see previous lesson), you might no be able
to see the new layers you just added to the map. In this case, you can focus the map on any of the layers
by right click on any layer and click Zoom to layer extent, or just enable any of the mentioned ‘on the
fly’ options.

• 기존 roads 레이어를 제거하십시오.

각 레이어에 대해 이 과정을 반복하십시오. 새 shapefile 을 생성하고, 명칭에 “_34S” 가 붙은 레이어를
추가한 다음 기존 레이어를 제거합니다.

각 레이어에 대해 이 과정을 완료한 다음 아무 레이어나 오른쪽 클릭하고 Zoom to layer extent 를 클릭해서
관심지역으로 맵을 이동시킵니다.

이제 OSM 데이터에 UTM 투영체를 적용시켰으니, 계산을 시작할 수 있습니다.

7.2.8 Follow Along: 문제 분석: 학교 및 도로부터의 거리

QGIS 는 어떤 벡터 오브젝트부터의 거리도 계산할 수 있습니다.

• 작업할 동안 맵을 단순화하도록 roads_34S 와 houses_34S 레이어만 보이도록 하십시오.

• 메뉴에서 Vector → Geoprocessing Tools → Buffer(s) 도구를 클릭합니다.

새 대화 창이 나타날 것입니다.

• 다음과 같이 설정하십시오.
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우리의 입력 데이터가 미터가 기본 측정 단위인 투영좌표계를 사용하기 때문에, Buffer distance 의 단위도
미터가 됩니다. 이 때문에 재투영된 데이터를 사용해야 하는 것입니다.

• 설정이 적용된 레이어를 roads_buffer_50m.shp 라는 파일명으로
exercise_data/residential_development/ 디렉터리에 저장하십시오.

• OK 를 클릭하면 버퍼가 생성될 것입니다.

• “TOC 에 새 레이어를 추가합니까?” 라고 물어볼 경우 Yes 를 클릭합니다. (“TOC” 는 “Table of
Contents” 의 약자로, Layers list 를 의미합니다.)

• Buffer(s) 대화 창을 닫습니다.

이제 여러분의 맵이 다음처럼 보일 것입니다.
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새 레이어가 Layers 목록의 최상단에 있다면, 맵 상의 다른 레이어를 가리게 되지만, 여러분 지역 안에서
도로로부터 50m 안에 있는 모든 구역을 보여줍니다.

그러나 버퍼 안에서 모든 개별 도로에 대응해서 뚜렷하게 구분되는 구역이 보일 것입니다. 이 문제를
해결하려면 레이어를 제거한 다음, 다음과 같은 설정을 이용해서 버퍼를 재생성하십시오.
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• 이번에는 Dissolve buffer results 체크박스를 체크했다는 점을 알아차리셨습니까?

• 설정이 적용된 레이어를 이전과 마찬가지로 저장하십시오. (이전 파일을 덮어쓸 것이냐는 질문에 Yes
를 클릭하십시오.)

• OK 를 클릭하고, 다시 Buffer(s) 대화 창을 닫습니다.

새 레이어를 Layers list 에 추가하면, 다음처럼 보일 것입니다.
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이제 필요 없는 부분들이 사라졌습니다.

7.2.9 Try Yourself 학교로부터의 거리

• 앞 단계와 동일한 방법으로 학교를 중심으로 하는 버퍼를 생성하십시오.

반경이 1 km 여야 하고, schools_buffer_1km.shp 라는 파일명으로 이전과 동일한 디렉터리에
저장하십시오.

결과 확인

7.2.10 Follow Along: 겹치는 구역

이제 도로에서 50m 이내 그리고 학교에서 (도로가 아니라 직선 거리로) 1km 이내에 있는 지역을 볼 수
있습니다. 그러나 당연히, 이 두 가지 기준을 모두 만족시키는 구역만 필요합니다. 이 구역을 구하려면
Intersect 도구를 사용해야 합니다. 메뉴에서 Vector → Geoprocessing Tools → Intersect 를 선택한 다음,
다음과 같이 설정합니다.
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입력 레이어 두 개는 버퍼 두 개입니다. 저장 위치는 이전과 같습니다. 파일명은
road_school_buffers_intersect.shp 로 하십시오. 이렇게 설정을 마친 다음, OK 를 클릭하고
새 레이어를 Layers list 에 추가합니다.

다음 이미지에서 두 가지 거리 기준을 모두 만족시키는 파란색 구역을 볼 수 있습니다!

7.2. Lesson: 벡터 분석 171



QGIS Training Manual, 출시 2.2

이제 두 버퍼 레이어를 제거하고 겹치는 구역만 보여주는 레이어만 남겨도 됩니다. 원래 그 레이어만을
원했기 때문입니다.

7.2.11 Follow Along: 건물 선택

이제 건물들과 겹치는 구역을 얻었습니다. 다음 단계는 해당 구역 안에 있는 건물들을 선택하는 것입니다.
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• 메뉴에서 Vector → Research Tools → Select by location항목을클릭하십시오. 다음대화창이나타날
것입니다.

• 다음과 같이 설정하십시오.

• OK 를 클릭한 다음, Close 를 클릭합니다.

• 아마도 바뀐 점이 거의 없다고 느낄지도 모르겠습니다. 그렇다면 레이어 목록 하단에 있는
school_roads_intersect 레이어를 선택해서 줌인해보십시오.
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우리의 기준을 만족하는 건물들이 선택되어 노란색으로 하이라이트되었습니다. 기준을 만족시키지 못 하는
건물들은 녹색으로 보입니다. 이제 선택된 건물들을 새 레이어로 저장할 수 있습니다.

• Layers list 에서 houses_34S 레이어를 오른쪽 클릭합니다.

• Save Selection As... 를 선택하십시오.

• 다음과 같이 대화 창을 설정하십시오.
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• 파일명은 well_located_houses.shp 으로 하십시오.

• OK 를 클릭합니다.

이제 선택된 건물들을 개별 레이어로 저장했으니 houses_34S 레이어를 제거해도 됩니다.
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7.2.12 Try Yourself 한 번 더 건물을 필터링

이제 학교에서 1km, 도로에서 50m 이내에 있는 모든 건물들을 보여주는 레이어가 생성됐습니다. 다음으로
이 레이어에서 식당으로부터 500m 이내에 있는 건물들만 추려내야 합니다.

앞에서 설명한 과정을 이용, well_located_houses 레이어를 한 번 더 필터링해서 식당에서 500m 이내에
있는 건물만을 보여주는 houses_restaurants_500m 라는 새 레이어를 생성하십시오.

결과 확인

7.2.13 Follow Along: 면적 기준을 만족하는 건물 선택

To see which buildings are the correct size (more than 100 square metres), we first need to calculate their
size.

• houses_restaurants_500m 레이어의 속성 테이블을 여십시오.

• 편집 모드로 들어가서 항목 계산기를 실행합니다.

• 다음과 같이 설정하십시오.
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• 목록에 AREA 가 없다면, 이 모듈의 이전 강의에서 했던 것처럼 새 항목을 생성해보십시오.

• OK 를 클릭합니다.

• 속성 테이블의 오른쪽으로 스크롤하면, 사용자의 AREA 항목에 houses_restaurants_500m 레이어에
있는 모든 건물들의 면적이 미터 단위로 담겨 있을 것입니다.

• 편집 모드 버튼을 한 번 더 클릭해서 편집을 끝내고, 편집 내용을 저장하십시오.

• 이전 단계에서처럼 다음과 같은 쿼리를 작성하십시오.

• OK 를클릭합니다. 이제여러분의맵에는면적 100평방미터이상이라는기준을만족시키는건물들만
보일 것입니다.

7.2.14 Try Yourself

• 이전단계와마찬가지로이해답을레이어로저장하십시오. 이전과동일한디렉터리에 solution.shp
라는 파일명으로 저장합니다.
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7.2.15 In Conclusion

QGIS 벡터 분석 도구와 함께 GIS 문제 해결 접근법을 이용하면, 복합적인 기준을 가진 문제를 쉽고 빠르게
해결할 수 있습니다.

7.2.16 What’s Next?

다음 강의에서는 한 지점에서 다른 지점까지의 최단 거리를 도로를 따라 계산하는 방법을 배워보겠습니다.

7.3 Lesson: 네트워크 분석

GIS 사용 시 두 포인트 사이의 가장 가까운 거리를 계산하는 일은 매우 흔합니다. QGIS 도 이 도구를
내장하고 있지만, 기본 설정에서는 보이지 않습니다. 이번 간단한 강의에서, 어떻게 해야 이 도구를 사용할
수 있는지 배워보겠습니다.

이 강의의 목표: Road Graph 플러그인을 활성화, 설정, 사용하기.

7.3.1 Follow Along: 도구 활성화

QGIS 의 기본 기능 외에 추가적인 플러그인이 많습니다. 이 플러그인들 대부분은 활용도가 높아서, QGIS
설치 시 기본적으로 내장되어 있습니다. 그러나 기본 설정에서는 보이지 않습니다. 따라서 이 플러그인들을
사용하려면 먼저 활성화시켜줘야 합니다.

Road Graph 플러그인을 활성화하려면,

• 먼저 QGIS메인창메뉴에서 Plugins → Manage and Install Plugins... 항목을클릭, Plugin Manager
를 실행합니다. 대화 창이 나타날 것입니다.

• 다음과 같이 플러그인을 선택하십시오.
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• Plugin Manager 대화 창의 Close 버튼을 클릭합니다.

주석: If you do not see the the plugin in your interface, go to View → Panels and ensure that Shortest
path has a check mark next to it.

인터페이스에 다음과 같은 패널이 나타날 것입니다.

7.3.2 Follow Along: 도구 설정

계산을 실행할 레이어를 설정하려면 먼저 현재 맵을 저장하십시오. 그 다음 roads_34S 레이어를 오른쪽
클릭하고 Save as... 를선택해서레이어를 shapefile로저장합니다. 그리고새맵을생성해서해당레이어를
로드하십시오.

네트워크 분석 작업 시 아주 많은 유형의 설정이 가능하기 때문에, 여러분이 설정하기 전까지 플러그인은
아무 것도 가정하지 않습니다. 즉 여러분이 먼저 설정하지 않으면 플러그인은 어떤 작업도 하지 않는다는
의미입니다.

• 메뉴에서 Vector → Road graph → settings 항목을 클릭하십시오. 대화 창이 나타날 것입니다.

• 다음과 같이 설정하도록 합니다. (다른 설명이 없으면 기본값을 사용합니다.)
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• Time unit: hour

• Distance unit: kilometer

• Layer: roads_34S

• Speed field: Always use default / km/h
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• Direction: Two-way direction

• Speed: 60

7.3.3 Follow Along: 도구 사용

여러분의지도에있는도로상의두포인트를선택하십시오. 포인트에어떤의미가있어야할필요는없지만,
이 두 포인트는 도로로 연결되어 있고 일정 거리 이상 떨어져 있어야 합니다.
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• 플러그인 패널에서 Start 항목 옆에 있는 Capture Point 버튼을 클릭하십시오.
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• 여러분이 선택한 시작 포인트를 클릭하십시오.

• Stop 항목 옆에 있는 Capture Point 버튼을 이용해서 여러분이 선택한 종료 포인트를 캡처하십시오.

• Calculate 버튼을 클릭하면 다음과 같은 계산 결과를 볼 수 있습니다.
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7.3.4 Follow Along: 기준 사용

주석: 이 부분은 Linfiniti 와 S. Motala(남아프리카공화국 케이프 페닌슐라 기술대학교) 가 작성했습니다.

• 사용자의 restaurants_34S 레이어를 (필요하다면 여러분의 analyis 맵에서 추출한 다음) 맵에
추가합니다.

• roads_34S 레이어의 속성 테이블을 열고 편집 모드로 들어가십시오.

• Add a new column with the name SPEED, and give it the type

Whole number (integer) with a width of 3.

• 메인 창에서 다음과 같이 Select Features by Rectangle 도구를 활성화합니다.
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• 주거 지역이 아닌 도심 지역에 있는 주 도로 가운데 아무 도로나 선택하십시오.

(하나 이상의 도로를 선택하려면, ctrl 버튼을 누른 채 포함하고자 하는 도로 위에 사각형을 드래그합니다.)

• 속성 테이블에서 Show selected features 를 선택하십시오.
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• 선택한 모든 도로의 SPEED 값을 60 으로 설정합니다.

문맥 상 해당 도로의 제한 속도를 60 km/h 로 설정한 것입니다.

• 도심 지역 바깥에 있는 고속 도로나 주요 도로 가운데 아무 도로나 선택하십시오.
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• 선택한 모든 도로의 SPEED 값을 120 으로 설정합니다.

• 속성 테이블을 닫고, 편집 내용을 저장한 다음 편집 모드를 종료합니다.

• Vector → Road graph → Road graph settings 메뉴에서 Speed 값을 여러분이 방금 생성한 SPEED
항목으로 설정한 다음, 다른 설정들은 이전과 동일한지 확인하십시오.

• Shortest path 패널에 있는 Start point 버튼을 클릭합니다.

• 다음과 같이 Swellendam 의 한 쪽에 있는 주요 도로 상에 시작 포인트를, 도시의 다른 한 쪽에 있는
주요 도로 상에 종료 포인트를 설정합니다.
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• Shortest path 패널에 있는 Criterion 드롭다운 목록에서 Length 를 선택합니다.

• Calculate 를 클릭하십시오. 다음과 같이 최단 거리의 경로를 계산합니다.

Shortest path 에 있는 Length 와 Time 의 값을 살펴보십시오.

• Criterion 을 Time 으로 설정합니다.

• Calculate 를 다시 클릭해보십시오. 다음과 같이 최단 시간의 경로를 계산할 것입니다.

이 기준들을 차례로 선택하면서 매번 재계산 작업을 할 수 있습니다. Length 와 Time 의 값이 어떻게
변화하는지 살펴보십시오. 해당 경로의 최단 시간 계산은 과속 등을 염두에 두지 않고, 항상 제한 속도로
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달린다는 가정 하에 이루어진다는 점을 기억하십시오. 실제 상황에서는 제한 속도보다는 도로를 좀 더 작은
구역으로 나누고, 각 구역에서의 평균 또는 기대 속도를 염두에 두어야 합니다.

Calculate 를클릭했을때경로를찾을수없다는오류가발생하는경우, 여러분이디지타이즈한도로가서로
연결되어 있는지 확인하십시오. 도로들이 서로 맞닿아 있지 않다면 피처를 수정하든지, 아니면 플러그인
설정에서 Topology tolerance 를 설정해서 문제를 해결해야 합니다. 두 도로가 서로 지나가지만 교차하지는
않을 경우, 다음 Split features 도구를 이용해서 교차점에서 도로를 “분리” 해야 합니다.

하지만 Split features 도구는 선택한 피처가 편집 모드일 경우에만 실행된다는 점을 기억해야 합니다!

그런데 최단 거리 경로와 최단 시간 경로가 동일한 경우에 이 오류가 발생할 수도 있습니다.

7.3.5 In Conclusion

이제 최단 경로 문제를 해결하려면 어떻게 Road Graph 플러그인을 사용해야 하는지 배웠습니다.

7.3.6 What’s Next?

다음 강의에서는 벡터 데이터셋 상에서 공간 통계 알고리듬을 실행하는 방법을 배워보겠습니다.

7.4 Lesson: 공간 통계

주석: 이 강의는 Linfiniti 와 S. Motala(남아프리카공화국 케이프 페닌슐라 기술대학교) 가 작성했습니다.

공간 통계를 이용하면 주어진 벡터 데이터셋이 어떤 의미인지 분석하고 이해할 수 있습니다. QGIS 는 이런
목적에 대해 유용하다고 알려진 몇몇 표준 통계 분석 도구를 포함하고 있습니다.

이 강의의 목표: QGIS 의 공간 통계 도구 사용 방법을 배우기.

7.4.1 Follow Along: 테스트용 데이터셋 생성

강의에서 사용할 포인트 데이터셋을 얻기 위해, 랜덤한 포인트들을 생성해보겠습니다.

이 때 포인트를 생성하려는 구역의 범위를 정의하는 폴리곤 데이터셋이 필요합니다.

거리들이 차지한 구역을 사용하겠습니다.

• 비어 있는 새 맵을 생성하십시오.

• roads_34S 레이어는 물론, exercise_data/raster/SRTM/ 경로에 있는 srtm_41_19.tif 래스터
(고도 데이터) 를 추가하십시오.

주석: SRTM DEM 레이어의 CRS 가 도로 레이어와 다를 수도 있습니다. 이럴 경우, 이 모듈의 이전
강의에서 배운 기술을 이용, 도로나 DEM 레이어 가운데 하나를 재투영할 수 있습니다.

• Vector → Geoprocessing Tools 메뉴에있는 Convex hull(s)도구를이용해서다음과같이모든도로를
전부 감싸는 구역을 생성합니다.
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• 산출물을 exercise_data/spatial_statistics/ 디렉터리에 roads_hull.shp 파일로
저장하십시오.

• 질문이 뜨면 TOC (Layers list) 에 추가합니다.

랜덤한 포인트 생성

• 메뉴에서 Vector → Research Tools → Random points도구를이용,다음과같이이구역안에포인트를
랜덤하게 생성합니다.
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• 산출물을 exercise_data/spatial_statistics/ 디렉터리에 random_points.shp 파일로
저장하십시오.

• 질문이 뜨면 TOC (Layers list) 에 추가합니다.
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데이터 샘플링

• 래스터에서 샘플 데이터셋을 생성하려면 Point sampling tool 플러그인을 이용해야 합니다.

• 필요한 경우 플러그인에 대한 강의를 미리 보는 것도 좋습니다.

• Plugin –> Manage and Install Plugins... 에서 point sampling이라는구절을검색해서플러그인을
찾을 수 있습니다.

• Plugin Manager 로 이 도구를 활성화시키면, 메뉴의 Plugins → Analyses → Point sampling tool
항목으로 다음과 같은 도구를 실행할 수 있습니다.
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• 샘플링할 포인트를 담은 레이어로 random_points 를, 값을 추출할 밴드로 SRTM 래스터를
선택합니다.

• “Add created layer to the TOC” 항목이 체크되어 있는지 확인하십시오.

• 산출물을 exercise_data/spatial_statistics/ 디렉터리에 random_samples.shp 파일로
저장하십시오.

이제 random_samples레이어의속성테이블에서래스터파일로부터샘플링한데이터를확인할수있습니다.
srtm_41_19.tif 이라는 명칭의 열에 데이터가 있을 것입니다.

다음과 비슷한 샘플 레이어가 보일 것입니다.
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샘플 포인트는 각각의 값에 따라 범주화됩니다. 이 경우 포인트의 고도가 낮을수록 색이 어두워집니다.

나머지 통계 실습 동안 이 샘플 레이어를 사용할 것입니다.

7.4.2 Follow Along: 기본 통계

이제 이 레이어에 대한 기본적인 통계를 내보겠습니다.

• 메뉴에서 Vector → Analysis Tools → Basic statistics 항목을 클릭하십시오.

• 대화 창이 뜨면 입력 레이어로 random_samples 를 설정합니다.

• Target field 가 여러분이 통계를 계산할 대상인 srtm_41_19.tif 으로 설정돼 있는지 확인하십시오.

• OK 를 클릭합니다. 다음과 같은 결과를 보게 될 것입니다.
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주석: 이 결과를 스프레드시트에 복사 & 붙여넣기 할 수 있습니다. 이 데이터는 구분자로 쌍점 : 을
사용합니다.
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• 완료되면 플러그인 대화 창을 닫으십시오.

이 통계를 이해하려면 다음 정의들을 참조하십시오.

Mean 중간 (평균) 값은 값을 모두 더한 것을 값의 개수로 나눈 값입니다.

StdDev 표준편차입니다. 값들이얼마나중간값에가까이모여있는지를나타냅니다. 표준편차가작을수록
값들이 중간값에 더 가까이 모이는 경향이 있습니다.

Sum 모든 값들을 더한 값입니다.

Min 최소값입니다.

Max 최대값입니다.

N 샘플/값의 개수입니다.

CV 데이터셋의 공간 공분산 입니다.

Number of unique values 이 데이터셋에서 유일한 값의 개수입니다. N=100 인 데이터셋에 90 개의
유일한 값이 있을 경우, 나머지 10 개의 값은 서로 하나 이상 같습니다.

Range 최소/최대값의 차이입니다.

Median 모든 값을 최소에서 최대로 배열할 경우, 그 중앙에 있는 (또는 N 이 짝수라면 두 중앙값의 평균)
값을 중앙값이라 합니다.

7.4.3 Follow Along: 거리 행렬 계산

• 다른 데이터셋 ( WGS 84 / UTM 34S ) 과 동일한 투영체로 새 포인트 레이어를 생성하십시오.

• 편집 모드로 들어가서 다른 포인트들 사이 어딘가에 포인트 3 개를 디지타이즈하십시오.

• 또는 이전과 마찬가지 방법으로 랜덤한 포인트를 생성하되 딱 3 개만 설정하십시오.

• 이 새 레이어를 distance_points.shp 파일로 저장합니다.

이 포인트들로 거리 행렬을 생성하는 방법은 다음과 같습니다.

• Vector → Analysis Tools → Distance matrix 도구를 실행합니다.

• 입력 레이어로 distance_points 레이어를, 목표 레이어로 random_samples 레이어를 선택합니다.

• 다음과 같이 설정하십시오.
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• 산출물을 distance_matrix.csv 파일로 저장하도록 지정하십시오.

• OK 를 클릭해서 거리 행렬을 생성합니다.

• 스프레드시트 프로그램으로 산출물 파일을 열어보십시오. 다음과 비슷한 결과를 볼 수 있습니다.
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7.4.4 Follow Along: 가장 가까운 이웃 분석

가장 가까운 이웃 분석을 하려면,

• 메뉴에서 Vector → Analysis Tools → Nearest neighbor analysis 항목을 클릭하십시오.

• 대화 창이 뜨면 random_samples 레이어를 선택한 다음 OK 를 클릭하십시오.

• 대화 창의 텍스트 창에 다음과 비슷한 결과가 나타날 것입니다.

주석: 이 결과를 스프레드시트에 복사 & 붙여넣기 할 수 있습니다. 이 데이터는 구분자로 쌍점 : 을
사용합니다.
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7.4.5 Follow Along: 평균 좌표

데이터의 평균 좌표를 얻으려면,

• 메뉴의 Vector → Analysis Tools → Mean coordinate(s) 항목을 클릭하십시오.

• 대화 창이 뜨면 입력 레이어로 random_samples 를 설정하되 다른 옵션들은 변경하지 마십시오.

• 산출 레이어로 mean_coords.shp 파일을 설정하십시오.

• OK 를 클릭합니다.

• 질문이 뜨면 Layers list 에 해당 레이어를 추가합니다.

이 레이어를 랜덤 샘플을 생성하는 데 쓰인 폴리곤의 중앙 좌표와 비교해봅시다.

• 메뉴에서 Vector → Geometry Tools → Polygon centroids 항목을 클릭하십시오.

• 대화 창이 뜨면 입력 레이어로 roads_hull 을 선택하십시오.

• 결과물을 center_point 로 저장하십시오.

• 질문이 뜨면 Layers list 에 해당 레이어를 추가합니다.

다음 그림에서 볼 수 있듯이, 평균 좌표와 연구 지역의 중앙 좌표 (오렌지색) 는 반드시 일치하지 않을 수도
있습니다.

7.4.6 Follow Along: 이미지 히스토그램

데이터셋의 히스토그램은 데이터셋의 값들의 분포를 보여줍니다. QGIS 에서 이를 보여줄 수 있는 가장
간단한 방법은 이미지 레이어의 Layer Properties 대화 창에서 쓸 수 있는 이미지 히스토그램을 사용하는
것입니다.

• Layers list 에서 SRTM DEM 레이어를 오른쪽 클릭하십시오.

• Properties 를 선택합니다.

• Histogram 탭을 선택하십시오. 그래픽을 생성하려면 Compute Histogram 버튼을 클릭해야 할 수도
있습니다. 이미지 안의 값들의 빈도를 나타내는 그래프를 볼 수 있을 것입니다.
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• 다음과 같이 그래프를 이미지로 내보낼 수 있습니다.

• Metadata 탭을 선택하면, Properties 박스 안에서 더 상세한 정보를 찾아볼 수 있습니다.

평균값은 332.8 이고, 최대값은 1699 입니다! 하지만 히스토그램에서 이 값들을 찾아볼 수 없습니다.
왜일까요? 평균 이하의 값을 가진 픽셀들이 어마어마한 개수에 비해 너무 적기 때문입니다. 또 약 250
이상인 값들의 빈도를 표시하는 빨간 줄이 보이지 않는 데도 히스토그램이 오른쪽으로 길게 연장되어 있는
이유이기도 합니다.

따라서 히스토그램은 값들의 분포를 보여줄 뿐, 그래프 상에 모든 값을 보여주지 않을 수도 있다는 점을
기억해야 합니다.

• (이제 Layer Properties 를 닫아도 됩니다.)

7.4.7 Follow Along: 공간 보간법

여러분이 어떤 샘플 포인트 집합으로부터 데이터를 추정하고자 한다고 해봅시다. 예를 들어 이번에 생성한
random_samples 데이터셋에 접근할 수 있는데, 이로부터 해당 지형이 어떻게 생겼는지 감을 잡고자 할
수도 있습니다.

메뉴에서 Raster → Analysis → Grid (Interpolation) 항목을 클릭해서 Grid (Interpolation) 도구를
실행하십시오.

• Input file 항목에 random_samples 를 선택하십시오.
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• Z Field 체크박스를 체크하고, srtm_41_19 항목을 선택하십시오.

• Output file 경로를 exercise_data/spatial_statistics/interpolation.tif 로 설정합니다.

• Algorithm 체크박스를 체크하고, Inverse distance to a power 를 선택하십시오.

• Power 를 5.0 로, Smoothing 을 2.0 로 설정하십시오. 다른 값은 변경하지 않습니다.

• Load into canvas when finished 체크박스를 체크한 다음 OK 를 클릭하십시오.

• 완료되면, Process completed 라고 나타나는 대화 창의 OK 를 클릭하고, 피드백 정보를 보여주는
대화 창의 (나타날 경우) OK 를 클릭한 다음, Grid (Interpolation) 대화 창의 Close 를 클릭합니다.

다음은 원래 데이터셋 (왼쪽) 과 샘플 포인트로부터 구축한 데이터셋 (오른쪽) 을 비교한 그림입니다.
사용자가 구축한 데이터셋은 샘플 포인트들의 위치의 랜덤성에 따라 달라 보일 수도 있습니다.

그림에 잘 나타나듯이, 샘플 포인트 100 개로는 해당 지형의 자세한 인상을 얻기에 턱없이 부족합니다. 아주
전반적인 감을 잡을 수는 있지만 쉽게 오도할 수도 있습니다. 예를 들어 앞의 그림에서 동쪽에서 서쪽으로
이어지는 높은 산맥이 있다는 사실을 알기란 어렵습니다. 사실 서쪽의 높은 봉우리와 그 옆의 골짜기로
이해하기 쉽죠. 육안으로만 살펴보아도 샘플 데이터셋이 해당 지역의 지형을 표현할 수 없다는 사실은
명백합니다.

7.4.8 Try Yourself

• 앞에서 설명한 과정대로, 새로운 랜덤 포인트 1000 개 집합을 생성하십시오.

• 이 포인트들을 이용해서 원 DEM 을 샘플링하십시오.

• Grid (Interpolation) 도구를 앞에 설명한 대로 이 새로운 데이터셋에 사용하십시오.

• Power 를 5.0 로, Smoothing 을 2.0 로 설정하고 산출물 파일명을 interpolation_1000.tif 로
설정하십시오.

결과물은 (여러분의 랜덤 포인트 위치에 따라) 다음과 비슷하게 보일 것입니다.
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경계선 바깥에서 갑작스럽게 세부 표현이 떨어지는 사실을 설명하기 위해 (랜덤한 샘플 포인트의 범위를
나타내는) roads_hull 레이어의 윤곽선을 보이게 했습니다. 샘플 포인트의 밀도가 훨씬 높기 때문에 지형을
더 잘 표현하고 있습니다.

다음은 샘플 포인트가 10 000 개일 경우 어떻게 보이는지에 대한 예시입니다.

주석: 샘플데이터셋의용량이클수록처리시간이늘어나기때문에,사용자의컴퓨터속도가빠르지않다면
샘플 포인트 1 만 개로 실습하지 않는 편이 낫습니다.
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7.4.9 Follow Along: 그 외의 공간 분석 도구들

QGIS 버전 2.0 부터, 원래 개별 프로젝트로 시작해서 플러그인으로서 접근할 수 있게 된 SEXTANTE
소프트웨어가 핵심 기능으로 추가되었습니다. QGIS 의 새로운 메뉴인 Processing 에서 이 도구를 찾을 수
있습니다. Processing 메뉴를 통해 단일 인터페이스에서 다양한 플러그인 도구에 접근할 수 있게 해주는
공간 분석 도구들의 다채로운 툴박스에 접근할 수 있습니다.

• Activate this set of tools by enabling the Processing → Toolbox

menu entry. The toolbox looks like this:

이 툴박스는 QGIS 맵 화면 오른쪽에 붙게 됩니다. 이 도구 목록은 실제 도구들로의 링크라는 점을
주의하십시오. 일부는 SEXTANTE 의 자체 알고리듬들이고, 다른 일부는 GRASS, SAGA 또는 Orfeo
Toolbox 와 같은 외부 응용 프로그램으로 접근하는 링크입니다. 이 외부 응용 프로그램들은 QGIS 와
함께 설치되므로 여러분은 그대로 이 도구들을 사용할 수 있습니다. Processing 도구들의 설정을 변경해야
하거나, 또는 예를 들어 외부 응용 프로그램 가운데 하나를 최신 버전으로 업데이트해야 할 경우, Processing
→ Options and configurations 메뉴에서 설정을 변경할 수 있습니다.

7.4.10 Follow Along: 공간 포인트 패턴 분석

random_samples 데이터셋에서 포인트들의 공간 분포를 간단히 표현하려면, 여러분이 방금 열었던 Pro-
cessing Toolbox 를 통해 SAGA 의 Spatial Point Pattern Analysis 도구를 사용할 수 있습니다.

• Processing Toolbox 에서 Spatial Point Pattern Analysis 도구를 찾아보십시오.

• 해당 도구를 더블클릭하면 대화 창이 열립니다.
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SAGA 설치

주석: 사용자 시스템에 SAGA 가 설치되어 있지 않다면 플러그인의 대화 창에서 의존성이 누락되었다고
알려줄 것입니다. 그렇지 않다면 이 단계를 건너뛰어도 됩니다.

윈도우 시스템

여러분의 강의 자료에 윈도우용 SAGA 설치 파일이 포함돼 있습니다.

• 프로그램을 실행하고 절차에 따라 사용자의 윈도우 시스템에 SAGA 를 설치합니다. 설치 경로를
확인해두십시오!

SAGA 설치를 완료하면, SEXTANTE 에 해당 설치 경로를 설정해야 합니다.

• 메뉴에서 Analysis → SAGA options and configuration 항목을 클릭하십시오.

• 대화 창이 뜨면, SAGA 항목을 확장해서 SAGA folder 를 찾으십시오. 비어 있을 것입니다.

• 해당 란에 사용자가 SAGA 를 설치한 경로를 입력합니다.

우분투 시스템

• Software Center 에서 SAGA GIS 를 검색하거나, 터미널에서 sudo apt-get install saga-gis
명령어를 입력합니다. (먼저 사용자의 자원에 SAGA 저장소를 추가해야 할 수도 있습니다.)

• QGIS 가 자동적으로 SAGA 를 찾을 것입니다. 하지만 한 번에 실행되지 않을 경우 QGIS 를
재시작해야 할 수도 있습니다.

Mac 시스템

Homebrew 사용자는 다음 명령어로 SAGA 를 설치할 수 있습니다.

• brew install saga-core

Homebrew 사용자가 아니라면 다음 절차를 따르십시오.

http://sourceforge.net/apps/trac/saga-gis/wiki/Compiling%20SAGA%20on%20Mac%20OS%20X

설치 후

이제 SAGA 를 설치하고 설정했으니, SAGA 의 기능을 사용할 수 있게 됐습니다.

SAGA 사용

• SAGA 대화 창을 엽니다.

• SAGA 는 산출물 3 개를 생성하기 때문에 산출물 경로도 3 개가 필요합니다.

• exercise_data/spatial_statistics/ 디렉터리 아래에 세 산출물을 저장하도록 설정하십시오.
파일명은 자유롭게 선택하십시오.
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산출물은 다음과 같이 보일 것입니다. (이 예제와는 심볼이 다를 수도 있습니다.)
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빨간점은평균중앙이고,큰원은평균중앙주변으로포인트들이얼마나가까이분포되어있는지를나타내는
표준 거리이며, 사각형은 모든 포인트들을 감싸는 가능한 한 작은 범위 상자 (bounding box) 입니다.

7.4.11 Follow Along: 최소 거리 분석

알고리듬의 산출물이 shapefile 이 아니라 데이터셋의 통계 속성을 종합한 테이블일 경우가 종종 있습니다.
Minimum Distance Analysis 도구가 그 가운데 하나입니다.

• Find this tool in the Processing Toolbox as :guilabel:‘Minimum

Distance Analysis‘.

분석할 벡터 포인트 데이터셋을 설정하는 일 외에는 어떤 입력도 할 필요가 없습니다.

• random_points 데이터셋을 선택하십시오.

• OK 를 클릭합니다. 완료되면, Layers list 에 DBF 테이블이 나타날 것입니다.

• 해당 테이블을 선택해서 속성 테이블을 여십시오. 값은 다를 수도 있지만, 이 결과물은 다음 서식으로
되어 있을 것입니다.
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7.4.12 In Conclusion

QGIS 를 사용하면 데이터셋의 속성에 대해 다양한 공간 통계 분석을 할 수 있습니다.

7.4.13 What’s Next?

이제 벡터 분석에 대한 내용을 마쳤으니, 래스터에 대해 알아보는 것은 어떨까요? 이것이 다음 모듈의
주제입니다!
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CHAPTER 8

Module: 래스터

이전 강의에서 디지타이즈 작업에 래스터를 사용했지만, 래스터 데이터를 직접 이용할 수도 있습니다. 이
모듈에서는 QGIS 가 어떻게 래스터 데이터를 이용하는지 배울 것입니다.

8.1 Lesson: 래스터 데이터 작업

래스터 데이터는 벡터 데이터와 많이 다릅니다. 벡터 데이터는 꼭짓점들로 구성된, 그리고 라인 및/또는
면과 연결되어 있을 수도 있는 개별 피처들로 이루어져 있습니다. 그러나 래스터 데이터는 일반 이미지와
같습니다. 실재 세계에 있는 오브젝트의 다양한 속성을 표현할 수도 있지만, 이 오브젝트들은 개별
오브젝트로 존재하는 것이 아니라 다양한 서로 다른 색상값을 가지는 픽셀을 이용하여 표현됩니다.

이 모듈에서 여러분은 기존 GIS 분석을 보충하는 데 래스터 데이터를 사용하게 될 것입니다.

이 강의의 목표: QGIS 환경에서 어떻게 래스터 데이터를 작업하는지 배우기.

8.1.1 Follow Along: 래스터 데이터 불러오기

• Open your analysis.qgs map.

• solution 및 important_roads 레이어를 제외한 모든 레이어를 비활성화하십시오.

• 다음 Load Raster Layer 버튼을 클릭하십시오.

Load Raster Layer 대화창이 열립니다. 이 예제에 쓰일 데이터는 exercise_data/raster 디렉터리 아래
있습니다.

• 데이터를 각각 불러오거나, ctrl 을 누른 채 데이터 4 개를 모두 선택해서 동시에 여십시오.

여러분의 맵에 아무 일도 일어나지 않은 것 같다는 것을 눈치채셨을 겁니다. 래스터를 불러오지 못 한
걸까요? 흠, Layers list 에 추가된 걸 보니 로드된 건 확실합니다. 문제는 동일한 투영체를 사용하고 있지
않다는 사실입니다. 다행히, 이런 상황에서 어떻게 해야하는지 이미 배웠습니다.

• 메뉴에서 Project –> Project Properties 를 선택하십시오.

• CRS 탭을 선택하십시오.

• “실시간” 재투영을 활성화하십시오.

• 사용자의 다른 데이터와 동일한 투영체 ( WGS 84 / UTM zone 33S ) 로 설정합니다.

• OK 를 클릭하십시오.

다음과 같이 래스터가 잘 맞춰질 것입니다.
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연구 지역 전체를 커버하는 항공사진 4 장을 불러왔습니다.

8.1.2 Follow Along: 가상 래스터 생성

이제이화면에서볼수있듯이,사용자의벡터레이어가사진네장전체에걸쳐있습니다. 즉항상이래스터
4개를동시에작업해야한다는뜻입니다. 그건좀불편하겠죠. 한장의 (합성)이미지파일로작업하는편이
훨씬 낫지 않을까요?

다행히 QGIS 는 정확히 이 기능을 지원합니다. 게다가 용량을 많이 차지할 수도 있는 새 래스터 파일을
실제로 생성해야 할 필요도 없습니다. 그 대신 가상 래스터 를 생성할 수 있습니다. 종종 이를 카탈로그
라고 하기도 하는데, 그 기능을 설명해주는 이름입니다. 정말로 새로운 래스터는 아니죠. 손쉬운 접근을
가능하게 해주는 하나의 파일, 하나의 카탈로그로 사용자의 기존 래스터를 조직하는 방법입니다.

카탈로그를 만들려면,

• 메뉴에서 Raster → Miscellaneous → Build Virtual Raster (Catalog) 항목을 클릭하십시오.

• 대화 창이 뜨면, Use visible raster layers for input 옆에 있는 체크박스를 체크하십시오.

• 산출물 경로에 exercise_data/residential_development 를 입력하십시오.

• 파일명을 aerial_photos.vrt 로 합니다.

• Load into canvas when finished 체크박스를 체크합니다.

210 Chapter 8. Module: 래스터



QGIS Training Manual, 출시 2.2

그 아래에 있는 텍스트 항목을 살펴보십시오. 이 대화 창이 실제로 하는 일은 그 텍스트를 사용자 대신
써주는 것입니다. QGIS 가 실행하게 될 긴 명령어죠.

주석: 이 명령어 텍스트를 편집할 수 있으므로, 원하는 경우 명령어를 사용자가 직접 변경할 수도 있다는
점을명심하십시오. 초기명령어 (이경우에는 gdalbuildvrt )의문법에대한도움말을보고싶다면온라인
검색을 해보십시오.

• OK 를 클릭해서 명령어를 실행합니다.

완료까지 시간이 걸릴 수도 있습니다. 완료 시 완료했다는 메시지 박스가 나타날 것입니다.

• 메시지를 끄려면 OK 를 클릭하십시오.

• Build Virtual Raster (Catalog) 대화 창의 Close 를 클릭하십시오. ( OK 를 클릭하면 명령어를 다시
실행하게 됩니다.)
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• 이제 Layers list 에서 원래 래스터 4 장을 제거할 수 있습니다.

• 필요한 경우 새로 생성된 aerial_photos 래스터 카탈로그 레이어를 Layers list 맨 아래로 클릭 &
드래그해서 활성화된 다른 레이어가 잘 보이도록 합니다.

8.1.3 래스터 데이터 변환

앞에서 설명한 방법으로 카탈로그를 이용해서 데이터셋을 가상으로 합치고 “실시간” 으로 재투영할 수
있습니다. 그러나비교적긴시간동안사용할데이터를준비하는경우,이미합쳐지고재투영된새래스터를
생성하는 편이 더 효율적일 수도 있습니다. 초기 준비 과정에 시간이 걸릴 수도 있지만, 맵 상에서 래스터를
사용할 때 속도를 향상시킬 수 있습니다.

래스터 재투영

• 메뉴에서 Raster → Projections → Warp (Reproject) 항목을 클릭하십시오.

이 도구에서 디렉터리에 있는 모든 데이터를 재투영할 수 있는 편리한 일괄 옵션을 사용할 수 있다는 점을
주목하십시오. 가상 래스터 (카탈로그) 를 재투영하는 것은 물론, 멀티스레드 처리 모드를 활성화할 수도
있습니다.
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래스터 합치기

• 메뉴에서 Raster → Miscellaneous → Merge 항목을 클릭하십시오.

이매우유용한,내장된일괄처리기능으로단일파일대신디렉터리전체를처리하도록선택할수있습니다.
가상 래스터를 입력 파일로 설정할 수도 있는데, 이 경우 가상 래스터를 구성하는 모든 래스터를 처리하게
됩니다.

Creation Options 체크박스 및 목록을 이용해서 사용자 지정 명령줄 옵션을 추가할 수도 있습니다. 다만 이
경우 GDAL 라이브러리의 운용법을 알고 있어야 합니다.
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8.1.4 In Conclusion

QGIS 를 통해 사용자의 기존 프로젝트에 래스터 데이터를 손쉽게 포함시킬 수 있습니다.

8.1.5 What’s Next?

다음 강의에서 항공사진이 아닌 래스터 데이터를 사용해서 래스터를 어떻게 심볼로도 활용할 수 있는지
배워보겠습니다.

8.2 Lesson: 래스터 심볼 변경

모든래스터데이터가항공사진인것은아닙니다. 다른형식의래스터데이터도많이있으며,대부분의경우,
데이터를 적절히 심볼화해서 제대로 활용할 수 있도록 표출하는 작업이 필요합니다.

이 강의의 목표: 래스터 레이어를 위해 심볼을 변경하기.

8.2.1 Try Yourself

• Start with the current map from the previous exercise analysis.qgs.

• Add Raster Layer 버튼을 사용해서 새 래스터 데이터셋을 불러옵니다.

• exercise_data/raster/SRTM/ 디렉터리에 있는 데이터셋 srtm_41_19.tif 을 로드하십시오.

• 래스터 데이터셋이 Layers list 에 추가되면 DEM 이라는 명칭으로 변경하십시오.

• 레이어 목록에서 해당 데이터셋을 오른쪽 클릭하고 Zoom to Layer Extent 를 선택해서 레이어 전체가
보이도록 줌인/줌아웃하십시오.

이 데이터셋은 수치 표고 모델 (Digital Elevation Model, DEM) 입니다. 지형의 표고 (고도) 를 표현하는
맵으로, 예를 들면 산과 계곡의 위치를 볼 수 있게 해줍니다.

불러오기가 완료되면, 이 데이터셋이 DEM 을 표현하는, 기본 구간화 흑백 스케일 래스터라는 것을 알 수
있습니다. 다음은 벡터 레이어를 맨 위에 놓은 화면입니다.
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QGIS 는 시각화 목적을 위해 자동적으로 이미지에 구간을 적용합니다. 이번 실습을 계속하면서 이것이
어떻게 작용하는지 배우게 될 것입니다.

8.2.2 Follow Along: 래스터 레이어 심볼 변경

• 레이어목록에서 SRTM 레이어를오른쪽클릭하고 Properties옵션을선택해서 Layer Properties대화
창을 여십시오.

• Style 탭을 선택하십시오.
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QGIS 가 기본적으로 적용한 현재 설정 화면입니다. 이 설정은 DEM 을 시각화하는 한 방법일 뿐이므로,
다른 설정을 알아보도록 합시다.

• Render type 을 Singleband pseudocolor 로 변경한 다음, 나타나는 기본 옵션을 그대로 사용하십시오.

• Classify 버튼을 클릭해서 새 색상 범주화를 생성한 다음, OK 를 클릭해서 해당 범주화를 DEM 에
적용하십시오.
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래스터가 다음과 같이 보이게 됩니다.
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DEM 을 시각화하는 데 있어 분명히 재미있는 방법이긴 하지만, 이 색상들로 심볼화하는 건 적당하지 않은
것 같군요.

• Layer Properties 대화 창을 다시 여십시오.

• Render Type 을 다시 Singleband gray 로 바꾸십시오.

• OK 를 클릭해서 이 설정을 래스터에 적용하십시오.

이제 하나도 쓸모 없는 회색 사각형만 보게 됩니다.
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색상값이 서로 대비되도록 구간을 적용하는 기본 설정이 사라졌기 때문입니다.

DEM 데이터의 범위에 기반해 색상값을 다시 “구간화” 하도록 QGIS 에 명령해봅시다. QGIS 는 사용할 수
있는 모든 색상 ( Grayscale 에서는, 검정, 하양 그리고 그 사이의 모든 회색 색조들을 말합니다) 을 이용할
것입니다.

• Min 과 Max 값을 다음과 같이 설정하십시오.

• Contrast enhancement 의 값을 Stretch To MinMax 로 설정하십시오.
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그런데 구간에 쓰여야 할 최소 및 최대값이란 무엇일까요? 지금 현재 Min 이나 Max 에 설정된 값으로는
아까처럼커다란회색사각형을만들뿐입니다. 그대신이미지에실제로담겨있는최소/최대값을사용해야
하지 않을까요? 다행히도, 래스터의 최소/최대값을 불러와 이 값들을 손쉽게 결정할 수 있습니다.

• Load min / max values 란에서 Min / Max 옵션을 선택하십시오.

• Load 버튼을 클릭하십시오.

Custom min / max values 가 어떻게 DEM 의 실제 값들을 반영해서 변경됐는지 살펴보십시오.
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• OK 를 클릭해서 이 설정을 이미지에 적용하십시오.

이제 래스터의 값들이 다시 한 번 제대로 표출되는 것을 볼 수 있습니다. 색이 어두울 수록 골짜기를, 밝을
수록 봉우리를 나타냅니다.
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하지만 좀 더 나은, 또는 쉬운 방법이 있지 않을까요?

네, 있습니다. 이제 어떤 작업을 해야 하는지 이해했으니, 이 모든 작업을 손쉽게 할 수 있는 도구가 있다는
사실을 알면 기뻐하실 겁니다.

• Layers list 에서 현재 DEM 을 제거하십시오.

• 래스터를 다시 불러들인 다음, 마찬가지로 DEM 이라는 명칭으로 변경합니다. 역시 회색 사각형이
보입니다...

• View → Toolbars → Raster 를 활성화해서 필요한 도구를 활성화하십시오. 인터페이스에 다음과
같은 아이콘들이 나타납니다.

왼쪽에서 세 번째, Local Histogram Stretch 버튼을 클릭하면, 여러분이 현재 보고 있는 지역에 가장 적절한
대비가 되도록 자동적으로 최소/최대값을 구간화합니다. 대용량 데이터셋에 유용합니다. 왼쪽에 있는
Local Cumulative Cut Stretch ... 버튼을 클릭하면 전체 이미지에 걸쳐 현재 최소. 최대값을 상수값으로
구간화합니다.

• 왼쪽에서 네 번째 Stretch Histogram to Full Dataset 버튼을 클릭해보십시오. 데이터가 이전과
마찬가지로 정확히 표현되는 것을 볼 수 있습니다.

이 툴바에 있는 다른 버튼들도 시험해보십시오. 어떤 지역으로 줌인했을 때, 또는 전체 레이어 범위로
줌아웃했을 때 이미지의 구간을 어떻게 변경시키는지 살펴보도록 합시다.
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8.2.3 In Conclusion

이 강의에서 설명한 것들은 래스터 심볼에 대한 가장 기본적인 기능들입니다. QGIS 에서는 표준 편차를
이용해서 레이어를 심볼화하거나, 다중 스펙트럼 이미지에서 밴드 별로 다른 색상을 표현하거나 하는, 다른
많은 옵션을 쓸 수 있습니다.

8.2.4 참조

SRTM 데이터셋의 출처는 http://srtm.csi.cgiar.org/ 입니다.

8.2.5 What’s Next?

이제 데이터를 제대로 표출할 수 있게 됐으니, 어떻게 더 심도 있게 분석할 수 있을지 알아보겠습니다.

8.3 Lesson: 지형 분석

래스터가 표현하고 있는 지형에 대해 더 깊이 이해할 수 있게 해주는 특정한 래스터 형식이 있습니다. 수치
표고 모델 (DEM) 이 이런 점에서 특히 유용합니다. 이 강의에서는 지형 분석을 이용해서, 이전 모듈에서
다뤘던 주거 구역 개발에 대해 더 자세히 알아보도록 하겠습니다.

이 강의의 목표: 지형 분석을 이용해서 지형에 대해 더 많은 정보를 끌어내기.

8.3.1 Follow Along: 음영기복도 계산

지금 여러분의 맵에 있는 DEM 이 지형의 표고를 보여주기는 하지만, 가끔은 조금 추상적으로 보일 수도
있습니다. 여러분에게 필요한 지형의 모든 3D 정보를 담고 있지만, 3D 오브젝트로 보이지는 않습니다. 이
지형을 좀 더 잘 표현하기 위해 음영기복도 를 계산할 수 있습니다. 음영기복도란 빛과 그림자를 이용해서
지형을 3D 처럼 보이는 이미지로 생성한 래스터입니다.

DEM 을 작업하려면 QGIS 의 일체형 DEM (Terrain models) 분석 도구를 사용해야 합니다.

• 메뉴에서 Raster → Analysis → DEM (Terrain models) 항목을 클릭하십시오.

• 대화 창이 뜨면, Input file 이 DEM 레이어인지 확인하십시오.

• Output file 을 exercise_data/residential_development 디렉터리의 hillshade.tif 로
설정하십시오.

• 또 Mode 옵션에서 Hillshade 를 선택하도록 합니다.

• Load into canvas when finished 옆에 있는 체크박스를 체크하십시오.

• 다른 옵션은 그대로 놔둬도 됩니다.

• OK 를 클릭해서 음영기복도를 생성합니다.

• 처리가 완료됐다는 메시지 창이 뜨면, 메시지 창의 OK 를 클릭해서 창을 닫으십시오.

• DEM (Terrain models) 대화 창의 Close 를 클릭하십시오.

이제 다음과 같이 hillshade 라는 새 레이어가 생성되었습니다.
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멋진 3D로보입니다만,좀더향상시킬수있을까요? 음영기복도그자체로는마치석고모형처럼보입니다.
다른, 좀 더 다채로운 래스터들과 어떻게 함께 사용할 수는 없을까요? 물론 할 수 있습니다. 음영기복도를
오버레이로서 사용한다면 말이죠.

8.3.2 Follow Along: 음영기복도를 오버레이로 사용

음영기복도는 낮 동안의 특정 시간의 햇빛에 대한 유용한 정보를 제공할 수 있습니다. 하지만 맵을 더 보기
좋게 하기 위한 심미적 목적을 위해서도 사용할 수 있습니다. 이렇게 하려면 음영기복도를 거의 투명하게
설정하면 됩니다.

• 이전 강의에서처럼 원래 DEM 의 심볼에 Pseudocolor 배합을 쓰도록 변경하십시오.

• DEM 과 hillshade 레이어를 제외한 모든 레이어를 비활성화하십시오.

• Layers list 에서 DEM 을 클릭 & 드래그해서 hillshade 레이어 밑으로 옮기십시오.

• hillshade 레이어의 Layer Properties 를 열고 Transparency 탭으로 가서 투명도를 설정하십시오.

• Global transparency 를 50% 로 설정합니다.

• Layer Properties 대화 창의 OK 를 클릭하십시오. 다음과 같은 화면을 보게 될 것입니다.
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• Layers list 에서 hillshade 레이어를 껐다 켰다 하면서 그 차이점을 살펴보십시오.

음영기복도를 이런 식으로 사용하면 경관의 지형을 향상시킬 수 있습니다. 만약 그 효과가 미미하다고
느껴진다면, hillshade 레이어의 투명도를 조절할 수 있습니다. 하지만 물론, 음영기복도가 밝아질수록 그
아래의 색상은 침침해질 것입니다. 여러분이 만족할 수 있는 균형을 찾아야 합니다.

작업 완료 시 맵을 저장하는 일을 잊지 마십시오.

주석: 다음 두 가지 실습에서는 새 맵을 사용하십시오. DEM 래스터 데이터셋 (
exercise_data/raster/SRTM/srtm_41_19.tif ) 만을 불러오십시오. 여러분이 래스터 분석 도구를
이용해 작업할 때 문제를 단순화하기 위해서입니다. 이 맵을 exercise_data/raster_analysis.qgs 로
저장하십시오.

8.3.3 Follow Along: 경사도 계산

지형에 대해 알아두면 좋은 점 가운데 하나는 얼마나 가파르냐는 것입니다. 예를 들어 어떤 토지에 집을
짓고 싶다고 할 때, 그 토지는 어느 정도 평평해야 할 것입니다.

이 작업을 하려면 DEM (Terrain models) 도구의 Slope 모드를 사용해야 합니다.

• 이전처럼 도구를 여십시오.

• 다음과 같이 Mode 옵션에서 Slope 를 선택하십시오.
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• 저장 경로를 exercise_data/residential_development/slope.tif 로 설정하십시오.

• Load into canvas... 체크박스를 체크하십시오.

• OK 를 클릭한 다음 처리가 완료되면 메시지 창을 닫고, Close 를 클릭해서 대화 창을 닫으십시오.
사용자 맵에 새 래스터가 로드됐을 것입니다.

• Layers list 에서새래스터를선택하고, Stretch Histogram to Full Dataset 버튼을클릭하십시오. 이제
검은 픽셀은 평평한 지형, 하얀 픽셀은 가파른 지형을 나타내는 다음과 같은 경사도를 볼 수 있습니다.

8.3.4 Try Yourself 향 계산

지형의 향 이란 어떤 지형이 면하고 있는 방향을 말합니다. 현재의 연구 지역이 남반구에 있으므로, 햇빛을
받으려면 북쪽을 면하고 있는 비탈에 건물을 지어야 하겠죠.

• 지형의 향을 계산하려면 DEM (Terain models) 도구의 Aspect 모드를 사용하십시오.

결과 확인

8.3.5 Follow Along: 래스터 계산기 사용

벡터 분석 강의에서 마지막으로 다뤘던 부동산 중개업자 문제를 다시 떠올려보십시오. 그때의 구매자가
지금은 건물을 산 다음 부지 내에 작은 집을 짓고 싶어 한다고 해봅시다. 남반구에서 이런 개발에 이상적인
계획은 우선 5˚ 미만 경사의 북쪽을 면한 토지가 있어야 할 것입니다. 그러나 경사가 2˚ 미만인 경우, 향은
문제가 되지 않습니다.

다행히 여러분에게는 이미 경사는 물론 향을 보여주는 래스터가 있습니다. 그런데 이 두 가지 조건을 동시에
만족하는 곳을 알 도리가 없죠. 어떻게 이런 분석을 할 수 있을까요?
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그 답은 Raster calculator 가 가지고 있습니다.

• Raster > Raster calculator... 를 클릭해서 이 도구를 실행하십시오.

• aspect데이터셋을사용하려면왼쪽에있는 Raster bands목록에서 aspect@1항목을더블클릭하십시오.
아래쪽에 있는 Raster calculator expression 텍스트 란에 나타날 것입니다.

북쪽은 0˚ 이므로, 북쪽을 면한 지형을 원한다면 그 향이 270˚ 이상, 90˚ 이하여야 합니다.

• Raster calculator expression 란에 다음 표현식을 입력하십시오.

aspect@1 <= 90 OR aspect@1 >= 270

• 산출물파일경로를 exercise_data/residential_development/ ,파일명을 aspect_north.tif로
설정하십시오.

• Add result to project 체크박스를 체크했는지 확인하십시오.

• OK 를 클릭해서 처리를 시작합니다.

결과는 다음과 같을 것입니다.
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8.3.6 Try Yourself

이제 향 작업을 끝냈으니, DEM 레이어에 대한 두 가지 새로운 분석을 생성해봅시다.

• 먼저 경사가 2 ˚ 이하인 모든 지역을 구분해봅시다.

• 다음도 비슷합니다. 다만 경사가 5 ˚ 이하인 지역을 구해봅시다.

• 그 결과물을 exercise_data/residential_development/ 디렉터리 아래, slope_lte2.tif 및
slope_lte5.tif 파일로 저장합니다.

결과 확인

8.3.7 Follow Along: 래스터 분석 결과 결합

이제 다음과 같은 DEM 레이어의 세 가지 분석 래스터가 생겼습니다.

• aspect_north : 북쪽을 면한 지형

• slope_lte2: 경사가 2˚ 이하인 지형

• slope_lte5: 경사가 5˚ 이하인 지형

이 레이어들의 조건을 만족하는 곳의 값은 1 로 동일합니다. 만족하지 않는 곳의 값도 0 으로 동일합니다.
따라서 이 래스터들 가운데 하나를 다른 래스터와 곱하면, 양쪽 모두의 값이 1 인 곳들을 얻을 수 있습니다.

만족해야 하는 조건은 다음과 같습니다. 경사가 5˚ 이하이며, 북쪽을 면하는 지형일 것, 다만 경사가 2˚
이하인 곳은 해당 지형이 어느쪽을 면하든지 상관 없슴.
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그러므로, 경사가 5˚ 이하 AND 북쪽을 면한 지형, OR 경사가 2˚ 이하인 지형을 찾아야 합니다. 그런 지형이
개발에 적합할 테니까요.

이 기준들을 만족하는 지역을 계산하려면,

• Raster calculator 를 다시 실행합니다.

• Raster bands 목록, Operators 버튼 및 사용자의 키보드를 이용해서 다음 표현식을 Raster calculator
expression 텍스트 란에 입력하십시오.

( aspect_north@1 = 1 AND slope_lte5@1 = 1 ) OR slope_lte2@1 = 1

• 산출물의경로를 exercise_data/residential_development/ , 파일명을 all_conditions.tif로
설정하십시오.

• Raster calculator 에 있는 OK 를 클릭하십시오. 결과는 다음과 같습니다.

8.3.8 Follow Along: 래스터 단순화

앞의이미지에서볼수있듯이, 이렇게결합된분석의결과물은조건을만족하는수많은, 아주작은지역들로
이루어져 있습니다. 그러나 이 결과는 우리의 분석에 그다지 쓸모가 없습니다. 뭔가를 짓기에는 너무 작은
토지들이니까요. 이 쓸모 없는 작은 토지들을 제거해보겠습니다.

• 메뉴에서 Raster → Analysis → Sieve 항목을 클릭해서 Sieve 도구를 실행하십시오.

• Input file 을 all_conditions 로, Output file 을 exercise_data/residential_development/
디렉터리의 all_conditions_sieve.tif 파일로 설정하십시오.

• Threshold 및 Pixel connections 의 값을 모두 8 로 설정한 다음 도구를 실행하십시오.
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처리가 완료되면 캔버스에 새 레이어가 로드될 것입니다. 하지만 데이터를 보기 위해 히스토그램 구간
도구를 사용하면 다음과 같은 화면을 보게 됩니다.
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무엇 때문일까요? 그 답은 이 새 래스터 파일의 메타데이터에 있습니다.

• Layer Properties 대화 창의 Metadata 탭을 선택해서 메타데이터를 살펴보십시오. 맨 아래에 있는
Properties 부분을 보십시오.
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이 래스터는, 추출되었던 원래 래스터와 마찬가지로, 1 과 0 값만을 가져야 하는데, 굉장히 큰 음수값의
STATISTICS_MINIMUM값을가지고있습니다. 이데이터를조사해보면이숫자가 null값역할을하고있다는
사실을 알 수 있습니다. 우리는 필터링되지 않은 지역만을 원하니까, 이 null 값들을 0 으로 바꿉시다.

• 다시 Raster Calculator 를 실행하고, 다음 표현식을 입력합니다.

(all_conditions_sieve@1 <= 0) = 0

이 표현식은 기존 0 값을 모두 보전하는 동시에 음수를 모두 0 으로 변경할 것입니다. 1 값을 가진
지역은 그대로 남게 됩니다.

• 산출물의 경로를 exercise_data/residential_development/ , 파일명을
all_conditions_simple.tif 로 설정하십시오.

산출물은 다음과 같습니다.
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우리가 기대한 산출물입니다. 이전 결과물을 단순화시킨 버전이죠. 어떤 도구의 결과물이 기대했던 것과
다를 경우, 문제를 해결 하는 데 메타데이터 (및, 적용 가능할 경우 벡터 속성) 을 살펴보는 작업이 필수적일
수도 있습니다.

8.3.9 In Conclusion

DEM 에서 모든 유형의 분석 결과를 추출하는 방법을 배웠습니다. 여기에는 음영기복도, 경사도, 향
계산이 포함됩니다. 또한 래스터 계산기를 이용해서 이 결과들을 더 심도 있게 분석하고 결합하는 방법도
배웠습니다.

8.3.10 What’s Next?

이제 여러분은 두 가지 분석을 할 수 있습니다. 벡터 분석은 잠재적으로 적합한 계획을 보여주며, 래스터
분석은 잠재적으로 적합한 지형을 보여줍니다. 이들을 어떻게 결합해야 문제에 대한 최종 결론을 얻을 수
있을까요? 이것이 다음 모듈에서 시작하는 강의의 주제입니다.
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CHAPTER 9

Module: 분석의 완성

이제 여러분은 분석의 반과 나머지 반을 배웠습니다. 벡터와 래스터죠. 이 모듈에서 여러분은 이 두 가지를
어떻게 결합하는지 배울 것입니다. 분석을 완결짓고, 최종 결과를 내게 될 것입니다.

9.1 Lesson: 래스터 - 벡터 변환

래스터와 백터 형식을 서로 변환하는 작업을 통해 GIS 문제 해결 시 래스터와 벡터 데이터를 동시에 사용할
수 있는 것은 물론, 이 두 지리 데이터 형식에 각각 특화된 다양한 분석 방법도 함께 사용할 수 있게 됩니다.
GIS 문제 해결에 쓰이는 데이터소스 및 처리 방법을 고려할 때, 이 변환 작업으로 유연성이 향상됩니다.

래스터및벡터분석을결합하려면,한데이터형식을다른형식으로변환해야합니다. 이전강의의결과물인
래스터를 벡터로 변환해봅시다.

이 강의의 목표: 래스터 결과물을 분석을 완성하는 데 쓰일 수 있는 벡터로 변환하기

9.1.1 Follow Along: Raster to Vector 도구

이전 모듈에사 사용한 raster_analysis.qgs 맵에서 시작합니다. 이 맵에 이전 실습에서 계산했던
all_conditions_simple.tif 파일이 포함되어 있을 것입니다.

• 메뉴에서 Raster → Conversion → Polygonize (Raster to Vector) 를 클릭하십시오. 도구 대화 창이
뜰 것입니다.

• 다음과 같이 설정하십시오.
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• 래스터의 값을 설명하는 Field name 을 suitable 로 변경하십시오.

• shapefile 을 exercise_data/residential_development 디렉터리 아래 all_terrain.shp
파일명으로 저장하도록 설정하십시오.

이제래스터의모든값을담고있는벡터파일을생성했지만, 여러분에게필요한것은적합한지역, 그러니까
suitable 값이 1 인 폴리곤들뿐입니다. 좀 더 명확한 시각화를 원한다면 이 레이어의 스타일을 변경할 수
있습니다.

9.1.2 Try Yourself

벡터 분석에 대한 모듈을 다시 참조하십시오.

• suitable 의 값이 1 인 폴리곤만 담고 있는 새 벡터 파일을 생성하십시오.

• 이 새 파일을 exercise_data/residential_development/ 디렉터리 아래 suitable_terrain.shp
파일명으로 저장하십시오.

결과 확인

9.1.3 Follow Along: Vector to Raster 도구

현재 상황에서 필요한 것은 아니지만, 앞에서 실습했던 변환과 반대되는 변환 방법을 알아두는 것도
유용합니다. 방금 생성했던 suitable_terrain.shp 벡터 파일을 래스터로 변환해보겠습니다.

• 메뉴에서 Raster → Conversion → Rasterize (Vector to Raster) 를 클릭해서 도구를 실행한 다음,
다음 스크린샷과 동일하게 설정하십시오.
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• Input file 을 all_terrain 으로,

• Output file... 을 exercise_data/residential_development/raster_conversion.tif 로,

• Width 및 Height 를 각각 837 과 661 로 설정합니다.

주석: 여기서 설정한 산출 이미지의 크기는 벡터화되었던 원래 래스터와 동일합니다. 이미지의 크기를
보려면 해당 이미지의 메타데이터 ( Layer Properties 에 있는 Metadata 탭) 를 열어보십시오.

• 대화 창의 OK 를 클릭해서 변환 처리 과정을 시작합니다.

• 변환 완료 시, 새 래스터와 원래 래스터를 비교해서 성공률을 측정해보십시오. 두 래스터는 픽셀
단위까지 완전히 일치해야 정상입니다.

9.1.4 In Conclusion

래스터와 벡터 형식을 서로 변환하는 작업을 통해 데이터의 질적 저하 없이 그 응용성을 넓힐 수 있습니다.

9.1.5 What’s Next?

이제 벡터 형식으로부터도 지형 분석 결과를 얻을 수 있으니, 주거 구역 개발을 위해 어떤 건물들을 골라야
하는지에 대한 문제를 해결하는 데 이 분석 결과를 쓸 수 있습니다.
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9.2 Lesson: 분석의 결합

래스터 분석을 벡터화한 결과물을 이용하면 적합한 지형에 있는 건물들만 선택할 수 있게 됩니다.

이 강의의 목표: 벡터화된 지형 분석 결과를 이용해서 적합한 계획을 선택하기.

9.2.1 Try Yourself

• 현재 맵 ( raster_analysis.qgs ) 을 저장하십시오.

• Open the map in which you did the vector analysis earlier (analysis.qgs).

• Layers list 에서 다음 레이어들을 활성화하십시오.

• hillshade,

• solution (또는 buildings_over_100)

• 이전에 작업했을 때 이미 맵에 로드돼 있어야 하는 이 레이어들 외에, suitable_terrain.shp
데이터셋도 추가하십시오.

• 일부 레이어가 보이지 않을 경우 exercise_data/residential_development/ 디렉터리에서 찾을
수 있을 것입니다.

• Intersect 도구 ( Vector → Geoprocessing Tools )를사용해서 suitable_terrain레이어와교차하는
건물들만 담고 있는 new_solution.shp 라는 새 벡터 레이어를 생성하십시오.

이제 해답으로 다음과 같이 특정한 건물들만 보이는 레이어를 생성했을 것입니다.

주석: Intersect 도구가 아무 결과도 생성하지 못 하는 경우, 각 레이어의 CRS 를 확인하십시오. 서로
비교하는 두 레이어 모두 동일한 CRS 를 사용하고 있어야 합니다. 한 레이어를 재투영해서 필요한 CRS 를
사용하는 새 shapefile 로 저장해야 할 수도 있습니다. 이 예제에서는 suitable_terrain 레이어를 WGS 84
/ UTM 34S 로 재투영하고 suitable_terrain_34S 라는 명칭으로 변경했습니다.

240 Chapter 9. Module: 분석의 완성



QGIS Training Manual, 출시 2.2

9.2.2 Try Yourself 결과 점검

new_solution 레이어에 있는 건물을 하나 하나 살펴보십시오. new_solution 레이어의 심볼을 변경해서
윤곽선만 보이도록 한 다음, suitable_terrain 레이어와 비교해보십시오. 어떤 건물에 눈에 띄는 점이
있습니까? 단지 suitable_terrain 레이어와 교차한다고 해서 모든 건물이 적합한가요? 아니라면 그 이유는
무엇일까요? 어떤 건물이 적합하지 않아 보입니까?

결과 확인

9.2.3 Try Yourself 분석 개선

결과물에 포함된 건물들 가운데 실제로는 적합하지 않는 건물을 볼 수 있습니다. 따라서 이제 분석을 개선할
수 있습니다.

우리는 suitable_terrain 레이어 안에 완전히 들어가는 건물들만 반환하도록 분석하고자 합니다. 어떻게
하면 될까요? 우리가 원하는 건물은 면적이 100 평방미터 이상이어야 한다는 점을 기억하면서 하나 또는 그
이상의 벡터 분석 도구를 사용해보십시오.

결과 확인

9.2.4 In Conclusion

이제 처음의 연구 문제에 해답을 내놓았고, 어떤 부지를 개발해야 할지에 대한 (분석 결과가 뒷받침하는
논리적인) 추천 의견을 제시할 수도 있습니다.

9.2.5 What’s Next?

다음으로, 여러분의 두 번째 과제의 일부로 이 결과물을 제출하게 될 것입니다.

9.3 과제 2

맵 작성자를 사용해서 여러분의 분석 결과를 나타내는 새 맵을 생성하십시오. 다음 레이어들을 포함해야
합니다.

• places (라벨 보이기)

• hillshade

• solution (또는 new_solution)

• roads

• aerial_photos 또는 DEM 가운데 하나

맵에 삽입할 짧은 설명문을 써보십시오. 매매 및 그에 따른 개발을 위한 건물을 고르는 데 썼던 기준은 물론,
어떤 건물들이 적합한지에 대한 여러분의 추천 의견을 설명하는 내용이 들어가야 합니다.

9.4 Lesson: 보충 예제

이 강의를 통해 QGIS 를 이용한 완전한 GIS 분석을 하게 될 것입니다.

주석: 이 강의는 Linfiniti 와 S. Motala(남아프리카공화국 케이프 페닌슐라 기술대학교) 가 작성했습니다.
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9.4.1 과제 제시

여러분은 케이프 페닌슐라 주변에서 희귀한 파인보스 식물종에 적합한 서식지를 찾아야 합니다. 케이프
페닌슐라에서의 조사 범위는 Melkbosstrand 의 남쪽, Strand 의 서쪽입니다. 식물학자들은 해당 종이
선호하는 환경을 다음과 같이 제시하고 있습니다.

• 동쪽을 면한 비탈에서 자랍니다.

• 15% 에서 60% 사이의 경사도에서 자랍니다.

• 연간 강수량이 1200mm 를 초과하는 지역에서 자랍니다.

• 인간 거주지에서 최소 250m 이상 떨어진 지역에서 발견됩니다.

• 초지의 면적이 최소 6000 ㎡ 이상이어야 합니다.

웨스턴 케이프 자연보전위원회의 자원봉사자로서, 여러분은 여러분의 집에서 가장 가까운 해당 식물에
적합한 토지를 찾아보기로 했습니다. 여러분의 GIS 기술을 이용해서 어디를 찾아봐야 할지 결정하십시오.

9.4.2 해답의 개요

이 문제를 해결하려면 여러분의 집에서 가장 가까운 후보 지역을 찾는 데 쓸 수 있는 데이터 (
exercise_data/more_analysis 경로에서 찾을 수 있습니다) 를 사용해야 할 것입니다. 여러분이 (이
문제가 제기된) 케이프타운에 살고 있지 않을 경우, 케이프타운 지역의 아무 집이나 선택해도 됩니다. 이
문제의 해답은 다음과 같은 단계를 포함할 것입니다.

• DEM 을 분석해서 알맞은 경사도를 가진, 동쪽을 면하고 있는 비탈을 찾고,

• 강수량 래스터를 분석해서 알맞은 강수량을 가진 곳을 찾아,

• 도시계획 벡터 레이어를 분석해서 인간 거주지에서 떨어져 있는, 알맞은 면적의 토지를 찾습니다.

9.4.3 맵 준비

• 화면의 최우하단에 있는 “CRS status” 버튼을 클릭하십시오. 대화 창이 뜨면 CRS 탭에 있는 Coor-
dinate reference systems of the world 박스가 보일 겁니다.

• 이박스에서 Projected Coordinate Systems → Universal Transverse Mercator (UTM)을찾으십시오.

• WGS 84 / UTM zone 33S (EPSG 코드 32733) 항목을 선택하십시오.

• OK 를 클릭하십시오. 이제 맵이 UTM33S 좌표계를 사용하게 됐습니다.

• 툴바에서 Save Project As 버튼을 클릭하거나, 메뉴에서 File → Save Project As... 항목을 선택해서
맵을 저장하십시오.

• 여러분의컴퓨터에 Rasterprac이라는디렉터리를생성한다음, 맵을해당디렉터리에저장하십시오.
여러분이 생성할 모든 레이어도 이 디렉터리에 저장하게 됩니다.

9.4.4 맵에 데이터 불러오기

데이터를 처리하려면 맵 캔버스에 필수 레이어 (도로명, 도시 구역, 강수량, DEM) 를 로드해야 합니다.

벡터의 경우

• Add Vector Layer 버튼을 클릭하거나, 메뉴에서 Layer → Add Vector Layer... 항목을 선택하십시오.

• 대화 창이 뜨면, File 라디오 버튼을 선택하도록 하십시오.

• Browse 버튼을 클릭하십시오.

• 대화 창이 뜨면, exercise_data/more_analysis/streets 디렉터리를 여십시오.
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• Street_Names_UTM33S.shp 파일을 선택하십시오.

• Open 을 클릭하십시오.

대화 창이 닫히면서 이전 대화 창의 Browse 버튼 옆에 있는 텍스트 란에 파일 경로가 지정됩니다. 이렇게
하면정확한파일을선택했는지확인할수있습니다. 또원한다면이텍스트란에파일경로를직접입력해도
됩니다.

• Open 을 클릭합니다. 맵에 벡터 레이어를 로드할 것입니다. 색상은 자동 할당됩니다. 이후 단계에서
색상을 조절하겠습니다.

• 레이어의 명칭을 Streets 로 변경합니다.

• (기본적으로 화면의 왼쪽에 있는 패널인) Layers list 에 있는 해당 레이어를 오른쪽 클릭하십시오.

• 컨텍스트 메뉴에서 Rename 을 클릭해서 명칭을 변경한 다음, 완료 시 Enter 키를 누르십시오.

• 벡터 추가 과정을 반복합니다. 다만 이번에는 Zoning 디렉터리에 있는 Gener-
alised_Zoning_Dissolve_UTM33S.shp 파일을 선택하십시오.

• 해당 레이어의 명칭을 Zoning 으로 변경하십시오.

래스터의 경우

• Add Raster Layer 버튼을 클릭하거나, 메뉴에서 Layer → Add Raster Layer... 항목을 선택하십시오.

• 적절한 파일을 찾아 선택한 다음, Open 을 선택하십시오.

• 두 래스터 파일에 대해 이 과정을 반복합니다. 필요한 파일은 DEM/reproject/DEM 과 Rain-
fall/reprojected/rainfall.tif 입니다.

• 강수량 래스터의 명칭을 Rainfall (첫 글자를 대문자로) 로 변경합니다. 처음 불러왔을 때 이미지가
회색 사각형으로 보일 것입니다. 걱정하지 마십시오. 이후 단계에서 조정할 것입니다.

• 맵을 저장하십시오.

레이어에 담긴 정보를 제대로 보려면 레이어의 심볼을 변경해야 합니다.

9.4.5 벡터 레이어의 심볼 변경

• Layers list 에서 Streets 레이어를 오른쪽 클릭하십시오.

• 컨텍스트 메뉴에서 Properties 항목을 선택합니다.

• 대화 창이 뜨면 Style 탭을 선택합니다.

• Streets 레이어의 현재 색상을 보여주는 사각형 옆의 Change 버튼을 클릭하십시오.

• 표준 색상 대화 창에서 새 색상을 선택하십시오.

• OK 를 클릭하십시오.

• 다시 Layer Properties 창의 OK 를 클릭하십시오. Streets 레이어의 색상이 변경됩니다.

• Zoning 레이어에 대해서도 비슷한 과정을 따라 적절한 색상을 선택하십시오.

9.4.6 래스터 레이어의 심볼 변경

래스터 레이어의 심볼은 조금 다릅니다.

• Rainfall 레스터의 Layer Properties 대화 창을 엽니다.

• Style 탭을 선택하십시오. 벡터 레이어 용 스타일 대화 창과는 매우 다르다는 것을 알 수 있습니다.

• Use standard deviation 버튼을 선택했는지 확인하십시오.

• 그 옆에 있는 텍스트 란의 값을 2.00 으로 변경하십시오. (기본값 0.00 으로 설정돼 있을 겁니다.)
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• Contrast enhancement 라는 제목 아래에 있는 Current 드롭다운 목록의 값을 Stretch to MinMax 로
변경합니다.

• OK 를 클릭하십시오. “Rainfall” 래스터가 보인다면, 각 픽셀의 서로 다른 밝기 값을 볼 수 있도록
색상이 변경될 것입니다.

• DEM 에 대해서도 이 과정을 반복하십시오. 다만 구간화에 쓰이는 표준 편차를 4.00 으로
설정하십시오.

9.4.7 레이어 순서 변경

• Layers list 에서, 레이어들을 아래위로 클릭 & 드래그해서 맵 상에 표출되는 순서를 변경하십시오.

• QGIS 신규 버전의 경우, Layers list 아래에 Control rendering order 체크박스가 있을 것입니다.
체크돼 있는지 확인하십시오.

이제 모든 데이터를 불러와서 제대로 시각화했으니, 분석을 시작할 수 있습니다. 처음에 오리기 작업을 하는
편이 제일 좋습니다. 그렇게 하면 어차피 사용하지도 않을 지역의 값들을 계산하는 데 컴퓨터의 계산 능력을
허비하지 않아도 됩니다.

9.4.8 알맞은 구역 찾기

• 여러분의 맵에 벡터 레이어 admin_boundaries/Western_Cape_UTM33S.shp 를 불러오십시오.

• 명칭을 Districts 로 변경하십시오.

• Layers list 에서 Districts 레이어를 오른쪽 클릭합니다.

• 컨텍스트 메뉴에서 Query... 항목을 선택하십시오. Query Builder 대화 창이 나타납니다.

이제 다음 구역들만 선택하는 쿼리를 만들어보겠습니다.

• Bellville

• Cape

• Goodwood

• Kuils River

• Mitchells Plain

• Simons Town

• Wynberg

• Fields 목록에서 NAME_2 항목을 더블클릭하십시오. 아래쪽에 있는 SQL where clause 텍스트 란에
나타날 것입니다.

• = 버튼을 클릭하면 SQL 쿼리에 = 부호가 추가됩니다.

• (현재비어있는) Values 목록아래있는 All 버튼을클릭하십시오. 잠시후 Values 목록이선택한항목
( NAME_2 ) 의 값들로 채워질 것입니다.

• Values 목록에서 Bellville 값을 더블클릭하십시오. 이전과 마찬가지로 SQL 쿼리에 추가됩니다.

하나 이상의 구역을 선택하려면, 불 연산자 OR 를 사용해야 합니다.

• OR 버튼을 클릭해서 SQL 쿼리에 추가하십시오.

• 앞과 비슷한 과정을 거쳐, 다음 내용을 기존 쿼리에 추가하십시오.

"NAME_2" = 'Cape'

• 다시 OR 연산자를 추가한 다음, 비슷한 방법으로 구역 목록을 차례로 추가하십시오.

• 최종 쿼리는 다음과 같아야 합니다.
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"NAME_2" = 'Bellville' OR "NAME_2" = 'Cape' OR "NAME_2" = 'Goodwood' OR
"NAME_2" = 'Kuils River' OR "NAME_2" = 'Mitchells Plain' OR "NAME_2" =
'Simons Town' OR "NAME_2" = 'Wynberg'

• OK 를 클릭하십시오. 이제 맵 상에 앞의 목록에 있는 구역들만 보이게 됩니다.

9.4.9 래스터 오리기

이제 관심 지역을 지정했으니, 래스터를 이 지역에 맞춰 자를 수 있습니다.

• DEM, Rainfall 과 Districts 레이어만 보이도록 확인하십시오.

• Districts 가 보이도록 맨 위에 위치해야 합니다.

• 메뉴에서 Raster → Extraction → Clipper 항목을 선택해서 오리기 대화 창을 여십시오.

• Input file (raster) 드롭다운 목록에서 DEM 레이어를 선택하십시오.

• Select... 버튼을 클릭해서 Output file 텍스트 란에 산출물의 경로를 지정하십시오.

• 사용자의 Rasterprac 디렉터리를 찾아가십시오.

• 파일명을 입력하십시오.

• 파일을 저장하십시오. No data value 체크박스는 체크하지 않습니다.

• 정확한 라디오 버튼을 선택했는지 확인해서 Extent 오리기 모드를 사용합니다.

• 캔버스 안의 지역을 클릭 & 드래그해서 구역들을 포함하고 있는 지역을 선택하십시오.

• Load into canvas when finished 체크박스를 체크합니다.

• OK 를 클릭하십시오.

• 오리기 작업이 완료된 후, Clipper 대화 창을 닫지 마십시오. (그러면 이미 지정한 오리기 지역을 잃게
됩니다.)

• Input file (raster) 드롭다운 목록에 있는 Rainfall 래스터를 선택하고 산출 파일명을 다르게
지정합니다.

• 다른 옵션들은 그대로 두십시오. 여러분이 이전 단계에 지정한 오리기 지역도 건드리지 마십시오.
모든 것을 그대로 둔 채 OK 를 클릭합니다.

• 이 두 번째 오리기 작업이 완료된 다음에, Clipper 대화 창을 닫아도 됩니다.

• 맵을 저장하십시오.

9.4.10 맵 정리

• Layers list 에서 원래 Rainfall 및 DEM 레이어를 제거합니다.

• 해당 레이어들을 오른쪽 클릭한 다음 Remove 를 선택하십시오.

– 사용자의 저장 장치에서 데이터를 삭제하는 것이 아니라, 사용자 맵에서 해당 데이터를 빼는
것뿐입니다.

• Streets 레이어의 라벨을 비활성화합니다.

– Labeling 버튼을 클릭하십시오.

– Label this layer with 체크박스를 해제하십시오.

– OK 를 클릭하십시오.

• 다시 모든 Streets 를 보이도록 하십시오.

– Layers list 에서 해당 레이어를 오른쪽 클릭합니다.

– Query 를 선택합니다.
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• Query 대화 창이 나타나면, Clear 버튼을 클릭한 다음 OK 를 클릭합니다.

• 데이터를 불러올 동안 기다리십시오. 이제 모든 도로가 보일 것입니다.

• 래스터 심볼을 이전처럼 변경하십시오. ( 래스터 레이어의 심볼 변경 참조)

• 맵을 저장하십시오.

• 이제 Layers list 에서 레이어 옆에 있는 체크박스를 해제해서 벡터 레이어를 보이지 않게 할 수
있습니다. 이렇게 하면 맵을 더 빨리 렌더링할 수 있어 시간을 절약할 수 있습니다.

음영기복도를 생성하려면, 그 목적을 위해 작성된 플러그인을 사용해야 합니다.

9.4.11 Raster Terrain Analysis 플러그인 활성화

QGIS 1.8 부터 기본적으로 이 플러그인을 포함하고 있습니다. 하지만 기본 상태에서는 보이지 않을 수도
있습니다. 사용자 시스템에서 사용할 수 있는지 확인하려면,

• 메뉴에서 Plugins → Manage Plugins... 항목을 클릭하십시오.

• Raster Terrain Analysis plugin 옆에 있는 체크박스가 체크되어 있는지 확인하십시오.

• OK 를 클릭하십시오.

이제 Raster → Terrain analysis 메뉴 항목을 통해 이 플러그인을 사용할 수 있습니다.

가끔 플러그인이 사용자 시스템에 설치된 특정 파이썬 모듈에 의존하고 있을 수도 있습니다. 플러그인이
의존성 문제로 작동하지 않을 경우, 강사에게 도움을 청하십시오.

9.4.12 음영기복도 생성

• Layers list 에서 DEM 레이어가 활성화돼 있는지 (예를 들어 클릭된 상태로 하이라이트돼 있는지)
확인하십시오.

• 메뉴에서 Raster → Terrain analysis → Hillshade 항목을 클릭해서 Hillshade 대화 창을 여십시오.

• 산출물 레이어를 위한 적절한 경로를 지정한 뒤 hillshade 라고 명명합니다.

• Add result to project 체크박스를 체크했는지 확인하십시오.

• OK 를 클릭하십시오.

• 처리가 끝날 때까지 기다리십시오.

Layers list 에 새 hillshade 레이어가 추가됐습니다.

• Layers list 에 있는 hillshade 레이어를 오른쪽 클릭해서 Properties 대화 창을 여십시오.

• Transparency 탭을 클릭한 다음 투명도 슬라이더를 80% 로 설정합니다.

• 대화 창의 OK 를 클릭합니다.

• 오린 DEM 위에 겹쳐진 반투명한 음영기복도의 효과를 확인해보십시오.

9.4.13 경사도

• 메뉴에서 Raster → Terrain analysis 항목을 클릭하십시오.

• Slope 분석 유형을 선택하고, 입력 레이어를 오린 DEM 으로 설정하십시오.

• 산출물을 위한 적절한 파일명 및 경로를 지정하십시오.

• Add result to project 체크박스를 체크했는지 확인하십시오.

• OK 를 클릭하십시오.

경사도 이미지가 계산되어 맵에 추가되었습니다. 하지만 이 역시 회색 사각형이군요. 그 내용을 제대로
보려면, 다음과 같이 심볼을 변경하십시오.
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• (마찬가지로 해당 레이어의 컨텍스트 메뉴를 통해) 레이어의 Properties 대화 창을 여십시오.

• Style 탭을 클릭하십시오.

• (Color map 드롭다운 메뉴가) Grayscale 이라면 Pseudocolor 로 변경하십시오.

• Use standard deviation 라디오 버튼을 선택했는지 확인하십시오.

9.4.14 향

• 경사를 계산할 때와 동일한 방법을 사용하지만, 초기 대화 창에서 Aspect 를 선택하십시오.

주기적으로 맵을 저장하는 일을 잊지 마십시오.

9.4.15 래스터 재범주화

• 메뉴에서 Raster → Raster calculator 항목을 클릭하십시오.

• 산출물 레이어를 위한 경로로 사용자의 Rasterprac 디렉터리를 지정하십시오.

• Add result to project 체크박스를 체크했는지 확인하십시오.

왼쪽에 있는 Raster bands 목록에서 사용자의 Layers list 에 있는 모든 래스터 레이어를 볼 수 있습니다.
사용자의 경사도 레이어 명칭이 slope 인 경우, 목록에 slope@1 이라고 나타날 것입니다.

경사는 15 ˚ 에서 60 ˚ 사이여야 합니다. 따라서 15 ˚ 미만이나 60 ˚ 초과 지역을 제외해야 합니다.

• 인터페이스에 있는 목록 항목 및 버튼을 이용해서 다음 표현식을 작성하십시오.

((slope@1 < 15) OR (slope@1 > 60)) = 0

• Output layer 란에 적절한 경로 및 파일명을 설정하십시오.

• OK 를 클릭하십시오.

이제 동일한 방법으로 알맞은 향 (동쪽 : 45 ˚ 에서 135 ˚ 사이) 을 찾으십시오.

• 다음 표현식을 작성하십시오.

((aspect@1 < 45) OR (aspect@1 > 135)) = 0

• 역시 동일한 방법으로 알맞은 강수량 ( 1200mm 초과) 을 찾으십시오. 다음 표현식을 작성하십시오.

(rainfall@1 < 1200) = 0

모든 레이어를 재범주화했다면, 이제 (레이어들이 맵에 제대로 추가됐다면) 맵 상에 회색 사각형들을 볼 수
있을 것입니다. 두 가지 범주만을 가진 (1 과 0, 즉 참과 거짓) 래스터 데이터를 제대로 표현하려면 래스터의
심볼을 변경해야 합니다.

9.4.16 재범주화된 레이어의 스타일 설정

• 레이어의 Properties 대화창에 있는 Style 탭을 선택합니다.

• Load min / max values from band 라는 제목 아래 있는 Actual (slower) 라디오 버튼을 선택하십시오.

• Load 버튼을 클릭하십시오.

이제 Custom min / max values란이 0과 1로채워질것입니다. (아닐경우,사용자가데이터를재범주화할
때 실수를 했다는 의미입니다. 다시 재범주화 작업을 해야 합니다.)

• Contrast enhancement 라는 제목 아래에 있는 Current 드롭다운 목록을 Stretch to MinMax 로
설정합니다.

• OK 를 클릭하십시오.

• 재범주화된 세 래스터에 대해 이 과정을 각각 반복한 다음, 반드시 작업을 저장하십시오!
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하나 남은 기준은 도시 지역에서 250m 이상 떨어진 지역이어야 한다는 것입니다. 교외 지역의 경계에서
250m 이상 안쪽에 있는 지역을 계산해서 이 요구 사항을 만족시킬 것입니다. 따라서, 먼저 모든 교외 지역을
찾아야 합니다.

9.4.17 교외 지역 찾기

• Layers list 에 있는 모든 레이어를 숨기십시오.

• Zoning 벡터 레이어만 활성화하십시오.

• 해당 레이어를 오른쪽 클릭한 다음, Query 대화 창을 불러옵니다.

• 다음 쿼리를 작성하십시오.

"Gen_Zoning" = 'Rural'

작성 방법을 잘 모르겠다면 이전 단계에서 Streets 쿼리 작성 시 지침을 참조하십시오.

• 작성 완료 시 Query 대화 창을 닫으십시오.

Zoning 레이어에서 추출된 폴리곤 집합이 보일 것입니다. 이것을 새 레이어 파일로 저장해야 합니다.

• Zoning 레이어를 오른쪽 클릭한 다음 Save As... 를 선택하십시오.

• Zoning 디렉터리에 새 레이어를 저장하십시오.

• 산출물 파일명을 rural.shp 으로 지정합니다.

• OK 를 클릭하십시오.

• 맵에 이 레이어를 추가하십시오.

• 메뉴에서 Vector → Geoprocessing Tools → Dissolve 항목을 클릭하십시오.

• 입력 벡터 레이어로 rural 레이어를 선택하고, Use only selected features 체크박스를 해제하십시오.

• Dissolve field 아래, — Dissolve all — 을 선택하십시오.

• Zoning 디렉터리에 새 레이어를 저장하십시오.

• OK 를 클릭합니다. 새 레이어를 TOC(“Table of Contents”, Layers list 를 의미) 에 추가하기
원하느냐고 묻는 대화 창이 나타날 것입니다.

• Yes 를 클릭하십시오.

• Dissolve 대화 창을 닫으십시오.

• rural 및 Zoning 레이어를 제거하십시오.

• 맵을 저장하십시오.

이제 교외 지역 경계선에서 안쪽으로 250m 까지의 지역을 제외해야 합니다. 다음 단계에서 설명할 음의
버퍼를 생성하면 됩니다.

9.4.18 음의 버퍼 생성

• 메뉴에서 Vector → Geoprocessing Tools → Buffer(s) 항목을 클릭하십시오.

• 대화 창이 뜨면, 입력 벡터 레이어로 rural_dissolve 레이어를 선택합니다. (Use only selected features
체크박스를 해제해야 합니다.)

• Buffer distance 버튼을 선택한 다음 옆의 텍스트 란에 -250 값을 입력하십시오. 음수 값은 이 버퍼가
내부 버퍼라는 것을 의미합니다.

• Dissolve buffer results 체크박스를 체크하십시오.

• 다른 교외 벡터 파일과 동일한 디렉터리에 산출물 파일을 저장하도록 설정하십시오.

• 산출물 파일명을 rural_buffer.shp 로 지정합니다.

248 Chapter 9. Module: 분석의 완성



QGIS Training Manual, 출시 2.2

• Save 를 클릭합니다.

• OK 를 클릭한 다음 처리가 완료될 때까지 기다리십시오.

• 대화 창이 뜨면 Yes 를 선택합니다.

• Buffer 대화 창을 닫습니다.

• rural_dissolve 레이어를 제거하십시오.

• 맵을 저장하십시오.

교외 구역을 기존 세 래스터와 함께 동일한 분석 작업에 포함시키려면, 해당 레이어도 래스터화해야 합니다.
그러나래스터들을분석작업을위해호환시키려면각래스터들의크기가똑같아야합니다. 따라서래스터화
작업 전에 벡터를 세 래스터와 같은 크기로 오려내야 합니다. 벡터는 벡터로만 오릴 수 있으므로, 래스터와
동일한 크기의 범위 (bounding box) 폴리곤을 생성해야 합니다.

9.4.19 범위 벡터 생성

• 메뉴에서 Layer –> New –> New Shapefile Layer... 항목을 클릭하십시오.

• Type 제목 아래 Polygon 버튼을 선택하십시오.

• Specify CRS 를 클릭한 다음, 좌표계를 WGS 84 / UTM zone 33S : EPSG:32733 으로 설정하십시오.

• OK 를 클릭하십시오.

• New Vector Layer 대화 창의 OK 도 클릭하십시오.

• Zoning 디렉터리에 벡터를 저장합니다.

• 산출물 파일명을 bbox.shp 로 지정하십시오.

• 새 bbox 레이어 및 재범주화된 래스터 가운데 하나를 제외한 모든 레이어를 비활성화하십시오.

• Layers list 에서 bbox 레이어가 하이라이트되었는지 확인하십시오.

• 메뉴에서 View > Toolbars 항목을 찾은 다음, Digitizing 이 선택되었는지 확인하십시오. 그러면 연필
또는 사인펜이 그려진 툴바 아이콘이 보일 것입니다. 바로 Toggle editing 버튼입니다.

• Toggle editing 버튼을 클릭해서 편집 모드 로 들어갑니다. 그러면 벡터 레이어를 편집할 수 있습니다.

• Toggle editing 버튼 근처에 있는 Add feature 버튼을 클릭하십시오. 쌍화살표 뒤에 숨어 있을 수도
있습니다. 이 경우, 쌍화살표를 클릭해서 Digitizing 툴바의 숨어 있는 버튼들을 보이도록 합니다.

• Add feature 도구를 활성화시킨 다음, 래스터의 구석들을 클릭하십시오. 정확한 위치를 찾기 위해
마우스 휠로 줌인해야 할 수도 있습니다. 이 모드에서 맵을 이동하려면 마우스 중간 버튼이나 마우스
휠로 맵을 클릭 & 드래그하면 됩니다.

• 네 번째이자 마지막 포인트에서 오른쪽 클릭해서 피처를 완성하십시오.

• shape ID 를 위한 임의의 숫자를 입력하십시오.

• OK 를 클릭하십시오.

• Save edits 버튼을 클릭합니다.

• Toggle editing 버튼을 클릭해서 편집 작업을 완료하십시오.

• 맵을 저장하십시오.

이제 범위를 생성했으니, 이를 사용해서 교외 버퍼 레이어를 오려낼 수 있습니다.

9.4.20 벡터 레이어 오리기

• rural_buffer 레이어가 bbox 위에 오도록 한 다음, 이 두 레이어만 보이도록 하십시오.

• 메뉴에서 Vector > Geoprocessing Tools > Clip 항목을 클릭하십시오.
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• 대화 창이 뜨면 입력 벡터 레이어에 rural_buffer 를, 오리기 레이어에 bbox 를 설정합니다. 양쪽 모두
Use only selected features 체크박스를 해제해야 합니다.

• 산출물 파일을 Zoning 디렉터리에 저장합니다.

• 산출물 파일명을 rural_clipped 로 지정하십시오.

• OK 를 클릭하십시오.

• 레이어를 TOC 에 추가하느냐는 메시지 창이 뜨면 Yes 를 클릭하십시오.

• 대화 창을 닫으십시오.

• 세 벡터를 비교해 보면서 결과를 직접 살펴보십시오.

• bbox 및 rural_buffer 레이어를 제거한 다음, 사용자 맵을 저장합니다.

이제 래스터화 준비가 끝났습니다.

9.4.21 벡터 레이어 래스터화

여러분이 생성할 새 래스터의 픽셀 크기를 설정해야 합니다. 따라서 먼저 기존 래스터의 픽셀 크기를 알아야
합니다.

• 기존 세 래스터 가운데 아무거나 골라서 Properties 대화 창을 여십시오.

• Metadata 탭을 선택하십시오.

• 메타데이터 테이블의 Dimensions 라는 제목 아래 있는 X 와 Y 값을 기억하십시오.

• Properties 대화 창을 닫으십시오.

• 메뉴에서 Raster → Conversion → Rasterize 항목을 클릭하십시오. 지원하지 않는 데이터셋이라는
경고가 뜰지도 모릅니다. 무시하고 클릭해서 메시지 창을 닫으십시오.

• 입력 레이어로 rural_clipped 를 선택하십시오.

• 산출물 파일을 Zoning 디렉터리에 저장하도록 설정합니다.

• 산출물 파일명을 rural_raster.tif 로 지정합니다.

• New size 체크박스를 체크하고, 방금 기억해둔 X 와 Y 값을 입력하십시오.

• Load into canvas... 체크박스를 체크하십시오.

• 실행될 명령어를 보여주는 텍스트 란 옆에 있는 연필 아이콘을 클릭하십시오. 입력되어 있는 텍스트
끝 부분에 공백을 입력한 후 -burn 1 이라고 입력합니다. 이렇게 하면 래스터화 기능이 기존 벡터를
새 래스터로 “굽고” 벡터가 커버하는 영역을 1 이라는 새 값으로 채웁니다. (이미지의 나머지 영역은
자동적으로 0 값이 됩니다.)

• OK 를 클릭하십시오.

• 계산 완료 시 새 래스터가 사용자 맵에 추가될 것입니다.

• 새 래스터가 회색 사각형처럼 보일 것입니다. 래스터를 재범주화했을 때처럼 표출 스타일을 변경해볼
수도 있습니다.

• 맵을 저장하십시오.

이제 모든 4 가지 기준이 각각 개별적인 래스터로 준비되었으므로, 모든 기준을 만족하는 지역을 보려면
래스터들을 결합해야 합니다. 그러려면 래스터들을 서로 곱하면 됩니다. 그렇게 하면 서로 겹치는 픽셀의
값이 모두 1 이면 1 값을 유지하지만, 네 래스터 가운데 하나라도 0 값의 픽셀인 경우엔 결과적으로 0 이
됩니다. 이런 방식으로, 서로 겹치는 지역만을 담은 결과물이 나오게 됩니다.

9.4.22 래스터 결합

• 메뉴에서 Raster → Raster calculator 항목을 클릭하십시오.
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• 다음 표현식을 작성하십시오. (여러분이 지정한 명칭에 따라 적합한 레이어명을 이용하십시오.)

[Rural raster] * [Reclassified aspect] * [Reclassified slope] *
[Reclassified rainfall]

• 산출물을 Rasterprac 디렉터리에 저장하도록 설정합니다.

• 산출물 파일명을 cross_product.tif 로 지정합니다.

• Add result to project 체크박스를 체크했는지 확인하십시오.

• OK 를 클릭하십시오.

• 다른재범주화래스터의 스타일을설정한것처럼새 래스터의심볼을변경하십시오. 이제새래스터가
모든 기준을 만족하는 지역을 제대로 표출할 것입니다.

최종 결과물을 얻으려면 면적이 6000m^2 를 초과하는 지역만을 선택해야 합니다. 그러나 면적을 정확하게
계산하는 것은 벡터 레이어에서만 가능하기 때문에, 래스터를 벡터화해야 합니다.

9.4.23 래스터 벡터화

• 메뉴에서 Raster → Conversion → Polygonize 항목을 클릭하십시오.

• cross_product 래스터를 선택하십시오.

• 산출물의 경로를 Rasterprac 으로 설정하십시오.

• 파일명을 candidate_areas.shp 로 지정하십시오.

• Load into canvas when finished 체크박스를 체크했는지 확인합니다.

• OK 를 클릭하십시오.

• 처리가 완료되면 대화 창을 닫으십시오.

래스터의 모든 영역이 벡터화되었으므로, 1 값을 가지는 영역만을 선택해야 합니다.

• 새 벡터의 Query 대화 창을 여십시오.

• 다음 쿼리를 작성하십시오.

"DN" = 1

• OK 를 클릭하십시오.

• 쿼리가 완료된 후 candidate_areas 벡터를 저장해서 결과물인 새 벡터 파일을 생성하십시오. (1
값을 가지는 영역만 보이게 됩니다.) 이를 위해 해당 레이어를 오른쪽 클릭해서 Save as... 기능을
사용하십시오.

• 파일을 Rasterprac 디렉터리에 저장하도록 설정합니다.

• 파일명을 candidate_areas_only.shp 로 지정하십시오.

• 맵을 저장하십시오.

9.4.24 각 폴리곤의 면적 계산

• 새 벡터 레이어를 오른쪽 클릭해서 컨텍스트 메뉴를 여십시오.

• Open attribute table 을 선택합니다.

• 테이블 아래쪽에 있는 Toggle editing mode 버튼을 클릭하거나, Ctrl+E 키를 누르십시오.

• 테이블 아래쪽에 있는 Open field calculator 버튼을 클릭하거나, Ctrl+I 키를 누르십시오.

• 새로 나타난 대화 창의 New field 제목 아래, 항목명을 area 라고 입력하십시오. 산출물 항목 유형은
정수, 항목 길이는 10 이어야 합니다.

• In Field calculator expresion, type:
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$area

이렇게하면항목계산기가벡터레이어의각폴리곤의면적을계산해서 (area 라는)새정수열에계산
값을 채우게 됩니다.

• OK 를 클릭하십시오.

• Do the same thing for another new field called id. In Field calculator expresion, type:
$id

이렇게 하면 각 폴리곤에 식별 목적의 유일한 ID 를 부여하게 됩니다.

• Toggle editing mode 를 다시 클릭하고, 저장 여부를 물어볼 경우 편집 내용을 저장하십시오.

9.4.25 주어진 면적의 영역 선택

이제 면적을 알게 됐으니,

• 쿼리를 (평소와같이)작성해서 6000m^2보다넓은폴리곤만을선택하십시오. 쿼리는다음과같습니다.
"area" > 6000

• 선택된 폴리곤 집합을 solution.shp 라는 명칭의 새 벡터 레이어로 저장하십시오.

이제 해답 영역들을 얻었으니, 사용자의 집에서 가장 가까운 곳을 선택할 차례입니다.

9.4.26 사용자 주택 디지타이즈 작업

• 이전과 동일한 방법으로 새 벡터 레이어를 생성하되, 이번에는 Type 값에 Point 를 선택합니다.

• 레이어가 정확한 CRS 를 사용하는지 확인하십시오!

• 새 레이어의 명칭을 house.shp 로 지정합니다.

• 새 레이어 생성을 완료하십시오.

• (새 레이어를 선택한 다음) 편집 모드로 들어갑니다.

• 도로명을 기준으로 사용자의 주택 또는 현재 주거지가 있는 곳의 포인트를 클릭하십시오. 사용자의
집을 찾기 위해 다른 레이어를 열어 참조해야 할 수도 있습니다. 여러분이 이 근처에 살지 않는다면,
도로를 따라 집이 있을 만한 곳을 골라 클릭하십시오.

• shape ID 를 위한 임의의 숫자를 입력하십시오.

• OK 를 클릭하십시오.

• 편집 내용을 저장하고 편집 모드를 끕니다.

• 맵을 저장하십시오.

사용자의 집에서 가장 가까운 폴리곤을 정하려면, 해답 영역 폴리곤들의 중심 (“형태의 중앙”) 을 찾아야
합니다.

9.4.27 폴리곤 중심 계산

• 메뉴에서 Vector → Geometry Tools → Polygon centroids 항목을 클릭하십시오.

• 입력 레이어로 solution.shp 을 설정하십시오.

• 산출물의 경로를 Rasterprac 으로 설정하십시오.

• 산출물 파일의 명칭을 solution_centroids.shp 로 설정하십시오.

• OK 를 클릭해서 결과물을 TOC( Layers list ) 에 추가한 다음, 대화 창을 닫습니다.

• 새 레이어를 레이어 순서의 맨 위로 드래그해서 볼 수 있도록 만듭니다.
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9.4.28 사용자 주택에서 가장 가까운 중심 계산

• 메뉴에서 Vector → Analysis Tools → Distance matrix 항목을 클릭합니다.

• 입력 레이어를 사용자의 집, 그리고 목표 레이어를 solution_centroids 로 설정해야 합니다. 두 레이어
모두 유일한 ID 항목인 id 항목을 사용해야 합니다.

• 산출물 행렬 유형을 linear 로 설정해야 합니다.

• 적절한 산출물 경로 및 파일명을 설정하십시오.

• OK 를 클릭하십시오.

• 텍스트 편집기로 (또는 스프레드시트로) 산출물 파일을 열어보십시오. 어떤 목표 ID 가 가장 짧은
Distance 와 연결되어 있는지 살펴보십시오. 동일한 거리가 하나 이상일 수도 있습니다.

• QGIS 에서 사용자의 집에서 가장 가까운 해답 영역을 (id 항목을 이용해서) 선택하는 쿼리를
작성하십시오.

연구 과제에 대한 최종 해답을 얻었습니다.

과제 제출 시 여러분이 선택한 (예를 들면 DEM 이나 slope 래스터 같은) 알맞은 래스터 위에 반투명한
음영기복도 레이어를 포함시키십시오. 또 여러분의 집은 물론 가장 가까운 해답 영역 (들) 의 폴리곤도
포함시켜야 합니다. 여러분의 결과물 맵을 생성하는 데 지도 제작을 위한 최상의 관습들을 따르십시오.

9.4. Lesson: 보충 예제 253



QGIS Training Manual, 출시 2.2

254 Chapter 9. Module: 분석의 완성



CHAPTER 10

Module: 플러그인

플러그인을 이용하면 QGIS 가 제공하는 기능을 확장할 수 있습니다. 이 모듈에서는 플러그인을 활성화하고
활용하는 방법을 배울 것입니다.

10.1 Lesson: 플러그인 설치 및 관리

플러그인을 사용하기 시작하려면 플러그인을 다운로드, 설치, 활성화하는 방법을 알아야 합니다. 이를
위해서 Plugin Installer 와 Plugin Manager 의 사용법을 배워보겠습니다.

이 강의의 목표: QGIS 의 플러그인 시스템을 이해하고 사용하기.

10.1.1 Follow Along: 플러그인 관리

• 메뉴에서 Plugins → Manage and Install Plugins 항목을 클릭해서 Plugin Manager 를 여십시오.

• 대화 창이 뜨면, 다음처럼 Processing 플러그인을 찾아보십시오.

• 이 플러그인 옆의 체크박스를 체크한 다음, 해제해서 비활성화하십시오.
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• Close 를 클릭합니다.

• 메뉴를 보면, 이제 Processing 메뉴가 사라졌다는 것을 알 수 있습니다. 그러니까 이전까지 사용했던
다양한 처리 기능을 사용할 수 없다는 뜻이죠! 처리 기능이 Processing 플러그인의 일부이며,
사용하려면 활성화를 필요로 하기 때문입니다.

• Plugin Manager 를 다시 열어서 Processing 플러그인 옆의 체크박스를 체크해서 재활성화한 다음
Close 를 클릭하십시오.

• Processing 메뉴가 다시 나타날 것입니다.

10.1.2 Follow Along: 새 플러그인 설치

사용자가 활성화/비활성화할 수 있는 플러그인의 목록은 사용자가 현재 설치한 플러그인들입니다.

• 새 플러그인을 설치하려면, Plugin Manager 대화 창에서 Not Installed 옵션을 선택하십시오.
사용자가 설치할 수 있는 플러그인들의 목록이 나타날 것입니다. 이 목록은 사용자의 기존 시스템
설정에 따라 달라집니다.

• 이 플러그인 목록에서 각 플러그인을 선택하면 관련 정보를 볼 수 있습니다.
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• 플러그인 정보 패널 아래 있는 Install Plugin 버튼을 클릭하면 플러그인을 설치할 수 있습니다.

10.1.3 Follow Along: 추가 플러그인 저장소 설정

사용자가 설치할 수 있는 플러그인은 사용자가 사용하도록 설정한 플러그인 저장소 에 따라 달라집니다.

QGIS플러그인은온라인저장소에저장되어있습니다. 기본설치시,공식저장소들만활성화되어있습니다.
즉 공식 플러그인만 사용할 수 있다는 뜻입니다. 공식 플러그인이 사용자가 보통 가장 원하는 기능들입니다.
철저히 테스트되었고, 기본적으로 QGIS 에 포함되기 때문입니다.

하지만 기본 플러그인 외에 다양한 플러그인들을 시험해볼 수 있습니다. 먼저 추가 저장소를 설정해야
합니다. 이를 위해서는,

• Plugin Manager 대화창에 있는 Settings 탭을 선택하십시오.
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• Add 를 클릭해서 새 저장소를 찾아 추가합니다.

• 사용자가 설정하기 원하는 새 저장소의 명칭과 URL 을 입력하고, Enabled 체크박스를 체크했는지
확인하십시오.

• 이제 설정된 플러그인 저장소 목록에 새 플러그인 저장소가 추가된 것을 볼 수 있습니다.
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• 또한 Show also experimental plugins체크박스를체크하면실험적플러그인을표출하는옵션을선택할
수도 있습니다.

• 다음으로 Get More 탭을 선택할 경우, 설치 가능한 추가 플러그인을 볼 수 있습니다.

• 이 플러그인을 설치하려면, 목록에서 하나를 선택한 다음 Install plugin 버튼을 클릭하면 됩니다.

10.1.4 In Conclusion

QGIS 에서 플러그인 설치 작업은 간단하고 효율적입니다!

10.1.5 What’s Next?

다음 강의에서, 예제를 통해 몇몇 유용한 플러그인을 소개하겠습니다.

10.2 Lesson: 유용한 QGIS 플러그인

이제 플러그인을 설치하고 활성화/비활성화할 수 있게 됐으니, 몇몇 유용한 플러그인의 예제를 통해 어떻게
활용할 수 있는지 배워보겠습니다.

이 강의의 목표: 플러그인 인터페이스에 익숙해지고 몇몇 유용한 플러그인에 대해 배우기.

10.2.1 Follow Along: 래스터 지형 분석 플러그인

• srtm_41_19.tif 래스터 데이터셋만 있는 새 맵을 시작하십시오. (exercise_data/raster/SRTM
경로에서 찾을 수 있습니다.)

래스터 분석에 대한 강의에서 이미 래스터 분석 기능에 대해 배웠습니다. (Raster → Analysis 메뉴를 통해)
GDAL 도구를 사용했죠. 하지만 래스터 지형 분석 플러그인도 알아둬야 합니다. QGIS 신규 버전에는
표준으로 내장되어 있기 때문에, 사용자가 개별적으로 설치할 필요도 없습니다.
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• Plugin Manager 를 열고, 다음과 같이 래스터 지형 분석 플러그인이 활성화돼 있는지 확인하십시오.

• Raster 메뉴를 클릭하십시오. Terrain analysis 서브메뉴를 볼 수 있을 겁니다.

• Terrain analysis → Relief 를 선택한 다음, 다음 옵션들을 입력하십시오.

• 새 파일의 경로 및 파일명을 exercise_data/plugins/relief.tif 로 지정하십시오. (필요한 경우
새 폴더를 생성하십시오.)

• Output format 과 Z factor 는 그대로 두십시오.

• Add result to project 체크박스를 체크했는지 확인하십시오.
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• Create automatically 버튼을 클릭하십시오. 다음과 같은 목록이 나타날 것입니다.

이 목록은 플러그인이 기복도를 생성하는 데 사용할 색상들입니다.

• 원한다면 색상 막대의 각 행을 더블클릭해서 다음과 같이 색상을 변경할 수도 있습니다.

• OK 를 클릭하면 기복도가 생성됩니다.
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이 기능은 반투명한 음영기복도를 다른 래스터 레이어 위에 오버레이하는 것과 비슷한 효과를 냅니다. 이
플러그인의 장점은 단 하나의 레이어로 이 효과를 생성한다는 것입니다.

10.2.2 Follow Along: OpenLayers 플러그인

• 새 맵을 시작한 다음 roads.shp 레이어를 추가하십시오.

• Swellendam 지역으로 줌인하십시오.

• Plugin Manager 에서 Filter 란에 OpenLayers 라고 입력해서 새 플러그인을 검색하십시오.

• Select the OpenLayers Layers plugin from the filtered list:
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• Install plugin 버튼을 클릭해서 설치합니다.

• 설치가 끝나면 Plugin Manager 를 닫으십시오.

이 플러그인을 사용하기 전에, 사용자의 맵과 해당 플러그인이 제대로 설정되었는지 확인합니다.

• Open the plugin’s settings by clicking on Plugins → OpenLayers plugin → OpenLayers Overview.

• 패널에서사용자가원하는 맵 유형을 선택하십시오. 이예제에서는 “혼합”유형을쓰겠지만, 사용자가
원하는 어떤 유형이든 선택할 수 있습니다.

• 메뉴에서 Project → Project Properties 를 선택해서 Project Properties 대화 창을 여십시오.

• “실시간” 투영을 활성화하고 구글 메르카토르 투영체를 선택하십시오.
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• 이제 플러그인을 써서 이 지역의 구글 지도를 불러와보겠습니다. 구글 지도를 추가하려면 메뉴에서
Plugins → OpenLayers Plugin → Add Google Hybrid Layer 항목을 클릭하면 됩니다.

이렇게하면구글에서새래스터이미지를불러오는데, 배경으로사용할수도, 현재맵상의위치가어디인지
알아내는 데 사용할 수도 있습니다. 다음은 구글 지도 위에 우리가 사용한 벡터 도로 레이어를 오버레이한
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화면입니다.

주석: 여러분의 도로 레이어를 구글 레이어 위로 드래그해서 배경 레이어 위에 도로 레이어가 보이도록
해야 할 수도 있습니다. 맵을 다시 정렬하기 위해 도로 레이어의 범위로 확대/축소해야 할 수도 있습니다.

10.2.3 Follow Along: GeoSearch 플러그인

• 아무 데이터셋도 없는 새 맵을 시작하십시오.

• Plugin Manager 를 열고, GeoSearch 플러그인을 검색한 다음 Install Plugin 을 클릭해서
설치하십시오.
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• Plugin Manager 를 닫습니다.

• 이제 GeoSearch 플러그인을 통해 지명을 검색할 수 있습니다. Plugins → GeoSearch Plugin →
GeoSearch 메뉴를 클릭해서 GeoSearch 대화 창을 여십시오.

• GeoSearch 대화 창에서 Swellendam 을 검색해서 사용자 맵 상 어디에 위치하는지 찾아보십시오.
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10.2.4 In Conclusion

QGIS 에서 사용할 수 있는 유용한 플러그인들이 많이 있습니다. 이 플러그인들을 설치하고 관리하기 위한
내장 도구를 사용하면, 새 플러그인을 찾아 최대한 활용할 수 있습니다.

10.2.5 What’s Next?

다음으로 원격 서버에 존재하는 레이어를 실시간으로 이용하는 방법을 배워보겠습니다.
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CHAPTER 11

Module: 온라인 자원

맵을 위한 데이터소스를 감안할 때, 여러분이 작업 중인 컴퓨터에 저장되어 있는 데이터로만 제한할 필요가
없습니다. 인터넷에 연결되어 있는 한, 여러분이 데이터를 불러올 수 있는 온라인 데이터소스들이 있습니다.

이 모듈에서 두 종류의 웹 기반 GIS 서비스에 대해 배울 것입니다. 바로 WMS(Web Mapping Service) 와
WFS(Web Feature Service) 입니다.

11.1 Lesson: WMS(Web Mapping Service)

WMS 는 원격 서버에서 호스팅되는 서비스입니다. 웹사이트와 비슷하게, 서버에 연결되어 있는 한 WMS
에 접근할 수 있습니다. QGIS 를 사용하면 사용자의 기존 맵에 직접 WMS 를 불러올 수 있습니다.

예를 들면, 플러그인에 대한 강의에서 구글에서 새 래스터 이미지를 불러올 수 있었다는 사실을 기억하실
겁니다. 하지만 그건 1 회용 전송이었습니다. 한번 이미지를 다운로드하면, 바뀌지 않는다는 뜻이죠. WMS
는 사용자가 맵을 이동하거나 확대/축소할 경우 자동적으로 그 뷰를 새로 고치는 라이브 서비스라는 점이
다릅니다.

이 강의의 목표: WMS 를 사용하고 그 한계를 이해하기.

11.1.1 Follow Along: WMS 레이어 불러오기

이실습에서이강의를시작할때만들었던기본맵을사용할수도있고,새맵을시작해서몇몇기존레이어를
불러올 수도 있습니다. 이번 예제의 경우, 새 맵을 시작하고 원래 places 와 landuse 레이어를 불러온 다음
다음과 같이 심볼을 조정하겠습니다.
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• 새 맵에 해당 레이어들을 불러오거나, 기본 맵에서 이 레이어들만 보이도록 설정하십시오.

• WMS 레이어를 추가하기 전에, 먼저 “실시간” 투영을 비활성화하십시오. 그러면 레이어들이 제대로
겹쳐지지 않을 수도 있지만 걱정하지 마십시오. 이후에 해결할 것입니다.

• WMS 레이어를 추가하려면 다음 Add WMS Layer 버튼을 클릭하십시오.

강의 초반에 어떻게 SpatiaLite 데이터베이스에 접속했는지 떠올려보십시오. landuse, places, water
레이어들이 그 데이터베이스 안에 있었습니다. 해당 레이어들을 사용하기 위해 먼저 데이터베이스에
접속해야 했죠. WMS 도 비슷합니다. 레이어가 원격 서버에 있다는 점만 빼면 말입니다.

• WMS 로의 새 연결을 생성하려면 New 버튼을 클릭하십시오.

계속하려면WMS주소가필요합니다. 인터넷에는사용가능한몇몇무료WMS서버가있습니다. 그가운데
하나가 OpenStreetMap 데이터셋을 사용하는 terrestris 입니다.

• 이 WMS 를 사용하려면, 현재 대화 창을 다음과 같이 설정하십시오.
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• Name 항목의 값이 terrestris 여야 합니다.

• URL 항목의 값이 http://ows.terrestris.de/osm/service 여야 합니다.

• OK 를 클릭하십시오. 새 WMS 서버가 목록에 나타날 것입니다.
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• Connect 를 클릭하십시오. 아래에 있는 목록에서 새 항목들을 볼 수 있을 것입니다.

해당 WMS 서버가 호스팅하고 있는 레이어들입니다.
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• OSM-WMS 레이어를 한 번 클릭하십시오. 해당 레이어의 Coordinate Reference System 을 표출할
것입니다.

여러분의 맵이 WGS 84 를 사용하지 않으므로, 선택할 수 있는 모든 CRS 들을 보도록 합시다.

• Change 버튼을 클릭하십시오. 표준 Coordinate Reference System Selector 대화 창이 나타납니다.

• We want a projected CRS, so let’s choose WGS 84 / Psuedo Mercator.
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• :guilabel:‘OK‘를 클릭하십시오.

• Add 를 클릭하면 사용자의 맵에 OSM-WMS 라는 명칭으로 새 레이어를 추가합니다.

• Layers list 에서 해당 레이어를 클릭 & 드래그해서 목록의 맨 밑으로 옮기십시오.

사용자 레이어의 위치가 정확하지 않다는 사실을 알아차렸을 겁니다. “실시간” 투영을 비활성화했기
때문입니다. 이 기능을 다시 활성화하되, OSM-WMS 레이어와 동일한 투영체, 즉 WGS 84 / Pseudo
Mercator 를 사용하도록 설정하겠습니다.

• “실시간” 투영을 활성화하십시오.

• (Project Properties 대화 창에 있는) CRS 탭에서, Filter 란에 pseudo 를 입력하십시오.
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• 목록에서 WGS 84 / Pseudo Mercator 를 선택합니다.

• :guilabel:‘OK‘를 클릭하십시오.

• 이제 Layers list 에 있는 사용자의 레이어 가운데 하나를 오른쪽 클릭하고 Zoom to layer extent 를
클릭합니다. 다음과 같이 Swellendam 지역을 볼 수 있을 것입니다.
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어떻게 WMS 레이어의 도로와 사용자의 도로가 겹쳐지는지 살펴보십시오. 좋은 징조군요!

WMS 의 본질과 한계

지금쯤이면이WMS레이어가실제로많은피처들을담고있다는사실을알아차렸을겁니다. 도로,강,자연
보호 구역 등을 담고 있습니다. 더우기, 벡터로 이루어져 있는 것으로 보이지만 사용자가 심볼을 변경할 수
없는 래스터 같기도 합니다. 어째서일까요?

이것이 WMS 가 작동하는 방식이기 때문입니다. 마치 종이 지도처럼, 사용자는 이 맵을 이미지로 받게
됩니다. 보통은 QGIS 가 맵으로 렌더링하는 벡터 레이어를 이용합니다. 그러나 WMS 를 사용하면, 이
벡터 레이어들이 WMS 서버 상에 있기 때문에 레이어를 맵으로 렌더링해서 사용자에게 이미지 형식으로
맵을 전송합니다. QGIS 는 이 이미지를 표출할 수 있지만 그 심볼을 변경할 수는 없습니다. 모든 작업이
서버에서 이루어지기 때문입니다.

사용자가 심볼에 대해 걱정할 필요가 없다는 점에서 몇몇 강점이 있습니다. 능숙하게 설계된 WMS 라면
이미 모든 작업이 이루어져 보기 좋은 맵을 전송하기 때문입니다.

다른 한 편으로는 사용자 마음에 들지 않아도 심볼을 변경할 수 없으며, WMS 서버에서 무언가를 변경하면
사용자 맵에서도 동일하게 변경됩니다. 때때로 WMS 스타일의 맵의 일부로서가 아니라 사용자에게 벡터
레이어를 개별적으로 전송하는 WFS(Web Feature Service) 를 이용하는 편이 나은 이유입니다.

하지만 WMS 에 대해서는 다음 상의에서 배울 것입니다. 그 전에, terrestris WMS 서버에서 다른 WMS
레이어를 추가해봅시다.

11.1.2 Try Yourself

• Layers list 에서 OSM-WSM 레이어를 비활성화하십시오.

• http://196.33.85.22/cgi-bin/ZAF_CGS_Bedrock_Geology/wms URL 을 이용해 “ZAF CGS 1M
Bedrock Lithostratigraphy” WMS 서버를 추가하십시오.

• 맵 상에 BEDROCKGEOLOGY 레이어를 불러오십시오. (이전과 마찬가지로 Add WMS Layer
버튼을이용합니다.) 사용자의맵과동일한WGS 84 / World Mercator 투영체를사용하도록설정하는
것을 잊지 마십시오!
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• 더 빠르게 불러오기 위해 Encoding 을 JPEG 으로, Tile size 옵션을 200 × 200 으로 설정할 수도
있습니다.

결과 확인

11.1.3 Try Yourself

• 배경에서 필요도 없이 렌더링되는 일을 막기 위해 다른 모든 WMS 레이어를 비활성화하십시오.

• http://ogc.gbif.org:80/wms URL 을 이용해 “OGC” WMS 서버를 추가하십시오.

• bluemarble 레이어를 추가합니다.

결과 확인

11.1.4 Try Yourself

WMS 를 이용하는 데 어려운 점 가운데 하나는 좋은 (무료) 서버를 찾는 일입니다.

• spatineo.com (또는 온라인 상의 다른 곳) 에서 새 WMS 를 찾아보십시오. 요금이나 사용 제한이
있어서는 안 되며, Swellendam 연구 지역의 커버리지를 가지고 있어야 합니다.

WMS 를 이용하는 데 필요한 것은 URL(그리고 어떤 형태의 설명이 있으면 좋습니다) 뿐이라는 것을
기억하십시오.

결과 확인

11.1.5 In Conclusion

WMS 를 사용하면, 고정된 맵을 사용자의 기존 맵 데이터의 배경으로 추가할 수 있습니다.

11.1.6 Further Reading

• spatineo.com
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• Geopole.org

• OpenStreetMap.org list of WMS servers

11.1.7 What’s Next?

이제 고정된 맵을 배경으로 추가해봤으니, (이전에 추가했던 다른 벡터 레이어 같은) 피처도 추가할 수
있다는 사실을 알면 기쁠 겁니다. WFS(Web Feature Service) 를 이용하면 원격 서버에서 피처를 추가할
수 있습니다. 이것이 다음 강의의 주제입니다.

11.2 Lesson: WFS(Web Feature Service)

WFS(Web Feature Service)는사용자가 QGIS에직접불러올수있는형식으로 GIS데이터를제공합니다.
사용자가 편집할 수 없는 맵만을 제공하는 WMS 와는 달리, WFS 는 피처 그 자체에 접근할 수 있도록
해줍니다.

이 강의의 목표: WFS 를 사용하고 WMS 와의 차이점을 이해하기.

11.2.1 Follow Along: WFS 레이어 불러오기

• 새 맵을 시작하십시오. 이 맵은 시연 용이기 때문에 저장하지 않을 겁니다.

• “실시간” 재투영이 비활성화돼 있는지 확인하십시오.

• 다음 Add WFS Layer 버튼을 클릭하십시오.

• New 버튼을 클릭합니다.

• 대화창이뜨면, Name에 nsidc.org를, URL에 http://nsidc.org/cgi-bin/atlas_south?version=1.1.0
을 입력하십시오.

• OK 를 클릭하면 Server connections 에 새 연결이 나타날 것입니다.
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• Connect 를 클릭하면 사용 가능한 레이어들의 목록이 나타납니다.

• south_poles_wfs 레이어를 찾으십시오.

• 해당 레이어를 클릭해서 선택한 다음,
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• Add 를 클릭하십시오.

레이어를불러오는데시간이걸릴수도있습니다. 불러오기가끝나면맵상에나타날것입니다. 다음화면은
남극대륙의윤곽선 (동일서버에서불러올수있는 antarctica_country_border)위에나타난레이어입니다.

이게 WMS 레이어와 다른 점은 무엇일까요? 레이어의 속성을 보게 되면 명확해집니다.

• south_poles_wfs 레이어의 속성 테이블을 여십시오. 다음과 같은 내용을 보게 될 겁니다.
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포인트에속성이부여돼있으므로,라벨을붙이는것은물론심볼도변경할수있습니다. 다음은그예입니다.

• 이 레이어의 속성 데이터를 활용해서 라벨을 추가해보십시오.

WMS 레이어와의 차이점

A Web Feature Service returns the layer itself, not just a map rendered from it. This gives you direct
access to the data, meaning that you can change ts symbology and run analysis functions on it. However,
this is at the cost of much more data being transmitted. This will be especially obvious if the layers
you’re loading have complicated shapes, a lot of attributes, or many features; or even if you’re just
loading a lot of layers. WFS layers typically take a very long time to load because of this.
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11.2.2 Follow Along: WFS 레이어 쿼리

WFS 레이어를 불러온 다음 쿼리할 수도 있지만, 대부분의 경우 불러오기 전에 쿼리하는 편이 훨씬
효율적입니다. 그렇게 하면 사용자가 원하는 피처만 요청하기 때문에 훨씬 적은 대역폭을 쓰게 되기
때문입니다.

예를 들어, 현재 사용 중인 WFS 서버 상에 countries (excluding Antarctica) 라는 레이어가 있습니다.
여기서 (아마도 antarctica_country_border 레이어와 함께) 이미 불러온 south_poles_wfs 레이어의 위치와
남아프리카 공화국의 위치를 비교해보고 싶다고 해봅시다.

두 가지 방법이 있습니다. 먼저 countries ... 레이어 전체를 불러온 다음, 평소와 마찬가지로 쿼리를 작성할
수 있습니다. 하지만 전 세계의 모든 나라들의 데이터를 전송받아 남아프리카 공화국의 데이터만 이용하는
것은 대역폭을 조금 낭비하는 것 같군요. 사용자의 인터넷 연결 속도에 따라 이 데이터를 불러오는 데 몇
분이 걸릴 수도 있습니다.

두 번째는 서버에서 레이어를 불러오기도 전에 필터 역할을 하는 쿼리를 작성하는 방법입니다.

• Add WFS Layer ... 대화 창에서 이전에 사용했던 서버에 연결하십시오. 사용 가능한 레이어들의
목록이 보일 겁니다.

• countries ... 레이어 옆의 Filter 란을 더블클릭하거나, Build query 를 클릭하십시오.

• 대화 창이 뜨면 다음과 같이 "Countryeng" = 'South Africa' 라는 쿼리를 작성하십시오.
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• 쿼리가 Filter 값으로 나타날 것입니다.
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• 앞의 그림처럼 countries 레이어를 선택한 상태에서 Add 를 클릭하십시오. 다음과 같이 해당
레이어에서 Countryeng 값이 South Africa 인 나라만 불러오게 됩니다.

그럴필요는없지만두가지방법을다해봤다면, 필터링하기전에모든나라를불러오는것이훨씬느리다는
것을 알 수 있을 겁니다!

WFS 의 사용성에 대해

사용자의 요구가 매우 특화되어 있을 경우, 사용자가 필요한 피처를 호스팅하고 있는 WFS 를 찾기란
매우 어렵습니다. WFS 가 상대적으로 희귀한 이유는 전체 피처를 표현하기 위해 전송해야 하는 데이터가
대용량이기 때문입니다. 따라서 이미지만을 전송하는 WMS 에 비해, WFS 를 호스팅하는 것은 가성비가
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떨어집니다.

그러므로사용자가앞으로보게될WFS는아마도인터넷상에있는것보다는로컬네트워크나혹은사용자
자신의 컴퓨터에 있을 가능성이 가장 큽니다.

11.2.3 In Conclusion

사용자가 레이어의 속성 및 도형에 직접 접근해야 할 경우, WMS 레이어보다 WFS 레이어가 더 낫습니다.
하지만 (속도는 물론 쉽게 사용할 수 있는 공공 WFS 서버 부족이라는 문제를 일으키는) 다운로드해야 할
데이터 용량을 감안하면 언제나 WMS 대신 WFS 를 사용할 수 있는 것은 아닙니다.

11.2.4 What’s Next?

다음으로 어떻게 QGIS 를 유명한 GRASS GIS 의 프론트엔드로 사용할 수 있는지 배워보겠습니다.
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CHAPTER 12

Module: GRASS

GRASS(Geographic Resources Analysis Support System) 는 다양하고 유용한 GIS 기능들을 갖춘 유명한
오픈소스 GIS 입니다. 1984 년 처음 출시된 후로 수많은 개선 작업 및 기능 추가를 거쳤습니다. QGIS 를
이용하면 GRASS 의 강력한 GIS 도구를 직접 사용할 수 있습니다.

12.1 Lesson: GRASS 설정

QGIS 에서 GRASS 를 사용하려면 인터페이스를 조금 다른 방식으로 봐야 할 필요가 있습니다. QGIS 에서
직접 작업하는 것이 아니라, QGIS 를 통해서 GRASS 에서 작업하는 것이라는 걸 기억하십시오.

이 강의의 목표: QGIS 에서 GRASS 프로젝트를 시작하기.

12.1.1 Follow Along: 새 GRASS 프로젝트 시작

QGIS 내에서 GRASS 를 실행하려면, 다른 플러그인과 마찬가지로 활성화해야 합니다. 먼저 새 QGIS
프로젝트를 여십시오.

• Plugin Manager 의 목록에서, GRASS 를 활성화하십시오.
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다음과 같은 GRASS 툴바가 나타날 것입니다.

GRASS 를 사용할 수 있으려면 먼저 맵셋 을 생성해야 합니다. GRASS 는 항상 데이터베이스 환경에서
작동하기 때문에, 사용자가 사용하길 바라는 모든 데이터를 GRASS 데이터베이스로 가져와야 합니다.

• 다음 New mapset 버튼을 클릭하십시오.

GRASS 맵셋의 구조를 설명하는 대화 창이 뜰 것입니다.

• exercise_data 폴더 아래 grass_db 라는 새 디렉터리를 생성하십시오.

• GRASS 의 데이터베이스를 설정하는 데 다음과 같이 이 디렉터리를 설정하십시오.
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• Next 를 클릭합니다.

GRASS 에서 사용자가 작업할 지리적 영역의 최대 범위를 지정하는 “위치” 를 생성해야 합니다.

• 새 위치를 South_Africa 라고 명명하십시오.
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• Next 를 클릭합니다.

• WGS 84 좌표계로 작업할 예정이니, 해당 CRS 를 검색해서 선택하십시오.
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• Next 를 클릭합니다.

• 이제 드롭다운 목록에서 South Africa 를 선택한 다음 Set 을 클릭하십시오.
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• Next 를 클릭합니다.

• 여러분이 작업하게 될 맵 파일인 맵셋을 생성하십시오.
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모두 완료되면 모든 설정을 보여주면서 정확하냐고 묻는 대화 창이 나타날 것입니다.

• Finish 를 클릭합니다.

• 이어지는 대화 창의 OK 를 클릭합니다.

12.1.2 GRASS 에 벡터 데이터 불러오기

이제 비어 있는 맵이 생겼습니다. GRASS 에 데이터를 불러오려면 다음 두 단계의 과정을 거쳐야 합니다.

• 하던 대로 QGIS 에 데이터를 불러오십시오. 지금은 (exercise_data/epsg4326/ 폴더에 있는)
roads.shp 데이터셋을 쓰겠습니다.

• 불러오기가 끝나자마자, 다음 GRASS Tools 버튼을 클릭하십시오.
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• 새 대화 창이 뜨면, Modules list 를 선택합니다.

• Filter 란에 v.in.ogr.qgis 라고 입력해서 벡터 가져오기 도구를 찾으십시오.

v 는 벡터를, in 은 GRASS 데이터베이스에 데이터를 가져오는 기능을, ogr 은 벡터 데이터를 읽는 데
사용되는 소프트웨어 라이브러리를, 그리고 qgis 는 이 도구가 QGIS 에 이미 로드된 벡터들 가운데 한
벡터를 찾을 것이라는 사실을 의미합니다.

• 해당 도구를 찾으면, 클릭해서 도구의 대화 창을 불러옵니다.

• 로드된 레이어에 roads 를 설정하고, 혼란을 피하기 위해 GRASS 버전의 명칭을 g_roads 로
설정하십시오.
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주석: Advanced Options 아래 있는 추가적인 가져오기 옵션들을 살펴보십시오. 이 옵션들 중에는
데이터를 가져오는 데 쓰이는 SQL 쿼리에 WHERE 구문을 추가할 수 있는 기능도 있습니다.

• Run 을 클릭해서 가져오기를 시작합니다.

• 가져오기가 끝나면 View output 버튼을 클릭해서 맵에 새로 가져온 GRASS 레이어를 살펴보십시오.

• Close first the import tool (click the Close button to the immediate right of View output), then
close the GDAL Tools window.

• 원래 roads 레이어를 제거합니다.

이제 사용자의 QGIS 맵에 가져온 GRASS 레이어만 보이게 됩니다.

12.1.3 Follow Along: GRASS 에 래스터 데이터 불러오기

우리가 사용했던 DEM 은 투영 CRS 인 UTM 33S / WGS 84 를 사용하지만, 이번 GRASS 프로젝트는 지리
CRS 인 WGS 84 를 사용한다는 점을 상기하십시오. 따라서 먼저 DEM 을 재투영하겠습니다.

• QGIS 의 Add Raster Layer 도구를 써서 QGIS 맵에 (exercise_data/raster/SRTM/ 폴더에 있는)
srtm_41_19.tif 데이터셋을 불러오십시오.
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• GDAL Warp 도구를 (Raster → Projections → Warp (Reproject)) 이용해서 재투영하십시오. 다음과
같이 설정해야 합니다.

• 원래 파일과 동일한 폴더에 래스터를 저장하되, 파일명은 DEM_WGS84.tif 로 지정하십시오. 사용자
맵에 래스터가 표출되면, Layers list 에서 srtm_41_19.tif 데이터셋을 제거하십시오.

재투영이 끝났으니, 이제 GRASS 데이터베이스로 불러올 수 있습니다.
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• GRASS Tools 대화 창을 다시 여십시오.

• Modules List 탭을 선택합니다.

• r.in.gdal.qgis 를 검색한 다음 도구를 더블클릭해서 도구 대화 창을 여십시오.

• 입력 레이어를 DEM_WGS84, 산출물을 g_dem 으로 설정하십시오.

• Run 을 클릭합니다.

• 처리가 끝나면 View output 을 클릭하십시오.

• 현재 탭의 Close 를 클릭한 다음, 전체 대화 창의 Close 를 클릭하십시오.
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• 이제 원래 DEM_WGS84 레이어를 제거해도 됩니다.

12.1.4 In Conclusion

GRASS 는 데이터를 공간 데이터베이스 구조로 불러온다는 점에서 GRASS 의 데이터 획득 작업 흐름은
QGIS 의 방법과 약간 다릅니다. 하지만 QGIS 를 프론트엔드로 사용하면, QGIS 의 기존 레이어를 GRASS
를 위한 데이터소스로 이용할 수 있기 때문에 GRASS 맵셋을 더 쉽게 설정할 수 있게 됩니다.

12.1.5 What’s Next?

이제 GRASS 에 데이터를 가져왔으니, GRASS 가 제공하는 고급 분석 작업을 해볼 차례입니다.

12.2 Lesson: GRASS 도구

이번 강의에서는 여러분이 GRASS 의 능력을 잘 알 수 있는 여러 도구들을 소개하겠습니다.

12.2.1 Follow Along: 래스터 색상 설정

• GRASS Tools 대화 창을 여십시오.

• Modules List 탭에 있는 Filter 란에서 검색, r.colors.table 모듈을 찾으십시오.

• 해당 도구의 대화 창를 열고 다음과 같이 설정하십시오.
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도구를 실행하면, 다음과 같이 래스터를 다시 칠할 겁니다.
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12.2.2 Follow Along: 데이터를 3D 로 시각화

GRASS에서는, DEM을써서사용자데이터를 3차원으로시각화할수있습니다. 이작업에사용할도구는
GRASS Region 기반으로 동작하는데, 여러분이 이전 강의에서 설정한 대로 남아프리카 공화국 전체 범위로
설정돼 있습니다.

• 이 범위를 사용자의 래스터 데이터셋만 커버하는 범위로 다시 정의하려면, 다음 버튼을 클릭하십시오.

When this tool is activated, your cursor will turn into a cross whe over the QGIS map canvas.

• 이 도구를 써서 GRASS 래스터의 경계 주위에 사각형을 클릭 & 드래그하십시오.

• 완료 시 GRASS Region Settings 대화 창의 OK 를 클릭하십시오.

• 다음과 같이 nviz 도구를 검색합니다.
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• 다음과 같이 설정하십시오.
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• 두 개의 래스터 선택 드롭다운 메뉴 오른쪽에 있는 Use region of this map 버튼들을 활성화하는 것을
잊지 마십시오. NVIZ 가 래스터의 해상도를 정확히 가늠할 수 있게 해줍니다.

• Run 버튼을 클릭합니다.

NVIZ 가 선택된 래스터 및 벡터를 이용해 3D 환경을 설정합니다. 사용자의 하드웨어 성능에 따라 시간이
걸릴 수도 있습니다. 처리가 끝나면, 새 창에서 3D 로 렌더링된 맵을 볼 수 있습니다.

302 Chapter 12. Module: GRASS



QGIS Training Manual, 출시 2.2

height, z-exag, View method 설정을 바꿔가면서 데이터의 사용자 뷰를 변경해보십시오. 조종 방법에
익숙해지는 데 시간이 조금 걸릴 겁니다.

충분히 연습했다면, NVIZ 창을 닫으십시오.

12.2.3 Follow Along: Mapcalc 도구

• GRASS Tools 대화 창의 Modules List 탭을 열고 calc 를 검색하십시오.

• 모듈 목록에서 r.mapcalc 를 선택하십시오. (r.mapcalculator 가 아닙니다. r.mapcalculator 는 좀 더
기본적인 도구입니다.)

• 도구를 실행하십시오.

Mapcalc대화창에서래스터하나,혹은래스터집합에대해일련의분석작업을하도록구성할수있습니다.
다음 도구들을 사용할 것입니다.

순서대로,

• Add map: 현재 GRASS 맵셋에 있는 래스터 파일을 추가합니다.

• Add constant value: 함수에 사용할 상수값을 추가합니다.

• Add operator or function: 입력 및 출력에 연결될 연산자나 함수를 추가합니다.

• Add connection: 요소들을 연결합니다. 이 도구를 써서 한 항목의 빨간 점에서 다른 항목의 빨간
점으로 클릭 & 드래그할 수 있습니다. 연결자 라인에 정확히 연결된 점들은 회색으로 변할 것입니다.
라인이나 점이 빨갛다면, 제대로 연결되지 않은 겁니다!

• Select item: 항목을 선택하고 선택한 항목을 옮깁니다.
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• Delete selected item: 현재 mapcalc 시트에서 선택한 항목을 제거하되, (기존 래스터일 경우)
맵셋에서 삭제하지는 않습니다.

이 도구들을 사용해서,

• 다음 알고리듬을 구성해보십시오.

• Run 클릭 시, 여러분의 산출물이 다음처럼 보여야 합니다.
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• 사용자 맵에 산출물을 표출하려면 View output 을 클릭하십시오.

이 산출물은 표고가 500m 에 못 미치거나 1000m 를 초과하는 모든 지역을 보여줍니다.
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12.2.4 In Conclusion

이 강의에서는 GRASS 가 제공하는 수많은 도구 가운데 몇 가지만을 살펴보았습니다. GRASS 의 능력을
직접 느껴보고 싶다면, GRASS Tools 대화 창을 열고 Modules List 를 스크롤해보십시오. 또는 더 정돈된
방법으로, 도구들을 유형별로 조직화한 Modules Tree 탭을 살펴보십시오.
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CHAPTER 13

Module: 평가

이 강의에서는 사용자의 데이터를 사용합니다. 다음과 같은 데이터가 필요합니다.

• 포인트 명칭 및 복수의 카테고리 속성을 가진, 관심 지점의 포인트 벡터 데이터셋

• 도로의 라인 벡터 데이터셋

• 토지이용도 (부지 윤곽선 사용) 폴리곤 벡터 데이터셋

• (항공사진 같은) 가시 스펙트럼 이미지

• DEM (사용자에게 없을 경우 이곳 에서 다운로드할 수 있습니다.)

13.1 기본 맵 생성

데이터 분석을 하기 전에, 여러분의 분석 결과의 맥락을 제공할 기본 맵이 필요합니다.

13.1.1 포인트 레이어 추가

• 포인트 레이어를 추가하십시오. 여러분이 받고 있는 강의의 수준에 따라, 다음 목록에서 적절한
단계만을 따르시기 바랍니다.

초급

• 지명과 같은 유일한 속성을 이용해서 포인트에 라벨을 부여하십시오. 작은 폰트를 사용해서 라벨을
눈에 띄지 않게 하십시오. 정보를 사용할 수 있어야 하지만, 맵의 주요 특성이 되어서는 안 됩니다.

• 포인트 자체를 카테고리에 따라 다른 색상으로 범주화하십시오. 예를 들면 “관광 명소”, “경찰서”,
“도심” 같은 카테고리를 포함시킬 수 있습니다.

중급

• 초급 단계와 동일한 작업을 하십시오.

• 해당 피처가 중요할수록 포인트가 커지도록 중요도에 따라 포인트 크기를 범주화하십시오. 그러나
포인트 크기가 2.00 을 넘지 않도록 합니다.

• 단일 지점에 위치하지 않은 피처의 경우 (예를 들어 지방/지역 명칭이나 대축척에서의 도시명 등),
포인트를 할당하지 마십시오.
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고급

• 포인트 심볼을 써서 레이어를 심볼화하지 마십시오. 그 대신 라벨의 중심점을 포인트로 지정하고,
포인트 심볼 자체의 크기를 0 으로 하십시오.

• Data defined settings 를 사용해서 라벨의 스타일을 유의미한 카테고리로 만드십시오.

• 필요할 경우 속성 데이터에 적절한 열을 추가하십시오. 이때 가상 데이터를 생성해서는 안 됩니다.
데이터셋의 적절한 기존 값을 이용해서 Field Calculator 로 새 열의 값을 채우도록 합니다.

13.1.2 라인 레이어 추가

• 도로 레이어를 추가한 다음 심볼을 변경하십시오. 라벨은 부여하지 마십시오.

초급

• 도로 심볼을 밝은 색상의 굵은 선으로 변경합니다. 또 투명도도 높이십시오.

중급

• 다중 심볼 레이어로 심볼을 생성하십시오. 결과적으로 심볼이 실재 도로처럼 보여야 합니다. 이를
위해 단순 심볼을 사용할 수도 있습니다. 예를 들면 검은 라인의 가운데에 가느다란 흰 실선을 두거나
해서 말이죠. 더 정교하게 만들어도 되지만, 결과적으로 맵이 너무 번잡해져서는 안 됩니다.

• 여러분이맵을보여주고자하는축척에서여러분의데이터셋의도로밀도가너무높을경우, 실재도로
같은 정교한 심볼 및 소축척에서 쓰일 더 단순한 심볼을 가진 두 개의 도로 레이어를 만들어야 합니다.
(적절한 축척에서 서로 바뀌도록 해주는 축척 기반 시각화 기능을 사용하십시오.)

• 모든 심볼에 다중 심볼 레이어를 이용하십시오. 심볼을 써서 피처가 정확하게 표현되도록 하십시오.

고급

• 중급 단계와 동일한 작업을 하십시오.

• 그에 더해 도로를 범주화해야 합니다. 실재 도로 같은 심볼을 사용할 경우, 각 도로 유형에 걸맞는
심볼을사용해야합니다. 예를들어고속도로라면양방향으로차선이각각두개씩이어야할것입니다.

13.1.3 폴리곤 레이어 추가

• 토지이용도 레이어를 추가한 다음 심볼을 변경하십시오.

초급

• 토지이용 유형에 따라 단색을 써서 레이어를 범주화하십시오.
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중급

• 토지이용 유형에 따라 레이어를 범주화하십시오. 적합하다고 생각될 때 심볼 레이어, 서로 다른 심볼
유형 등을 사용하십시오. 하지만 결과물은 은은하고 균일해 보여야 합니다. 이 레이어는 배경의
일부라는 것을 명심하십시오!

고급

• 규칙 기반 범주화 기능을 써서 토지이용도를 “도심”, “교외”, “자연보호구역” 등 일반적인 카테고리로
범주화하십시오.

13.1.4 래스터 배경 생성

• DEM으로부터음영기복도를생성하고, DEM자체의범주화된버전을위한오버레이로이용하십시오.
(플러그인에 대한 강의에서 다뤘던) Relief 플러그인을 사용해도 됩니다.

13.1.5 기본 맵 완성

• Using the resources you above, create a base map using some or all of the layers. This map should
include all the basic information needed to orient the user, as well as being visually unified /
“simple”.

13.2 데이터 분석

• 특정 기준을 만족시키는 부지를 찾아야 합니다.

• 여러분 스스로 기준을 정할 수 있습니다. 반드시 문서화하십시오.

• 이 기준을 위한 몇 가지 지침이 있습니다.

– 목표 부지는 토지이용도의 특정한 유형 (들) 이어야 합니다.

– 도로로부터 주어진 거리 안에 있거나, 도로와 교차해야 합니다.

– 어떤 카테고리의 (예를 들어 병원 같은) 포인트로부터 주어진 거리 안에 있어야 합니다.

13.2.1 중급 / 고급

• 여러분의 결과물에 래스터 분석을 포함시키십시오. 래스터의 향이나 경사도 같은, 적어도 한 가지
속성을 추출하도록 합니다.

13.3 최종 맵

• Map Composer 를 통해 여러분의 분석 결과를 종합하는 최종 맵을 생성하십시오.

• Include this map in a document along with your documented criteria. If the map has become too
vsually busy due to the added layer(s), deselect the layers which you feel are the least necessary.

• 여러분의 맵은 제목과 범례를 포함해야 합니다.
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CHAPTER 14

모듈: 산림관리 응용

모듈 1부터 13까지 QGIS에관한많은것과그것으로어떻게작업을해야하는지배웠습니다. 만약기본적인
산림관리 응용방법을 GIS 로 배우는 것에 관심이 있다면, 이 모듈을 따라하는 것이 그동안 배운 것을 적용할
수 있는 능력과 이 모듈이 새로운 유용한 툴이란 것을 보여줄 것입니다.

이 모듈은 유럽연합의 지원으로 개발되었습니다.

14.1 Lesson: 산림관리 모듈 프리젠테이션

산림관리응용에관한모듈을따르는것은그동안연습했던모듈 1부터 11까지습득했던지시이필요합니다.
여기서 연습하게 될 것은 이미 QGIS 의 기본적인 활용능력이 있다는 것을 가정하고 있고 전에 사용하지
않았던 툴이 상세하게 제시될 것입니다.

그럼에도 불구하고 이 모듈은 기본적인 단계를 따를 것이고 만약 QGIS 에 대한 경험이 없다해도 문제없이
지시사항을 따라할 수 있을 것입니다.

이 모듈을 위해서 추가적인 데이터 패키지를 다운받으십시오.

14.1.1 산림관리 표본 데이터

주석: The sample data used in this module can be downloaded here (125 Mb). Download the zip file
and extract the forestry\ folder into your exercise_data\ folder.

The forestry related sample data (forestry map, forest data), has been provided by the EVO-HAMK
forestry school. The datasets have been modified to adapt to the lessons needs.

The general sample data (aerial images, LiDAR data, basic maps) has been obtained from the National
Land Survey of Finland open data service, and adapted for the purposes of the exercises. The open data
file download service can be accessed in English here.

경고: As for the rest of the training manual, this module includes instructions on adding, deleting
and altering GIS datasets. We have provided training datasets for this purpose. Before using the
techniques described here on your own data, always ensure you have proper backups!
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14.2 Lesson: Georeferencing a Map

A common forestry task would be the update of the information for a forestry area. It is possible that
the previous information for that area dates several years back and was collected analogically (that is,
in paper) or perhaps it was digitized but all you have left is the paper version of that inventory data.

Most likely you would like to use that information in your GIS to, for example, compare later with
later inventories. This means that you will need to digitize the information at hand using your GIS
software. But before you can start the digitizing, there is an important first step to be done, scanning
and georeferencing your paper map.

The goal for this lesson: To learn to use the Georeferencer tool in QGIS.

14.2.1 Scan the map

The first task you will have to do is to scan your map. If your map is too big, then you can scan it in
different parts but keep in mind that you will have to repeat preprocessing and georeferencing tasks for
each part. So if possible, scan the map in as few parts as possible.

If you are going to use a different map that the one provided with this manual, use your own scanner to
scan the map as an image file, a resolution of 300 DPI will do. If your map has colors, scan the image in
color so that you can later use those colors to separate information from your map into different layers
(for ex., forest stands, contour lines, roads...).

For this exercise you will use a previously scanned map, you can find it as rautjarvi_map.tif in the
data folder exercise_data/forestry

14.2.2 Follow Along: Georeferencing the scanned map

Open QGIS and set the project’s CRS to ETRS89 / ETRS-TM35FIN in Project → Project Properties →
CRS, which is the currently used CRS in Finland. Make sure that Enable ‘on the fly’ CRS transformation
is checked, since we will be working with old data that is another CRS.
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Save the QGIS project as map_digitizing.qgs.

You will use the georeferencing plugin from QGIS, the plugin is already installed in QGIS. Activate
the plugin using the plugin manager as you have done in previous modules. The plugin is named
Georeferencer GDAL.

To georeference the map:

• Open the georeference tool, Raster → Georeferencer → Georeferencer.

• Add the the map image file, :kdb:‘rautjarvi_map.tif‘, as the image to georeferenciate, File →
Open raster.

• When prompted find and select the KKJ / Finland zone 2 CRS, it is the CRS that was used in
Finland back in 1994 when this map was created.

• Click OK.

Next you should define the transformation settings for georeferencing the map:

• Open Settings → Transformation settings.

• Click the icon next to the Output raster box, go to the folder and create the folder
exercise_data\forestry\digitizing and name the file as rautjarvi_georef.tif.

• Set the rest of parameters as shown below.
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• Click OK.

The map contains several cross-hairs marking the coordinates in the map, we will use those to georefer-
enciate this image. You can use the zooming and panning tools as you usually do in QGIS to inspect
the image in the Georeferencer’s window.

• Zoom in to the left lower corner of the map and note that there is a cross-hair with a coordinate
pair, x and y, that as mentioned before are in KKJ / Finland zone 2 CRS.You will use this point
as the first ground control point for the georeferencing your map.

• Select the Add point tool and click in the intersection of the cross-hairs (pan and zoom as needed).

• In the Enter map coordinates dialogue write the coordinates that appear in the map (X: 2557000
and Y: 6786000).

• Click OK.

The first coordinate for the georeferencing is now ready.
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Look for other cross-hairs in the black lines image, they are separated 1000 meters from each other both
in North and East direction. You should be able to calculate the coordinates of those points in relation
to the first one.

Zoom out in the image and move to the right until you find other cross-hair, and estimate how many
kilometres you have moved. Try to get ground control points as far from each other as possible. Digitize
at least three more ground control points in the same way you did the first one. You should en up with
something similar to this:

With already three digitized ground control points you will be able to see the georeferencing error as a
red line coming out of the points. The error in pixels can be seen also in the GCP table in the dX[pixels]
and dY[pixels] columns. The error in pixels should not be higher than 10 pixels, if it is you should review
the points you have digitized and the coordinates you have entered to find what the problem is. You can
use the image above as a guide.

Once you are happy with your control points save your ground control points, in case that you will need
them later, and you will:
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• File → Save GCP points as....

• In the folder exercise_dataforestrydigitizing, name the file
:kdb:‘rautjarvi_map.tif.points‘.

Finally, georeference you map:

• File → Start georeferencing.

• Note that you named the file already as rautjarvi_georef.tif when you edited the Georeferencer
settings.

Now you can see the map in QGIS project as a georeferenced raster. Note that the raster seems to be
slightly rotated, but that is simply because the data is KKJ / Finland zone 2 and your project is in
ETRS89 / ETRS-TM35FIN.

To check that your data is properly georeferenced you can open the aerial image in the
exercise_dataforestry folder, named rautjarvi_aerial.tif. Your map and this image should match
quite well. Set the map transparency to 50% and compare it to the aerial image.
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Save the changes to your QGIS project, you will continue from this point for the next lesson.

14.2.3 In Conclusion

As you have seen, georeferencing a paper map is a relatively straight forward operation.

14.2.4 What’s Next?

In the next lesson, you will digitize the forest stands in your map as polygons and add the inventory
data to them
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14.3 Lesson: Digitizing Forest Stands

Unless you are going to use your georeferenced map as a simple background image, the next natural step
is to digitize elements from it. You have already done so in the exercises about creating vector data in
..create_vector_data/create_new_vector , when you digitized the school fields. In this lesson, you
are going to digitize the forest stands’ borders that appear in the map as green lines but instead of doing
it using an aerial image, you will use your georeferenced map.

The goal for this lesson: Learn a technique to help the digitizing task, digitizing forest stands and
finally adding the inventory data to them.

14.3.1 Follow Along: Extracting the Forest Stands Borders

Open your map_digitizing.qgs project in QGIS, that you saved from the previous lesson.

Once you have scanned and georeferenced your map you could start to digitize directly by looking at the
image as a guide. That would most likely be the way to go if the image you are going to digitize from
is, for example, an aerial photograph.

If what you are using to digitize is a good map, as it is in our case, it is likely that the information is
clearly displayed as lines with different colors for each type of element. Those colors can be relatively
easy extracted as individual images using an image processing software like GIMP. Such separate images
can be used to assist the digitizing, as you will see below.

The first step will be to use GIMP to obtain an image that contains only the forest stands, that is, all
those greenish lines that you could see in the original scanned map:

• Open GIMP (if you don’t have it installed yet, download it from the internet or ask your teacher).

• Open the original map image, File → Open, rautjarvi_map.tif in the exercise_data/forestry
folder. Note that the forest stands are represented as green lines (with the number of the stand
also in green inside each polygon).
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Now you can select the pixels in the image that are making up the forest stands’ borders(the greenish
pixels):

• Open the tool Select → By color.

• With the tool active, zoom into the image (Ctrl + mouse wheel) so that a forest stand line is close
enough to differentiate the pixels forming the line. See the left image below.

• Click and drag the mouse cursor in the middle of the line so that the tool will collect several pixel
color values.

• Release the mouse click and wait a few seconds. The pixels matching the colors collected by the
tool will be selected through the whole image.

• Zoom out to see how the greenish pixels have been selected throughout the image.

• If you are not happy with the result, repeat the click and drag operation.

• You pixel selection should look something like the right image below.
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Once you are done with the selection you need to copy this selection as a new layer and then save it as
separate image file:

• Copy (Ctr+C) the selected pixels.

• And paste the pixels directly (Ctr+V ), GIMP will display the pasted pixels as a new temporary
layer in the Layers - Brushes panel as a Floating Selection (Pasted Layer).

• Right click that temporary layer and select To New Layer.

• Click the “eye” icon next to the original image layer to switch it off, so that only the Pasted Layer
is visible:
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• Finally, select File → Export..., set Select File Type (By Extension) as a TIFF image, select the
digitizing folder and name it rautjarvi_map_green.tif. Select no compression when asked.

You could do the same process with other elements in the image, for example extracting the black lines
that represent roads or the brown ones that represent the terrain’ contour lines. But for us, the forest
stands is enough.

14.3.2 Try Yourself Georeference the Green Pixels Image

As you did in the previous lesson, you need to georeference this new image to be able to use it with the
rest of your data.

Note that you don’t need to digitize the ground control points any more because this image is basically
the same image as the original map image, as far as the Georeferencer tool is concerned. Here are some
things you should remember:

• This image is also, of course, in KKJ / Finland zone 2 CRS.

• You should use the ground control points you saved, File → Load GCP points.

• Temember to review the Transformation settings.

• Name the output raster as rautjarvi_green_georef.tif in the digitizing folder.

Check that the new raster is fitting nicely with the original map.

14.3.3 Follow Along: Creating Supporting Points for Digitizing

Having in mind the digitizing tools in QGIS, you might already be thinking that it would be helpful to
snap to those green pixels while digitizing. That is precisely what you are going to do next create points
from those pixels to use them later to help you follow the the forest stands’ borders when digitizing, by
using the snapping tools available in QGIS.
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• Use the Raster → Conversion → Polygonize (Raster to Vector) tool to vectorize your green lines
to polygons. If you don’t remember how, you can review it in Lesson: 래스터 - 벡터 변환.

• Save as rautjarvi_green_polygon.shp inside the digitizing folder.

Zoom in and see what the polygons look like. You will get something like this:

Next one option to get points out of those polygons is to get their centroids:

• Open Vector → Geometry tools → Polygon centroids.

• Set your the polygon layer you just got as the input file for the tool.

• Name the output as green_centroids.shp inside the digitizing folder.

• Check Add result to canvas.

• Run the tool to calculate the centroids for the polygons.
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Now you can remove the rautjarvi_green_polygon layer from the TOC.

Change the symbology of the centroids layer as:

• Open the Layer Properties for green_centroids.

• Go to the Style tab.

• Set the Unit to Map unit.

• Set the Size to 1.

It is not necessary to differentiate points from each other, you just need them to be there for the snapping
tools to use them. You can use those points now to follow the original lines much easily than without
them.

14.3.4 Follow Along: Digitize the Forest Stands

Now you are ready to start with the actual digitizing work. You would start by creating a vector file of
polygon type, but for this exercise, there is a shapefile with part of the area of interest already digitized.
You will just finish digitizing the half of the forest stands that are left between the main roads (wide
pink lines) and the lake:
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• Go to the digitizing folder using your file manager browser.

• Drag and drop the forest_stands.shp vector file to your map.

Change the new layer’s symbology so that it will be easier to see what polygons have already been
digitized:

• The filling of the polygon to green.

• The polygons’ borders to 1 mm.

• and set the transparency to 50%.

Now, if you remember past modules, we have to set up and activate the snapping options:
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• Go to Settings → Snapping options....

• Activate the snapping the green_centroids and the forest_stands layers.

• Set their Tolerance to 5 map units.

• Check the Avoid Int. box for the forest_stands layer.

• Check Enable topological editing.

• Click Apply.

With these snapping settings, whenever you are digitizing and get close enough to one of the points in
the centroids layer or any vertex of your digitized polygons, a pink cross will appear on the point that
will be snapped to.

Finally, turn off the visibility of all the layers except forest_stands and rautjarvi_georef. Make sure
that the map image has not transparency any more.

A couple of important things to note before you start digitizing:

• Don’t try to be too accurate with the digitizing of the borders.

• If a border is a straight line, digitize it with just two nodes. In general, digitize using as few nodes
as possible.

• Zoom in to close ranges only if you feel that you need to be accurate, for example, at some corners
or when you want a polygon to connect with another polygon at a certain node.

• Use the mouse’s middle button to zoom in/out and to pan as you digitize.

• Digitize only one polygon at a time.

• After digitizing one polygon, write the forest stand id that you can see from the map.

Now you can start digitizing:

• Locate the forest stand number 357 in the map window.

• Enable editing for the forest_stands.shp layer.

• Select the Add feature tool.

• Start digitizing the stand 357 by connecting some of the dots.

• Note the pink crosses indicating the snapping.
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• When you are done, right click to end digitizing that polygon.

• Enter the forest stand id (in this case 357).

• Click OK.

If you were not prompted for the polygon id when you finished digitizing it, go to Settings → Options →
Digitizing and make sure that the Suppress attribute form pop-up after feature creation is not checked.

Your digitized polygon will look like this:
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Now for the second polygon, pick up the stand number 358. Make sure that the Avoid int. is checked for
the forest_stands layer. This option does not allow intersecting polygons at digitizing, so that if you
digitize over an existing polygon, the new polygon will be trimmed to meet the border of the already
existing polygon/s. You can use this characteristic to automatically obtain a common border.

• Begin digitizing the stand 358 at one of the common corners with the stand 357.

• Then continue normally until you get to the other common corner for both stands.

• Finally, digitize a few points inside polygon 358 making sure that the common border is not
intersected. See left image below.

• Right click to finish editing the forest stand 358.

• Enter the id as 358.

• Click OK, your new polygon should show a common border with the stand 357 as you can seen in
the image on the right.
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The part of the polygon that was overlapping the existing polygon has been automatically trimmed out
and you are left with a common border, as you intended it to be.

14.3.5 Try Yourself Finish Digitizing the Forest Stands

Now you have two forest stands ready. And a good idea on how to proceed. Continue digitizing on your
own until you have digitized all the forest stands that are limited by the main road and the lake.

It might look like a lot of work, but you will soon get used to digitizing the forest stands. It should take
you about 15 minutes.

During the digitizing you might need to edit or delete nodes, split or merge polygons. You learned about
the necessary tools in ..create_vector_data/topo_editing, now is probably a good moment to go
read about them again.

Remember that having Enable topological editing activated, allows you to move nodes common to two
polygons so that the common border is edited at the same time for both polygons.

Your result will look like this:
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14.3.6 Follow Along: Joining the Forest Stand Data

It is possible that the forest inventory data you have for you map is also written in paper. In that case,
you would have to first write that data to a text file or a spreadsheet. For this exercise, the information
from the inventory for 1994 (the same inventory as the map) is ready as a comma separated text (csv)
file.

Open the rautjarvi_1994.csv file from the exercise_data\forestry in a text editor and note that
the inventory data file has an attribute called ID that has the numbers of the forest stands. Those
numbers are the same as the forest stands ids you have entered for your polygons and can be used to
link the data from the text file to your vector file. You can see the metadata for this inventory data in
the file rautjarvi_1994_legend.txt in the same folder.

• Open the .csv in QGIS with the Layer → Add Delimited Text Layer... tool. In the dialog, set it
as follows:
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To add the data from the .csv file:

• Open the Layer Properties for the forest_stands layer.

• Go to the Joins tab.

• Click the plus sign on the bottom of the dialog box.

• Select rautjarvi_1994.csv as the Join layer and ID as the Join field.

• Make sure that the Target field is also set to id.

• Click OK two times.

The data from the text file should be now linked to your vector file. To see what has happened, open
the attribute table for the forest_stands layer. You can see that all the attributes from the inventory
data file are now linked to your digitized vector layer.

14.3.7 Try Yourself Renaming Attribute Names and Adding Area and Perime-
ter

The data from the .csv file is just linked to your vector file. To make this link permanent, so that the
data is actually recorded to the vector file you need to save the forest_stands layer as a new vector file.
Close the attribute table and right click the forest_stands layer to save it as forest_stands_1994.shp.

Open your new forest_stands_1994.shp in your map if you did not added yet. Then open the attribute
table. You notice that the names of the columns that you just added are no very useful. To solve this:

• Add the plugin Table Manager as you have done with other plugins before.
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• Make sure the plugin is activated.

• In the TOC select the layer forest_stands_1994.shp.

• Then, go to Vector → Table Manger → Table manager.

• Use the dialogue box to edit the names of the columns to match the ones in the .csv file.

• Click on Save.

• Select Yes to keep the layer style.

• Close the Table Manager dialogue.

To finish gathering the information related to these forest stands, you might calculate the area and the
perimeter of the stands. You calculated areas for polygons in Lesson: 보충 예제. Go back to that lesson
if you need to and calculate the areas for the forest stands, name the new attribute Area and make sure
that the values calculated are in hectares.

Now your forest_stands_1994.shp layer is ready and packed with all the available information.

Save your project to keep the current map presentation in case you need to come back later to it.
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14.3.8 In Conclusion

It has taken a few clicks of the mouse but you now have your old inventory data in digital format and
ready for use in QGIS.

14.3.9 What’s Next?

You could start doing different analysis with your brand new dataset, but you might be more interested
in performing analysis in a dataset more up to date. The topic of the next lesson will be the creation of
forest stands using current aerial photos and the addition of some relevant information to your dataset.

14.4 Lesson: Updating Forest Stands

Now that you have digitized the information from the old inventory maps and added the corresponding
information to the forest stands, the next step would be to create the inventory of the current state of
the forest.

You will digitize new forest stands from scratch following an aerial photo from that forest area. The
forestry map you digitized in the previous lesson was created from an aerial Color Infrared (CIR) pho-
tograph. This type of imagery, where the infrared light is recorded instead of the blue light, are widely
used to study vegetated areas. You will also use a CIR photograph in this lesson.

After digitizing the forest stands, you will add information such as new constraints given by conservation
regulations.

The goal for this lesson: To digitize a new set of forest stands from CIR aerial photographs and add
information from other data-sets.

14.4.1 Comparing the Old Forest Stands to Current Aerial Photographs

The National Land Survey of Finland has an open data policy that allows you downloading a variety of
geographical data like aerial imagery, traditional topographic maps, DEM, LiDAR data, etc. The service
can be accessed also in English here. The aerial image used in this exercise has been created from two
orthorectified CIR images downloaded from that service (M4134F_21062012 and M4143E_21062012).

• Open QGIS and set the project’s CRS to ETRS89 / ETRS-TM35FIN in Project → Project Properties
→ CRS.

• Make sure that Enable ‘on the fly’ CRS transformation is checked.

• From the exercise_data\forestry\ folder, add the CIR image rautjarvi_aerial.tif and con-
taining the digitized lakes.

• Then save the QGIS project as digitizing_2012.qgs.

The CIR images are from 2012. You can compare the stands that were created in 1994 with the situation
almost 20 years ago.

• Add your forest_stands_1994.shp layer.

• Set its styling so that you can see through your polygons.

• Review how the old forest stands follow (or not) what you might visually interpret as an homoge-
neous forest.

Zoom and pan around the area. You probably will notice that some of the old forest stands might be
still corresponding with the image but others are not.

This is a normal situation, as some 20 years have passed by and different forest operations have been
done (harvesting, thinning...). It is also possible that the forest stands looked homogeneous back in 1992
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to the person who digitized them but as time has passed some forest has developed in different ways. Or
simply the priorities for the forest inventory were different that they are today.

Next, you will create new forest stands for this image without using the old ones. Later you can compare
them to see the differences.

14.4.2 Interpreting the CIR Image

Let’s digitize the same area that was covered by the old inventory, limited by the roads and the lake.
You don’t have to digitize the whole area, as in the previous exercise you can start with a vector file that
already contains most of the forest stands.

• Remove the forest_stands_1994.shp layer.

• Add the forest_stands_2012.shp layer, located in the exercise_data\forestry\ folder.

• Set the styling of this layer so that the polygons have no fill and the borders are visible.
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You can see that a region to the North of the inventory area is still missing. That will be your task,
digitizing the missing forest stands.

But before you start, spend some time reviewing the forest stands already digitized and the corresponding
forest in the image. Try to get an idea about how the stands borders are decided, it helps if you have
some forestry knowledge.

Some ideas about what you could identify from the images:

• What forests are deciduous species (in Finland mostly birch forests) and which ones are conifers
(in this region pine or spruce). In CIR images, deciduous species will often come as bright red color
whereas conifers present dark green colors.

• When a forest stand age changes, by looking at the sizes of the tree crowns that can be identified
in the imagery.

• The different forest stands’ densities, for example forest stand were a thinning operation has recently
been done would clearly show spaces between the tree crowns and should be easy to differentiate
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from other forest stands around it.

• Blueish areas indicate barren terrain, roads and urban areas, crops that have not started to grow
etc.

• Don’t use zooms too close to the image when trying to identify forest stands a scale between 1:3
000 and 1: 5 000 should be enough for this imagery. See the image below (1 : 4 000 scale):

14.4.3 Try Yourself Digitizing Forest Stands from CIR Imagery

When digitizing the forest stands, you should try to get forest areas that are as homogeneous as possible
in terms of tree species, forest age, stand density... Don’t be too detailed though, or you will end up
making hundreds of small forest stands that would not be useful at all. You should try to get stands
that are meaningful in the context of forestry, not too small (at least 0.5 ha) but not too big either (no
more than 3 ha).

With this indications in mind, you can now digitize the missing forest stands.

• Enable editing for forest_stands_2012.shp.

• Set up the snapping and topology options as in the image.

• Remember to click Apply or OK.
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Start digitizing as you did in the previous lesson, with the only difference that you don’t have any
point layer that you are snapping to. For this area you should get around 14 new forest stands. While
digitizing, fill in the Stand_id field with numbers starting at 901.

When you are finished your layer should look something like:

Now you have a new set of polygons defining the different forest stands for the current situation as can
interpreted from the CIR images. But you are obviously still missing the forest inventory data, right?
For that you will still need to visit the forest and get some sample data that you will use to estimate the
forest attributes for each of the forest stands. You will see how to do that in the next lesson.

336 Chapter 14. 모듈: 산림관리 응용



QGIS Training Manual, 출시 2.2

For the moment, you still can improve your vector layer with some extra information that you have
about conservation regulation that should be taken into account for this area.

14.4.4 Follow Along: Updating Forest Stands with Conservation Information

For the area you are working with, it has been researched that the following conservation regulations
must be taken into account while doing the forest planning:

• Two locations of a protected species of Siberian flying squirrel (Pteromys volans) have been iden-
tified. According to the regulation, an area of 15 meters around the spots must be left untouched.

• A riparian forest of special interest growing along a stream in the area must be protected. In a
visit to the field, it was found that 20 meters to both sides of the stream must be protected.

You have one vector file containing the information about the squirrel locations and another containing
the digitized stream running in the North area towards the lake. From the exercise_data\forestry\
folder, add the vector files squirrel.shp and stream.shp.

For the protection of the squirrels locations, you are going to add a new attribute (column) to your
new forest stands that will contain information about point locations that have to be protected. That
information will later be available whenever a forest operation is planned, and the field team will be able
to mark the area that has to be left untouched before the work starts.

• Open the attribute table for the squirrel layer.

• You can see that there are two locations that are defined as Siberian flying squirrel, and that the
area to be protected is indicated by a distance of 15 meters from the locations.

To join the information about the squirrels to your forest stands, you can use the Join attributes by
location:

• Open menu:Vector –> Data Management Tools –> Join attributes by location.

• Set the forest_stands_2012.shp layer as the gui:Target vector layer.

• As gui:Join vector layer select the squirrel.shp point layer.

• Name the output file as stands_squirrel.shp.

• In gui:Output table select gui:Keep all records (including non-matching target records). So that you
keep all the forest stands in the layer instead of only keeping those that are spatially related to the
squirrel locations.

• Click gui:OK.

• Select Yes when prompted to add the layer to the TOC.

• Close the dialogue box.
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Now you have a new forest stands layer, stands_squirrel where there are new attributes corresponding
to the protection information related to the Siberian flying squirrel.

Open the table of the new layer and order it so that the forest stands with information for the Protection
attribute. You should have now two forest stands where the squirrel has been located:

338 Chapter 14. 모듈: 산림관리 응용



QGIS Training Manual, 출시 2.2

Although this information might be enough, look at what areas related to the squirrels should be pro-
tected. You know that you have to leave a buffer of 15 meters around the squirrels location:

• Open Vector → Geoprocessing Tools → Buffer.

• Make a buffer of 15 meters for the squirrel layer.

• Name the result squirrel_15m.shp.

14.4. Lesson: Updating Forest Stands 339



QGIS Training Manual, 출시 2.2

You will notice that if you zoom in to the location in the Northern part of the area, the buffer area
extends to the neighbouring stand as well. This means that whenever a forest operation would take
place in that stand, the protected location should also be taken into account.

340 Chapter 14. 모듈: 산림관리 응용



QGIS Training Manual, 출시 2.2

From your previous analysis, you did not get that stand to register information about the protection
status. To solve this problem:

• Run the Join attributes by location tool again.

• But this time use the squirrel_15m layer as join layer.

• Name the output file as stands_squirrel_15m.shp.
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Open the attribute table for the this new layer and note that now you have three forest stands that have
the information about the protection locations. The information in the forest stands data will indicate
to the forest manager that there are protection considerations to be taken into account. Then he or she
can get the location from the squirrel dataset, and visit the area to mark the corresponding buffer
around the location so that the operators in the field can avoid disturbing the squirrels environment.

14.4.5 Try Yourself Updating Forest Stands with Distance to the Stream

Following the same approach as indicated for the protected squirrel locations you can now update your
forest stands with protection information related to the stream identified in the field:

• Remember that the buffer in this case is 20 meters around it.
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• You want to have all the protection information in the same vector file, so use the
stands_squirrel_15m layer as the target.

• Name your output as forest_stands_2012_protect.shp.

Open the attributes table for the new vector layer and confirm that you now have all the protection
information for the stands that are affected by the protection measures to protect the riparian forest
associated with the stream.

Save your QGIS project.

14.4.6 In Conclusion

You have seen how to interpret CIR images to digitize forest stands. Of course it would take some
practice to make more accurate stands and usually using other information like soil maps would give
better results, but you know now the basis for this type of task. And adding information from other
datasets resulted to be quite a trivial task.

14.4.7 What’s Next?

The forest stands you digitized will be used for planning forestry operations in the future, but you still
need to get more information about the forest. In the next lesson, you will see how to plan a set of
sampling plots to inventory the forest area you just digitized, and get the overall estimate of forest
parameters.

14.5 Lesson:: 체계적인 표본 설계

You have already digitized a set of polygons that represent the forest stands, but you don’t have infor-
mation about the forest just yet. For that purpose you can design a survey to inventory the whole forest
area and then estimate its parameters. In this lesson you will create a systematic set of sampling plots.

산림의 목록화를 시작했을때 가장 중요한 것은 목적, 사용될 표본 조사구의 유형 그리고 목적을 달성하기
위해 수집될 자료를 명확히 정의하는 것입니다. 각각의 사례에서 이러한 것들은 산림의 유형과 관리목적에
달려있습니다. 그리고 산림관리의 지식을 가진 전문가에 의해 계획되어져야 합니다. 여기서 여러분들은
체계적인 표본 조사구설계에 기초한 이론적인 목록화를 시행하게 될 것입니다.

산림지역을 조사하기 위한 체계적인 표본 조사구 설계하기.

14.5.1 산림의 목록화

산림을 목록화 하기 위해서는 여러방법들이 있습니다. 각각의 방법은 각기 다른 목적과 상태에 적합합니다.
예를들면, 산림을 아주 정확하게 목록화 (여러분이 만일 나무수종만을 고려한다면) 산림에 직접 들어가서
모든 나무 수종과 그 특성을 목록화 해야할 것입니다. 여러분들이 생각한대로 이것은 면적이 작은 지역이나
특별한 상황을 제외하면 일반적으로 적용할 방법은 아닙니다.

산림의정보를알아내는가장일반적인방법은산림곳곳에서측정을하고전체산림으로정보를일반화하는
것입니다. 이러한 방법은 종종 “표본 조사구” 에서 이뤄지며, 표본조사구는 손쉽게 측정할 수 있는 작은
산림으로 이해하면 됩니다. 표본 조사구는 크기 (예를들면, 50m2, 0.5ha 등) 와 다양한 형태 (예를 들면,
원형, 다각형, 변형 크기 등) 가 될 수 있고, 산림 곳곳에 위치 (임의적, 체계적, 선형 등) 할 수 있습니다.
표본 조사구의 크기, 형태 그리고 위치는 일반적으로 통계적, 경제적 그리고 실제적인 것을 고려하여
결정됩니다. 만약 여러분들이 산림관리에 대한 지식이 없다면 다음의 위키피디아 내용을 읽어보시기
바랍니다.<http://en.wikipedia.org/wiki/Forest_inventory>
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14.5.2 체계적인 표본 조사구 설계 실행

여러분들이작업할산림에서관리자는체계적인표본설계가이산림에적절한지를결정해왔고,표본조사구
간에 80m 의 거리와 표본 라인이 적절한 결과 (이 경우 68% 의 확률에서 표준오차가 +,- 5%) 를 만들어 낼
것이지를결정해왔습니다. 다양한크기의조사구가목록,생장및성숙임분을위해 -단, 4m반경의조사구는
묘목임분에 적용 - 가장 효과적인 방법으로 결정이 되어 왔습니다.

실습에서 여러분들은 단순히 표본조사구를 점으로 표현하면 되는데, 이 점은 나중에 현장조사팀이 사용할
것입니다.

• 전 레슨에서 사용했던 kbd:‘digitizing_2012.qgs‘를 열어주십시오.

• ‘forest_stands_2012‘를 제외한 모든 레이어를 제거합니다.

• 프로젝트를 ‘forest_inventory.qgs‘라는 이름으로 저장합니다.

지금부터 점간 거리가 80m 간격을 갖는 사각형 점 그리드를 만듭니다.

• 열기: 메뉴 ‘벡터 –> 조사도구 –> 규칙적 점군’

• ‘영역’ 정의에서 ‘입력 경계 레이어’ 선택

• 입력 레이어로 forest_stands_2012 선택

• ‘격자 간격’ 에서 ‘사용할 점 간격 ‘선택 후 ‘80’ 입력

• forestry\sampling\ 폴더에서 ‘systematic_plots.shp‘로 출력 shape 파일 저장

• ‘결과를 캔버스에 추가’ 체크

• ‘확인’ 클릭

주석: ‘규칙적 점군’ 은 체계적인 점들을 선택된 폴리곤의 왼쪽 위 모서리부터 만듭니다. 만약 이 ‘규칙적
점군’ 에 임의의 수를 부여하고 싶으면, 0 부터 80 까지 (80 은 점간의 거리) 의 임의의 계산숫자를 사용할
수 있습니다. 그리고 그것을 ‘Initial inset from corner (LH side)‘매개변수라고 다이얼로그 툴에서 쓸 수
있습니다.

주목할 것은 사각형 그리드 점을 만드는데 툴이 전체 범위의 임분레이어를 사용했다는 것입니다. 그러나
여러분들은 단지 산림지역내 만들어진 점들에만 관심을 가지면 됩니다.(아래 이미지를 보시기 바랍니다. )
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• 열기: 메뉴: ‘벡터 –> 공간 연산 도구 –> 클립’

• ‘입력 벡터 레이어’ 로 ‘systematic_plots‘선택

• ‘레이러 클리핑’ 으로 ‘forest_stands_2012‘설정

• ‘systematic_plots_clip.shp‘로 ‘출력 shape 파일’ 저장

• ‘결과를 캔버스에 추가’ 체크

• ‘확인’ 클릭

이제 여러분이 만든 점들은 현장조사팀이 표본조사구의 위치가 지정된 곳을 찾아가는데 사용될 것입니다.
여러분은 이러한 점들을 준비할 수 있고 현장에서 매우 유용합니다. 최소한 여러분들은 점에 의미있는
명칭을 부여할 수 있고, 그들의 GPS 기기에서 사용할 수 있는 형식으로 내보기를 할 수 있습니다.

표본 조사구들에 명칭을 부여해 봅시다. 만약 산림 지역내 조사구 ‘속성 테이블’ 을 확인한다면, ‘규칙적
점군’ 툴에 의해 자동적으로 만들어진 ‘id’ 필드를 볼 수 있을 것입니다. 지도상에서 볼 수 있도록 점들의
라벨을 나타내고 표본조사구의 명칭으로써 번호들이 부여되었는지 확인합니다.

• ‘systematic_plots_clip‘의 오른쪽 마우스 클릭 ‘속성 –> 라벨’ 열기

• ‘이 레이어의 라벨 ‘을 체크하고, ‘ID‘필드를 선택.

• Go to the Buffer options and check the :guilabel:‘‘Draw text buffer‘, set the Size to 1.

• ‘확인’ 클릭

이제의 지도 라벨을 확인합니다. 처음 서쪽에서 동쪽으로 그리고 북쪽에서 남쪽으로 점들이 만들어졌고
번호가 부여된 것을 볼 수 있습니다. 다시 속성테이블을 보면 테이블의 순서가 패턴을 따르고 있음을
주지하게됩니다. 다른 방법으로 표본 조사구에 이름을 부여할 이유가 없다면 서쪽 -동쪽/북쪽 -남쪽의
경향으로 이름을 붙이는 것은 논리적이며 좋은 옵션이되겠습니다.

..note:: If you would like to order or name them in a different way, you could use a spreadsheet to be
able to order and combine rows and columns in any different way.
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그럼에도 불구하고 ‘id’ 필드의 숫자값이 맘에 들지 않으면 ‘p_1, p_2...’ 와 같이 명칭을 부여하는 것도
고려해볼 만합니다. ‘systematic_plots_clip‘레이어에 새로운 열을 만들 수 있습니다.

• ‘systematic_plots_clip‘레이어의 ‘속성 테이블’ 로 이동.

• ‘편집모드 전환’ 활성화.

• Open the Field calculator and name the new column :kbd:‘Plot_id?.

• ‘출력 필드 유형’ 에 ‘텍스트 (string)’ 설정

• ‘표현식’ 필드에 concat(‘P_’, $rownum )‘라고 식을 쓰거나 복사하거나 연산자를 이용해서 만들어
냅니다. 기억할 것은 ‘함수 목록’ 에서 필요요소를 더블클릭 할 수도 있습니다. ‘concat’ 함수는
‘String’ 아래’ 에서 그리고 ‘$rownum 매개변수는 ‘Record’ 아래쪽에서 찾을 수 있습니다.

• ‘확인’ 클릭

• 편집모드 활성화를 해제하고 변동사항을 저장

이제부터 의미있는 조사구 명칭을 가진 새로운 열이 생겼습니다. ‘systematic_plots_clip‘레이어에서
라벨링을 위한 사용했던 필드를 새로운 ‘Plot_id’ 필드로 변경합니다.
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14.5.3 Follow Along: 표본 조사구를 GPX 포맷으로 내보냅니다.

현장조사팀은 아마도 GPS 기기를 이용해서 계획된 표본 조사구를 설정할 것입니다. 다음 단계는
만든 점들을 GPS 기기에서 읽을 수 있는 포맷으로 내보냅니다. QGIS 는 ‘GPS eXchange Format
(GPX)<http://en.wikipedia.org/wiki/GPS_Exchange_Format>‘라는표준 GPS데이터형식으로특화된
소프트웨어로 읽어낼 수 있는 있는데, 이러한 형식으로 점과 선의 벡터데이터를 저장할 수 있습니다.
데이터를 저장할 때 CRS 세팅에 주의할 필요가 있습니다.

• 마우스 오른쪽 버트을 이용해서 ‘systematic_plots_clip‘레이어를 클릭하고 ‘다른 이름으로 저장 ‘을
선택
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• ‘형식’ 에서 GPS eXchange Format [GPX] 선택

• ‘plots_wgs84.gpx‘로 새 이름으로 저장

• ‘CRS’ 에서 ‘Selected CRS‘선택

• Browse for as WGS 84 (EPSG:4326).

노트: ‘GPX’ 형식은 이 CRS 만 가능합니다 만약 다른 것을 선택하면 QGiS 는 에러메세지를 내보지는
않지만 빈 파일을 얻게됩니다.

• ‘확인’ 클릭

• 다이알로그가 열리면 ‘waypoints‘레이어만 선택 (다른 레이어는 비었음)

표본조사구목록은이제표준형식으로대부분의GPS소프트웨어로관리될수있습니다. 현장조사팀은이제
그들의기기에표본조사구의위치를업로드할수있습니다. 이는기기에서사용하는소프트웨어를사용하여
수행되고, ‘plots_wgs84.gpx‘파일이 저장됩니다. 다른 옵션은 ‘GPS Tools‘플러그인을 사용하면 되나,
특별한 GPS 기기로 자겁하는 툴의 세팅도 대부분 포함될 것입니다. 만약 자신만의 데이터를 작업을 한다면
그리고툴이어떻게작동하는지보고싶다면,그것에관한정보는 ‘GIS사용자매뉴얼’의 ‘Working with GPS
Data <http://docs.qgis.org/2.2/en/docs/user_manual/working_with_gps/index.html>‘편에서 찾으면
됩니다.

이제 QGiS 프로젝트 저장.
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14.5.4 In Conclusion

좀 전에 산림목록에서 사용되는 체계적인 표본 설계를 얼마나 쉽게 만들 수 있는 확인했습니다. 다른
형식의 표본 설계를 만드는 것은 일반적인 아이디가 같다는 것을 제외하면 표본 조사구의 좌표를 계산하는
스프레트쉬트 혹은 스크립트 등 QGIS 내의 다른 툴을 사용하는 것을 포함합니다.

14.5.5 What’s Next?

다음 레슨에서는 현장조사팀이 상세지도의 표본조사구를 찾는데 사용될 상세한 지도가 자동적으로 만들어
지기 위해 QGIS 의 아틀라스 능력이 어떻게 사용되지는 보게 될 것입니다.

14.6 Lesson: Creating Detailed Maps with the Atlas Tool

The systematic sampling design is ready and the field teams have loaded the GPS coordinates in their
navigation devices. They also have a field data form where they will collect the information measured
at every sample plot. To easier find their way to every sample plot, they have requested a number of
detail maps where some ground information can be clearly seen along with a smaller subset of sample
plots and some information about the map area. You can use the Atlas tool to automatically generate
a number of maps with a common format.

The goal for this lesson: Learn to use the Atlas tool in QGIS to generate detailed printable maps to
assist in the field inventory work.

14.6.1 Follow Along: Preparing the Map Composer

Before we can automate the detailed maps of the forest area and our sampling plots, we need to create a
map template with all the elements we consider useful for the field work. Of course the most important
will be a properly styled but, as you have seen before, you will also need to add lots of other elements
that complete the printed map.

Open the QGIS project from the previous lesson forest_inventory.qgs. You should have at least the
following layers:

• forest_stands_2012 (with a 50% transparency, green fill and darker green border lines).

• systematic_plots_clip.

• rautjarvi_aerial.

Save the project with a new name, map_creation.qgs.

To create a printable map, remember that you use the Composer Manager:

• Open Project → Composer Manager....

• In the Composer manager dialog.

• Click the Add button and name your composer forest_map.

• Click OK.

• Click the Show button.

Set up the printer options so that your maps will suit your paper and margins, for an A4 paper:

• Open menuselection:Composer –> Page Setup.

• Size is A4 (217 x 297 mm).

• Orientation is Landscape.

• Margins (milimeters) are all set to 5.
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In the Print Composer window, go to the Composition tab (on the right panel) and make sure that these
settings for Paper and quality are the same you defined for the printer:

• Size: A4 (210x297mm).

• Orientation: Landscape.

• Quality: 300dpi.

Composing a map is easier if you make use of the canvas grid to position the different elements. Review
the settings for the composer grid:

• In the Composition tab expand the Grid region.

• Check that Spacing is set to 10 mm.

• And that Tolerance is set to 2 mm.

You need to activate the use of the grid:

• Open the View menu.

• Check Show grid.

• Check Snap to grid.

• Notice that options for using guides are checked by default, which allows you to see red guiding
lines when you are moving elements in the composer.

Now you can start to add elements to your map canvas. Add first a map element so you can review how
it looks as you will be making changes in the layers symbology:

• Click on the Add New Map button: .

• Click and drag a box on the canvas so that the map occupies most of it.

Notice how the mouse cursor snaps to the canvas grid. Use this function when you add other elements.
If you want to have more accuracy, change the grid Spacing setting. If for some reason you don’t want
to snap to the grid at some point, you can always check or uncheck it in the View menu.
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14.6.2 Follow Along: Adding Background Map

Leave the composer open but go back to the map. Lets add some background data and create some
styling so that the map content is as clear as possible.

• Add the background raster basic_map.tif that you can find in the exercise_data\forestry\
folder.

• When prompted select the ETRS89 / ETRS-TM35FIN CRS for the raster.

As you can see the background map is already styled. This type of ready to use cartography raster is
very common. It is created from vector data, styled in a standard format and stored as a raster so that
you don’t have to bother styling several vector layers and worrying about getting a good result.

• Now zoom to your sample plots, so that you can see only about four or five lines of plots.

The current styling of the sample plots is not the best, but how does it look in the map composer?:

While during the last exercises, the white buffer was OK on top of the aerial image, now that the
background image is mostly white you barely can see the labels. You can also check how it looks like on
the composer:

• Go to the Print Composer window.

• Use the button to select the map element in the composer.

• Go to the Item properties tab.

• Under Extents click on Set to map canvas extent.

• If you need to refresh the element, under Main properties click on the Update preview.

Obviously this is not good enough, you want to make the plot numbers as clearly visible as possible for
the field teams.

14.6.3 Try Yourself Changing the Symbology of the Layers

You have been working in ../training_manual/basic_map/index with symbology and in Module: 벡터
데이터 범주화 with labeling. Go back to those modules if you need to refresh about some of the available
options and tools. Your goal is to get the plots locations and their name to be as clearly visible as
possible but always allowing to see the background map elements. You can take some guidance from
this image:
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You will use later the the green styling of the forest_stands_2012 layer. In order to keep it, and have
a visualization of it that shows only the stand borders:

• Right click on forest_stands_2012 and select Duplicate

• you get a new layer named forest_stands_2012 copy that you can use to define a different style,
for example with no filling and red borders.

Now you have two different visualizations of the forest stands and you can decide which one to display
for your detail map.

Go back to the Print composer window often to see what the map would look like. For the purposes of
creating detailed maps, you are looking for a symbology that looks good not at the scale of the whole
forest area (left image below) but at a closer scale (right image below). Remember to use Update preview
and Set to map canvas extent whenever you change the zoom in your map or the composer.
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14.6.4 Try Yourself Create a Basic Map Template

Once you have a symbology your happy with, you are ready to add some more information to your
printed map. Add at least the following elements:

• Title.

• A scale bar.

• Grid frame for your map.

• Coordinates on the sides of the grid.

You have created a similar composition already in Module: 맵 생성. Go back to that module as you
need. You can look at this example image for reference:

Export your map as an image and look at it.

• Composer → Export as Image.

• Use for example the JPG format.

That is what it will look like when printed.

14.6.5 Follow Along: Adding More Elements to the Composer

As you probably noticed in the suggested map template images, there are plenty of room on the right
side of the canvas. Lets see what else could go in there. For the purposes of our map, a legend is not
really necessary, but an overview map and some text boxes could add value to the map.

The overview map will help the field teams place the detail map inside the general forest area:

• Add another map element to the canvas, right under the title text.

• In the Item properties tab, open the Overview dropdown.
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• Set the Overview frame to Map 0. This creates a shadowed rectangle over the smaller map repre-
senting the extent visible in the bigger map.

• Check also the Frame option with a black color and a Thickness of 0.30.

Notice that your overview map is not really giving an overview of the forest area which is what you want.
You want this map to represent the whole forest area and you want it to show only the background map
and the forest_stands_2012 layer, and not display the sample plots. And also you want to lock its
view so it does not change anymore whenever you change the visibility or order of the layers.

• Go back to the map, but don’t close the Print composer.

• Right click the forest_stands_2012 layer and click on Zoom to Layer Extent.

• Deactivate all layers except for basic_map and forest_stands_2012.

• Go back to the Print composer.

• With the small map selected, click the Set to map canvas extent to set its extents to what you can
see in the map window.

• Lock the view for the overview map by checking Lock layers for map item under Main properties.

Now your overview map is more what you expected and its view will not change anymore. But, of course,
now your detail map is not showing anymore the stand borders nor the sample plots. Lets fix that:

• Go to the map window again and select the layers you want to be visible (systematic_plots_clip,
forest_stands_2012 copy and Basic_map).

• Zoom again to have only a few lines of sample plots visible.

• Go back to the Print composer window.

• Select the bigger map in your composer ( ).

• In Item properties click on Update preview and Set to map canvas extent.
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Notice that only the bigger map is displaying the current map view, and the small overview map is
keeping the same view you had when you locked it.

Note also that the overview is showing a shaded frame for the extent shown in the detail map.

Your template map is almost ready. Add now two text boxes below the map, one containing the text
‘Detailed map zone: ‘ and the other one ‘Remarks: ‘. Place them as you can see in the image above.

You can also add a North arrow to the overview map:

• Use the Add image tool, .

• Click at the upper right corner of the overview map.

• In Item properties open Search directories and browse for an arrow image.

• Under Image rotation, check the Sync with map and select Map 1 (the overview map).

• Uncheck Background.

• Resize the arrow image to a size that looks good on the small map.

The basic map composer is ready, now you want to make use of the Atlas tool to generate as many detail
maps in this format as you consider necessary.

14.6.6 Follow Along: Creating an Atlas Coverage

The Atlas coverage is just a vector layer that will be used to generate the detail maps, one map for every
feature in the coverage. To get an idea of what you will do in the next , here is a full set of detail maps
for the forest area:
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The coverage could be any existing layer, but usually it makes more sense to create one for the specific
purpose. Let’s create a grid of polygons covering the forest area:

• In the QGIS map view, open Vector → Research Tools → Vector grid.

• Set the tool as shown in this image:
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• Save the output as atlas_coverage.shp.

• Style the new atlas_coverage layer so that the polygons have no filling.

The new polygons are covering the whole forest area and you have already an they give you an idea of
what each map (created from each polygon) will contain.
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14.6.7 Follow Along: Setting Up the Atlas Tool

The last step is to set up the Atlas tool:

• Go back to the Print Composer.

• In the panel on the right, go to the Atlas generation tab.

• Set the options as follows:
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That tells the Atlas tool to use the features (polygons) inside atlas_coverage as the focus for every
detail map. It will output one map for every feature in the layer. The Hidden coverage layer tells the
Atlas to not show the polygons in the output maps.

One more thing needs to be done. You need to tell the Atlas tool what map element is going to be
updated for every output map. By now, you probably can guess that the map to be changed for every
feature is the one you have prepared to contain detail views of the sample plots, that is the bigger map
element in your canvas:

• Select the bigger map element.

• Go to the Item properties tab.

• In the list, check Controlled by atlas.

• And set the Marging around feature to 10%. The view extent will be 10% bigger than the polygons,
which means that your detail maps will have a 10% overlap.
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Now you can use the preview tool for Atlas maps to review what your maps will look like:

• Activate the Atlas previews using the button or if your Atlas toolbar is not visible, via Atlas
→ Preview Atlas.

• You can use the arrows in the Atlas tool bar or in the Atlas menu to move through maps that will
be created.

Note that some of them cover areas that are not interesting. Lets do something about it and save some
trees by not printing those useless maps.

14.6.8 Follow Along: Editing the Coverage Layer

Besides removing the polygons for those areas that are not interesting, you can also customize the text
labels in your map to be generated with content from the Attribute table of your coverage layer:

• Go back to the map view.

• Enable editing for the atlas_coverage layer.
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• Select the polygons that are selected (in yellow) in the image below.

• Remove the selected polygons.

• Disable editing and save the edits.

You can go back to the Print Composer and check that the previews of the Atlas use only the polygons
you left in the layer.

The coverage layer you are using does not yet have useful information that you could use to customize
the content of the labels in your map. The first step is to create them, you can add for example a zone
code for the polygon areas and a field with some remarks for the field teams to have into account:

• Open the Attribute table for the atlas_coverage layer.

• Enable editing.

• Use the calculator to create and populate the following two fields.

• Create a field named Zone and type Whole number (integer).

• In the Expression box write/copy/construct $rownum.

• Create another field named Remarks, of type Text (string) and a width of 255.
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• In the Expression box write 'No remarks.'. This will set all the default value for all the polygons.

The forest manager will have some information about the area that might be useful when visiting the
area. For example, the existence of a bridge, a swamp or the location of a protected species. The
atlas_coverage layer is probably in edit mode still, add the following text in the Remarks field to the
corresponding polygons (double click the cell to edit it):

• For the Zone 2: Bridge to the North of plot 19. Siberian squirrel between p_13 and
p_14..

• For the Zone 6: Difficult to transit in swamp to the North of the lake..

• For the Zone 7: Siberian squirrel to the South East of p_94..

• Disable editing and save your edits.

Almost ready, now you have to tell the Atlas tool that you want some of the text labels to use the
information from the atlas_coverage layer’s attribute table.

• Go back to the Print Composer.

• Select the text label containing Detailed map....

• Set the Font size to 12.

• Set the cursor at the end of the text in the label.

• In the Item properties tab, inside the Main properties click on Insert an expression.

• In the Function list double click on the field Zone under Field and Values.

• Click OK.

• The text inside the box in the Item properties should show Detail map inventory zone: [%
"Zone" %]. Note that the [% "Zone" %] will be substituted by the value of the field Zone for the
corresponding feature from the atlas_coverage.

Test the contents of the label by looking at the different Atlas preview maps.

Do the same for the labels with the text Remarks: using the field whit the zone information. You can
leave a break line before you enter the expression. You can see the result for the preview of zone 2 in
the image below:
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Use the Atlas preview to browse through all the maps you will be creating soon and enjoy!

14.6.9 Follow Along: Printing the Maps

Last but not least, printing or exporting your maps to image files or PDF files. You can use the Atlas
→ Export Atlas as Images... or Atlas → Export Atlas as PDF.... Currently the SVG export format is
not working properly and will give a poor result.

Lets print the maps as a single PDF that you can send to the field office for printing:

• Go to the Atlas generation tab on the right panel.

• Under the Output check the Single file export when possible. This will put all the maps together
into a PDF file, if this option is not checked you will get one file for every map.

• Open Composer → Export as PDF....

• Save the PDF file as inventory_2012_maps.pdf in your
exercise_data\forestry\samplig\map_creation\ folder.

Open the PDF file to check that everything went as expected.

You could just as easily create separate images for every map (remember to uncheck the single file
creation), here you can see the thumbnails of the images that would be created:
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In the Print Composer, save your map as a composer template as forestry_atlas.qpt in your
exercise_data\forestry\map_creation\ folder. Use Composer → Save as Template. You will be
able to use this template again and again.

Close the Print Composer and save your QGIS project.

14.6.10 In Conclusion

You have managed to create a template map that can be used to automatically generate detail maps to
be used in the field to help navigate to the different plots. As you noticed, this was not an easy task
but the benefit will come when you need to create similar maps for other regions and you can use the
template you just saved.

14.6.11 What’s Next?

In the next lesson, you will see how you can use LiDAR data to create a DEM and then use it to your
enhance your data and maps visibility.

14.7 Lesson: Calculating the Forest Parameters

Estimating the parameters of the forest is the goal of the forest inventory. Continuing the example
from previous lesson, you will use the inventory information gathered in the field to calculate the forest
parameters, for the whole forest first, and then for the stands you digitized before.

The goal for this lesson: Calculate forest parameters at general and stand level.

14.7.1 Follow Along: Adding the Inventory Results

The field teams visited the forest and with the help of the information you provided, gathered information
about the forest at every sample plot.

Most often the information will be collected into paper forms in the field, then typed to a spreadsheet.
The sample plots information has been condensed into a .csv file that can be easily open in QGIS.

Continue with the QGIS project from the lesson about designing the inventory, you probably named it
forest_inventory.qgs.

First, add the sample plots measurements to your QGIS project:
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• Go to Layer → Add Delimited Text Layer....

• Browse to the file systematic_inventory_results.csv located in
exercise_data\forestry\results\.

• Make sure that the Point coordinates option is checked.

• Set the fields for the coordinates to the X and Y fields.

• Click OK.

• When prompted, select ETRS89 / ETRS-TM35FIN as the CRS.

• Open the new layer’s Attribute table and have a look at the data.

You can read the type of data that is contained in the sample plots measurements in the text file
legend_2012_inventorydata.txt located in the exercise_data\forestry\results\ folder.

The systematic_inventory_results layer you just added is actually just a virtual representation of the
text information in the .csv file. Before you continue, convert the inventory results to a real shapefile:

• Right click on the systematic_inventory_results layer.

• Browse to exercise_data\forestry\results\ folder.

• Name the file sample_plots_results.shp.

• Check Add saved file to map.

• Remove the systematic_inventory_results layer from your project.

14.7.2 Follow Along: Whole Forest Parameters Estimation

You can calculate the averages for this whole forest area from the inventory results for the some interesting
parameters, like the volume and the number of stems per hectare. Since the systematic sample plots
represent equal areas, you can directly calculate the averages of the volumes and number of stems per
hectare from the sample_plots_results layer.

You can calculate the average of a field in a vector layer using the Basic statistics tool:

• Open Vector → Analysis Tools → Basic statistics.

• Select the sample_plots_results as the Input Vector Layer.

• Select Vol as Target field.

• Click OK.

The average volume in the forest is 135.2 m3/ha.

You can calculate the average for the number of stems in the same way, 2745 stems/ha.
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14.7.3 Follow Along: Estimating Stand Parameters

You can make use of those same systematic sample plots to calculate estimates for the different forest
stands you digitized previously. Some of the forest stands did not get any sample plot and for those
you will not get information. You could have planned some extra sample plots when you planned the
systematic inventory, so that the field teams would have measured a few extra sample plots for this
purpose. Or you could send a field team later to get estimates of the missing forest stands to complete
the stand inventory. Nevertheless, you will get information for a good number of stands just using the
planned plots.

What you need is to get the averages of the sample plots that are falling within each of the forest stands.
When you want to combine information based on their relative locations, you perform a spatial join:

• Open the Vector → Data Management → Join attributes by location tool.

• Set forest_stands_2012 as the Target vector layer. The layer you want the results for.

• Set sample_plots_results as the Join vector layer. The layer you want to calculate estimates
from.

• Check Take summary of intersecting features.

• Check to calculate only the Mean.

• Name the result as forest_stands_2012_results.shp and save it in the
exercise_data\forestry\results\ folder.

• Finally select Keep all records..., so you can check later what stands did not get information.

• Click OK.

• Accept adding the new layer to your project when prompted.

• Close the Join attributes by location tool.

Open the Attribute table for forest_stands_2012_results and review the results you got. Note that a
number of forest stands have NULL as the value for the calculations, those are the ones having no sample
plots. Select them all review them in the map, they are some of the smaller stands:
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Lets calculate now the same averages for the whole forest as you did before, only this time you will use
the averages you got for the stands as the bases for the calculation. Remember that in the previous
situation, each sample plot represented a theoretical stand of 80x80 m. Now you have to consider the
area of each of the stands individually instead. That way, again, the average values of the parameters
that are in, for example, m3/ha for the volumes are converted to total volumes for the stands.

You need to first calculate the areas for the stands and then calculate total volumes and stem numbers
for each of them:

• In the Atributes table enable editing.

• Open the Field calculator.

• Create a new field called area.
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• Leave the Output field type to Decimal number (real).

• Set the Precision to 2.

• In the Expression box, write $area / 10000. This will calculate the area of the forest stands in
ha.

• Click OK.

Now calculate a field with the total volumes and number of stems estimated for every stand:

• Name the fields s_vol and s_stem.

• The fields can be integer numbers or you can use real numbers also.

• Use the expressions "area" * "MEANVol" and "area" * "MEANStems" for total volumes and total
stems respectively.

• Save the edits when you are finished.

• Disable editing.

In the previous situation, the areas represented by every sample plot were the same, so it was enough to
calculate the average of the sample plots. Now to calculate the estimates, you need to divide the sum of
the stands volumes or number of stems by the sum of the areas of the stands containing information.

• In the guilabel:Atributes table for the forest_stands_2012_results layer, select all the stands
containing information.

• Open Vector → Analysis Tools → Basic statistics.

• Select the forest_stands_2012_results as the Input Vector Layer.

• Select area as Target field.

• Check the Use only selected features

• Click OK.
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As you can see, the total sum of the stands’ areas is 66.04 ha. Note that the area of the missing forest
stands is only about 7 ha.

In the same way, you can calculate that the total volume for these stands is 8908 m3/ha and the total
number of stems is 179594 stems.

Using the information from the forest stands, instead of directly using that from the sample plots, gives
the following average estimates:

• 184.9 m3/ha and

• 2719 stems/ha.

Save your QGIS project, forest_inventory.qgs.

14.7.4 In Conclusion

You managed to calculate forest estimates for the whole forest using the information from your systematic
sample plots, first without considering the forest characteristics and also using the interpretation of the
aerial image into forest stands. And you also got some valuable information about the particular stands,
which could be used to plan the management of the forest in the coming years.
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14.7.5 What’s Next?

In the following lesson, you will first create a hillshade background from a LiDAR dataset which you will
use to prepare a map presentation with the forest results you just calculated.

14.8 Lesson: DEM from LiDAR Data

You can improve the look of your maps by using different background images. You could use the basic
map or the aerial image you have been using before, but a hillshade raster of the terrain will look nicer
in some situations.

You will use LAStools to extract a DEM from a LiDAR dataset and then create a hillshade raster to use
in your map presentation later.

The goal for this lesson: Install LAStools and calculate a DEM from LiDAR data and a hillshade
raster.

14.8.1 Follow Along: Installing Lastools

Managing LiDAR data within QGIS is possible using the Processing framework and the algorithms
provided by LAStools.

You can obtain a digital elevation model (DEM) from a LiDAR point cloud and then create a hill-
shade raster that is visually more intuitive for presentation purposes. First you will have to set up the
:guilabel:‘Processing‘framework settings to properly work with LAStools:

• Close QGIS, if you have already started it.

• An old lidar plugin might be installed by default in your system in the folder C:/Program
Files/QGIS Valmiera/apps/qgis/python/plugins/processing/.

• If you have a folder named lidar, delete it. This is valid for some installations of QGIS 2.2 and
2.4.
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• Go to the exercise_data\forestry\lidar\ folder, there you can find the file
QGIS_2_2_toolbox.zip. Open it and extract the lidar folder to replace the one you just
deleted.

• If you are using a different QGIS version, you can see more installation instructions in this tutorial.

Now you need to install the LAStools to your computer. Get the newest lastools version here and
extract the content of the lastools.zip file into a folder in your system, for example, c:\lastools\.
The path to the lastools folder cannot have spaces or special characters.

주석: Read the LICENSE.txt file inside the lastools folder. Some of the LAStools are open source and
other are closed source and require licensing for most commercial and governmental use. For education
and evaluation purposes you can use and test LAStools as much as you need to.

The plugin and the actual algorithms are now installed in your computer and almost ready to use, you
just need to set up the Processing framework to start using them:

• Open a new project in QGIS.

• Set the project’s CRS to ETRS89 / ETRS-TM35FIN.

• Save the project as forest_lidar.qgs.

To setup the LAStools in QGIS:

• Go to Processing → Options and configuration.

• In the Processing options dialog, go to Providers and then to Tools for LiDAR data.

• Check Activate.

• For LAStools folder set c:\lastools\ (or the folder you extracted LAStools to).
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14.8.2 Follow Along: Calculating a DEM with LAStools

You have already used the Processing toolbox in Lesson: 공간 통계 to run some SAGA algorithms. Now
you are going to use it to run LAStools programs:

• Open Processing → Toolbox.

• In the dropdown menu at the bottom, select Advanced interface.

• You should see the Tools for LiDAR data category.
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• Expand it to see the tools available, and expand also the LAStools category (the number of algo-
rithms may vary).

• Scroll down until you find the lasview algorithm, double click it to open.

• At Input LAS/LAZ file, browse to exercise_data\forestry\lidar\ and select the
rautjarvi_lidar.laz file.
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• Click Run.

Now you can see the LiDAR data in the just a little LAS and LAZ viewer dialog window:

There are many things you can do within this viewer, but for now you can just click and drag on the
viewer to pan the LiDAR point cloud to see what it looks like.

주석: If you want to know further details on how the LAStools work, you can read the README text files
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about each of the tools, in the C:\lastools\bin\ folder. Tutorials and other materials are available at
the Rapidlasso webpage.

• Close the viewer when you are ready.

Creating a DEM with LAStools can be done in two steps, first one to classify the point cloud into ground
and no ground points and then calculating a DEM using only the ground points.

• Go back to the Processing Toolbox.

• Note the Search... box, write lasground.

• Double click to open the lasground tool and set it as shown in this image:

• The output file is saved to the same folder where the rautjarvi_lidar.laz is located and it is
named rautjarvi_lidar_1.las.

You can open it with lasview if you want to check it.
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The brown points are the points classified as ground and the gray ones are the rest, you can click the
letter g to visualize only the ground points or the letter u to see only the unclassified points. Click the
letter a to see all the points again. Check the lasview_README.txt file for more commands. If you are
interested, also this tutorial about editing LiDAR points manually will show you different operations
within the viewer.

• Close the viewer again.

• In the Processing Toolbox, search for las2dem.

• Open the las2dem tool and set it as shown in this image:
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The result DEM is added to your map with the generic name Output raster file.

주석: The lasground and las2dem tools require licensing. You can use the unlicensed tool as indicated
in the license file, but you get the diagonals you can appreciate in the image results.

14.8.3 Follow Along: Creating a Terrain Hillshade

For visualization purposes, a hillshade generated from a DEM gives a better visualization of the terrain:

• Open Raster → Terrain analysis → Hillshade.

• As the Output layer, browse to exercise_data\forestry\lidar\ and name the file
hillshade.tif.

• Leave the rest of parameters with the default settings.
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• Select ETRS89 / ETRS-TM35FIN as the CRS when prompted.

Despite the diagonal lines remaining in the hillshade raster result, you can clearly see an accurate relief
of the area. You can even see the different soil drains that have been dug in the forests.
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14.8.4 In Conclusion

Using LiDAR data to get a DEM, specially in forested areas, gives good results with not much effort.
You could also use ready LiDAR derived DEMs or other sources like the SRTM 9m resolution DEMs.
Either way, you can use them to create a hillshade raster to use in your map presentations.

14.8.5 What’s Next?

In the next, and final step in this module, lesson you will use the hillshade raster and the forest inventory
results to create a map presentation of the results.

14.9 Lesson: Map Presentation

In the previous lessons you have imported an old forest inventor as a GIS project, updated it to the
current situation, designed a forest inventory, created maps for the field work and calculated forest
parameters from the field measurements.

It is often important to create maps with the results of a GIS project. A map presenting the results of
the forest inventory will make it easier for anyone to have a good idea of what the results are in a quick
glance, without looking at the specific numbers.
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The goal for this lesson: Create a map to present the inventory results using a hillshade raster as
background.

14.9.1 Follow Along: Preparing the Map Data

Open the QGIS project from the parameters calculations lesson, forest_inventory.qgs. Keep at least
the following layers:

• forest_stands_2012_results.

• basic_map.

• rautjarvi_aerial.

• lakes (if you don’t have it, add it from the exercise_data\forestry\ folder).

You are going to present the average volumes of your forest stands in a map. If you open the Attribute
table for the forest_stands_2012_results layer, you can see the NULL values for the stands without
information. To be able to get also those stands into your styling you should change the NULL values to,
for example, -999, knowing that those negative numbers mean there is no data for those polygons.

For the forest_stands_2012_results layer:

• Open the Attribute table and enable editing.

• Select the polygons with NULL values.

• Use the calculator to update the values of the MEANVol field to -999 only for the selected features.

• Disable editing and save the changes.

Now you can use a saved style for this layer:

• Go to the Style tab.

• Click on Load Style.

• Select the forest_stands_2012_results.qml from the exercise_data\forestry\results\
folder.

• Click OK.
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Your map will look something like this:
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14.9.2 Try Yourself Try Different Blending Modes

The style you loaded:
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is using the Hard light mode for the Layer blending mode. Note that the different modes apply different
filters combining the underlying and overlying layers, in this case the hillshade raster and your forest
stands are used. You can read about these modes in the User Guide.

Try with different modes and see the differences in your map. Then choose the one you like better for
your final map.

14.9.3 Try Yourself Using a Composer Template to Create the Map result

Use a template prepared in advanced to present the results. The template forest_map.qpt is located
in the exercise_data\forestry\results\ folder. Load it using the Project → Composer Manager...
dialog.
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Open the map composer and edit the final map to get a result you are happy with.

The map template you are using will give a map similar to this one:
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Save your QGIS project for future references.
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14.9.4 In Conclusion

Through this module you have seen how a basic forest inventory can be planned and presented with
QGIS. Many more forest analysis are possible with the variety of tools that you can access, but hopefully
this manual has given you a good starting point to explore how you could achieve the specific results
you need.
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CHAPTER 15

Module: PostgreSQL 을 통해 보는 데이터베이스 개념들

어떤 GIS 시스템에서든 관계형 데이터베이스가 중요한 부분을 차지합니다. 이번 모듈에서 관계형
데이터베이스 관리 시스템 (Relational Database Management System, RDBMS) 개념을 배우게 될
것입니다. PostgreSQL을이용해서데이터를저장할새데이터베이스를생성하는것은물론,다른전형적인
RDBMS 기능에 대해서도 배울 것입니다.

15.1 Lesson: 데이터베이스의 기초

PostgreSQL 을 사용해보기 전에, 일반적인 데이터베이스 이론으로 기초를 다지도록 합시다. 어떤 예제
코드도 입력할 필요는 없습니다. 모든 코드는 오직 설명을 목적으로 합니다.

이 강의의 목표: 핵심적인 데이터베이스 개념들을 이해하기.

15.1.1 데이터베이스란 무엇일까요?

데이터베이스는하나또는그이상의용도로쓰이는,일반적으로디지털형태인,데이터의조직화된집합으로
이루어진다. - 위키백과

DBMS(데이터베이스 관리 시스템) 는 저장소, 접속, 보안, 백업 및 기타 기능을 제공하는, 데이터베이스를
조작하는 소프트웨어로 이루어진다. - 위키백과

15.1.2 테이블

관계형데이터베이스및플랫파일데이터베이스에서, 테이블이란 (명칭으로식별되는)수직열과수평행의
모델을 사용해 조직된 데이터 요소 (값) 들의 집합이다. 테이블의 열은 지정된 개수이지만, 행은 무한대로
확장될 수 있다. 각 행은 후보 키라고 식별되는 특정 열 서브셋에 나타나는 값으로 식별된다. - 위키백과

id | name | age
----+-------+-----
1 | Tim | 20
2 | Horst | 88

(2 rows)

SQL 데이터베이스에서는 테이블을 관계 라고도 합니다.

15.1.3 열/필드

열이란 테이블의 각 행의 하나씩을 차지하는, 특정 단순형 데이터 값들의 집합이다. 열은 어떤 행들로
이루어지느냐에 따르는 구조를 제공한다. 필드라는 용어는 종종 열과 바꿔 쓰이기도 하지만, 많은 이들은
필드 (또는 필드 값) 을 한 행과 한 열의 교차 지점에 있는 단일 값을 특별히 지칭하는 용어라고 간주한다. -
위키백과
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열 :

| name |
+-------+
| Tim |
| Horst |

필드 :

| Horst |

15.1.4 레코드

레코드란 테이블의 행에 저장된 정보를 말합니다. 각 레코드는 테이블 안 각 열에 대한 필드를 차지하게
됩니다.

2 | Horst | 88 <-- one record

15.1.5 데이터형

데이터형이란 열에 저장될 수 있는 정보의 유형을 제한한다. - Tim & Horst

여러 유형의 데이터형이 있습니다. 가장 흔히 쓰이는 데이터형에 대해 알아봅시다.

• 문자열 - 자유 형식 텍스트 데이터를 저장

• 정수 - 정수를 저장

• 실수 - 소수를 저장

• 날짜 - 아무도 잊지 않도록 Horst 의 생일을 저장

• 불 - 단순한 참/거짓 값을 저장

데이터베이스가 필드에 아무것도 저장하지 않도록 할 수도 있습니다. 필드에 아무것도 없을 경우, 필드의
내용을 ‘널’ 값 이라고 합니다.

insert into person (age) values (40);

select * from person;

결과 :

id | name | age
----+-------+-----
1 | Tim | 20
2 | Horst | 88
4 | | 40 <-- null for name

(3 rows)

더 많은 데이터형을 사용할 수 있습니다. PostgreSQL 매뉴얼을 살펴보세요!

15.1.6 주소 데이터베이스 모델링

간단한 예제를 통해 데이터베이스가 어떻게 구성되는지 알아봅시다. 주소 데이터베이스를 생성하겠습니다.

Try Yourself 초급

단순한 주소를 적어보고, 어떤 요소로 이루어져 있는지 그리고 데이터베이스에 어떤 요소를 저장해야 할지
생각해보십시오.
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결과 확인

주소의 구조

주소를표현하는요소가곧열입니다. 각열에저장되는데이터의유형이곧데이터형입니다. 다음단계에서
이 개념적인 주소 테이블을 분석해서 어떻게 향상시킬 수 있는지 알아보겠습니다!

15.1.7 데이터베이스 이론

데이터베이스를 생성하는 과정은 실재 세계의 모형을 생성하는 것입니다. 실재 세계의 개념을 취해서
데이터베이스에 엔티티로서 표현하는 것입니다.

15.1.8 정규화

데이터베이스의 주요아이디어 가운데 하나는 데이터의 복제/중복을피하자는것입니다. 데이터베이스에서
중복을 제거하는 과정을 정규화라고 합니다.

정규화란 데이터베이스의 구조가 범용 쿼리 및, 데이터 무결성을 잃을 수 있는 바람직하지 않은 특정 특성들
- 인서트, 업데이트, 딜리트 이상 - 을 피하는 데 적합한지 확인하는 체계적인 방법이다. - 위키백과

정규화 ‘서식’ 에는 서로 다른 유형들이 있습니다.

간단한 예를 살펴보겠습니다.

Table "public.people"

Column | Type | Modifiers
----------+------------------------+-----------------------------------------
id | integer | not null default

| | nextval('people_id_seq'::regclass)
| |

name | character varying(50) |
address | character varying(200) | not null
phone_no | character varying |

Indexes:
"people_pkey" PRIMARY KEY, btree (id)

select * from people;

id | name | address | phone_no
--+---------------+-----------------------------+-------------
1 | Tim Sutton | 3 Buirski Plein, Swellendam | 071 123 123
2 | Horst Duester | 4 Avenue du Roix, Geneva | 072 121 122

(2 rows)

동일한 도로명 또는 도시명을 가진 친구들이 많다고 상상해보십시오. 이 데이터가 복제될 때마다 용량을
소비하게 됩니다. 더구나 도시명이 변경될 경우, 데이터베이스를 업데이트하는 데 많은 작업을 해야 합니다.

15.1.9 Try Yourself 초급

복제를 줄이고 데이터 구조를 정규화하기 위해 앞의 이론적인 ‘people’ 테이블을 재설계해보십시오.

데이터베이스 정규화에 대해 이곳 에서 더 읽어볼 수 있습니다.

결과 확인
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15.1.10 인덱스

데이터베이스 인덱스란 데이터베이스 테이블에서 데이터 검색 작업의 속도를 향상시키는 데이터 구조이다.
- 위키백과

교과서를 읽다가 어떤 개념에 대한 설명을 찾는다고 상상해보십시오 - 그런데 교과서에 색인이 없군요!
여러분은 필요한 정보를 찾을 때까지 표지부터 책 전체를 다시 훑어야 할 겁니다. 책의 끝부분에 있는
색인은 관련 정보가 있는 페이지를 빨리 찾을 수 있게 해줍니다.

create index person_name_idx on people (name);

이제 성명 검색이 빨라질 겁니다.

Table "public.people"

Column | Type | Modifiers
----------+------------------------+-----------------------------------------
id | integer | not null default

| | nextval('people_id_seq'::regclass)
| |

name | character varying(50) |
address | character varying(200) | not null
phone_no | character varying |

Indexes:
"people_pkey" PRIMARY KEY, btree (id)
"person_name_idx" btree (name)

15.1.11 시퀀스

시퀀스란 유일 숫자 생성기입니다. 보통 테이블의 어떤 열을 위한 유일한 식별자를 생성하는 데 쓰입니다.

이 예제에서 id 가 시퀀스입니다. 테이블에 레코드가 추가될 때마다 숫자가 증가합니다.

id | name | address | phone_no
---+--------------+-----------------------------+-------------
1 | Tim Sutton | 3 Buirski Plein, Swellendam | 071 123 123
2 | Horst Duster | 4 Avenue du Roix, Geneva | 072 121 122

15.1.12 엔티티 관계 도표

정규화된 데이터베이스는 일반적으로 많은 관계 (테이블) 을 가지게 됩니다. 이 관계들 사이의 논리적
의존성을 설계하는 데 엔티티 -관계 도표 (ER Diagram) 를 사용합니다. 이전 단계의 아직 정규화되지 않은
‘people’ 테이블을 생각해보십시오.

select * from people;

id | name | address | phone_no
----+--------------+-----------------------------+-------------
1 | Tim Sutton | 3 Buirski Plein, Swellendam | 071 123 123
2 | Horst Duster | 4 Avenue du Roix, Geneva | 072 121 122

(2 rows)

같은 거리에 사는 개인들에 대해 도로명을 반복할 필요가 없도록 이 테이블을 손쉽게 두 테이블로 나눌 수
있습니다.

select * from streets;

id | name
----+--------------
1 | Plein Street

(1 row)
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이렇게 하면,

select * from people;

id | name | house_no | street_id | phone_no
----+--------------+----------+-----------+-------------
1 | Horst Duster | 4 | 1 | 072 121 122

(1 row)

이 두 테이블을 streets.id 와 people.streets_id 라는 ‘키’ 를 이용해서 연결할 수 있습니다.

이 두 테이블에 대해 ER 도표를 그린다면 다음과 같이 보일 것입니다.

ER 도표를 통해 ‘일대다’ 관계를 표현할 수 있습니다. 이 예제에서 화살표는 한 도로에 많은 사람이 살 수
있다는 사실을 보여줍니다.

Try Yourself 중급

이 ‘people’ 모델에는 아직 몇몇 정규화 문제가 남아 있습니다. 사용자 스스로 더 정규화를 진행시킬 수
있을지 생각해보고, ER 도표로 사용자의 생각을 표현해보십시오.

결과 확인

15.1.13 제약 조건, 기본 키, 외래 키

데이터베이스 제약 조건은 관계 안에 있는 데이터가 어떻게 데이터가 저장되어야 하는지에 대한 모델러의
시각과 일치하는지 확인하는 데 쓰입니다. 예를 들어 우편번호에 대한 제약 조건으로 1000 과 9999 사이의
숫자만 저장되도록 할 수 있습니다.

기본키는레코드를유일하게만들어주는하나이상의필드값입니다. 기본키를보통 id라고하며,시퀀스인
경우가 대부분입니다.

외래 키는 유일한 레코드를 (해당 테이블의 기본 키를 써서) 다른 테이블에 참조시키는 데 쓰입니다.

ER 도표를 그릴 때, 테이블 사이의 연결은 보통 기본 키와 연결되는 외래 키에 기반하고 있습니다.

이 ‘people’ 예제를 보면, 테이블 정의에서 street 열이 streets 테이블의 기본 키를 참조하는 외래 키라는
사실을 보여주고 있습니다.

Table "public.people"

Column | Type | Modifiers
-----------+-----------------------+--------------------------------------
id | integer | not null default

| | nextval('people_id_seq'::regclass)
name | character varying(50) |
house_no | integer | not null
street_id | integer | not null
phone_no | character varying |

Indexes:
"people_pkey" PRIMARY KEY, btree (id)
Foreign-key constraints:
"people_street_id_fkey" FOREIGN KEY (street_id) REFERENCES streets(id)
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15.1.14 트랜잭션

데이터베이스에서 데이터를 추가, 변경, 삭제할 때 뭔가 문제가 발생해도 데이터베이스는 언제나 양호한
상태로남아있어야합니다. 대부분의데이터베이스는트랜잭션지원이라는기능을제공합니다. 트랜잭션은
데이터베이스에대한사용자의수정작업이계획대로되지않았을경우되돌아갈수있는복원지점을생성할
수 있게 해줍니다.

사용자가 은행 계좌 시스템을 가지고 있다고 생각해보십시오. 어떤 계좌에서 다른 계좌로 자금을 전송해야
합니다. 이 일련의 단계를 다음과 같이 가정해볼 수 있습니다.

• 조에게서 R20 을 출금

• 앤에게 R20 을 입금

이 과정에서 무언가 (정전 같은) 문제가 생길 경우, 트랜잭션이 이전으로 복원됩니다.

15.1.15 In Conclusion

데이터베이스를 이용하면 간단한 코드 구조를 써서 데이터를 구조화된 방법으로 관리할 수 있습니다.

15.1.16 What’s Next?

이제 데이터베이스가 이론적으로 어떻게 작동하는지 알아봤으니, 지금 배운 이론을 시행할 수 있는 새
데이터베이스를 생성해봅시다.

15.2 Lesson: 데이터 모델 시행

이제 모든 이론을 살펴봤으니, 새 데이터베이스를 생성해봅시다. 이 강의에서 생성할 데이터베이스를 이번
모듈 내내 예제로 사용할 것입니다.

이 강의의 목표: 필수 소프트웨어를 설치하고 예제 데이터베이스를 시행하는 데 사용하기.

15.2.1 PostgreSQL 설치

주석: 이 교재가 다루는 범위에서는 벗어나지만, 맥 사용자는 홈브루 를 사용해서 PostgreSQL 을 설치할
수있습니다. 윈도우사용자는 GUI인스톨러를여기에서다운로드할수있습니다. 이강의에서는사용자가
우분투에서 QGIS 를 실행하고 있다고 가정한다는 사실을 알아두십시오.

우분투에서 다음과 같이 설치하면,

sudo apt-get install postgresql-9.1

다음과 같은 메시지를 받게 될 것입니다.

[sudo] password for qgis:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
postgresql-client-9.1 postgresql-client-common postgresql-common
Suggested packages:
oidentd ident-server postgresql-doc-9.1
The following NEW packages will be installed:
postgresql-9.1 postgresql-client-9.1 postgresql-client-common postgresql-common
0 upgraded, 4 newly installed, 0 to remove and 5 not upgraded.
Need to get 5,012kB of archives.
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After this operation, 19.0MB of additional disk space will be used.
Do you want to continue [Y/n]?

Y 를 입력하고 Enter 키를 누른 다음, 다운로드 및 설치가 끝날 때까지 기다리십시오.

15.2.2 도움말

PostgreSQL 는 매우 훌륭한 온라인 문서를 갖추고 있습니다.

15.2.3 데이터베이스 사용자 생성

우분투의 경우,

설치가 완료된 후 다음 명령어를 실행해서 PostgreSQL 의 사용자가 된 다음, 새 데이터베이스 사용자를
생성하십시오.

sudo su - postgres

시스템이비밀번호를요구하면사용자의우분투비밀번호를입력하십시오. (사용자에게 sudo권한이있어야
합니다)

그 다음 PostgreSQL 사용자의 배시 프롬프트에서 데이터베이스 사용자를 생성하십시오. 이때 사용자명을
우분투 사용자명과 동일하게 하십시오. 해당 사용자로 로그인 시 PostgreSQL 이 자동적으로 인증할 것이기
때문에 프로그램 사용이 훨씬 쉬워집니다.

createuser -d -E -i -l -P -r -s qgis

시스템이 비밀번호를 요구하면 입력합니다. 시스템 로그인 비밀번호와는 달라야 합니다.

이 옵션들은 무슨 뜻일까요?

-d, --createdb role can create new databases
-E, --encrypted encrypt stored password
-i, --inherit role inherits privileges of roles it is a member of (default)
-l, --login role can login (default)
-P, --pwprompt assign a password to new role
-r, --createrole role can create new roles
-s, --superuser role will be superuser

이제 다음 명령어를 입력해서 PostgreSQL 사용자의 배시 셸 환경에서 벗어나십시오.

exit

15.2.4 새 계정 확인

psql -l

다음과 같은 화면을 보게 될 것입니다.

Name | Owner | Encoding | Collation | Ctype |
----------+----------+----------+------------+------------+
postgres | postgres | UTF8 | en_ZA.utf8 | en_ZA.utf8 |
template0 | postgres | UTF8 | en_ZA.utf8 | en_ZA.utf8 |
template1 | postgres | UTF8 | en_ZA.utf8 | en_ZA.utf8 |
(3 rows)

q 를 입력해서 벗어나십시오.
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15.2.5 데이터베이스 생성

새데이터베이스를생성하려면 createdb명령어를사용합니다. 다음과같이배시셸프롬프트에서실행해야
합니다.

createdb address -O qgis

다음 명령어를 통해 새 데이터베이스의 존재를 확인할 수 있습니다.

psql -l

다음과 같은 내용을 반환할 것입니다.

Name | Owner | Encoding | Collation | Ctype | Access privileges
----------+----------+----------+------------+------------+-----------------------
address | qgis | UTF8 | en_ZA.utf8 | en_ZA.utf8 |
postgres | postgres | UTF8 | en_ZA.utf8 | en_ZA.utf8 |
template0 | postgres | UTF8 | en_ZA.utf8 | en_ZA.utf8 | =c/postgres: postgres=CTc/postgres
template1 | postgres | UTF8 | en_ZA.utf8 | en_ZA.utf8 | =c/postgres: postgres=CTc/postgres
(4 rows)

q 를 입력해서 벗어나십시오.

15.2.6 데이터베이스 셸 세션 시작

다음과 같이 손쉽게 사용자 데이터베이스에 접속할 수 있습니다.

psql address

psql 데이터베이스 셸에서 나오려면 다음과 같이 입력하십시오.

\q

셸 사용법에 대한 도움말을 보려면 다음과 같이 입력하십시오.

\?

SQL 명령어에 대한 도움말을 보려면 다음과 같이 입력하십시오.

\help

특정 명령어에 대한 도움말을 보려면 (예를 들어) 다음과 같이 입력합니다.

\help create table

psql 치트 시트 도 참조하십시오. 이곳 에서 구할 수 있습니다.

15.2.7 SQL 로 테이블 생성

테이블을 만들어보겠습니다! 이전 강의에서 만들었던 ER 도표를 지침으로 삼을 것입니다. 먼저 주소 DB
에 접속하십시오.

psql address

그 다음 streets 테이블을 생성합니다.

create table streets (id serial not null primary key, name varchar(50));

serial 과 varchar 는 **데이터형 ** 입니다. serial 은 PostgreSQL 이 새 레코드가 추가될 때마다
자동적으로 id 를 정수 시퀀스 (자동 숫자) 로 채우도록 지정합니다. varchar(50) 은 PostgreSQL 이 길이
50 글자인 캐릭터 필드를 생성하도록 합니다.
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명령어가 ; 문자로 끝난다는 것을 알아차리셨을 겁니다. 모든 SQL 명령어가 이렇게 끝나야 합니다. 엔터를
입력하면, psql 이 다음과 같은 내용을 보고할 것입니다.
NOTICE: CREATE TABLE will create implicit sequence "streets_id_seq" for

serial column "streets.id"
NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "streets_pkey"

for table "streets"
CREATE TABLE

사용자의 테이블을 streets.id 를 이용하는 기본 키 streets_pkey 와 함께 성공적으로 생성했다는
뜻입니다.

주석 : ; 을 입력하지 않고 엔터를 누르면 address-# 과 같은 프롬프트로 들어가게 됩니다. PostgreSQL 이
연속되는 명령어를 기다리고 있기 때문입니다. 명령어를 실행하려면 ; 을 입력하십시오.

테이블 스키마를 살펴보려면 다음처럼 하면 됩니다.

\d streets

그러면 다음과 같은 내용을 반환할 것입니다.
Table "public.streets"
Column | Type | Modifiers

--------+-----------------------+--------------------------------------
id | integer | not null default

| | nextval('streets_id_seq'::regclass)
name | character varying(50) |

Indexes:
"streets_pkey" PRIMARY KEY, btree (id)

테이블의 내용을 살펴보려면 다음처럼 하면 됩니다.
select * from streets;

그러면 다음과 같은 내용을 반환할 것입니다.

id | name
---+------
(0 rows)

사용자 테이블이 현재 비어 있다는 것을 알 수 있습니다.

Try Yourself 중급

앞에서 배운 내용대로 people 이라는 테이블을 만드십시오.

Add fields such as phone number, home address, name, etc. (these aren’t all valid names: change them
to make them valid). Make sure you give the table an ID column with the same data-types as above.

결과 확인

15.2.8 SQL 로 키 생성

앞단계까지의문제점은데이터베이스가 people과 streets가논리적관계를가지고있다는사실을모른다는
것입니다. 이 관계를 표현하려면, streets 테이블의 기본 키를 가리키는 외래 키를 정의해야만 합니다.

두 가지 방법이 있습니다.
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• 테이블 생성 후 키 추가

• 테이블 생성 시 키 정의

이미 테이블을 생성했으므로, 첫 번째 방법을 써봅시다.

alter table people
add constraint people_streets_fk foreign key (street_id) references streets(id);

이렇게 하면 people 테이블에 street_id 필드가 streets 테이블의 유효한 도로 id 와 일치해야만 한다고
알려주게 됩니다.

제약 조건을 생성하는 좀 더 일반적인 방법은 테이블 생성 시 다음과 같이 하는 것입니다.

create table people (id serial not null primary key,
name varchar(50),
house_no int not null,
street_id int references streets(id) not null,
phone_no varchar null);

\d people

제약 조건을 추가하면, 테이블 스키마가 다음과 같이 변합니다.

Table "public.people"

Column | Type | Modifiers
-----------+-----------------------+---------------------------------
id | integer | not null default

| | nextval('people_id_seq'::regclass)
name | character varying(50) |
house_no | integer | not null
street_id | integer | not null
phone_no | character varying |

Indexes:
"people_pkey" PRIMARY KEY, btree (id)

Foreign-key constraints:
"people_streets_fk" FOREIGN KEY (id) REFERENCES streets(id)

15.2.9 SQL 로 인덱스 생성

우리는 인명 검색이 눈 깜짝할 사이에 이뤄지기를 바랍니다. 이렇게 하려면 다음과 같이 people 테이블의
name 열에 인덱스를 생성하면 됩니다.

create index people_name_idx on people(name);

\d people

테이블 스키마가 다음과 같이 변경됩니다.

Table "public.people"

Column | Type | Modifiers
-----------+-----------------------+-----------------------------------
id | integer | not null default nextval

| | ('people_id_seq'::regclass)
name | character varying(50) |
house_no | integer | not null
street_id | integer | not null
phone_no | character varying |

Indexes:
"people_pkey" PRIMARY KEY, btree (id)
"people_name_idx" btree (name) <-- new index added!
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Foreign-key constraints:
"people_streets_fk" FOREIGN KEY (id) REFERENCES streets(id)

15.2.10 SQL 로 테이블 드롭

테이블을 없애버리고 싶은 경우 drop 명령어를 쓸 수 있습니다.

drop table streets;

주석: 현재 예제에서 이 명령어는 동작하지 않습니다. 어째서일까요? 이런 이유 때문입니다.

‘people’ 테이블에 대해 동일한 drop table 명령어를 사용할 경우, 성공적으로 동작할 것입니다.

drop table people;

주석: 실제로 명령어를 입력해서 people 테이블을 드롭했다면, 다음 예제에 필요하므로 지금 다시
생성하도록 하십시오.

15.2.11 pgAdmin III 에 대해

We are showing you the SQL commands from the psql prompt because it’s a very useful way to learn
about databases. However, there are quicker and easier ways to do a lot of what we are showing you.
Install pgAdminIII and you can create, drop, alter etc tables using ‘point and click’ operations in a GUI.

우분투에서 다음과 같이 설치할 수 있습니다.

sudo apt-get install pgadmin3

다른 모듈에서 pgAdmin III 에 대해 더 자세히 배우게 될 것입니다.

15.2.12 In Conclusion

이제 완전히 처음부터 새 데이터베이스를 생성하는 방법을 배웠습니다.

15.2.13 What’s Next?

다음 강의에서 DBMS 를 통해 새 데이터를 추가하는 방법을 배울 것입니다.

15.3 Lesson: 모델에 데이터 추가

이제 우리가 생성한 모델을, 원래 담으려던 데이터로 채워야 합니다.

이 강의의 목표: 데이터베이스 모델에 새 데이터를 인서트하는 방법을 배우기.

15.3.1 인서트 선언문

어떻게 테이블에 데이터를 추가할까요? SQL INSERT 를 선언하면 해당 기능을 쓸 수 있습니다.

insert into streets (name) values ('High street');

다음 내용을 기억하십시오.
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• 테이블명 ( streets ) 뒤에 사용자가 채우려고 하는 열명을 나열하십시오. (이 경우에는 name
열뿐입니다.)

• values 키워드 뒤에 필드 값의 목록을 넣으십시오.

• 문자열을 작은따옴표로 감싸야 합니다.

• id 열을 위한 값을 인서트하지 않았습니다. id 는 시퀀스로 자동 생성되기 때문입니다.

• id 를 수동으로 설정하면, 사용자 데이터베이스의 무결성을 심각하게 해칠 수도 있습니다.

선언이 성공했다면 INSERT 0 1 을 볼 수 있을 것입니다.

테이블의 모든 데이터를 선택하면 사용자의 인서트 선언의 결과를 볼 수 있습니다.

select * from streets;

결과물 :

select * from streets;
id | name

----+-------------
1 | High street

(1 row)

Try Yourself 초급

INSERT 명령어를 사용해서 streets 테이블에 새 도로를 추가하십시오.

결과 확인

15.3.2 제약 조건에 따라 데이터 연속 추가

15.3.3 Try Yourself 중급

people 테이블에 다음 세부 사항을 갖춘 인물 오브젝트를 추가해보십시오.

Name: Joe Smith
House Number: 55
Street: Main Street
Phone: 072 882 33 21

주석: 이 예제에서 전화번호를 정수가 아니라 문자열로 정의한 것을 기억하십니까?

이 시점에서 streets 테이블에 Main Street 에 대한 레코드를 먼저 생성하지 않고 데이터를 추가하려 하면
오류 보고를 받게 될 것입니다.

다음 사항에 대해서도 알게 됐을 것입니다.

• 도로명으로는 추가할 수 없습니다.

• ‘streets’ 테이블에 도로 레코드를 먼저 생성하지 않으면 도로 id 를 이용해서 도로를 추가할 수
없습니다.

사용자의 두 테이블이 기본/외래 키로 연결되어 있다는 사실을 기억하십시오. 다시 말해 상응하는 유효한
도로 레코드 없이는 유효한 인물을 생성할 수 없다는 뜻입니다.

이런 지식을 사용해서 데이터베이스에 새 인물을 추가해보십시오.

결과 확인
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15.3.4 데이터 선택

이미 데이터를 선택할 수 있는 문법을 배웠습니다. 몇 가지 예를 더 들어보겠습니다.

select name from streets;

select * from streets;

select * from streets where name='Main Road';

이후 단계에서 데이터를 선택하고 필터링하는 방법에 대해 더 자세히 알아볼 것입니다.

15.3.5 데이터 업데이트

어떤 기존 데이터를 변경하고자 할 경우 어떻게 해야 할까요? 예를 들어 도로명이 변경됐다고 해봅시다.

update streets set name='New Main Road' where name='Main Road';

이런 업데이트 선언문을 사용할 때는 매우 주의해야 합니다. WHERE 구문과 일치하는 레코드가 하나 이상일
경우 모두 업데이트될 겁니다!

다음과 같이 변경할 레코드를 참조하는 테이블 기본 키를 사용하는 방법이 더 낫습니다.

update streets set name='New Main Road' where id=2;

UPDATE 1 을 반환할 것입니다.

주석: WHERE선언문기준은대소문자를구분합니다. Main Road와 Main road를서로다르게인식합니다.

15.3.6 데이터 딜리트

테이블에서 오브젝트를 삭제하려면, DELETE 명령어를 이용하십시오.

delete from people where name = 'Joe Smith';

‘people’ 테이블이 어떻게 변경됐는지 볼까요?

address=# select * from people;

id | name | house_no | street_id | phone_no
----+------+----------+-----------+----------

(0 rows)

15.3.7 Try Yourself 고급

지금까지 배운 기술을 이용해서 사용자 데이터베이스에 새 친구들 몇 명을 추가해보십시오.

name | house_no | street_id | phone_no
-----------------+----------+-----------+--------------
Joe Bloggs | 3 | 2 | 072 887 23 45
Jane Smith | 55 | 3 | 072 837 33 35
Roger Jones | 33 | 1 | 072 832 31 38
Sally Norman | 83 | 1 | 072 932 31 32
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15.3.8 In Conclusion

이제이전단계에서생성했던기존모델에새데이터를추가하는방법을배웠습니다. 새로운유형의데이터를
추가하려면기존모델을수정하거나, 해당데이터를담을수있는새모델을생성해야할수도있다는사실을
기억하십시오.

15.3.9 What’s Next?

이제데이터를추가했으니,쿼리를통해이데이터에다양한방식으로접근하는방법에대해배워보겠습니다.

15.4 Lesson: 쿼리

SELECT ... 명령을 작성할 때 이를 흔히 쿼리라고 합니다. 사용자가 데이터베이스에서 정보를 얻는
행위입니다.

이 강의의 목표: 유용한 정보를 반환하는 쿼리를 생성하는 방법을 배우기.

주석: 이전강의에서벌써하지않았다면,사용자의 people테이블에다음인물오브젝트들을추가하십시오.
외래키제약조건에관한오류를반환받았을경우,먼저 streets테이블에 ‘Main Road’오브젝트를추가해야
합니다.

insert into people (name,house_no, street_id, phone_no)
values ('Joe Bloggs',3,2,'072 887 23 45');

insert into people (name,house_no, street_id, phone_no)
values ('Jane Smith',55,3,'072 837 33 35');

insert into people (name,house_no, street_id, phone_no)
values ('Roger Jones',33,1,'072 832 31 38');

insert into people (name,house_no, street_id, phone_no)
values ('Sally Norman',83,1,'072 932 31 32');

15.4.1 결과물 정렬

인물 목록을 번지 순으로 정렬해서 받아봅시다.

select name, house_no from people order by house_no;

결과물 :

name | house_no
--------------+----------
Joe Bloggs | 3
Roger Jones | 33
Jane Smith | 55
Sally Norman | 83

(4 rows)

하나 이상의 열의 값들을 기준으로 결과를 정렬할 수 있습니다.

select name, house_no from people order by name, house_no;

결과물 :

name | house_no
--------------+----------
Jane Smith | 55
Joe Bloggs | 3
Roger Jones | 33
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Sally Norman | 83
(4 rows)

15.4.2 필터링

대부분의 경우 데이터베이스에 있는 모든 레코드를 하나하나 보고 싶지는 않을 겁니다. 특히 레코드가 수
천 개 있는데 그 중 하나나 두 개에만 관심이 있을 때는 말이죠.

다음은 house_no 값이 50 미만인 오브젝트만 반환하도록 하는 숫자 필터의 예입니다.
select name, house_no from people where house_no < 50;

name | house_no
-------------+----------
Joe Bloggs | 3
Roger Jones | 33

(2 rows)

You can combine filters (defined using the WHERE clause) with sorting (defined using the ORDER BY):
select name, house_no from people where house_no < 50 order by house_no;

name | house_no
-------------+----------
Joe Bloggs | 3
Roger Jones | 33

(2 rows)

텍스트 데이터를 기준으로 필터링할 수도 있습니다.

select name, house_no from people where name like '%s%';

name | house_no
-------------+----------
Joe Bloggs | 3
Roger Jones | 33

(2 rows)

이 예시에서 LIKE 구문을 이용해 s 가 들어간 모든 성명을 찾았습니다. 이 쿼리가 대소문자를 구분하기
때문에 Sally Norman 항목을 반환하지 않았다는 사실을 알아차리셨을 겁니다.

대소문자를 구분하지 않고 어떤 문자열을 검색하고자 한다면, ILIKE구문을써서 대소문자를구분하지 않는
검색을 실행할 수 있습니다.

select name, house_no from people where name ilike '%r%';

name | house_no
--------------+----------
Roger Jones | 33
Sally Norman | 83

(2 rows)

이 쿼리는 성명에 r 이나 R 이 들어간 모든 ‘people’ 오브젝트를 반환했습니다.

15.4.3 결합

여러분이 인물의 ID 대신 상세 정보와 주소를 알고 싶을 땐 어떻게 할까요? 이렇게 하려면 단일 쿼리에서
두 테이블을 함께 결합해야 합니다. 다음 예시를 살펴보십시오.
select people.name, house_no, streets.name
from people,streets
where people.street_id=streets.id;
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주석: With joins, you will always state the two tables the information is coming from, in this case
people and streets. You also need to specify which two keys must match (foreign key & primary key). If
you don’t specify that, you will get a list of all possible combinations of people and streets, but no way
to know who actually lives on which street!

정확한 산출물은 다음과 같을 것입니다.

name | house_no | name
--------------+----------+-------------
Joe Bloggs | 3 | Low Street
Roger Jones | 33 | High street
Sally Norman | 83 | High street
Jane Smith | 55 | Main Road

(4 rows)

이후 좀 더 복잡한 쿼리를 생성할 때 다시 이 결합을 살펴볼 것입니다. 지금은 두 개 이상의 테이블에서
정보를 조합할 수 있는 간단한 방법이라는 것만 기억해두십시오.

15.4.4 내부 선택

내부선택을사용하면외래키관계를통해연결된다른테이블의데이터를기반으로테이블에서오브젝트를
선택할 수 있습니다. 이 예시에서는 특정 거리에 사는 인물을 찾고자 합니다.

먼저 데이터를 약간 수정해봅시다.

insert into streets (name) values('QGIS Road');
insert into streets (name) values('OGR Corner');
insert into streets (name) values('Goodle Square');
update people set street_id = 2 where id=2;
update people set street_id = 3 where id=3;

이렇게 수정한 다음 데이터를 살펴보도록 합시다. 이전 단계에서 사용했던 쿼리를 다시 쓸 수 있습니다.

select people.name, house_no, streets.name
from people,streets
where people.street_id=streets.id;

결과물 :

name | house_no | name
--------------+----------+-------------
Roger Jones | 33 | High street
Sally Norman | 83 | High street
Jane Smith | 55 | Main Road
Joe Bloggs | 3 | Low Street

(4 rows)

이제 이 데이터에 대해 어떻게 결과 내 선택을 하는지 볼까요? street_id 숫자가 1 인 곳에 사는 인물들만
보려 합니다.

select people.name
from people, (

select *
from streets
where id=1

) as streets_subset
where people.street_id = streets_subset.id;

결과물 :
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name
--------------
Roger Jones
Sally Norman

(2 rows)

이 예시가 매우 단순하며 여러분의 작은 데이터셋에서는 불필요하긴 하지만, 복잡한 대용량 데이터셋을
쿼리할 때 내부 선택이 얼마나 유용하고 중요할 수 있는지를 보여줍니다.

15.4.5 집계 쿼리

데이터베이스의강력한기능가운데하나가테이블에있는데이터를요약할수있다는것입니다. 이런요약을
집계 쿼리라고 부릅니다. 다음은 ‘people’ 테이블에 있는 인물 오브젝트가 몇 개인지 보여주는 예시입니다.

select count(*) from people;

결과물 :
count

-------
4

(1 row)

도로명으로 요약한 집계를 바란다면 다음과 같이 할 수 있습니다.

select count(name), street_id
from people
group by street_id;

결과물 :

count | street_id
-------+-----------

2 | 1
1 | 3
1 | 2

(3 rows)

주석: ORDER BY구문을쓰지않았기때문에, 사용자의결과물순서가예시와일치하지않을수도있습니다.

Try Yourself 중급

도로명으로 인물을 요약하고 ‘street_id’ 대신 실제 도로명을 나타내도록 하십시오.

결과 확인

15.4.6 In Conclusion

어떻게 데이터베이스에서 유용한 정보를 추출할 수 있게 해주는 방식으로 쿼리를 사용해서 데이터베이스의
데이터를 반환받을 수 있는지 배웠습니다.

15.4.7 What’s Next?

다음 강의에서 사용자가 작성한 쿼리에서 뷰를 생성하는 방법을 배워보겠습니다.
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15.5 Lesson: 뷰

쿼리 작성 시 쿼리를 구성하는 데 많은 시간과 노력을 들여야 합니다. 뷰를 사용하면 SQL 쿼리의 정의를
재사용할 수 있는 ‘가상 테이블’ 에 저장할 수 있습니다.

이 강의의 목표: 쿼리를 뷰로 저장하기.

15.5.1 뷰 생성

뷰를 테이블과 똑같이 다룰 수 있지만, 뷰의 데이터는 쿼리에서 나옵니다. 앞의 내용을 바탕으로 간단한
뷰를 만들어봅시다.

create view roads_count_v as
select count(people.name), streets.name
from people, streets where people.street_id=streets.id
group by people.street_id, streets.name;

보시면 알겠지만 단 하나 달라진 점은 시작 부분의 create view roads_count_v as 뿐입니다. 이제 이
뷰에서 데이터를 선택할 수 있습니다.

select * from roads_count_v;

결과 :

count | name
-------+-------------

1 | Main Road
2 | High street
1 | Low Street

(3 rows)

15.5.2 뷰 수정

뷰는 고정되지 않았으며, ‘실제 데이터’ 를 담고 있지도 않습니다. 즉 사용자 데이터베이스에 있는 어떤
데이터도 건드리지 않고 뷰를 변경할 수 있다는 뜻입니다.

CREATE OR REPLACE VIEW roads_count_v AS
SELECT count(people.name), streets.name
FROM people, streets WHERE people.street_id=streets.id
GROUP BY people.street_id, streets.name
ORDER BY streets.name;

(또한 이 예시는 모든 SQL 키워드에 대문자 를 사용하는 모범적인 실행 관습을 보여주고 있습니다.)

ORDER BY 구문을 추가해서 뷰의 행들이 알파벳 순서로 정렬된 것을 볼 수 있을 것입니다.

select * from roads_count_v;

count | name
-------+-------------

2 | High street
1 | Low Street
1 | Main Road

(3 rows)

15.5.3 뷰 삭제

뷰가 더 이상 필요 없을 경우, 다음과 같이 삭제할 수 있습니다.
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drop view roads_count_v;

15.5.4 In Conclusion

뷰를 이용하면 쿼리를 저장하고, 그 쿼리가 마치 테이블인 것처럼 결과물에 접근할 수 있습니다.

15.5.5 What’s Next?

데이터 변경 시, 가끔 변경 사항이 데이터베이스의 다른 부분에 영향을 주기를 바랄 수도 있습니다. 다음
강의에서 그 방법을 배워보겠습니다.

15.6 규칙

규칙을 쓰면 입력 받은 쿼리의 “쿼리 트리” 를 재작성할 수 있다. 흔히 업데이트 가능한 뷰를 포한한 뷰를
시행하는 데 쓰인다. - 위키백과

이 강의의 목표: 데이터베이스에 대해 새 규칙을 생성하는 방법을 배우기.

15.6.1 구체화 뷰 (규칙 기반 뷰)

사용자의 ‘people’테이블에서 ‘phone_no’의모든변경사항을 ‘people_log’테이블에로그기록하고싶다고
해봅시다. 그러면 새 테이블을 생성해야 합니다.

create table people_log (name text, time timestamp default NOW());

그 다음, ‘people’ 테이블에서 일어나는 ‘phone_no’ 의 모든 변경 사항을 ‘people_log’ 테이블에 로그
기록하는 규칙을 다음과 같이 생성하십시오.

create rule people_log as on update to people
where NEW.phone_no <> OLD.phone_no
do insert into people_log values (OLD.name);

이 규칙이 작동하는지 시험해보기 위해, 전화번호를 수정해보겠습니다.

update people set phone_no = '082 555 1234' where id = 2;

people 테이블이 정확히 업데이트됐는지 확인하십시오.

select * from people where id=2;

id | name | house_no | street_id | phone_no
----+------------+----------+-----------+--------------
2 | Joe Bloggs | 3 | 2 | 082 555 1234

(1 row)

이제 방금 생성한 규칙 덕분에 people_log 테이블이 다음과 같이 보일 것입니다.

select * from people_log;

name | time
------------+----------------------------
Joe Bloggs | 2014-01-11 14:15:11.953141

(1 row)

주석: time 필드의 값은 현재 날짜와 시간에 따라 달라집니다.
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15.6.2 In Conclusion

규칙을 사용하면 사용자 데이터베이스에 자동적으로 데이터베이스의 다른 부분에서 일어난 변경 사항을
반영하는 데이터를 추가하거나 변경하도록 할 수 있습니다.

15.6.3 What’s Next?

다음 모듈에서 PostGIS 를 사용한 공간 데이터베이스를 소개할 것입니다. 이번 모듈에서 배운
데이터베이스의 개념들을 GIS 데이터에 적용하는 단계입니다.
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CHAPTER 16

Module: PostGIS 를 통해 보는 공간 데이터베이스 개념들

공간데이터베이스는데이터베이스안에도형레코드들을저장할수있을뿐만아니라이도형들을이용해서
레코드를 쿼리하거나 추출할 수 있는 기능도 제공합니다. 이번 모듈에서 PostgreSQL 의 확장 소프트웨어인
PostGIS를사용해서어떻게공간데이터베이스를설정하고,어떻게 shapefile에서데이터베이스로데이터를
가져오며, 어떻게 PostGIS 가 제공하는 지리적 기능들을 사용할 수 있는지 배워볼 것입니다.

이번 모듈을 배우는 과정에서 PostGIS 치트 시트 를 함께 보는 편이 좋습니다. Boston GIS 사용자 그룹
에서 구할 수 있습니다. 온라인 PostGIS 문서도 유용할 것입니다.

또한 Boundless Geo 에서도 PostGIS 와 공간 데이터베이스에 대해 다음과 같은 좀 더 광범위한 예제들을
볼 수 있습니다.

• PostGIS 소개

• 공간 데이터베이스 노하우

PostGIS 온라인 도 참조하십시오.

16.1 Lesson: PostGIS 설정

PostGIS 기능을 설정하면 PostgreSQL 이 내장한 공간 기능에 접근할 수 있습니다.

이 강의의 목표: 공간 기능을 설치하고 그 효과를 간단히 실행해보기.

주석: 이번 예제에서는 PostGIS 2.1 버전을 사용한다고 가정합니다. 설치 및 데이터베이스 설정은 이전
버전과다르지만,이모듈에서소개하는다른기능을실행하는데문제는없을겁니다. 설치및데이터베이스
설정에 대한 도움말은 사용자 플랫폼에 대한 PostGIS 문서를 참조하십시오.

16.1.1 우분투 설치

apt 를 통해 PostGIS 를 간단히 설치할 수 있습니다.

$ sudo apt-get install postgis
$ sudo apt-get install postgresql-9.1-postgis

네, 정말로 쉽죠...

주석: 사용자의 우분투 버전 및 설정한 저장소에 따라, 이 명령어로 PostGIS 1.5 나 2.x 버전이 설치됩니다.
psql 이나 다른 도구에서 select PostGIS_full_version(); 쿼리를 실행하면 설치된 버전을 알 수
있습니다.

PostGIS 최신 버전을 설치하려면 다음 명령어를 사용하면 됩니다.
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$ sudo apt-add-repository ppa:sharpie/for-science
$ sudo apt-add-repository ppa:sharpie/postgis-nightly
$ sudo apt-get update
$ sudo apt-get install postgresql-9.1-postgis-nightly

16.1.2 윈도우 설치

윈도우에 설치하는 것은 좀 더 복잡하지만, 어렵지는 않습니다. PostGIS 스택을 설치하려면 인터넷에
연결되어 있어야 합니다.

먼저 다운로드 페이지 로 가십시오.

그리고 이 지침 을 따르십시오.

PostGIS 웹사이트 에서 윈도우 설치에 대한 자세한 정보를 얻을 수 있습니다.

16.1.3 다른 플랫폼 설치

The PostGIS website has information about installing on other platforms including MacOSX and on
other linux distributions

16.1.4 PostGIS 를 사용하기 위한 데이터베이스 설정

PostGIS 설치가 끝나면 이 확장 프로그램을 사용하기 위해 사용자 데이터베이스를 설정해줘야 합니다.
PostGIS 2.0 버전 이상을 설치했다면, 이전 모듈에서 사용했던 주소 데이터베이스를 사용하는 다음 psql
명령어를 실행해서 손쉽게 설정할 수 있습니다.

$ psql -d address -c "CREATE EXTENSION postgis;"

주석: PostGIS 1.5 및 PostgreSQL 9.1 미만 버전을 사용하고 있을 경우, 사용자 데이터베이스에 Post-
GIS 확장 프로그램을 설치하려면 다른 단계들을 밟아야 합니다. 그 방법에 대한 지침은 PostGIS 문서 를
참조하십시오. 이 매뉴얼의 이전 버전 에서도 일부 지침을 찾을 수 있습니다.

16.1.5 설치된 PostGIS 의 기능 살펴보기

PostGIS 를 PostgreSQL 의 핵심 기능을 공간 데이터를 다룰 수 있도록 확장하는 데이터베이스 내장
기능들의 집합으로 생각할 수 있습니다. ‘다룬다’ 라는 말은 저장, 추출, 쿼리, 조작을 뜻합니다. 이를
위해, 데이터베이스에 많은 기능들이 설치되어 있습니다.

PostGIS 덕분에 이제 사용자의 PostgreSQL address 데이터베이스가 공간 데이터를 다룰 수 있게
되었습니다. 다음 강의에서 이를 심도 있게 살펴보겠지만, 먼저 간단한 예를 들어보겠습니다. 텍스트에서
포인트를 생성하려 한다고 해봅시다. 먼저 포인트에 관련된 기능을 찾기 위해 psql 명령어를 사용합니다.
아직 address 데이터베이스에 접속하지 않았다면 지금 하십시오. 그리고 다음 명령어를 실행합니다.

\df *point*

우리가 찾는 것은 st_pointfromtext 라는 명령어입니다. 아래 방향 화살표 키를 이용해 목록을 살펴본
다음, q 키를 눌러 psql 셸로 나오십시오.

다음 명령어를 실행해보십시오.

select st_pointfromtext('POINT(1 1)');

결과 :
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st_pointfromtext
--------------------------------------------
0101000000000000000000F03F000000000000F03F
(1 row)

세 가지 사실을 알 수 있습니다.

• POINT(1 1) 을 통해 1,1 위치에 (EPSG:4326 투영체를 적용) 포인트를 정의했습니다.

• SQL 선언문을 테이블이 아니라 SQL 프롬프트에서 입력된 데이터에 대해 실행했습니다.

• 결과물 행을 이해하기 힘듭니다.

결과물 행은 ‘WKB(Well Known Binary)’ 라는 OGC 포맷으로 되어 있습니다. 다음 강의에서 이 포맷을
자세히 살펴볼 것입니다.

결과물을 텍스트로 받아보려면, 텍스트를 반환하는 기능을 찾아 기능 목록을 검색해볼 수 있습니다.

\df *text

지금 찾고 있는 쿼리는 st_astext 입니다. 이 명령어를 이전 쿼리과 합쳐봅시다.

select st_astext(st_pointfromtext('POINT(1 1)'));

결과 :
st_astext

------------
POINT(1 1)
(1 row)

POINT(1,1) 을 입력해서 st_pointfromtext() 를 통해 포인트로 변환한 다음 st_astext() 로 사람이
읽을 수 있는 형태로 다시 바꿨습니다. 그 결과 원래 문자열을 반환했습니다.

다음은 PostGIS 사용법을 자세히 알아보기 전, 마지막 예시입니다.

select st_astext(st_buffer(st_pointfromtext('POINT(1 1)'),1.0));

어떤 의미일까요? 이 명령은 포인트 주변에 1˚ 의 버퍼를 생성하고 그 결과를 텍스트로 반환시킵니다.

16.1.6 공간 참조 시스템

PostGIS 는 이런 기능 외에도 EPSG(European Petroleum Survey Group) 가 정의한 SRS(spatial refer-
ence system) 모음을 포함하고 있습니다. CRS(coordinate reference system) 변환과 같은 작업 시 SRS 를
사용합니다.

SRS 가 일반 데이터베이스 테이블에 저장되어 있기 때문에, 사용자 데이터베이스에서 이 SRS 의 정의를
조사할 수 있습니다.

먼저 psql 프롬프트에 다음 명령어를 입력해서 테이블의 스키마를 살펴봅시다.

\d spatial_ref_sys

다음과 같은 결과가 나와야 합니다.

Table "public.spatial_ref_sys"
Column | Type | Modifiers

-----------+-------------------------+-----------
srid | integer | not null
auth_name | character varying(256) |
auth_srid | integer |
srtext | character varying(2048) |
proj4text | character varying(2048) |
Indexes:

"spatial_ref_sys_pkey" PRIMARY KEY, btree (srid)
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표준 SQL 쿼리를 (서론 부분에서 배웠던 것처럼) 사용해서 이 테이블을 보고 조작할 수 있습니다. 그러나
SRS 에 대해 잘 모른다면 어떤 레코드도 업데이트 혹은 삭제하지 않는 편이 좋습니다.

사용자가 관심을 가져야 할 SRID 가 있다면 바로 EPSG:4326 입니다. WGS84 타원체를 사용하는
지리/경위도 참조 시스템입니다. 한번 살펴봅시다.

select * from spatial_ref_sys where srid=4326;

결과 :

srid | 4326
auth_name | EPSG
auth_srid | 4326
srtext | GEOGCS["WGS 84",DATUM["WGS_1984",SPHEROID["WGS
84",6378137,298.257223563,AUTHORITY["EPSG","7030"]],TOWGS84[0,
0,0,0,0,0,0],AUTHORITY["EPSG","6326"]],PRIMEM["Greenwich",0,
AUTHORITY["EPSG","8901"]],UNIT["degree",0.01745329251994328,
AUTHORITY["EPSG","9122"]],AUTHORITY["EPSG","4326"]]
proj4text | +proj=longlat +ellps=WGS84 +datum=WGS84 +no_defs

srtext 가 WKT(well known text) 포맷으로 된 투영체 정의입니다. (사용자의 shapefile 가운데 .prj
파일에서 봤을 수도 있습니다.)

16.1.7 In Conclusion

이제 PostgreSQL 에 PostGIS 기능을 설치했습니다. 이것으로 PostGIS 의 광범위한 공간 기능들을 이용할
수 있게 되었습니다.

16.1.8 What’s Next?

다음으로 공간 피처가 데이터베이스 안에서 어떻게 표현되는지 알아보겠습니다.

16.2 Lesson: 단순 피처 모델

어떻게 데이터베이스 안에 지리 피처를 저장하고 표현할 수 있을까요? 이번 강의에서 OGC 가 정의한 단순
피처 모델이라는 한 가지 접근법을 배워보도록 합시다.

이 강의의 목표: SFS 모델이 무엇인지 그리고 어떻게 사용하는지 배우기.

16.2.1 OGC 란?

자발적인 국제 표준 합의 기구 OGC(Open Geospatial Consortium) 는 1994 년 창립되었다. 전 세계적으로
370 개 이상의 기업, 정부, 비영리 및 연구 조직들이 모여 지리공간 콘텐츠와 서비스, GIS 데이터 처리와
데이터 공유를 위한 표준 개발 및 시행을 장려하는 공개 합의 과정에 협력하고 있다. - 위키백과

16.2.2 SFS 모델이란?

SFS(Simple Feature for SQL) 모델은 데이터베이스에 비위상적인 방식으로 지리공간 데이터를 저장하고
이 데이터를 접근, 작업, 구성하는 기능들을 정의합니다.
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이 모델은 포인트, 라인스트링, 폴리곤 (그리고 이들의 집합인 다중 오브젝트) 유형으로 지리공간 데이터를
정의합니다.

더 자세한 정보를 알고 싶다면 OGC Simple Feature for SQL 표준을 참조하십시오.

16.2.3 테이블에 도형 필드 추가

사용자의 ‘people’ 테이블에 포인트 필드를 추가해봅시다.

alter table people add column the_geom geometry;

16.2.4 도형의 유형을 기반으로 하는 제약 조건 추가

도형 필드의 유형이 무조건 필드에 들어 있는 도형의 *유형 * 을 지정하지는 않는다는 사실을 눈치챘을
겁니다. 이를 위해서는 제약 조건이 필요합니다.

alter table people
add constraint people_geom_point_chk

check(st_geometrytype(the_geom) = 'ST_Point'::text OR the_geom IS NULL);

이렇게 테이블에 제약 조건을 걸면 포인트 도형 또는 널 값만을 받아들이게 됩니다.

16.2.5 Try Yourself 고급

‘cities’ 라는 새 테이블을 생성하고 폴리곤 (도시 경계) 을 저장하기 위한 도형 필드를 포함한 적절한 몇몇
열을 부여하십시오. 도형 필드가 폴리곤만을 받아들이도록 하는 제약 조건을 걸어야 합니다.

결과 확인

16.2.6 ‘geometry_columns’ 테이블 채우기

이제 geometry_columns 테이블에도 항목을 추가해야 합니다.
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insert into geometry_columns values
('','public','people','the_geom',2,4326,'POINT');

왜냐구요? 특정 응용 프로그램들이 데이터베이스에서 도형 데이터를 담고 있는 테이블을 찾을 때
geometry_columns 를 이용하기 때문입니다.

주석: 앞의 INSERT 선언문이 오류를 일으키면 우선 다음 쿼리를 실행하십시오.
select * from geometry_columns;

If the column :kbd:`f_table_name` contains the value :kbd:`people`, then
this table has already been registered and you don't need to do anything
more.

2 값은 차원의 개수를 의미합니다. 이 경우 x 와 y 2 개를 뜻합니다.

4326 값은 우리가 사용할 투영체를 의미합니다. 이 경우, 4326 이란 숫자는 (EPSG 에 대한 앞에서의
설명대로) WGS84 를 뜻합니다.

Try Yourself 초급

사용자의 ‘cities’ 레이어에 적합한 ‘geometry_columns’ 항목을 추가하십시오.

결과 확인

16.2.7 SQL 을 이용해 테이블에 도형 레코드 추가

이제 테이블에서 지리공간 데이터를 이용할 수 있으므로, 테이블에 도형을 저장할 수 있습니다.

insert into people (name,house_no, street_id, phone_no, the_geom)
values ('Fault Towers',

34,
3,
'072 812 31 28',
'SRID=4326;POINT(33 -33)');

주석: 이 새 항목에 대해, 사용하고자 하는 투영체 (SRID) 를 지정해야 합니다. 플레인 텍스트로 이 새
포인트 도형을 입력했기 때문에, 자동적으로 정확한 투영체 정보를 추가하지 못 합니다. 이 새 포인트는
당연히 자기가 추가되는 데이터셋과 동일한 SRID 를 사용해야 하므로, 이를 지정해주어야 합니다.

예를들어이시점에서 GUI를사용하고있을경우,각포인트에대해자동적으로투영체를지정할것입니다.
다시 말해 이전 단계에서처럼 데이터셋에 투영체를 설정했다면, 추가하고자 하는 모든 포인트에 정확한
투영체를 사용했는지 일반적으로 걱정할 필요가 없습니다.

이제 QGIS 를 실행해서 사용자의 people 테이블을 살펴보도록 합시다. 또, 레코드를 편집/추가/삭제한
다음 데이터베이스에 선택 쿼리를 실행해서 데이터가 어떻게 변경됐는지 보도록 합시다.

QGIS 에 PostGIS 레이어를 불러오려면, 메뉴에서 Layer → Add PostGIS Layers 항목을 선택하거나 다음
툴바 버튼을 클릭하십시오.

다음 대화 창이 나타날 것입니다.
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New 버튼을 클릭해서 다음 대화 창을 여십시오.
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다음처럼 새 연결을 정의하십시오.

Name: myPG
Service:
Host: localhost
Port: 5432
Database: address
User:
Password:

QGIS가 address데이터베이스를찾았는지,그리고사용자의사용자명과비밀번호가정확한지보려면 Test
Connect 를 클릭하십시오. 성공할 경우, Save Username 및 Save Password 옆의 체크박스를 체크하십시오.
그 다음 OK 를 클릭해서 이 연결을 생성합니다.
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다시 Add PostGIS Layers 대화 창으로 돌아가서, Connect 를 클릭한 다음 평상시처럼 사용자 프로젝트에
레이어를 추가하십시오.

Try Yourself 중급

인물의 성명, 도로명 및 (‘the_geom’ 열로부터) 위치를 플레인 텍스트로 보여주는 쿼리를 작성하십시오.

결과 확인

16.2.8 In Conclusion

사용자데이터베이스에공간오브젝트를추가하는방법및GIS소프트웨어에서해당오브젝트를보는방법을
배웠습니다.

16.2.9 What’s Next?

다음으로 어떻게 사용자 데이터베이스에 데이터를 가져오는지, 그리고 사용자 데이터베이스에서 데이터를
내보내는지 배울 것입니다.

16.3 Lesson: 임포트와 엑스포트

물론, 데이터를 가져오거나 내보내기 힘든 데이터베이스는 쓸모가 없습니다. 다행히도 PostGIS 에서
데이터를 쉽게 가져오거나 내보낼 수 있는 도구가 많이 있습니다.

16.3.1 shp2pgsql

shp2pgsql은데이터베이스에 ESRI shapefile을임포트할수있는커맨드라인도구입니다. 유닉스에서다음
명령어를 써서 새 PostGIS 테이블을 임포트할 수 있습니다.

shp2pgsql -s <SRID> -c -D -I <path to shapefile> <schema>.<table> | \
psql -d <databasename> -h <hostname> -U <username>

윈도우에서는, 임포트 과정을 다음 두 단계로 실행해야 합니다.

shp2pgsql -s <SRID> -c -D -I <path to shapefile> <schema>.<table> > import.sql
psql psql -d <databasename> -h <hostname> -U <username> -f import.sql

다음과 같은 오류가 발생할 수도 있습니다.

ERROR: operator class "gist_geometry_ops" does not exist for access method
"gist"

사용자가 임포트하는 데이터에 대한 공간 인덱스의 생성 *원위치 * 와 관련된, 잘 알려진 문제입니다.
이 오류를 피하려면 -I 파라미터를 제외하십시오. 이렇게 하면 공간 인덱스를 자동으로 생성하지 않고,
데이터를 임포트한 뒤 사용자가 데이터베이스에 직접 생성해야 합니다. (다음 강의에서 공간 인덱스 생성에
대해 배울 것입니다.)

16.3.2 pgsql2shp

pgsql2shp 는 PostGIS 테이블, 뷰, 또는 SQL 선택 쿼리를 엑스포트하는 커맨드라인 도구입니다.
유닉스에서는 이 명령어를 다음과 같이 사용합니다.
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pgsql2shp -f <path to new shapefile> -g <geometry column name> \
-h <hostname> -U <username> <databasename> <table | view>

쿼리를 이용해 데이터를 엑스포트하려면 다음과 같이 합니다.

pgsql2shp -f <path to new shapefile> -g <geometry column name> \
-h <hostname> -U <username> "<query>"

16.3.3 ogr2ogr

ogr2ogr 은 PostGIS 의 데이터를 다른 데이터 포맷으로 변환하거나, 다른 데이터 포맷을 PostGIS 데이터로
변환할 수 있는 매우 강력한 도구입니다. ogr2ogr 은 GDAL/OGR 소프트웨어의 일부로, 개별적으로
설치해야 합니다. PostGIS 의 테이블을 GML 로 엑스포트하려면 다음 명령어를 사용하면 됩니다.

ogr2ogr -f GML export.gml PG:'dbname=<databasename> user=<username>
host=<hostname>' <Name of PostGIS-Table>

16.3.4 SPIT

SPIT 은 QGIS 에 내장된 QGIS 플러그인입니다. ESRI shapefile 을 PostGIS 로 업로드하는 데 쓸 수
있습니다.

Plugin Manager 를 통해 SPIT 을 추가한 다음, 다음 버튼을 찾아보십시오.

이버튼을클릭하거나메뉴에서 Database –> Spit –> Import Shapefiles to PostgreSQL을선택하면다음과
같은 SPIT 대화 창이 뜹니다.
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Add 버튼을 클릭하면 데이터베이스에 shapefile 을 추가할 수 있는 파일 탐색기 창이 뜹니다.

16.3.5 DB 관리자

Database메뉴에서 DB Manager 라는또다른옵션을눈치챘을지도모르겠습니다. QGIS 2.0부터추가된이
새로운도구는 PostGIS를포함한공간데이터베이스와상호작용할수있는통합인터페이스를제공합니다.
또데이터베이스로다른포맷을임포트할수도,데이터베이스에서다른포맷으로엑스포트할수도있습니다.
다음 모듈이 거의 이 도구에 대한 내용이기 때문에, 여기에서는 간단히 언급만 하겠습니다.

16.3.6 In Conclusion

데이터베이스에 (서) 데이터를 임포트하거나 엑스포트하는 방법은 여러 가지가 있습니다. 특히 서로 전혀
다른 데이터소스를 이용할 경우, 상시적으로 이 기능들, 또는 다른 비슷한 기능들을 사용하게 될 것입니다.

16.3.7 What’s Next?

다음으로 이전에 생성했던 데이터를 어떻게 쿼리할 수 있는지 알아보겠습니다.

16.4 Lesson: 공간 쿼리

공간 쿼리는 다른 데이터베이스 쿼리와 크게 다르지 않습니다. 도형 열도 다른 어떤 데이터베이스 열과
똑같이사용할수있습니다. 데이터베이스에 PostGIS를설치하면,데이터베이스를쿼리할수있는추가적인
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기능들이 생깁니다.

이 강의의 목표: 공간 기능이 얼마나 “일반적인” 비공간 기능과 비슷하게 시행되는지 보기.

16.4.1 공간 연산자

포인트 (X,Y) 에서 2˚ 거리 안에 어떤 포인트가 있는지 알고 싶을 경우 다음과 같이 쿼리할 수 있습니다.

select *
from people
where st_distance(the_geom,'SRID=4326;POINT(33 -34)') < 2;

결과 :

id | name | house_no | street_id | phone_no | the_geom
----+--------------+----------+-----------+---------------+-----------------
6 | Fault Towers | 34 | 3 | 072 812 31 28 | 01010008040C0

(1 row)

주석: 앞의 ‘the_geom’ 값은 이 페이지의 공간을 절약하기 위해 중간에서 잘랐습니다. 사람이 읽을 수
있는 좌표로 포인트를 보려면, 앞의 “View a point as WKT” 부분에서 한 작업과 비슷하게 해보십시오.

이 쿼리가 2˚ 내에 있는 모든 포인트를 반환하는지 어떻게 알 수 있을까요? 왜 2m 가 아닐까요? 다른
단위를 쓸 수도 있지 않을까요?

결과 확인

16.4.2 공간 인덱스

사용자가 공간 인덱스도 정의할 수 있습니다. 공간 인덱스는 사용자의 공간 쿼리를 더 빠르게 해줍니다.
도형 열에 대해 공간 인덱스를 생성하려면 다음 선언문을 이용하십시오.

CREATE INDEX people_geo_idx
ON people
USING gist
(the_geom);

\d people

결과 :

Table "public.people"
Column | Type | Modifiers

-----------+-----------------------+----------------------------------------
id | integer | not null default

| | nextval('people_id_seq'::regclass)
name | character varying(50) |
house_no | integer | not null
street_id | integer | not null
phone_no | character varying |
the_geom | geometry |

Indexes:
"people_pkey" PRIMARY KEY, btree (id)
"people_geo_idx" gist (the_geom) <-- new spatial key added
"people_name_idx" btree (name)

Check constraints:
"people_geom_point_chk" CHECK (st_geometrytype(the_geom) = 'ST_Point'::text
OR the_geom IS NULL)

Foreign-key constraints:
"people_street_id_fkey" FOREIGN KEY (street_id) REFERENCES streets(id)
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16.4.3 Try Yourself 중급

‘cities’ 테이블을 수정해서 도형 열에 공간 인덱스를 생성하십시오.

결과 확인

16.4.4 PostGIS 공간 기능 시연

PostGIS의공간기능을시연하기위해,몇몇 (가상)데이터를담고있는새데이터베이스를생성하겠습니다.

첫 번째로, 새 데이터베이스를 생성하십시오. (먼저 psql 셸에서 나오십시오.)

createdb postgis_demo

PostGIS 확장 프로그램을 설치하는 것을 잊지 마십시오.

psql -d postgis_demo -c "CREATE EXTENSION postgis;"

두 번째로, exercise_data/postgis/ 디렉터리에서 제공하는 데이터를 임포트하십시오. 이전 강의에서
배운 내용대로 하되, 새 데이터베이스에는 새 PostGIS 연결을 생성해야 한다는 것을 기억하십시오.
터미널에서또는 SPIT을통해임포트할수있습니다. 파일을다음데이터베이스테이블에임포트하십시오.

• points.shp 를 building 테이블로

• lines.shp 파일을 road 테이블로

• polygons.shp 파일을 region 테이블로

평상시대로 Add PostGIS Layers 대화 창을 통해 이 세 데이터베이스 레이어를 QGIS 로 불러오십시오. 이
레이어들의 속성 테이블을 열면, id 필드와 함께 PostGIS 임포트 과정에서 생성된 gid 필드를 둘 다 가지고
있다는 사실을 알 수 있습니다.

이제테이블을임포트했으니, PostGIS를사용해서데이터를쿼리할수있습니다. 다시터미널 (커맨드입력
창) 으로 가서 다음 명령을 실행해서 psql 프롬프트로 들어가십시오.

psql postgis_demo

다음 선택된 선언문들을 시연해서 뷰를 생성하겠습니다. 이렇게 하면 QGIS 에서 뷰를 열어 결과물을 볼 수
있습니다.

위치에 따른 선택

KwaZulu 지역에 있는 모든 건물을 가져오십시오.

SELECT a.id, a.name, st_astext(a.the_geom) as point
FROM building a, region b

WHERE st_within(a.the_geom, b.the_geom)
AND b.name = 'KwaZulu';

결과 :

id | name | point
----+------+------------------------------------------
30 | York | POINT(1622345.23785063 6940490.65844485)
33 | York | POINT(1622495.65620524 6940403.87862489)
35 | York | POINT(1622403.09106394 6940212.96302097)
36 | York | POINT(1622287.38463732 6940357.59605424)
40 | York | POINT(1621888.19746548 6940508.01440885)

(5 rows)

또는, 다음과 같이 뷰를 생성할 경우,
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CREATE VIEW vw_select_location AS
SELECT a.gid, a.name, a.the_geom

FROM building a, region b
WHERE st_within(a.the_geom, b.the_geom)
AND b.name = 'KwaZulu';

QGIS 에 뷰를 레이어로 추가해서 볼 수 있습니다.

인접 검색

Hokkaido 지역에 붙어 있는 모든 지역들의 명칭 목록을 가져오십시오.

SELECT b.name
FROM region a, region b

WHERE st_touches(a.the_geom, b.the_geom)
AND a.name = 'Hokkaido';

결과 :
name

--------------
Missouri
Saskatchewan
Wales

(3 rows)

뷰 생성 :

CREATE VIEW vw_regions_adjoining_hokkaido AS
SELECT b.gid, b.name, b.the_geom

FROM region a, region b
WHERE TOUCHES(a.the_geom, b.the_geom)
AND a.name = 'Hokkaido';

QGIS 에서 뷰를 봅니다.
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오류 지역 (Queensland) 이 보이십니까? 위상 오류 때문일지도 모릅니다. 이런 오류는 데이터 안에 어떤
잠재적인문제가있다고경고해주는것일수있습니다. 데이터에있을지도모르는이상을피해이수수께끼를
풀려면, 대신 버퍼 인터섹트를 이용할 수 있습니다.

CREATE VIEW vw_hokkaido_buffer AS
SELECT gid, ST_BUFFER(the_geom, 100) as the_geom

FROM region
WHERE name = 'Hokkaido';

Hokkaido 지역 주변에 100m 의 버퍼를 생성했습니다.

어두운 영역이 버퍼입니다.
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이 버퍼를 써서 선택합니다.

CREATE VIEW vw_hokkaido_buffer_select AS
SELECT b.gid, b.name, b.the_geom

FROM
(
SELECT * FROM

vw_hokkaido_buffer
) a,
region b
WHERE ST_INTERSECTS(a.the_geom, b.the_geom)
AND b.name != 'Hokkaido';

이 쿼리에서 다른 어떤 테이블과도 마찬가지로 원래 버퍼 뷰를 사용했습니다. 뷰에 a 라는 가칭을 부여하고,
a.the_geom 이라는 해당 뷰의 도형 필드를 사용해서 region 테이블 (가칭 b ) 에서 뷰와 교차하는 모든
폴리곤을 선택했습니다. 그러나 Hokkaido 자체는 이 선택 선언문에서 제외되었습니다. 해당 지역이 아니라
인접한 지역만을 원하기 때문입니다.

QGIS 에서 뷰를 봅니다.
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버퍼 생성이라는 추가적인 단계 없이 어떤 주어진 거리 안에 있는 모든 오브젝트를 선택할 수도 있습니다.

CREATE VIEW vw_hokkaido_distance_select AS
SELECT b.gid, b.name, b.the_geom

FROM region a, region b
WHERE ST_DISTANCE (a.the_geom, b.the_geom) < 100
AND a.name = 'Hokkaido'
AND b.name != 'Hokkaido';

이렇게 하면 임시적인 버퍼 단계 없이도 동일한 결과를 달성할 수 있습니다.
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유일 값 선택

Queensland 지역에 있는 모든 건물들에 대해 유일한 도시명 목록을 가져오십시오.

SELECT DISTINCT a.name
FROM building a, region b

WHERE st_within(a.the_geom, b.the_geom)
AND b.name = 'Queensland';

결과 :
name

---------
Beijing
Berlin
Atlanta

(3 rows)

심화 예시

CREATE VIEW vw_shortestline AS
SELECT b.gid AS gid, ST_ASTEXT(ST_SHORTESTLINE(a.the_geom, b.the_geom)) as

text, ST_SHORTESTLINE(a.the_geom, b.the_geom) AS the_geom
FROM road a, building b
WHERE a.id=5 AND b.id=22;

CREATE VIEW vw_longestline AS
SELECT b.gid AS gid, ST_ASTEXT(ST_LONGESTLINE(a.the_geom, b.the_geom)) as

text, ST_LONGESTLINE(a.the_geom, b.the_geom) AS the_geom
FROM road a, building b
WHERE a.id=5 AND b.id=22;

CREATE VIEW vw_road_centroid AS
SELECT a.gid as gid, ST_CENTROID(a.the_geom) as the_geom

FROM road a
WHERE a.id = 1;

CREATE VIEW vw_region_centroid AS
SELECT a.gid as gid, ST_CENTROID(a.the_geom) as the_geom

FROM region a
WHERE a.name = 'Saskatchewan';

SELECT ST_PERIMETER(a.the_geom)
FROM region a

WHERE a.name='Queensland';

SELECT ST_AREA(a.the_geom)
FROM region a

WHERE a.name='Queensland';

CREATE VIEW vw_simplify AS
SELECT gid, ST_Simplify(the_geom, 20) AS the_geom

FROM road;

CREATE VIEW vw_simplify_more AS
SELECT gid, ST_Simplify(the_geom, 50) AS the_geom

FROM road;

CREATE VIEW vw_convex_hull AS
SELECT

ROW_NUMBER() over (order by a.name) as id,
a.name as town,
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ST_CONVEXHULL(ST_COLLECT(a.the_geom)) AS the_geom
FROM building a
GROUP BY a.name;

16.4.5 In Conclusion

PostGIS 의 새로운 데이터베이스 기능을 사용해 공간 오브젝트를 쿼리하는 방법을 배웠습니다.

16.4.6 What’s Next?

다음으로 좀 더 복잡한 도형의 구조 및 PostGIS 를 써서 생성하는 방법을 알아보겠습니다.

16.5 Lesson: 도형 구조

이 강의에서 우리는 SQL 로 단순한 도형을 구성하는 방법에 대해 좀 더 깊이 알아볼 것입니다. 실제
상황에서는 아마도 QGIS 같은 GIS 의 디지타이즈 작업 도구를 사용해서 복잡한 도형을 생성할 테지만,
도형이 어떻게 구성되는지 이해한다면 쿼리 작성 및 데이터베이스가 어떻게 조성되는지 이해하는 데 도움이
될 수 있습니다.

이 강의의 목표: PostgreSQL/PostGIS 에서 직접 공간 엔티티를 생성하는 방법을 더 잘 이해하기.

16.5.1 라인스트링 생성

address데이터베이스로돌아가서, ‘streets’테이블을다른테이블과일치시켜봅시다. 다시말하자면도형에
제약 조건을 걸고, ‘geometry_columns’ 테이블에 인덱스 및 항목을 추가해봅시다.

16.5.2 Try Yourself 중급

• Modify the streets table so that it has a geometry column of type

ST_LineString. * Don’t forget to do the accompanying update to the geometry columns table! * Also
add a constraint to prevent any geometries being added that are not LINESTRINGS or null. * Create
a spatial index on the new geometry column

결과 확인

이제 ‘streets’테이블에라인스트링을인서트해봅시다. 이경우,다음과같이기존도로레코드를업데이트할
것입니다.

update streets set the_geom = 'SRID=4326;LINESTRING(20 -33, 21 -34, 24 -33)'
where streets.id=2;

QGIS 에서 결과를 살펴보십시오. (Layers 패널에서 ‘streets’ 레이어를 오른쪽 클릭한 다음 Zoom to layer
extent 를 선택해야 할 수도 있습니다.)

이제 QGIS 에서 그리고 커맨드 입력 창에서 더 많은 도로 항목을 생성하십시오.

16.5.3 폴리곤 생성

폴리곤 생성 작업도 아주 쉽습니다. 다만 한 가지, 폴리곤은 정의상 적어도 네 꼭짓점을 가지며, 첫 번째와
마지막 꼭짓점이 동일한 위치에 있다는 사실을 기억해야 합니다.
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insert into cities (name, the_geom)
values ('Tokyo', 'SRID=4326;POLYGON((10 -10, 5 -32, 30 -27, 10 -10))');

주석: 폴리곤의 좌표 목록에 이중 괄호를 사용해야 합니다. 이렇게 하면 서로 연결되지 않은 복수의 영역을
가진 복잡한 폴리곤을 추가할 수 있습니다. 다음은 그 예입니다.

insert into cities (name, the_geom)
values ('Tokyo Outer Wards', 'SRID=4326;POLYGON((20 10, 20 20, 35 20, 20 10),

(-10 -30, -5 0, -15 -15, -10 -30))');

이단계를따라했다면, QGIS에 ‘cities’데이터셋을불러와서속성테이블을열고새항목을선택해서결과를
확인할 수 있습니다. 이 두 폴리곤이 어떻게 하나의 폴리곤처럼 반응하는지 살펴보십시오.

16.5.4 예제 : 도시와 인물을 연결

이 예제를 위해 다음 단계를 거쳐야 합니다.

• ‘people’ 테이블에서 모든 데이터를 삭제하십시오.

• ‘people’ 테이블에 ‘cities’ 테이블의 기본 키를 참조하는 외래 키를 추가하십시오.

• QGIS 를 사용해 몇몇 도시를 디지타이즈하십시오.

• SQL 을 이용해서 새 인물 레코드를 몇 개 인서트하고, 각 레코드가 관련 도로 및 도시 정보를 갖고
있는지 확인하십시오.

사용자가 업데이트한 ‘people’ 스키마가 다음과 비슷해야 합니다.

\d people

Table "public.people"
Column | Type | Modifiers

-----------+-----------------------+--------------------------------------------
id | integer | not null

| | default nextval('people_id_seq'::regclass)
name | character varying(50) |
house_no | integer | not null
street_id | integer | not null
phone_no | character varying |
the_geom | geometry |
city_id | integer | not null

Indexes:
"people_pkey" PRIMARY KEY, btree (id)
"people_name_idx" btree (name)

Check constraints:
"people_geom_point_chk" CHECK (st_geometrytype(the_geom) =

'ST_Point'::text OR the_geom IS NULL)
Foreign-key constraints:
"people_city_id_fkey" FOREIGN KEY (city_id) REFERENCES cities(id)
"people_street_id_fkey" FOREIGN KEY (street_id) REFERENCES streets(id)

결과 확인

16.5.5 사용자 스키마 살펴보기

이 시점에서 사용자의 스키마가 이렇게 보여야 합니다.
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16.5.6 Try Yourself 고급

해당도시의주소를모두포함하는최소컨벡스헐 (minimum convex hull)영역및해당영역주변의버퍼를
계산해서 도시 경계를 생성하십시오.

16.5.7 하위 오브젝트에 접근

SFS 모델 기능을 통해 SFS 도형의 하위 오브젝트에 접근할 수 있는 광범위한 옵션을 쓸 수 있습니다.
‘myPolygonTable’ 테이블의 모든 폴리곤 도형의 첫 번째 꼭짓점을 선택하고 싶다면, 다음과 같은 방법을
사용해야 합니다.

• 폴리곤 경계선을 라인스트링으로 변환하십시오.

select st_boundary(geometry) from myPolygonTable;

• 그 결과 생성된 라인스트링의 첫 번째 꼭짓점을 선택하십시오.

select st_startpoint(myGeometry)
from (

select st_boundary(geometry) as myGeometry
from myPolygonTable) as foo;

16.5.8 데이터 처리

PostGIS 는 OGC SFS/MM 표준을 따르는 모든 기능을 지원합니다. 이 기능들의 명칭은 모두 ST_ 로
시작합니다.

16.5.9 클리핑

ST_INTERSECT() 기능을 사용해서 사용자 데이터의 하위 부분을 오려낼 수 있습니다. 비어 있는 도형을
오려내지 않으려면 다음 조건문을 사용하십시오.

where not st_isempty(st_intersection(a.the_geom, b.the_geom))
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select st_intersection(a.the_geom, b.the_geom), b.*
from clip as a, road_lines as b
where not st_isempty(st_intersection(st_setsrid(a.the_geom,32734),
b.the_geom));
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16.5.10 다른 도형에서 도형 생성

어떤 주어진 포인트 테이블에서 라인스트링을 생성하고자 합니다. 포인트의 순서는 id 로 정의됩니다.
또다른 배열 방법으로, GPS 수신기로 웨이포인트를 캡처할 때 얻게 되는 것과 같은 타임스탬프를 쓸 수도
있습니다.

‘points’ 라는 새 포인트 레이어에서 라인스트링을 생성하려면, 다음 명령어를 실행하면 됩니다.

select ST_LineFromMultiPoint(st_collect(the_geom)), 1 as id
from (
select the_geom
from points
order by id

) as foo;

새 레이어를 생성하지 않고 이 결과를 보려면 ‘people’ 레이어에 대해 이 명령어를 실행할 수도 있지만, 물론
실재 세계에서는 아무런 의미도 없습니다.
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16.5.11 도형 청소

이 주제에 대해 이 블로그 포스트 에서 더 자세한 정보를 얻을 수 있습니다.

16.5.12 테이블 사이의 차이점

동일한구조를가진두테이블간의차이점을알아내려면 PostgreSQL키워드인 EXCEPT를사용하면됩니다.

select * from table_a
except
select * from table_b;

이렇게 하면 table_a 의 레코드 가운데 table_b 에는 없는 모든 레코드를 얻을 수 있습니다.

16.5.13 테이블스페이스

사용자가 테이블스페이스를 생성해서 PostgreSQL 이 디스크 어디에 데이터를 저장해야 하는지 정의할 수
있습니다.

CREATE TABLESPACE homespace LOCATION '/home/pg';
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데이터베이스 생성 시, 다음과 같은 명령어를 통해 사용할 테이블스페이스를 지정할 수 있습니다.

createdb --tablespace=homespace t4a

16.5.14 In Conclusion

PostGIS 선언문을 사용해서 좀 더 복잡한 도형을 생성하는 방법을 배웠습니다. 이 강의는 대부분 GIS
프론트엔드를 통해 지리공간 기능이 활성화된 데이터베이스와 작업할 때를 위해 사용자의 관습적인 지식을
향상시키기위한것이라는사실을기억하십시오. 보통이런선언문들을수작업으로입력해야할경우는거의
없지만, 도형의 구조를 대강이나마 아는 것은 GIS 를 사용할 때 도움이 될 것입니다. 특히 구조를 모르는
경우 암호문처럼 보일 오류를 맞닥뜨렸을 때 말입니다.
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CHAPTER 17

QGIS 처리 과정 지침서

빅터 올라야 (Victor Olaya) 가 이 모듈을 작성했습니다.

목차:

17.1 개요

이 지침서는 QGIS 처리 과정 프레임워크 사용법을 설명합니다. 사용자가 처리 과정 프레임워크는 물론
의존하는 응용 프로그램들에 대해 아무것도 모른다고 가정하고 있습니다. QGIS 에 대한 기초 지식은
가지고 있다고 가정합니다. 스크립트에 대한 부분에서는 사용자가 파이썬, 그리고 아마도 QGIS 파이썬
API 에 대한 기초 지식을 가지고 있다고 가정합니다.

이 지침서는 독학, 또는 처리 과정 워크샵을 운영하는 데 쓸 수 있도록 설계되었습니다.

이 지침서의 예제들은 QGIS 2.0 을 사용합니다. 해당 버전이 아닌 경우 기능이 동작하지 않거나, 없을 수도
있습니다.

이 지침서는 점진적으로 복잡해지는 짧은 예제들로 이루어져 있습니다. 한 번도 처리 과정 프레임워크를
이용해본 적이 없다면, 맨 처음부터 시작해야 합니다. 이전에 이용해본 적이 있다면, 강의를 건너뛰어도
괜찮습니다. 이 모듈의 강의들은 거의 서로 직접적인 관계가 없고, 각 강의는 그 제목과 강의 시작 부분에
있는 짧은 개요로 알 수 있는 새로운 개념 또는 새로운 요소를 소개하고 있습니다. 따라서 특정 주제를
다루고 있는 강의를 찾기 쉬울 것입니다.

프레임워크의 구성 요소들과 그 사용법에 대한 더 체계적인 설명을 원한다면 QGIS 매뉴얼에서 상응하는
부분을 확인해보는 것이 좋습니다. 이 지침서의 부교재로 이용하십시오.

All the exercises in this guide use free data set that can be downloaded here. The zip file to download
contains several folders corresponding to each one of the lessons in this guide. In each of them you will
find a QGIS project file. Just open it and you will be ready to start the lesson.

즐기세요!

17.2 시작하기 전 중요한 경고

워드프로세서의 매뉴얼이 사용자에게 소설이나 시를 쓰는 법을 가르쳐주지 않듯이, 또는 CAD 예제가
건물 기둥의 규격을 계산하는 법을 알려주지 않듯이, 이 지침서도 공간 분석 방법을 가르치지 않습니다.
대신, 공간 분석을 수행할 수 있는 강력한 도구인 QGIS 처리 과정 프레임워크를 사용하는 방법을 보여줄
것입니다. 그러나 해당 분석 유형을 이해하는 데 필요한 필수 개념들을 배우는 일은 사용자에게 달렸습니다.
이런 개념들을 모르고서는 프레임워크와 그 알고리듬을 사용하는 의미가 없지만, 그래도 해보고 싶을지도
모르겠군요.

예시를 통해 더 명확히 말해봅시다.
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포인트들과 각 포인트에 부여된 다양한 값들이 있다고 할 때, 사용자는 Kriging (크리그 격자법) 알고리듬을
이용해서 포인트들로부터 래스터 레이어를 계산할 수 있습니다. 이 모듈의 파라미터 대화 창은 다음과
같습니다.

복잡해보이죠?

이지침서를공부하면해당모듈을어떻게사용하는지,수백개의포인트레이어들로부터래스터레이어들을
한 번에 생성하는 배치 처리 과정을 어떻게 실행하는지, 또는 입력 레이어에서 일부 포인트를 선택하면
어떻게 되는지 배우게 될 것입니다. 하지만 파라미터 자체에 대한 설명은 없습니다. 지리통계에 대해 잘
알고 있는 숙련된 분석가라면 이 파라미터들을 쉽게 이해할 것입니다. 사용자가 이런 경우가 아니라면
그리고 sill, range, 또는 nugget 같은 개념을 잘 모른다면 Kriging 모듈을 사용해서는 안 됩니다. 그뿐만
아니라 Kriging 모듈을 사용할 준비가 전혀 안 되었다고 할 수 있습니다. 사용자가 들어본 적도 없는, 또는
적어도 충분히 공부하지 않은 공간 자동상관관계 (spatial autocorrelation) 나 반분산도 (semivariogram)
같은 개념을 이해하고 있어야 하기 때문입니다. QGIS 에서 실제로 이 모듈을 실행하고 분석을 수행하기
전에, 먼저 이런 개념들을 공부하고 이해해야 합니다. 이런 단계를 거치지 않고서는 잘못된 결과와 형편없는
(그리고 대부분 쓸모없는) 분석을 얻게 될 것입니다.

모든 알고리듬이 크리그 격자법처럼 복잡한 것은 아니지만 (다만 일부는 더 복잡하기도 합니다!) 대부분의
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경우 해당 알고리듬이 기반하고 있는 핵심적인 분석 방안을 이해하고 있어야 합니다. 그런 지식 없이
알고리듬을 사용할 경우 대부분 형편 없는 결과로 이어질 것입니다.

공간 분석에 대한 충분한 기초 없이 지리 알고리듬을 사용하는 것은 문법이나 통사론, 그리고 스토리텔링에
대해 아무것도 모른 채 소설을 써보려고 하는 것과 다름없습니다. 결과를 얻을 수는 있겠지만, 어떤 가치도
없을 것입니다. 부탁합니다. 이 지침서를 읽으면 공간 분석을 수행해서 괜찮은 결과를 얻을 수 있을 거라고
자신을 속이지 마십시오. 공간 분석에 대해서도 공부해야 합니다.

공간 데이터 분석에 대해 좀 더 배울 수 있는 좋은 자료가 있습니다.

Geospatial Analysis (3rd Edition): A Comprehensive Guide to Principles, Techniques and Software Tools
Michael John De Smith, Michael F. Goodchild, Paul A. Longley

온라인 에서 구할 수 있습니다.

17.3 처리 과정 프레임워크 설정

처리 과정 프레임워크를 사용하기 전에 먼저 설정부터 해줘야 합니다. 설정할 것이 별로 없으므로, 쉬운
작업이 될 것입니다.

이후에사용가능한알고리듬목록을확장하는데쓰이는외부응용프로그램을설정하는방법을배우겠지만,
이 시점에서는 프레임워크 자체만을 가지고 작업하겠습니다.

처리 과정 프레임워크는 QGIS 의 핵심 플러그인입니다. 즉 QGIS 2.0 을 실행하고 있을 경우, QGIS 에
내장되어 있으므로 사용자 시스템에 이미 설치되어 있다는 의미입니다. 프레임워크가 활성화되어 있다면
메뉴에 Processing 이라는 메뉴가 보일 것입니다. 해당 메뉴를 통해 모든 프레임워크 구성 요소에 접근할 수
있습니다.

해당 메뉴를 찾을 수 없다면, 플러그인 관리자에서 활성화시켜야 합니다.
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우리가 작업하게 될 주요 요소는 툴박스입니다. 상응하는 메뉴 항목을 클릭하면 QGIS 창의 오른쪽에
툴박스가 붙는 것을 볼 수 있습니다.

이툴박스는그룹으로구분된사용가능한알고리듬목록을담고있습니다. 이알고리듬을표출하고조직하는
방법으로 고급 (advanced) 모드와 단순 (simplified) 모드가 있습니다.

기본적으로 알고리듬이 수행하는 작업의 유형에 따라 그룹을 나누는 단순 모드를 보게 됩니다. 툴박스에
보이는 알고리듬 가운데 일부 (사실 거의 대부분) 는 다른 외부 응용 프로그램에 의존하고 있지만, 이
응용 프로그램에 대한 설명을 볼 수는 없습니다. 처리 과정 프레임워크를 통해 알고리듬을 사용하는 일을
단순화시키는 단순 모드에서는 알고리듬의 기원이 숨겨져 있습니다.
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이 지침서의 예제는 단순 모드만을 사용합니다. 고급 모드는 추가적인 기능 및 알고리듬을 갖추고 있지만,
호출하는 응용 프로그램에 대해 이해해야 하기 때문에 좀 더 고급 단계의 주제입니다. 지침서의 마지막
부분에서 몇몇 고급 주제를 소개하고 있지만, 다른 부분에서는 단순화된 인터페이스만 사용할 것입니다.

툴박스 하단의 선택자를 통해 단순 모드와 고급 모드를 변경할 수 있습니다.

고급 모드를 사용할 때, 툴박스가 다음과 같이 보입니다.

이시점까지왔다면이제지리알고리듬을사용할준비가된것입니다. 지금다른설정을할필요는없습니다.
다음 강의에서 첫 번째 알고리듬을 실행해보겠습니다.

17.4 첫 번째 알고리듬 실행과 툴박스

주석: 이 강의에서 첫 번째 알고리듬을 실행하고, 첫 번째 결과를 얻을 것입니다.

앞에서 언급했듯이, 처리 과정 프레임워크는 다른 응용 프로그램에서 알고리듬을 실행할 수도 있지만,
외부 소프트웨어 없이 실행할 수 있는 자체 알고리듬을 내장하고 있기도 합니다. 처리 과정 프레임워크에
대해 알아보기 위해 이 자체 알고리듬 가운데 하나를 실행해보겠습니다. 먼저 폴리곤 집합의 중심점을
계산해봅시다.

먼저 이 강의에 해당하는 QGIS 프로젝트를 여십시오. 폴리곤 두 개가 있는 레이어 하나를 담고 있습니다.
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그다음,툴박스맨위에있는텍스트박스를선택하십시오. 이박스는검색란으로,여기에텍스트를입력하면
입력한텍스트를포함하는알고리듬만보이도록목록을필터링합니다. centroids를입력하면다음과같은
화면을 보게 될 것입니다.

검색란을 통해 사용자가 찾는 알고리듬을 매우 실용적인 방식으로 검색할 수 있습니다.

알고리듬을 실행하려면, 툴박스에서 그 명칭을 더블클릭하기만 하면 됩니다. Centroids 알고리듬을
더블클릭하면, 다음 대화 창이 나타날 것입니다.
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모든 알고리듬은 비슷한 인터페이스를 가지고 있습니다. 기본적으로 사용자가 입력해야 하는 입력
파라미터와,결과를어디에저장할지선택해야하는출력파라미터입니다. 이경우에입력레이어는폴리곤을
담고있는벡터레이어하나뿐입니다. 단일피처가다중영역피처일경우중심점을여러개원하는지선택할
수 있는 선택자도 있는데, 이 선택자를 선택하지 않으면 알고리듬이 각 피처 당 중심점 하나씩만 생성할
것입니다.

입력에 ‘polygons’ 레이어를 선택하십시오. 입력 레이어가 다중 영역 피처를 담고 있지 않기 때문에, 다른
항목은 어떤 역할도 하지 못 합니다.

알고리듬이 중심점 레이어 하나를 출력합니다. 데이터 출력물을 어디에 저장할지 정의하는 두 가지 옵션이
있습니다. 파일 경로를 입력하거나, 임시 파일명으로 저장할 수 있습니다.

결과물을 임시 파일로 저장하지 않고 저장 위치를 설정하고자 할 경우, 파일 확장자로 출력물의 포맷을
정의합니다. 포맷을 선택하려면 해당 포맷에 대응하는 파일 확장자를 선택하면 됩니다. (또는 파일 경로를
직접입력하는경우, 확장자를추가하십시오.) 사용자가입력한파일경로의파일확장자가지원하는포맷이
아닐 경우, 기본 확장자 (일반적으로 테이블은 .dbf, 래스터 레이어는 .tif, 벡터 레이어는 .shp ) 가 파일
경로에 추가되어 해당 확장자에 상응하는 파일 포맷으로 레이어나 테이블을 저장할 것입니다.

이 지침서의 모든 예제에서 결과물을 임시 파일로 저장할 것입니다. 이후에 다른 용도로 쓰기 위해 저장할
필요가 없기 때문입니다. 사용자가 원한다면 항구적인 위치에 저장해도 됩니다.

QGIS 를 종료하면 모든 임시 파일도 삭제된다는 점을 명심하십시오. 출력물을 임시 파일로 저장하는
프로젝트를 생성했다면, 다음에 해당 프로젝트를 열었을 때 출력 파일이 존재하지 않기 때문에 QGIS 가
경고 메시지를 표출할 것입니다.

알고리듬 대화 창의 설정을 완료했다면 Run 을 클릭해서 알고리듬을 실행하십시오.

다음 출력물을 얻게 됩니다.
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출력물은 입력물과 동일한 CRS 를 사용합니다. 지리 알고리듬은 모든 입력 레이어가 동일한 CRS 를
공유한다고가정하며어떤재투영작업도하지않습니다. 몇몇특별한알고리듬 (예를들면재투영알고리듬)
을 제외하면, 출력물도 동일한 CRS 를 사용합니다. 곧 이에 대해 더 자세히 다루게 될 것입니다.

서로 다른 파일 포맷으로 저장해보십시오. (에를 들어 확장자로 shp 와 geojson 을 각각 사용해보십시오.)
또 출력 레이어를 생성한 다음 QGIS 에 불러오고 싶지 않을 경우, 출력물 경로 박스 아래 있는 체크박스를
해제하면 됩니다.

17.5 더 많은 알고리듬과 데이터 유형

주석: 이 강의에서 알고리듬 3 개를 더 실행해보면서 다른 입력 유형을 사용하는 방법 및 주어진 폴더에
자동적으로 출력물을 저장하도록 설정하는 방법을 배워보겠습니다.

이 강의에는 테이블과 폴리곤 레이어가 필요합니다. 테이블에 저장된 좌표를 기반으로 포인트 레이어를
생성한 다음, 각 폴리곤 내부에 위치하는 포인트의 개수를 알아낼 것입니다. 이번 강의에 해당하는 QGIS
프로젝트를열면, X와 Y좌표를담고있는테이블을찾을수있지만폴리곤레이어를찾을수는없을겁니다.
걱정하지 마십시오. 처리 과정 알고리듬을 통해 폴리곤 레이어를 생성할 것입니다.

The first thing we are going to do is to create a points layer from the coordinates in the table, using the
Convert table to points algorithm. You now know how to use the search box, so it should not be hard
for you to find it. Double–click on it to run it and get to its following dialog.

이전 강의에서와 마찬가지로 이 알고리듬은 산출물 하나를 생성하는데, 입력 파라미터는 3 개입니다.

• Table : 좌표를 저장하고 있는 테이블. 여기에 강의 데이터에서 찾은 테이블을 선택해야 합니다.

• X & Y field : 이 두 파라미터는 첫 번째 파라미터와 연결돼 있습니다. 해당 선택자가 앞에서
선택한 테이블의 사용 가능한 필드의 명칭을 보여줄 것입니다. X 파라미터에 XCOORD 필드를,
Y 파라미터에 YCOORD 필드를 선택하십시오.

• CRS : 이 알고리듬은레이어를 입력받지 않으므로, 입력레이어를따라 산출레이어에 CRS 를할당할
수 없습니다. 그 대신, 사용자가 테이블의 좌표가 사용하는 CRS 를 직접 선택하도록 합니다. 오른쪽
버튼을 클릭해서 QGIS CRS 선택자를 열고, 산출물 CRS 로 EPSG:4326 을 선택하십시오. 테이블에
저장된 좌표의 CRS 이기 때문에 해당 CRS 를 선택하는 것입니다.
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대화 창이 다음과 같이 보여야 합니다.

이제 Run 버튼을 클릭해서 다음 레이어를 얻으십시오.

다음으로 폴리곤 레이어가 필요합니다. Create grid 알고리듬을 사용해서 균일 격자 폴리곤을 생성할
것입니다. 이 알고리듬은 다음과 같은 파라미터 대화 창을 띄웁니다.
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격자를생성하는데필요한입력값이모두숫자입니다. 숫자값을입력해야할경우,두가지옵션이있습니다.
해당 란에 직접 입력하든지, 오른쪽에 있는 버튼을 클릭해서 다음 그림과 같은 대화 창을 불러오면 됩니다.
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이대화창은간단한계산기를포함하고있어서, 11 * 34.7 + 4.6같은표현식을입력하면결과를계산해서
파라미터 대화 창의 해당 텍스트 박스에 입력해줍니다. 또, 사용자가 쓸 수 있는 상수 및 다은 레이어에서
나온 값들도 포함하고 있습니다.

In this case, we want to create a grid that covers the extent of the inut points layer, so we should use its
coordinates to calculate the center coordinate of the grid and its width and height, since those are the
parameters that the algorithm takes to create the grid. With a little bit of math, try to do that yourself
using the calculator dialog and the constants from the input points layer.

Type 항목에 Rectangles (polygons) 를 선택하십시오.

이전 알고리듬과 마찬가지로, 여기에도 CRS 를 입력해야 합니다. 이전과 동일하게 target CRS 에
EPSG:4326 을 선택하십시오.

이제 파라미터 대화 창이 다음과 같이 보여야 합니다.
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Run 을 클릭하면 다음과 같은 격자선 레이어를 얻게 됩니다.

444 Chapter 17. QGIS 처리 과정 지침서



QGIS Training Manual, 출시 2.2

마지막 단계로 이 격자선의 사각형 하나하나에 들어가는 포인트의 개수를 계산해야 합니다. Count points
in polygons 알고리듬을 사용하겠습니다.

이제 우리가 찾던 결과를 보게 되었습니다.

이 강의를 끝내기 전에, 사용자가 고집스럽게 사용자 데이터를 저장하고자 할 경우 더 쉽게 설정할 수 있는
방법이 있습니다. 사용자가 모든 산출물 파일을 어떤 주어진 폴더에 저장하고자 할 경우, 매번 폴더 경로를
입력할 필요가 없습니다. 대신 메뉴에서 Processing → Options and configuration 항목을 선택하십시오.
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다음 설정 대화 창이 나타날 것입니다.

General 그룹에서 Output folder 항목을 찾아, 사용자의 지정 경로를 입력하십시오.
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이제부터 알고리듬 실행 시, 전체 경로 대신 파일명만 입력하십시오. 예를 들어 앞의
설정대로라면, 방금 실행했던 알고리듬의 산출물 경로에 graticule.shp 라고 입력한 경우 산출물을
D:processing_outputgraticule.shp 로 저장할 것입니다. 산출물을 다른 폴더에 저장하고 싶다면 전체
경로를 입력할 수 있습니다.

Create grid 알고리듬을 통해 다른 격자 크기는 물론 다른 격자 유형으로 만들어보십시오. 다음 강의에서는
육각 격자를 사용할 것입니다.

17.6 CRS 와 재투영

주석: 이 강의에서 처리 과정 프레임워크의 CRS 이용법을 배울 것입니다. 또 재투영이라는 매우 유용한
알고리듬도 살펴볼 것입니다.

QGIS 처리 과정 사용자는 대부분 CRS 를 혼란스러워합니다. 따라서 새 레이어 생성 시 지리 알고리듬이
CRS 를 어떻게 다루는지에 대한 몇몇 일반적인 규칙을 설명하겠습니다.

• 입력레이어가있을경우첫번째레이어의 CRS를사용합니다. 모든레이어의 CRS가동일해야하기
때문에, 첫 번째 레이어의 CRS 를 모든 레이어의 CRS 라고 가정하는 것입니다. 서로 일치하지 않는
CRS 를 사용하는 레이어들을 쓸 경우, QGIS 가 경고 메시지를 띄울 것입니다. 파라미터 대화 창에
입력 레이어의 CRS 가 레이어명과 함께 나타난 다는 사실을 명심하십시오.

• 입력레이어가없을경우, 알고리듬이 (이전강의의격자선알고리듬처럼)특정 CRS필드를담고있지
않는 이상, 프로젝트 CRS 를 사용합니다.

이 강의에 해당하는 프로젝트를 열어보면 23030 및 4326 이라는 두 레이어를 볼 수 있습니다. 양쪽 다
동일한 포인트들을 담고 있지만, 서로 다른 CRS( EPSG:23030 및 EPSG:4326 ) 를 사용합니다. QGIS 가
실시간 재투영으로 프로젝트 CRS( EPSG:4326 ) 로 재투영하기 때문에 같은 위치에 있는 것으로 보일 뿐,
실제로 동일한 레이어는 아닙니다.

Export/Add geometry columns 알고리듬을 실행하십시오.
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이 알고리듬이 벡터 레이어의 속성 테이블에 새 열을 추가합니다. 해당 열의 내용은 레이어의 도형 유형에
따라 달라집니다. 포인트일 경우 각 포인트의 X 및 Y 좌표를 담은 새 열들을 추가합니다.

입력 레이어 항목에서 찾은 사용 가능한 레이어 목록에서, 각 레이어를 그에 대응하는 CRS 와 함께 보게 될
것입니다. 즉 아무리 사용자의 맵 캔버스 위에 동일한 위치로 나타나더라도, 서로 다르게 다루어질 것이라는
의미입니다. 4326 레이어를 선택하십시오.

이 알고리듬의 또 하나의 파라미터로 어떻게 알고리듬이 좌표를 이용, 결과 레이어에 추가할 새 값을
계산하는지 설정할 수 있습니다. 알고리듬 대부분은 이런 옵션을 지원하지 않고, 좌표를 직접 이용할
뿐입니다. Layer CRS 옵션을 선택해서 좌표 그자체로 이용하십시오. 대부분의 지리 알고리듬도 이렇게
작동합니다.

다른 두 레이어와 정확하게 동일한 포인트를 담은 새 레이어를 얻게 될 것입니다. 레이어명을 오른쪽
클릭해서 속성을 열어보면, 입력 레이어의 CRS 인 EPSG:4326 을 사용한다는 사실을 알게 될 것입니다.
QGIS 가 이 레이어를 불러올 때, 해당 레이어의 CRS 를 입력하라고 묻지 않을 것입니다. QGIS 가 이미
알고 있기 때문입니다.

새 레이어의 속성 테이블을 열어보면 각 포인트의 X 및 Y 좌표를 담은 2 개의 새 필드를 담고 있는 것을
보게 될 것입니다.

448 Chapter 17. QGIS 처리 과정 지침서



QGIS Training Manual, 출시 2.2

이 좌표값들은 레이어의 CRS 를 사용합니다. 해당 옵션을 선택했기 때문입니다. 그러나 사용자가 다른
옵션을 선택했더라도, 입력 레이어의 CRS 를 사용해 산출물 레이어의 CRS 를 설정하기 때문에, 산출물의
CRS는동일했을것입니다. 다른옵션을선택했더라면값은달라졌겠지만산출포인트가달라지거나산출물
레이어의 CRS 가 입력 레이어의 CRS 와 달라지지는 않습니다.

이제 다른 레이어를 사용해 동일한 계산을 하십시오. 산출물 레이어가 다른 레이어들과 정확히 동일한
위치에 렌더링됩니다. 이 레이어는 입력 레이어의 CRS 인 EPSG:23030 을 사용할 것입니다.

해당 레이어의 속성 테이블을 열어보면, 첫 번째로 생성한 레이어와는 다른 값들을 볼 수 있을 것입니다.

원래 데이터가 (다른 CRS 를 사용했기 때문에) 다르며, 이 다른 데이터에서 좌표를 가져왔기 때문입니다.

여기에서 무엇을 배울 수 있을까요? 이 예제의 중요한 의미는 지리 알고리듬이 레이어를 원래 데이터소스
그대로사용하며, QGIS가렌더링하기전에어떤재투영을하더라도그것을철저히무시한다는사실입니다.
다시 말해 맵 캔버스에 보이는 것을 믿지 말고, 원래 데이터가 사용된다는 사실을 항상 기억해야 한다는
뜻입니다. 이 경우에는 한 번에 하나의 레이어만 사용했기 때문에 그렇게 중요한 사실은 아니지만, 복수의
레이어가 필요한 (클리핑 알고리듬 같은) 알고리듬의 경우 일치하거나 겹치는 것처럼 보이는 레이어들이
서로 다른 CRS 를 사용하고 있을 수도 있기 때문에 실제로는 서로 매우 다를 수도 있습니다.

알고리듬은 (다음에 배울 재투영 알고리듬을 제외하면) 재투영을 수행하지 않습니다. 따라서 레이어들이
동일한 CRS 를 사용하도록 사용자가 확인해야 합니다.

재투영알고리듬은 CRS를다루는흥미로운모듈입니다. 이알고리듬은매우특별한경우인데, (재투영하게
될) 입력 레이어를 사용하지만, 입력 레이어의 CRS 를 산출물의 CRS 로 사용하지 않기 때문입니다.

Reprojection 알고리듬을 실행하십시오.
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아무 레이어나 입력 레이어로 선택한 다음, 산출물의 CRS 로 EPSG:23029 를 선택하십시오. 알고리듬을
실행하면 입력 레이어와 동일하지만, 다른 CRS 를 사용하는 새 레이어를 얻게 됩니다. QGIS 가 실시간
재투영을 하기 때문에 다른 레이어들과 마찬가지로 맵 캔버스의 동일한 지역에 나타나지만, 원래 좌표는
다릅니다. 이새레이어를입력레이어로사용해 Add geometry columns알고리듬을실행해서,먼저계산했던
두 레이어의 속성 테이블에 있는 값과는 다른 좌표가 추가되었다는 사실을 확인할 수 있습니다.

17.7 선택 집합

주석: 이 강의에서 처리 과정 알고리듬이 어떻게 입력물로 사용되는 벡터 레이어에서의 선택 집합을
다루는지, 그리고 특정 알고리듬 유형을 사용해 선택 집합을 생성하는지 배울 것입니다.

QGIS 의 다른 분석 플러그인들과는 달리, 처리 과정 지리 알고리듬에는 “선택한 피처들만 사용” 이라는
체크박스나 그 비슷한 옵션이 없습니다. 모든 알고리듬에서 선택에 관련된 작업은 각 알고리듬 실행 시
수행되는 것이 아니라, 플러그인 하나를 통채로 사용합니다. 벡터 레이어 사용 시 알고리듬은 다음과 같은
간단한 규칙을 따릅니다.

• 레이어에 선택 집합이 있을 경우, 선택된 피처만 사용합니다.

• 선택 집합이 없다면 모든 피처를 사용합니다.

이전 강의에서 사용했던 어떤 레이어에서 포인트 몇 개를 선택한 다음 재투영 알고리듬을 실행해서 직접
시험해볼 수 있습니다. 재투영된 산출 레이어는 사용자가 선택했던 포인트만 담고 있을 것입니다. 선택한
포인트가 없을 경우 산출 레이어는 원래 레이어의 모든 포인트를 담고 있을 것입니다.

선택 집합을 만들려면 QGIS 에서 사용할 수 있는 어떤 방법이나 도구를 사용할 수 있습니다. 하지만
알고리듬을 사용해서 선택할 수도 있습니다. 툴박스의 Vector/Selection 그룹에서 선택 집합을 생성하는
알고리듬을 찾을 수 있습니다.
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Random selection 알고리듬을 실행하십시오.

기본 값을 유지하면, 현재 레이어에서 포인트 10 개를 선택할 것입니다.
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이알고리듬은산출물을생성하지않지만,입력레이어를 (레이어자체가아니라그선택집합을)수정한다는
사실을 알 수 있습니다. 다른 모든 알고리듬은 입력 레이어를 건드리지 않고 새 레이어를 생성하기 때문에
이는 굉장히 희귀한 작동 방식입니다.

선택집합이데이터자체의일부가아니며 GIS내부에서만존재하기때문에,이선택알고리듬을사용하려면
QGIS 에 열려 있는 레이어를 선택해야만 합니다. 해당 파라미터 항목에서 찾을 수 있는 파일 선택 옵션을
사용해서는 안 됩니다.

다른 선택 알고리듬으로 생성한 것과 마찬가지로, QGIS 에서 방금 만든 선택 집합을 수작업으로 생성할
수도 있기 때문에 어째서 선택 작업에 알고리듬을 써야 하는지 의문을 가질 수도 있습니다. 이 시점에서는
말이 안 되는 것 같겠지만, 이후 모델 및 스크립트를 생성하는 방법을 배울 예정입니다. (처리 과정 작업
흐름을 정의하는) 모델 형성 과정에서 선택 집합을 만들고자 할 경우, 오직 지리 알고리듬만 모델에 추가할
수 있습니다. 다른 QGIS 요소 및 작업을 추가할 수는 없습니다. 이것이 다른 QGIS 요소를 통해서도 가능한
기능들을 복제한 처리 과정 알고리듬들이 존재하는 이유입니다.

현재로써는 처리 과정 알고리듬을 사용해 선택 집합을 생성할 수 있으며, 알고리듬은 선택 집합이 존재할
경우 선택된 피처만을 사용하고, 존재하지 않을 경우 모든 피처를 사용한다는 사실만을 기억하십시오.

17.8 외부 알고리듬 실행

주석: 이 강의에서 제 3 자 응용 프로그램에 의존하는 알고리듬의 사용법을 배울 것입니다. 특히 주요
알고리듬 제공자 가운데 하나인 SAGA 에 대해 배워보겠습니다.

우리가지금까지실행했던알고리듬은모두처리과정프레임워크의일부였습니다. 그러니까, 플러그인에서
시행되어 마치 플러그인 자체를 실행하는 것처럼 QGIS 가 실행하는 자체 (native) 알고리듬입니다. 하지만,
처리 과정 프레임워크의 가장 훌륭한 기능 가운데 하나가 외부 응용 프로그램으로부터 알고리듬을 사용해서
해당 응용 프로그램의 가능성을 확장시킬 수 있다는 점입니다. 이런 알고리듬들은 잘 포장되어 툴박스에
포함되어 있으므로 QGIS 에서 쉽게 쓸 수 있으며, QGIS 데이터를 사용해 실행할 수 있습니다.

단순 뷰에서 볼 수 있는 알고리듬 중 일부를 사용하려면 제 3 자 응용 프로그램을 사용자 시스템에 설치해야
합니다. 이 가운데 특히 관심을 기울여야 할 알고리듬 제공자가 SAGA(System for Automated Geospatial
Analysis) 입니다. 이 강의 마지막에서 Convergence index 라는 알고리듬을 실행할 텐데, SAGA 가 제공한
이 알고리듬은 DEM 에서 형상 측정 (morphometrical measurement) 을 계산합니다. 그러나 먼저, QGIS
가 제대로 SAGA 를 호출할 수 있도록 모든 것을 설정해야 합니다. 그렇게 어려운 일은 아니지만, SAGA 가
어떻게 작동하는지 이해하는 것이 중요합니다. 외부 응용 프로그램은 각각 자신만의 설정을 가지고 있으며,
이 지침서의 이후 부분에서 다른 응용 프로그램에 대해서도 배우겠지만, SAGA 가 주요 백엔드 (backend)
가 될 것이므로 여기에서는 SAGA 에 대해 이야기하겠습니다.

윈도우 시스템의 경우 외부 알고리듬 작업을 위한 가장 좋은 방법은 OSGeo4W 인스톨러를 통해 QGIS 를
설치하는 것입니다. OSGeo4W 인스톨러가 SAGA 를 포함하는 필요한 모든 의존성을 설치해주기 때문에
이 인스톨러를 사용했다면 아무것도 할 필요가 없습니다. 설정 대화 창을 열고 Providers/SAGA 그룹을
찾으십시오.
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이미 SAGA 경로가 설정되어 SAGA 가 설치된 폴더를 가리키고 있을 것입니다.

OSGeo4W 인스톨러를 통해 QGIS 를 설치하지 않았다면, (사용자가 개별적으로 설치해야만 하는) SAGA
설치 경로를 입력해야 합니다. SAGA 2.1 버전이 필요합니다.

리눅스 시스템의 경우, 처리 과정 설정에서 SAGA 설치 경로를 설정할 필요가 없습니다. 그 대신 SAGA
를 설치한 다음, 콘솔에서 SAGA 를 호출할 수 있도록 SAGA 폴더가 PATH 에 포함되었는지 확인하십시오.
(콘솔을 열고 saga_cmd 를 입력해 확인하면 됩니다.) 리눅스에서도 2.1 버전이 필요하지만, (OSGeo Live
DVD 같은) 몇몇 설치의 경우 2.0.8 버전밖에 사용할 수 없을지도 모릅니다. 사용자가 쓸 수 있는 2.1 버전
패키지가 몇 개 있기는 하지만 일반적인 방법으로 설치하기도 어렵고 문제가 생길 수도 있으므로, 좀 더
일반적이고 안정적인 2.0.8 버전을 사용하고 싶다면 설정 대화 창의 SAGA 그룹에 있는 2.0.8 호환성을
활성화하면 됩니다.
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SAGA 설치가 완료되면 다른 알고리듬과 마찬가지로 알고리듬 명칭을 더블클릭해서 실행할 수 있습니다.
단순인터페이스를사용하고있기때문에어떤알고리듬이 SAGA혹은다른외부응용프로그램을기반으로
하고 있는지 알 수 없지만, 우연히 그런 알고리듬을 더블클릭했는데 상응하는 응용 프로그램이 설치되지
않았을 경우 다음과 같은 메시지 창을 보게 됩니다.

SAGA 를 제대로 설치하고 설정했다면 이 메시지 창을 볼 일이 없습니다. 그 대신 다음과 같은 파라미터
대화 창을 보게 될 것입니다.

그러면 Split shapes layer randomly 라는 SAGA 기반 알고리듬을 실행해봅시다.
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이 강의에 해당하는 프로젝트의 포인트 레이어를 입력으로 설정하고 다른 파라미터 값을 그대로 둘 경우
다음과 비슷한 결과를 얻게 됩니다. (스플릿이 임의로 일어나므로 사용자의 결과는 다를 수도 있습니다.)

입력 레이어가 각각 동일한 개수의 포인트를 담은 레이어 두 개로 스플릿되엇습니다. SAGA 가 이 결과물을
계산한 QGIS 가 결과물을 가져와 QGIS 프로젝트에 추가한 것입니다.

모든 작업이 잘 이루어졌다면 이전에 실행했던 다른 알고리듬과 이 SAGA 기반 알고리듬을 구분하지 못할
것입니다. 그러나 어떤 이유에서인지 SAGA 가 결과물을 생산하지 못 해 QGIS 가 기대하고 있던 파일을
생성하지 못 할 수도 있습니다. 이럴 경우 결과물을 QGIS 프로젝트에 추가하는 과정에서 문제가 발생,
다음과 같은 메시지를 보게 될 것입니다.
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SAGA 가 (또는 처리 과정 프레임워크가 호출하는 어떤 다른 응용 프로그램이든) 제대로 설치되었다
하더라도 이런 문제가 발생할 수 있기 때문에, 이런 문제에 대응하는 법을 아는 것이 중요합니다. 이런
오류 메시지를 나타나게 해봅시다.

Create graticule from extent 알고리듬을 실행하고 다음과 같은 값들을 사용하십시오.

설정된 범위보다 큰 높이 및 너비 값을 사용했기 때문에 SAGA 가 어떤 산출물도 생산하지 못 합니다. 다시
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말하면파라미터값이잘못되었는데도 SAGA가이값을받아서격자선을계산하려할때까지값을확인하지
않는다는 뜻입니다. SAGA 가 결과를 생성하지 못 하므로, 기대했던 레이어를 생산하지 못 하게 되고, 앞에
나왔던 오류 메시지를 띄우게 됩니다.

이런 유형의 문제를 이해하면 해당 문제를 해결하고, 어떤 일이 일어나고 있는지에 대한 설명을 찾는 데
도움이 됩니다. 오류 메시지에서 볼 수 있듯이 SAGA 와의 연결이 제대로 작동하고 있는지 확인하기 위한
테스트를 수행했다는 사실은 알고리듬이 실행된 방식에 문제가 있을지도 모른다는 것을 암시하고 있습니다.
이 사실은 SAGA 뿐만이 아니라 다른 외부 응용 프로그램들에도 동일하게 적용됩니다.

다음강의에서지리알고리듬이실행하는명령어에대한정보를저장하는처리과정로그를소개하겠습니다.
앞에서 본 것과 같은 문제가 발생했을 때, 어떻게 더 자세한 정보를 얻을 수 았는지 배울 것입니다.

17.9 처리 과정 로그

주석: 이 강의에서 처리 과정 로그에 대해 설명합니다.

처리 과정 프레임워크가 수행하는 모든 분석을 자체 로그 시스템이 기록하고 있습니다. 이를 통해 문제 발생
시 해결하기 위해 처리 과정 도구가 어떤 작업을 했는지 더 자세히 알 수 있습니다. 또 로그 시스템이 일종의
쌍방향성을 지원하기 때문에 이전 작업을 재실행할 수도 있습니다.

로그를 열어보려면 처리 과정 메뉴에 있는 해당 항목을 선택하십시오. 다음 대화 창이 나타날 것입니다.

Info, Error, Warnings 그리고 Algorithms 라는 네 개의 정보 항목을 담고 있습니다. 다음은 그 각각에 대한
설명입니다.

• Info : 몇몇 알고리듬은 여기에 자신의 실행에 대한 정보를 남길 수도 있습니다. 예를 들면, 외부
응용 프로그램을 호출하는 알고리듬은 일반적으로 해당 응용 프로그램의 콘솔 산출물을 이 항목에
기록합니다. 여기를 살펴보면, 이전 강의에서 실행했던 (그리고 입력 데이터가 정확하지 않아 실행에
실패했던) SAGA 알고리듬의 산출물이 여기에 저장되어 있는 것을 알 수 있을 겁니다.
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This is helpful to understand what is going on. Advanced users will be able to analyze that output to
find out why the algorithm failed. IF you are not an advanced user, this will be useful for others to help
you diagnose the problem you are having, which might be a problem in the installation of the external
software or an issue with the data you provided.

• Warnings : 알고리듬을 실행할 수 있다 하더라도, 결과물이 정확하지 않을 경우 몇몇 알고리듬은
경고 메시지를 띄울 수도 있습니다. 예를 들면 아주 적은 개수의 포인트를 가지고 보간법 알고리듬을
실행했을경우입니다. 알고리듬을실행하고결과를생산할수도있지만,좀더많은포인트를사용해야
하기때문에,결과물이정확하지않을가능성이높습니다. 사용자가주어진알고리듬의어떤면에대해
잘 모를 경우, 이런 경고 유형을 주기적으로 확인하는 편이 좋습니다.

• Error : 외부 응용 프로그램과 직접 연관되지 않은 오류가 발생하면 이 항목에 기록됩니다.

• Algorithms : 콘솔이아니라 (이지침서의이후에서설명할) GUI에서실행되었더라도,이로그항목에
실행된모든알고리듬을콘솔호출로 저장합니다. 즉사용자가알고리듬을실행할때마다로그에콘솔
명령어를 추가하므로, 사용자의 작업 이력이 전부 기록됩니다. 다음은 그 이력의 예입니다.
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이 로그는 콘솔 작업을 시작할 때, 알고리듬의 문법을 배우는 데 굉장히 유용합니다. 콘솔에서 어떻게 분석
명령어를 실행하는지 설명할 때 이 로그를 이용할 것입니다.

이 이력은 쌍방향성도 가지고 있기 때문에, 이전에 실행했던 알고리듬이라면 어떤 것이든 더블클릭해서
재실행할 수 있습니다. 이를 통해 이전에 이미 했던 작업을 손쉽게 복제할 수 있습니다.

예를 들면 다음을 실행해보십시오. 이 지침서의 첫 번째 강의에 해당하는 데이터를 열어 그 강의에서
설명하는알고리듬을실행하십시오. 이제로그대화창을열고목록에서여러분이방금실행했던알고리듬에
해당하는마지막알고리듬을찾아보십시오. 그알고리듬을더블클릭하면,일반적인경우의대화창을이용해
툴박스에서 호출해서 실행했을 때와 동일한 새로운 결과물을 생산할 것입니다.

17.9.1 고급

사용자가 알고리듬을 수정할 수도 있습니다. 로그에서 복사한 다음, 메뉴에서 Plugins
→ Python console 을 열고 Import class → Import Processing class 항목을 클릭한 후,
붙여넣고 마음대로 텍스트를 변경해서 분석을 재실행하십시오. 결과물 파일을 맵에 표출하려면
iface.addVectorLayer('/path/filename.shp', 'Layer name in legend', 'ogr') 이라고
입력하십시오.

17.10 래스터 계산기와 비 (�) 데이터 값

주석: 이 강의에서 래스터 레이어에 대한 몇몇 작업을 수행하는 데 어떻게 래스터 계산기를 사용하는지
배워보겠습니다. 또 비 데이터 값이 무엇인지, 래스터 계산기와 다른 알고리듬이 비 데이터 값을 어떻게
다루는지도 배울 것입니다.
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래스터 계산기는 가장 강력한 알고리듬 가운데 하나입니다. 매우 탄력적이고 다용도인 알고리듬으로, 여러
가지 계산에 쓸 수 있어, 사용자의 툴박스에서 중요한 부분이 될 것입니다.

이 강의에서 래스터 계산기를 써서 거의 단순한 편인 몇 가지 계산을 수행할 것입니다. 이를 통해 래스터
계산기를 어떻게 사용하는지, 특별한 상황이 발생할 경우 어떻게 그런 상황을 다루는지 알게 될 것입니다.
이후 래스터 계산기 사용 시 기대한 결과를 얻는 것, 그리고 일반적으로 적용되는 특정 기법들을 이해하는
것이 중요합니다.

이 강의에 해당하는 QGIS 프로젝트를 여십시오. 래스터 레이어 몇 개를 담고 있습니다.

이제 툴박스를 열고 래스터 계산기 대화 창을 실행하십시오.

이 대화 창은 파라미터 2 개를 가지고 있습니다.

• Raster layers 는 분석에 쓰일 레이어입니다. 사용자가 원하는 만큼 많은 레이어를 선택할 수 있는
다중 입력이 가능합니다. 오른쪽에 있는 버튼을 클릭하면 나타나는 대화 창에서 사용자가 사용하길
원하는 레이어들을 선택하십시오.

• Formula 는 적용할 공식입니다. 이 공식은 앞에서 선택한 레이어를 알파벳 문자 ( :kdb:‘a, b, c...‘ )
또는 :kdb:‘g1, g2, g3...‘ 를 변수명으로 사용합니다. 즉 :kdb:‘a + 2 * b‘ 와 :kdb:‘g1 + 2 * g2‘
는 동일하며, 첫 번째 레이어의 값에 두 번째 레이어의 값의 두 배를 더한 합계를 계산할 것입니다. 이
레이어들의 순서는 선택 대화 창에 보이는 순서와 동일합니다.

경고: 래스터 계산기는 대소문자를 구분합니다.

DEM 의 단위를 미터에서 피트로 변경하는 작업부터 시작할 것입니다. 다음 공식을 사용하면 됩니다.

h' = h * 3.28084

Raster layers 필드에서 DEM 을 선택한 다음 Formula 필드에 a * 3.28084 를 입력하십시오.

경고: 소수점으로 , 가 아니라, 언제나 . 를 써야 합니다.
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Run 을 클릭해서 알고리듬을 실행하십시오. 입력 레이어와 동일한 모양이지만 값이 다른 레이어를 얻게
됩니다. 우리가사용한입력레이어가모든셀에유효한값을담고있으므로,마지막파라미터에어떤영향도
끼치지 못 합니다.

이번에는 accflow 레이어에 대해 다른 계산을 수행해봅시다. 이 레이어는 수자원 파라미터인 누적 수량
(accumulated flow) 값을 담고 있습니다. 주어진 유역의 영역 안에 있는 값만을 담고 있으며, 영역 밖은
비 데이터 값입니다. 값들이 분포되어 있는 방식 때문에 렌더링된 레이어에서 정보를 얻기가 힘든 것을 볼
수 있습니다. 누적 수량의 로그를 쓰면 훨씬 유익하게 표현할 수 있습니다. 래스터 계산기를 써서 로그를
계산해보겠습니다.

알고리듬 대화 창을 다시 열고, 입력 레이어에 accflow 레이어만 선택한 다음, log(a) 라는 공식을
입력하십시오.

다음과 같은 레이어를 얻게 될 것입니다.

If you select the Identify tool to know the value of a layer at agiven point, select the layer that we have
just created, and click on a point outside of the basin, you will see that it contains a no–data value.
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다음예제에서레이어하나가아니라두개를사용해서두번째레이어가정의하고있는유역범위안에있는
유효한 표고값만을 가진 DEM 을 얻어보겠습니다. 래스터 계산기 대화 창을 열고 Raster layers 필드에
프로젝트의 두 레이어를 모두 선택하십시오. Formula 필드에 다음 공식을 입력하십시오.

a/a * b

a 가 (목록에 첫 번째로 나타나기 때문에) 누적 수량 레이어를 가리키고, b 가 DEM 을 가리킵니다. 공식의
처음 부분에서 누적 수량 레이어를 자기 자신으로 나누어 유역 안의 값을 모두 1 로, 바깥의 값을 비 데이터
값으로 만듭니다. 이것을 DEM 으로 곱하면 유역 안의 셀에 표고값이 (DEM * 1 = DEM) 생성되고, 바깥의
셀에 비 데이터 값이 (DEM * no_data = no_data) 생성됩니다.

다음과 같은 레이어가 산출됩니다.

이 기술은 래스터 레이어 안의 값을 마스킹 하는 데 자주 쓰입니다. 래스터 레이어가 사용하는 임의적인
사각형 지역이 아닌 다른 모양의 지역에 대해 계산을 수행하고자 할 때 유용합니다. 예를 들면 래스터
레이어의 표고 히스토그램에는 그렇게 큰 의미가 없습니다. 하지만 유역에 해당하는 값만을 사용해서 (앞의
경우와같이)계산할경우얻게되는것은실제로유역의지형에대한정보를제공하는의미있는결과입니다.

방금 실행한 이 알고리듬에는 비 데이터 값과 이를 다루는 방식 외에도 또다른 흥미로운 점이 있습니다.
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방금 계산에 사용한 두 레이어의 범위를 살펴보면 (레이어 목록에서 레이어명을 더블클릭해서 속성을 보면
됩니다)두레이어의범위가다르다는것을알수있습니다. 누적수량레이어가커버하는범위가전체 DEM
의 범위보다 작기 때문입니다.

즉 두 레이어가 일치하지 않으며, 레이어 하나 혹은 모두를 리샘플링해서 레이어의 크기와 범위를 통일하지
않으면 일대일로 곱할 수 없다는 의미입니다. 그런데 우리는 아무 일도 하지 않았습니다. QGIS 가 이
상황을 처리해서, 필요할 경우 자동적으로 입력 레이어들을 리샘플링하는 것입니다. 산출물의 범위는 입력
레이어들로부터 계산된 최소 범위이며, 셀 크기는 두 레이어에서 계산된 최소 셀 크기가 됩니다.

이경우 (그리고거의대부분의경우)래스터계산기가훌륭한결과물을생산하지만,그아래에서이루어지는
추가적인작업에대해서도알고있어야합니다. 결과에영향을미필수도있기때문입니다. 래스터계산기가
바람직하지 않은 결과를 내놓을 경우, 미리 수작업으로 리샘플링 작업을 해놓아야 합니다. 이후 다른
강의들에서복수의래스터레이어를사용할때알고리듬이어떻게동작하는지에대해자세히배울것입니다.

다른 마스킹 예제로 이 강의를 끝내겠습니다. 표고가 1000 에서 1500 사이인 모든 영역의 평균 경사도를
계산해보겠습니다.

이 경우 마스킹 레이어로 사용할 레이어가 없지만, 래스터 레이어를 이용해서 계산할 수 있습니다.

입력 레이어에 DEM 만 선택하고, 다음 공식을 써서 래스터 계산기를 실행하십시오.

ifelse(abs(a-1250) < 250, 1, 0/0)

이와같이래스터계산기는간단한산술적인작업만이아니라조건문을이용하는좀더복잡한계산도실행할
수 있습니다.

우리가 작업하고자 하는 영역 내부의 셀은 1, 외부 셀은 비 데이터 값을 가지는 결과물이 생성됩니다.

비 데이터 값은 0/0 표현식에서 나옵니다. 비 데이터 값이 부정확한 값이기 때문에, SAGA 는 NaN(Not
a Number) 값을 추가해서 실제 비 데이터 값인 것처럼 처리합니다. 이런 방법으로 셀의 비 데이터 값이
실제로 어떤 값인지 알 필요 없이 비 데이터 값을 설정할 수 있습니다.

이제이결과물레이어를프로젝트에포함된경사도레이어와곱하기만하면원하던결과를얻을수있습니다.

래스터 계산기에서 이 모든 작업을 단 한 번에 처리할 수도 있습니다. 어떻게 할 수 있는지 여러분이 직접
시험해보십시오.

17.11 벡터 계산기

주석: 이 강의에서는 벡터 계산기를 이용해 수리적 표현식을 기반으로 벡터 레이어에 새 속성을 추가하는
방법을 배울 것입니다.
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우리는 이미 래스터 계산기에서 어떻게 수리적 표현식을 이용해 새 래스터 레이어를 생성하는지 알고
있습니다. 이와 비슷한 벡터 레이어용 알고리듬이 있습니다. 입력 레이어와 동일하지만, 입력한 표현식의
결과를 속성값으로 추가한 새 레이어를 생성하는 Field calculator 알고리듬입니다. 파라미터 대화 창은
다음과 같습니다.

주석: 처리 과정 새 버전의 인터페이스는 많이 바뀌었습니다.

이 알고리듬을 사용하는 예제들을 보겠습니다.

먼저 인구 조사를 나타내는 각 폴리곤에 있는 백인의 인구 밀도를 계산해봅시다. 이를 위해 속성 테이블에서
WHITE와 SHAPE_AREA필드두개를사용할수있습니다. 이두값을나누고 (평방킬로미터당밀도를구하기
위해) 1 백만을 곱해야 하므로, Formula 필드에 다음 공식을 쓸 수 있습니다.

( WHITE / SHAPE_AREA ) * 1000000

파라미터 대화 창을 다음과 같이 설정하십시오.

WHITE_DENS 라는 명칭의 새 필드를 생성할 것입니다.

다음으로 MALES 와 FEMALES 필드의 비율을 계산해서 남성 인구가 여성 인구보다 우세한지 보여주는 새
필드를 생성해봅시다.

다음 공식을 입력하십시오.

float(MALES) / FEMALES

이번에는 OK 버튼을 클릭하기 전에 파라미터 대화 창을 다음과 같이 설정해야 합니다.

464 Chapter 17. QGIS 처리 과정 지침서



QGIS Training Manual, 출시 2.2

Both fields are of type integer, and the result would be truncate to an integer. That’s why we have
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added the float() function, to indicate that we want floating point number a result. You can use other
Python functions as needed, since the calculator supports python commands (the raster calculator,
however, doesn’t).

Since the formula field accepts Python syntax, we can have a new field with male or female text strings
instead of those ratio value, using the following formula instead.

'male' if MALES > FEMALES else 'female'

파라미터 창이 다음과 같이 보여야 합니다.

A more powerful python field calculator is available in the “Advanced Python field calculator”, which
will not be detailed here
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17.12 범위 정의

주석: 이 강의에서 일부 알고리듬, 특히 래스터 관련 알고리듬이 필요로 하는 범위를 정의하는 방법을 배울
것입니다.

일부 알고리듬은 자신이 수행하는 분석이 커버해야 할 영역을 정의하는 범위를 필요로 합니다. 일반적으로
이 범위는 결과물 레이어의 범위를 정의하게 됩니다.

범위가 필요할 경우, 범위를 정의하는 값 4 개 (min X, min Y, max X, max Y) 를 직접 입력해서 정의할 수
있지만, 좀 더 실용적이고 재미 있는 방식으로 정의할 수도 있습니다. 이번 강의에서 그 모든 방식을 다룰
것입니다.

먼저 범위를 정의해야 하는 알고리듬을 선택해봅시다. 벡터 레이어에서 래스터 레이어를 생성하는 Shapes
to grid 알고리듬을 실행하십시오.
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마지막 2 개를 제외한 모든 파라미터는 어떤 레이어를 래스터화할지 정의하고, 래스터화 과정을 어떻게
작업할지 설정하는 데 쓰입니다. 그러나 마지막 파라미터 2 개는 산출 레이어의 특성을 정의합니다. 다시
말해 (입력벡터레이어가커버하는영역과일치하지않을수도있는)커버할영역과, (벡터레이어에는셀이
없기 때문에 벡터 레이어에서 가져올 수 없는) 해상도/셀 크기를 정의합니다.

사용자가 처음 할 수 있는 일은 앞에서 설명한 4 개의 정의 값을 쉼표로 구분해서 입력하는 것입니다.

별도의설명은필요없을것입니다. 이작업이가장탄력적인옵션이기는하지만,어떤경우실용적이지않을
수도 있습니다. 이것이 다른 옵션들이 존재하는 이유입니다. 이 옵션들에 접근하려면, Output extent(xmin,
xmax, ymin, ymax) 텍스트 란 오른쪽에 있는 버튼을 클릭해야 합니다.

이 옵션들이 어떤 일을 하는지 하나씩 알아봅시다.

첫 번째 옵션은 다음 선택 대화 창을 띄우는 Use layer/canvas extent 입니다.

468 Chapter 17. QGIS 처리 과정 지침서



QGIS Training Manual, 출시 2.2

캔버스의 (현재 줌 단계에서 커버하는) 범위 혹은 사용할 수 있는 레이어 가운데 아무 범위나 선택할 수
있습니다. 선택한 다음 OK 를 클릭하면, 텍스트 란에 자동적으로 상응하는 값을 채울 것입니다.

두번째옵션은 Select extent on canvas 입니다. 이경우알고리듬대화창이사라지고, QGIS캔버스상에서
클릭 & 드래그하여 원하는 범위를 정의할 수 있습니다.

마우스 버튼을 놓으면 대화 창이 다시 나타나는데, 정의한 범위에 상응하는 값이 이미 텍스트 란을 채우고
있을 것입니다.

마지막은 기본 옵션인 Use min covering extent from input layers 입니다. 알고리듬을 실행하는 데 쓰이는
모든 레이어의 최소 커버 범위를 계산할 것입니다. 텍스트 란에 어떤 값도 입력할 필요가 없습니다. 지금
실행하고 있는 알고리듬처럼 입력 레이어가 단 하나일 경우, 앞에서 살펴본 Use layer/canvas extent 와
동일한 입력 레이어를 선택해서 동일한 범위를 얻을 수 있습니다. 하지만 입력 레이어가 두 개 이상일 경우,
최소 커버 범위는 어떤 입력 레이어의 범위와도 일치하지 않습니다. 모든 입력 레이어로부터 계산되기
때문입니다.

래스터화 알고리듬을 실행하는 데 이 마지막 방식을 사용하겠습니다.

파라미터 대화 창을 다음과 같이 설정한 다음, OK 를 클릭하십시오.
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원래 벡터 레이어와 정확히 동일한 영역을 커버하는, 래스터화된 레이어를 얻을 것입니다.

어떤 경우 마지막 Use min covering extent from input layers 옵션을 사용하지 못 할 수도 있습니다.
입력 레이어 없이 다른 유형의 파라미터만을 가지는 알고리듬일 때 그렇습니다. 이런 경우, 값들을 직접
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입력하거나 다른 옵션을 이용해야 할 것입니다.

선택 집합이 존재할 경우에도 범위를 계산하는 데 선택 집합을 사용하지 않으며, 피처 집합 전체의 범위가
레이어의 범위라는 사실을 유념하십시오. 이런 경우 선택 집합에서 새 레이어를 생성한 다음 해당 레이어를
입력 레이어로 사용해야 할 수도 있습니다.

17.13 HTML 산출물

주석: 이 강의에서 QGIS 가 텍스트 산출물과 도표를 생산하는 데 쓰이는 HTML 포맷으로 된 산출물을
어떻게 다루는지 배울 것입니다.

지금까지 생성한 산출물은 모두 (래스터이든 벡터이든) 레이어였습니다. 하지만 몇몇 알고리듬은 텍스트 및
도표의 형태로 산출물을 생성합니다. 이 모든 산출물은 HTML 파일로 포장되어 처리 과정 프레임워크의
또다른 요소, 통칭 Results viewer 에 표출됩니다.

이런 알고리듬들이 어떻게 작동하는지 알아봅시다.

이 강의에 쓰일 데이터를 담고 있는 프로젝트를 열고, Basic statistics for numeric fields 알고리듬을
실행하십시오.

이 알고리듬은 단순한 편으로, 사용할 레이어 및 레이어의 (숫자) 필드 하나만 선택하면 됩니다. 산출물이
HTML 유형이지만, 이에 상응하는 텍스트 란은 래스터 또는 벡터 레이어의 경우와 완전히 동일하게
작동합니다. 파일 경로를 입력하거나, 임시 파일로 저장하려면 비워두면 됩니다. 하지만 이 경우 확장자로
html 및 htm 만 사용할 수 있습니다. 산출물 포맷을 변경하려고 다른 확장자를 사용할 수는 없습니다.

프로젝트에 단 하나 있는 레이어와 레이어의 POP2000 필드를 선택해서 실행하십시오. 알고리듬 작업이
완료되면 파라미터 대화 창이 닫히고 다음과 같은 새 대화 창이 나타날 것입니다.
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This is the Results viewer. It keeps all the HTML result generated during the current session, easily
accesible, so you can check them quickly whenever you need it. As it happens with layers, if you have
saved the output to a temporary file, it will be deleted once you close QGIS. If you have saved to a
non-temporary path, the file will remain, but it will not appear in the Results viewer the next time you
open QGIS.

일부알고리듬은좀더상세한다른산출물로나눌수없는텍스트를생성합니다. 예를들어외부에서처리된
텍스트 산출물을 수집하는 알고리듬의 경우가 그렇습니다. 산출물이 텍스트로 표현되지만 내부적으로 더
작은, 일반적으로 숫자값 형태의 산출물들로 나뉘는 경우도 있습니다. 방금 실행한 알고리듬이 바로 이런
경우입니다. 이 값들은 각각 단일한 산출물로서 다뤄지며, 변수로 저장됩니다. 지금은 중요하지 않지만,
일단 도표 모델 작성자 단계로 가면 이 값들을 다른 알고리듬의 입력값으로 사용할 수 있다는 것을 알게 될
것입니다.

17.14 첫 번째 분석 예제

주석: 이 강의에서는 사용자가 처리 과정 프레임워크 요소에 더 익숙해질 수 있도록 툴박스만을 사용해서
실제 분석 작업을 수행할 것입니다.

필요한모든설정을끝내고외부알고리듬을사용할수있으므로, 공간분석을수행할수있는강력한도구를
갖게 되었습니다. 이제 실재 세계의 데이터를 써서 광범위한 예제를 풀어볼 때가 되었습니다.

존 스노우 (John Snow) 가 자신의 획기적인 작업에 사용했던 유명한 데이터셋을 이용해서 흥미로운 결과를
얻을것입니다. 이데이터셋을분석하는작업은꽤명확한편으로제대로된결과물및결론을얻는데복잡한
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GIS기술이필요하지는않지만,이공간문제들을서로다른처리과정도구들을써서어떻게분석하고해결할
수 있는지 알 수 있는 훌륭한 방법입니다.

이 데이터셋은 콜레라에 의한 사망자 수 및 펌프 위치를 담고 있는 shapefile 과 TIFF 포맷으로 렌더링된
OSM 맵을 포함합니다. 이 강의에 해당하는 QGIS 프로젝트를 여십시오.

먼저 Pumps 레이어의 보로노이 도표 (Voronoi diagram, 일명 티센 (Thyessen) 폴리곤) 을 계산해서 각
펌프의 영향 범위를 계산해야 합니다. 이 작업에 Voronoi Diagram 알고리듬을 사용할 수 있습니다.
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꽤 쉬운 작업이지만, 벌써 흥미로운 정보를 알려주고 있습니다.
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명백히 보이듯이, 폴리곤 중 하나 안에 사망자 대부분이 존재합니다.

좀더 정량적인 결과를 얻으려면 각 폴리곤에서의 사망자 수를 세어볼 수 있습니다. 각 포인트가 사망자가
발생한 건물을 나타내고 사망자 수는 포인트의 속성에 저장돼 있으므로, 그냥 포인트만 세어서는 안 됩니다.
숫자에 가중치를 부여해야 하므로, Count points in polygon (weighted) 도구를 사용할 것입니다.
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새 필드에 DEATHS 라는 명칭을 부여하고, 가중치 항목에 COUNTS 필드를 이용합니다. 그 결과 생성되는
테이블은첫번째펌프에해당하는폴리곤에서의사망자수가다른폴리곤들보다훨씬많다는사실을분명히
반영하고 있습니다.
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Cholera_deaths레이어의각포인트와 Pumps레이어의포인트사이의의존성을시각화하는또다른훌륭한
방법은 각 Cholera_deaths 포인트에서 가장 가까운 Pumps 포인트로 라인을 그려보는 것입니다. Distance
to closest hub 도구를 다음과 같이 설정해서 이 작업을 할 수 있습니다.
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결과는 다음과 같습니다.
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중앙에 있는 펌프의 라인 개수가 가장 많지만, 이것은 사망자 수가 아니라 콜레라가 발생한 위치의 개수라는
점을 잊어서는 안 됩니다. 분명 결과를 대표할 수 있는 파라미터이긴 하지만 일부 위치의 사망자 수가 다른
곳보다 더 많을 수 있다는 사실을 고려하지 않고 있습니다.

A density layer will also give us a very clear view of what is happening. We can create it with the Kernel
density algorithm. Using the Cholera_deaths layer and its COUNT field as weight field, and with a
radius of 100, we get something like this.
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The resulting layer has the extent and cellsize of the streets raster layer.

산출물의 범위를 설정하기 위해 직접 입력할 필요가 없다는 사실을 기억하십시오. Output extent... 항목
오른쪽에 있는 버튼을 클릭한 다음 Use layer/canvas extent 를 선택하면 됩니다.
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그리고 도로 래스터 레이어를 선택하면 해당 레이어의 범위가 자동적으로 텍스트 란에 채워질 것입니다. 셀
크기도 동일한 방법으로, 해당 레이어의 셀 크기를 선택해서 설정해야 합니다.

Pumps레이어와결합하면,콜레라발생지역에서명확하게사망자수가최대밀도를보이는곳에펌프하나가
있다는 사실을 알 수 있습니다.

17.15 래스터 레이어 자르기 및 합치기

주석: 이강의에서는계속실재세상의시나리오안에서지리알고리듬을사용해서공간데이터를준비하는
또다른 예제를 풀어볼 것입니다.

이 강의에서는, 단일 폴리곤으로 이루어진 벡터 레이어로부터 도시 지역을 둘러싼 영역의 경사도 레이어를
계산해보겠습니다. 기본 DEM 은 래스터 레이어 두 개로 나뉘어져 있습니다. 이 두 레이어를 함께
표출해야만 우리가 작업하고자 하는 도시 주변 영역보다 더 넓은 영역을 커버하게 됩니다. 이 강의에
해당하는 프로젝트를 열어보면, 다음과 같은 화면을 보게 될 것입니다.
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이 레이어들은 두 가지 문제점을 가지고 있습니다.

• 우리가원하는것보다 (우리의관심지역은도심을둘러싼좁은영역입니다)너무넓은지역을커버하고
있습니다.

• 서로 다른 파일 두 개로 되어 있습니다. (도시의 범위는 래스터 레이어 가운데 하나에 들어가지만,
앞에서 언급했듯이 더 넓은 범위를 원합니다.)

적합한 알고리듬을 사용한다면 두 문제점 모두 쉽게 해결할 수 있습니다.

먼저, 우리가 원하는 영역을 정의하는 사각형을 생성하십시오. 이를 위해 도시 지역의 경계를 나타내는 경계
범위 (bounding box) 를 담고 있는 레이어를 생성하고, 꼭 필요한 것보다 조금 더 넓은 영역을 커버하는
래스터 레이어를 얻기 위한 버퍼를 부여하십시오.

경계 범위를 계산하는 데 Polygon from layer extent 알고리듬을 사용할 수 있습니다.
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버퍼를 부여하려면 Fixed distance buffer 알고리듬을 실행하고 다음과 같이 파라미터 값을 설정하십시오.

이 파라미터 값을 통해 다음과 같은 경계 범위 결과물을 얻을 수 있습니다.
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모서리가 둥근 사각형이지만, 이 레이어에 Polygon from layer extent 알고리듬을 실행해서 동등한 직각
사각형 경계 범위를 쉽게 얻을 수 있습니다. 먼저 도시 범위에 버퍼를 부여한 다음 범위 사각형을 계산해서
한 단계를 생략할 수도 있습니다.

래스터와 벡터의 투영체가 다르다는 사실을 알 수 있을 것입니다. 따라서 다음 단계를 진행하기 전에 Warp
(reproject) 도구를 이용, 재투영해야 합니다.
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우리가 얻고자 하는 래스터 레이어의 경계 범위를 담고 있는 레이어를 써서 두 래스터 레이어를 잘라낼 수
있습니다. Clip Grid with Polygons algorithm 을 이용하십시오.
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레이어를 잘라낸 다음, Merge raster layers 알고리듬을 써서 두 레이어를 합칠 수 있습니다.

합쳐진 레이어를 위한 셀 크기가 필요합니다. 입력 레이어와 동일한 셀 크기를 사용하겠습니다. 알고리듬을
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호출하기 전에 셀 크기를 알아야 할 필요는 없습니다. Cell Size 텍스트 란 오른쪽에 있는 버튼을 클릭하면
간단한 수학 공식을 입력하거나, 자주 사용하는 값의 목록, 그리고 사용 가능한 모든 레이어들의 셀 크기 및
범위 좌표를 선택할 수 있는 대화 창이 뜰 것입니다.

주석 : 합치기를 먼저 하고 자르기를 하면 클리핑 알고리듬을 두 번 호출할 필요가 없어 시간을 절약할 수
있습니다. 하지만 합쳐야 할 레이어가 두 개 이상인데 용량이 큰 편일 경우, 합치기를 먼저 하면 나중에
처리하기 어려워질 수가 있습니다. 이런 경우 클리핑 알고리듬을 몇 번 호출해야만 해서 시간이 걸릴 수도
있지만,곧이런작업을자동화할수있는추가도구들을소개할것이므로걱정하지마십시오. 이예제에서는
레이어 두 개뿐이므로 이런 상황에 대해 걱정할 필요는 없습니다.

합치기 작업으로 결국 원하는 DEM 을 얻게 되었습니다.

이제 경사도 레이어를 계산할 시간입니다.

A slope layer can be computed with the Slope, Aspect, Curvature algorithm, but the DEM obtained in
the last step is not suitable as input, since elevation values are in meters but cellsize is not expressed
in meters (the layer uses a CRS with geographic coordinates). A reprojection is needed. To reproject a
raster layer, the Warp (reproject) algorithm can be used again. We reproject into a CRS with meters as
units, so we can then correctly calculate the slope.

다음이 재투영된 DEM 입니다.
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이 새 DEM 을 써서 경사를 계산할 수 있습니다.
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다음이 결과물인 경사도 레이어입니다.
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Slope, Aspect, Curvature 알고리듬이 생산한 경사는 라디안 단위로 되어 있습니다. 그러나 도 단위가
더 실용적이고 자주 쓰입니다. Metric conversions 알고리듬으로 단위를 변환할 수 있습니다. (다만 이
알고리듬의 존재를 모를 경우, 이전에 사용했던 래스터 계산기를 사용하면 됩니다.)
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이렇게변환한경사도레이어를 :guilabel:‘Reproject raster layer‘를써서다시원래대로재투영하면, 우리가
원했던 최종 레이어를 얻게 됩니다.

재투영 과정에서 최종 레이어가 초기 단계에서 계산했던 경계 범위 바깥의 값을 가지게 됩니다. 기본 DEM
을 얻기 위해 했던 것과 동일한 방법으로 다시 클리핑하면 이 문제를 해결할 수 있습니다.

17.16 수문학적 분석

주석: 이 강의에서는 수문학적 분석을 수행할 것입니다. 이 분석은 분석 작업 흐름에 대한 매우
훌륭한 예이기 때문에, 이어지는 강의들에서도 사용될 것입니다. 이 분석을 통해 몇몇 고급 기능들도
소개하겠습니다.

이 강의에서는 수문학적 분석을 수행하겠습니다. DEM 으로부터 시작, 하계망 (���, channel network)
을 추출하고 유역을 묘사한 다음 몇 가지 통계를 계산할 것입니다.

먼저 이 강의에 해당하는 프로젝트를 불러오십시오. DEM 하나만을 담고 있습니다.
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The first module to execute is Catchment area (Parallel). You can use anyone of the others named
Catchment area. They have different algorithms underneath, but the results are basically the same.

Elevation 항목에 DEM 을 선택하고, 나머지 파라미터는 기본값을 유지하십시오.
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This algorithm calculates many layers, but the Catchment Area one is the only one we will be using.

원한다면 다른 레이어들을 삭제해도 됩니다.

이 레이어의 렌더링에서 그렇게 많은 정보를 알 수가 없습니다.

그이유는히스토그램을살펴보면알수있습니다. 값들이고르게분포되어있지않기때문입니다. (하계망에
해당하는적은셀에만매우높은값이부여되어있습니다.) 집수지역 (catchment area)값의로그를계산하면
훨씬 많은 정보를 제공하는 레이어를 얻을 수 있습니다. (래스터 계산기를 이용하십시오.)
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The catchment area (also known as flow accumulation), can be used to set a threshold for channel
initiation. This can be done using the Channel network algorithm. Here is how you have to set it up.
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로그 값이 아닌 원래 집수 지역 레이어를 사용하십시오. 로그 값을 계산한 것은 렌더링 때문이었습니다.

Initiation Threshold 값을 증가시킬 경우, 더 밀도가 낮은 하계망을 얻게 됩니다. 감소시킬 경우 밀도가
높아집니다. 앞의 그림에 나온 값으로 계산하면, 다음과 같은 레이어를 얻게 됩니다.
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이 그림은 결과물 벡터 레이어와 DEM 만을 보여주지만, 동일한 하계망을 담고 있는 래스터 레이어도 있을
것입니다. 사실 우리가 사용할 것이 바로 그 래스터 레이어입니다.

이제 Watersheds Basins 알고리듬을 써서, 해당 하계망이 가진 모든 분기들을 발산점 (outlet point) 으로
이용하여 하계망에 대응하는 소분지 (subbasin) 를 묘사할 것입니다. 이 알고리듬의 파라미터 대화 창을
다음과 같이 설정하십시오.
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다음이 그 결과입니다.

이 결과물은 래스터입니다. Vectorise Grid Classes 알고리듬을 통해 벡터화할 수 있습니다.
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이제 이 소분지들 가운데 하나가 담고 있는 표고 값들에 대한 통계를 계산해봅시다. 해당 소분지 안의
표고만을 나타내는 레이어를 생성한 다음 해당 통계를 계산하는 알고리듬에 넘겨주면 됩니다.
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먼저, 소분지를나타내는폴리곤을가지고원래 DEM을잘라내봅시다. Clip Grid with Polygon 알고리듬을
사용하겠습니다. 소분지 폴리곤 하나를 선택한 다음 클리핑 알고리듬을 호출하면, 알고리듬이 선택 집합을
인식하기 때문에 해당 폴리곤이 커버하는 영역의 DEM 만 잘라낼 수 있습니다.

폴리곤 하나를 선택한 다음,

클리핑 알고리듬을 호출하고 다음과 같이 설정하십시오.
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Input 항목에 선택된 요소는 물론 잘라내고자 하는 DEM 입니다.

다음과 같은 결과를 얻게 됩니다.
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Raster Layer Statistics 알고리듬에 이 레이어를 그대로 사용할 수 있습니다.

다음과 같은 통계를 생산할 것입니다.

다른 강의에서도 분지 계산 과정 및 통계 계산을 � 다른 요소들이 어떻게 이 두 계산을 자동화해서 좀 더
효율적으로 작업할 수 있는지 알아보기 위해 � 모두 사용할 것입니다.
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17.17 도표 모델 작성자 시작

주석: 이 강의에서 작업 흐름을 정의하고 일련의 알고리듬들을 실행할 수 있는 강력한 구성 요소인 도표
모델 작성자 (graphical modeler) 사용법을 배울 것입니다.

일반적으로 처리 과정 도구를 사용할 때에는 알고리듬 하나를 실행하는 것보다 더 많은 작업을 포함합니다.
결과를 얻기 위해 보통 몇 개의 알고리듬을 실행하며, 그 가운데 일부 알고리듬의 산출물은 다른 알고리듬의
입력 레이어로 쓰이곤 합니다.

도표 모델 작성자를 사용하면, 이런 작업 흐름을 모델로 구성할 수 있습니다. 즉 필요한 모든 알고리듬을 한
번에 실행할 수 있으므로, 전체 과정을 단순화하고 자동화할 수 있습니다.

이 강의를 시작하기 전에 지형 습윤 지수 (Topographic Wetness Index) 라는 명칭의 파라미터를 계산해야
합니다. 이를 계산하는 알고리듬이 Topographic Wetness Index (TWI) 입니다.

그림에서 알 수 있듯이 Slope 와 Catchment Area 두 입력 레이어가 반드시 있어야 합니다. 다른 선택적인
입력 레이어도 있지만, 지금 사용할 것은 아니기 때문에 무시하도록 하겠습니다.

이강의에해당하는데이터는 DEM하나만을담고있으므로필요한입력레이어가없습니다. 그러나우리는
DEM 에서 이 두 레이어를 계산하는 방법을 알고 있습니다. 경사도와 집수 지역을 게산하는 알고리듬을
배웠기 때문이죠. 따라서, 먼저 해당 레이어들을 계산한 다음 TWI 알고리듬에 쓸 수 있습니다.

이 중간 단계의 두 레이어를 계산하는 데 사용해야 하는 파라미터 대화 창은 다음과 같습니다.
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TWI 알고리듬의 파라미터 대화 창을 다음과 같이 설정해야 합니다.
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다음과 같은 결과물을 얻게 될 것입니다. (렌더링에 기본값인 단일 밴드 의사 (pseudo) 색상 반전 색상표를
사용했습니다.)

이제 DEM에서 TWI를한단계만에계산하는알고리듬을생성해보도록하겠습니다. 이후다른 DEM에서
TWI 레이어를 계산해야 할 경우 작업 시간을 절약해줄 것입니다. 앞에서 했던 3 단계 대신 단 1 단계만에
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할 수 있기 때문입니다. 필요한 모든 처리 과정은 툴박스에서 찾을 수 있으므로 이 단계들을 포장하는 작업
흐름을 정의하기만 하면 됩니다. 바로 도표 모델 작성자를 사용해서 말이죠.

Processing 메뉴에서 Processing modeler 항목을 선택해서 모델 작성자를 실행하십시오.

모델을생성하려면두가지가필요합니다. 필요한입력물을설정하고,모델이담고있는알고리듬을정의해야
합니다. 모델 작성자 창의 왼쪽에 있는 Inputs 및 Algorithms 탭에서 두 요소들을 추가하면 됩니다.

Inputs 부터 시작해보겠습니다. 이 경우 추가할 것이 많지 않습니다. DEM 래스터 레이어만 필요하므로,
그것만 입력 데이터로 추가하겠습니다.

Input 탭에서 Raster Layer 를 더블클릭하면 다음 대화 창이 뜹니다.

여기서 원하는 입력물을 정의해야 합니다. 이 래스터 레이어가 DEM 이어야 하므로, DEM 이라고
명명하겠습니다. 모델실행시사용자가보게될명칭입니다. 작업시이레이어가필요하기때문에필수적인
레이어로 정의하겠습니다.

다음과 같이 대화 창을 설정해야 합니다.
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OK 를 클릭하면 모델 작성자 캔버스에 입력물이 나타납니다.

이제 Algorithms 탭으로 옮겨볼까요? 처음 실행해야 할 알고리듬은 Slope, aspect, curvatures 입니다.
알고리듬 목록에서 해당 알고리듬을 찾은 다음 더블클릭하면 다음 대화 창이 나타날 것입니다.
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이대화창은툴박스에서알고리듬을실행할때볼수있는창과매우비슷하지만,파라미터값으로사용할수
있는요소를현재QGIS프로젝트에서가져오는것이아니라모델자체에서가져옵니다. 즉이경우 Elevation
항목에 쓸 수 있는 프로젝트의 래스터 레이어가 없다는 뜻입니다. 다만 모델에서 정의된 레이어뿐입니다.
마침 DEM이란명칭의입력래스터레이어하나를추가했기때문에, Elevation파라미터에해당하는목록에서
볼 수 있는 래스터 레이어도 이 레이어 하나뿐입니다.

Output generated by an algorithm are handled a bit differently when the algorithm is used as a part of
a model. Instead of selecting the filepath where you want to save each output, you just have to specify
if that ouput is an intermediate layer (and you do not want it to be preserved after the model has been
executed), or it is a final one. In this case, all layers produced by this algorithm are intermediate. We will
only use one of them (the slope layer), but we do not want to keep it, since we just need it to calculate
the TWI layer, which is the final resutl that we want to obtain.

레이어가 최종 결과물이 아니라면 해당 항목을 변경해서는 안 됩니다. 최종 결과물일 경우, 후에 모델 실행
시 파라미터 대화 창에서 레이어를 식별하는 데 쓰이게 될 명칭을 입력해야 합니다.

이 첫 대화 창에서 선택할 것은 별로 없습니다. 모델에 단 하나의 레이어 (DEM 입력 레이어) 만 있기
때문입니다. 실제로 이 경우 대화 창의 기본 설정이 정확하므로, OK 만 클릭하면 됩니다. 이제 모델 작성자
캔버스가 다음과 같이 보일 것입니다.
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모델에두번째로추가해야할알고리듬은집수지역알고리듬입니다. Catchment area (Paralell)알고리듬을
사용하십시오. DEM 레이어를 다시 입력 레이어로 사용하고, 이 알고리듬이 생산하는 모든 산출물이 최종
결과물이 아니므로, 해당 대화 창을 다음과 같이 설정해야 합니다.
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이제 모델이 다음과 같이 보여야 합니다.
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마지막으로 Topographic Wetness Index 알고리듬을 추가하고, 다음과 같이 설정하십시오.

이 경우, 입력 레이어에 DEM 이 아니라 이전 단계에서 추가했던 알고리듬이 계산한 경사도 및 집수 지역
레이어를 사용할 것입니다. 새 알고리듬을 추가하면 해당 알고리듬이 생산하는 산출물을 다른 알고리듬이
사용할 수 있습니다. 이를 이용해서 알고리듬들을 연결, 작업 흐름을 생성하는 것입니다.

이 때 산출물인 TWI 레이어가 최종 레이어이기 때문에, 그렇게 지정해야 합니다. 해당 텍스트 란에 이
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산출물에 부여할 명칭을 입력하십시오.

이제 모델 작성이 끝났습니다. 다음 화면처럼 보여야 합니다.

모델 작성자 창 위쪽에 모델명 및 모델 그룹명을 입력한 다음, Save 버튼을 클릭해서 저장하십시오.

모델을 원하는 아무 위치에나 저장해서 나중에 열 수 있지만, models 폴더 (파일 저장 대화 창에서 볼 수
있는 기본 폴더) 에 저장할 경우 해당 모델을 툴박스에서도 사용할 수 있습니다. 따라서 폴더를 변경하지
말고 사용자가 원하는 파일명으로 저장하십시오.

이제 모델 작성자 대화 창을 닫고 툴박스를 살펴보십시오. Models 그룹에서 사용자가 방금 작성한 모델을
볼 수 있습니다.

모델을 더블클릭해서, 다른 보통 알고리듬처럼 실행할 수 있습니다.
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As you can see, the parameters dialog, contain the inut that you added to the model, along with the
outputs that you set as final when adding the corresponding algorithms.

입력 레이어로 DEM 을 설정해서 실행해보십시오. 클릭 한 번으로 TWI 레이어를 얻을 수 있을 것입니다.

17.18 더 복잡한 모델

주석: 이 강의에서는, 도표 모델 작성자에서 좀 더 복잡한 모델로 작업할 것입니다.

이전강의에서생성했던첫번째모델은입력물하나와알고리듬 3개만으로된아주단순한모델이었습니다.
서로 다른 입력물들과 더 많은 단계를 담고 있는 더 복잡한 모델을 생성할 수 있습니다. 이 강의에서 우리는
DEM및임계값을기반으로유역벡터레이어를생성하는모델을작성할것입니다. 이모델은매번매단계를
반복할 필요 없이 서로 다른 임계값에 상응하는 여러 벡터 레이어를 계산하는 데 매우 유용할 것입니다.

This lesson does not contain instructions about how to create you model. You already know the necessary
steps (we saw them in a previous lesson) and you have already seen the basic ideas about the modeler,
so you should try it yourself. Spend a few minutes trying to create your model, and don’t worry about
making mistakes. Remember: first add the inputs and then add the algorithms that use them to crete
the workflow.

여러분이 전체 모델을 생성할 수 없어 도움이 필요할 경우, 이 강의에 해당하는 데이터 폴더는 ‘거의’ 완성된
버전의 모델을 담고 있습니다. 모델 작성자를 실행해서 해당 데이터 폴더에 있는 모델 파일을 열어보십시오.
다음과 같은 모델을 보게 될 것입니다.
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이 모델은 계산을 완료하는 데 필요한 모든 단계를 담고 있지만, 입력물은 DEM 하나뿐입니다. 즉 하천
형성을 위한 임계값에 고정 값을 사용한다는 의미로, 이 모델의 가능성을 제한하고 있습니다. 하지만 모델을
편집할 수 있기 때문에 문제는 없습니다. 이제 모델을 수정해봅시다.

First, let’s add a numerical input. That will ask the user for a numerical input that we can use when
such a value is needed in any of the algorithms included in our model. Click on the Numerical value
entry in the inputs tree, and you will see the corresponding dialog. Fill it with the values shown next.

이제 모델이 다음과 같이 보일 것입니다.
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방금 추가한 입력을 사용하고 있지 않으므로, 모델이 실제로 변경되지는 않았습니다. 이 입력을 사용하는
알고리듬에 연결시켜야 합니다. 이 경우에는 Channel network 알고리듬입니다. 모델 작성자의 기존
알고리듬을 편집하려면 캔버스 상의 해당 박스를 더블클릭하면 됩니다. Channel network 알고리듬을
더블클릭하면, 다음 대화 창이 나타날 것입니다.

The dialog is filled with the current values used by the algorithm. You can see that the threshold
parameter has a fixed value of 1000000 (this is also the default value of the algorithm, but any other
value could be put in there). However, you might notice that the parameter is not entered in a common
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text box, but in an option menu. If you unfold it, you will see something like this.

The input that we added is there and we can select it. Whenever an algorithm in a model requires a
umerical value, you can hardcode it and directly type it, or you can use any of the available inputs and
values (remember that some algorithms generate sinlge numerical values. We will see more about this
soon.). In the case of a string parameter, you will also see string inputs and you will be able to select on
of them or type the desired fixed value.

Initiation Threshold 파라미터에 Threshold for ... 입력을선택한다음, OK 를클릭해서모델의변경사항을
적용하십시오. 이제 모델이 다음과 같이 보일 것입니다.
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이제모델이완성됐습니다. 이전강의에서사용했던 DEM과,서로다른임계값을사용해서실행해보십시오.
다음은 서로 다른 임계값을 사용해 얻은 결과물의 예시들입니다. 수문학적 분석 강의에서 얻은, 기본값을
사용한 결과물과 비교해볼 수 있습니다.

Threshold = 100000
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Threshold = 10000000

17.19 모델 작성자 내부에서의 숫자 계산

경고: 이 강의는 제대로 검증되지 않았으므로 주의하십시오. 어떤 문제라도 알려주십시오. 그림이 뜨지
않을 수도 있습니다.

주석: 이 강의에서는 모델 작성자에서 숫자 산출물을 사용하는 방법에 대해 배워보겠습니다.

이강의에서, 마지막강의에서생성했던 (시작하기전에모델작성자에서파일을여십시오)수문학적모델을
수정, 유효한 임계값을 자동적으로 계산해서 사용자에게 입력하도록 요청하지 않을 수 있게 만들 것입니다.
해당 임계값이 임계값 래스터 레이어 내부의 변수를 참조하므로, 몇몇 단순한 통계 분석을 기반으로 해당
레이어에서 변수를 추출할 것입니다.

앞에서 말했던 모델을 실행해서, 다음과 같이 변경해봅시다.

먼저 Raster Layer Statistics 알고리듬을 사용해 집수 지역 레이어의 통계를 계산하십시오.
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이를 통해 생성된 통계값들을 다른 알고리듬의 모든 숫자 파라미터에 입력할 수 있습니다.

이전 강의와 마찬가지로 Channel network 알고리듬을 수정하기 위해 더블클릭할 경우, 사용자가 추가했던
숫자 입력 외에 다른 옵션이 생성된 것을 볼 수 있습니다.
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하지만 이 값들을 그대로 유효한 임계값으로 사용할 수는 없습니다. 아주 현실적이지 않은 하계망이 산출될
것이기 때문입니다. 그 대신 이 값들을 바탕으로 몇 가지 새로운 파라미터를 유도해서 더 나은 결과물을
생성할 수 있습니다. 예를 들면 평균 더하기 표준 편차의 2 배라는 값을 사용할 수 있습니다.

산술연산을추가하려면, Algorithms탭의 Geoalgorithms → Modeler → Modeler tools그룹에있는계산기를
사용할수있습니다. 이그룹은모델작성자바깥에서는그닥쓸모가없지만모델생성시몇몇유용한기능을
제공하는 알고리듬들을 담고 있습니다.

계산기 알고리듬의 파라미터 대화 창은 다음과 같습니다.
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As you can see, the dialgo is different to the other ones we have ssen, but you have in there the same
variables that were available in the Threshold field in the Channel network algorithm. Enter the above
formula and click on OK to add the algorithm.

모델 작성자 캔버스를 보면, 앞의 그림과 같이 계산기 알고리듬이 평균과 표준 편차라는 두 개의 값과
연결되어 있는 것을 볼 수 있습니다. 바로 공식에서 사용했던 값들입니다.

이렇게새알고리듬을추가하면새숫자값이추가됩니다. 다시 Channel network 알고리듬을더블클릭하면,
Initiation Threshold 파라미터에 해당 값을 선택할 수 있습니다.
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OK 를 클릭하면 모델이 다음과 같이 변할 것입니다.

이전 강의에서 추가했던 숫자 입력을 더 이상 사용하지 않으므로 삭제해도 됩니다. 숫자 입력을 오른쪽
클릭한 다음 Remove 를 선택하십시오.

이제 새 모델을 완성했습니다.

17.20 모델 내부의 모델

경고: 이 강의는 제대로 검증되지 않았으므로 주의하십시오. 어떤 문제라도 알려주십시오. 그림이 뜨지
않을 수도 있습니다.

주석: 이 강의에서 더 큰 모델 안에서 모델을 사용하는 방법을 배울 것입니다.

We have already created a few models, and in this lesson we are going to see how we can combine them
on a single bigger one. A model behaves like any other algorithm, which means that you can add a model
that you have already craeted as part of another one that you create after that.

이 강의에서는 수문학적 모델이 생성하는 결과물인 각 분지에 평균 TWI 값을 추가해서 해당 모델을 확장할
것입니다. 이를위해 TWI를계산한다음통계를생성해야합니다. 이미DEM에서 TWI를계산하는모델을
생성했기때문에,해당모델이담고있는알고리듬들을개별적으로추가하는대신그모델을재사용하는편이
낫습니다.

마지막 강의에서 사용했던 모델로부터 시작해봅시다.

First, we will add the TWI model. for it to be available, it should have been saved on the models folder,
since otherwise it will not be shown in the toolbox or the algorithms list in the modeler. Make sure you
have it available.
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TWI 모델을 현재 모델에 추가한 다음 입력 DEM 을 입력받도록 설정하십시오. TWI 레이어가 통계를
생성하기만을 원하므로, 산출물을 임시 파일로 설정하십시오. 우리가 생성하는 모델의 유일한 산출물은
유역을 담고 있는 벡터 레이어가 될 것입니다.

다음은 해당 파라미터 대화 창입니다.

이제 유역 벡터 레이어와 함께 사용할 수 있는 TWI 레이어를 생성할 수 있으므로, 각 유역에 상응하는 TWI
값을 담고 있는 새 레이어를 생성하겠습니다.

Grid statistics in polygons알고리듬을사용해계산하십시오. 앞에서언급한두레이어를입력물로사용해서
최종 결과를 생성하십시오.

원래 최종 산출물은 Vectorize grid classes 알고리듬의 산출물이었지만, 지금은 중간 단계의 결과물로
사용해야합니다. 이렇게변경하려면알고리듬을편집해야합니다. 해당알고리듬을더블클릭해서파라미터
대화 창을 띄운 다음, 산출물 명칭을 삭제하십시오. 기본값인 임시 산출물로 변경될 것입니다.

최종 모델이 다음과 같이 보여야 합니다.

어떤 모델을 다른 모델 안에서 사용하는 것은 그리 특별한 일이 아니라는 사실을 알 수 있습니다. 모델이
models 폴더에 저장되어 있고 툴박스에서 사용할 수 있는 한, 다른 알고리듬과 마찬가지로 모델을 추가할
수 있습니다.

17.21 보간법

주석: 이 강의에서는 포인트 데이터를 보간하는 방법과 함께 공간 분석을 수행하는 또다른 실제 사례를
배워보겠습니다.

이 강의를 통해, 포인트 데이터를 보간해서 래스터 레이어를 얻을 것입니다. 그러나 그 전에 데이터를
준비해야 하며, 보간 후에 결과 레이어를 수정하기 위한 몇 가지 처리 과정을 추가해야 합니다. 그래야
완전한 분석 과정을 마칠 수 있기 때문입니다.

이 강의에 해다하는 예제 데이터를 불러오십시오. 다음과 같이 보일 것입니다.
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이데이터는현대적인수확기가제공한작물수확량데이터로,이데이터를이용해서작물수확량을나타내는
래스터 레이어를 생성할 것입니다. 래스터 레이어로 더 심화된 분석을 수행하지는 않습니다. 생산성이 가장
높은 지역 및 생산성을 향상시킬 수 있는 지역을 쉽게 식별하기 위한 배경 레이어로만 사용할 것입니다.

가장 먼저 해야 할 일은 레이어 정리입니다. 너무 많은 포인트를 담고 있기 때문입니다. 수확기가 방향을
틀거나 어떤 이유로 속도를 변경할 때마다 위치를 표시하는 수확기의 움직임 때문입니다. Point filter
알고리듬이 이 작업에 유용합니다. 값의 분포에서 맨 위와 아래에 있는 이상값 (outlier) 으로 생각되는
포인트들을 제거하기 위해 해당 알고리듬을 두 번 사용할 것입니다.

For the first execution, use the following parameter values. [Note: this does not work, resulting file
empty]
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두 번째 실행 시, 다음과 같이 설정하십시오.
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입력 레이어에 원래 레이어가 아니라 첫 번째 실행의 산출물을 사용한다는 사실을 유념하십시오.

줄어든 포인트 집합을 담은 최종 필터링 레이어는 원래 레이어와 비슷하게 보이지만 담고 있는 포인트의
개수는 줄어들었습니다. 두 레이어의 속성 테이블을 비교해서 확인할 수 있습니다.

이제 Shapes to grid 알고리듬을 써서 레이어를 래스터화해봅시다.
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여기서 Filtered points 레이어는 두 번째 실행의 결과물을 뜻합니다. 알고리듬이 할당했기 때문에 첫
번째 실행에서 생성된 레이어와 동일한 명칭이지만, 첫 번째 결과물을 이용해서는 안 됩니다. 다른 용도가
없으므로 혼란을 피하기 위해 첫 번째 결과 레이어를 제거하고 마지막으로 필터링된 레이어만 남겨둘 수
있습니다.

결과물 레이어는 다음과 같습니다.
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이미 래스터 레이어이긴 하지만, 일부 셀의 데이터가 사라졌습니다. 방금 래스터화 한 벡터 레이어에서
포인트를 가져온 셀들만 유효한 값을 담고 있고, 다른 셀들은 비 데이터 값을 담고 있습니다. 사라진 값들을
채우기 위해 Close gaps 알고리듬을 사용할 수 있습니다.
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비 데이터 값이 없는 레이어는 다음과 같습니다.
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To restrict the area covered by the data to just the region where crop yield was measured, we can clip
the raster layer with the provided limits layer
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좀더매끄러운 (덜정확하지만배경용레이어로서더잘렌더링되는)결과물을얻기위해레이어에 Gaussian
filter 를 적용할 수 있습니다.
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그림과 같은 파라미터를 적용하면, 다음과 같은 결과를 얻게 됩니다.

17.22 심화 보간법

주석: 이 강의에서는 보간법 알고리듬을 사용하는 또다른 실질적인 사례를 배울 것입니다.

보간법은일반적인기법으로, QGIS처리과정프레임워크를사용해적용할수있는몇가지기술을시연하는
데 쓰일 수 있습니다. 이 강의에서는 앞에서 이미 언급했던 몇몇 보간법 알고리듬을 사용하지만, 다르게
접근해볼 것입니다.

이 강의를 위한 데이터는 표고 데이터를 담고 있는 포인트 레이어 하나입니다. 이전 강의에서와 거의 동일한
방법으로보간할것이지만,이번에는보간처리과정의질을평가하는데사용하기위해원래데이터의일부를
보전할 것입니다.

먼저, 포인트 레이어를 래스터화하고 결과물의 비 데이터 셀을 채워야 합니다. 다만 레이어가 담고 있는
포인트의 일부만을 사용할 것입니다. 이후에 확인하기 위해 포인트 가운데 10% 를 보전할 것이므로,
보간하기 위한 90% 의 포인트를 준비해야 합니다. 이를 위해 Split shapes layer randomly 알고리듬을 쓸 수
있습니다. 이전 강의에서 벌써 사용해본 알고리듬이지만, 새로운 중간 단계 레이어를 생성할 필요가 없는
더 나은 방법이 있습니다. 중간 단계 대신, 보간하고자 하는 (90% 부분) 포인트를 선택한 다음 알고리듬을
실행하면 됩니다. 이미 배웠듯이, 래스터화 알고리듬은 선택한 포인트만 사용하고 나머지는 무시합니다.
Random selection 알고리듬을 통해 선택 집합을 만들 수 있습니다. 다음 파라미터 값을 써서 실행하십시오.
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래스터화할 레이어에 있는 포인트 가운데 90% 를 선택할 것입니다.

랜덤하게선택하기때문에, 앞의그림에보이는선택집합과사용자의선택집합이서로다를수도있습니다.

이제 Shapes to grid 를 실행해서 첫 번째 래스터 레이어를 생성한 다음, Close gaps 알고리듬을 실행해서
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비 데이터 값을 가진 셀을 채우십시오. [셀 크기 : 100m]

보간 결과의 질을 확인하기 위해, 이제 선택하지 않은 포인트를 사용할 수 있습니다. 이 시점에서 (포인트
레이어의값인)실제표고와 (보간처리된래스터레이어의값인)보간된표고를알고있습니다. 이두값들의
차이를 계산해서 비교해볼 수 있습니다.

선택하지 않은 포인트를 사용할 것이므로, 먼저 선택을 반전시킵시다.

포인트는 보간 처리된 값이 아니라 원래 값을 담고 있습니다. 이 값들을 새 필드에 추가하는 데 Add grid
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values to points 알고리듬을 사용할 수 있습니다.

The raster layer to select (the algorithm supports multiple raster, but we just need one) is the resulting
one from the interpolation. WE have renamed it to interpolate and that layer name is the one that will
be used for the name of the field to add.

이제 보간 처리에 쓰이지 않았던 포인트가 두 가지 값을 담고 있는 벡터 레이어를 얻었습니다.
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다음 작업에 필드 계산기를 사용할 것입니다. Field calculator 알고리듬을 열고 다음 파라미터 값을 써서
실행하십시오.
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래스터 레이어에서 가져온 값을 담은 필드명을 다른 명칭으로 정했다면, 앞의 그림에 나온 공식을 그에 맞춰
수정해야 합니다. 이 알고리듬을 실행하면, 보간 퍼리에 쓰이지 않았던 포인트가 두 가지 표고 값의 차를
담고 있는 새 레이어를 얻게 됩니다.

이차이값에따라레이어를렌더링하면,불일치가가장크게발생하는곳이어디인지감을잡을수있습니다.

해당 레이어를 보간하면, 보간된 지역의 모든 포인트에서 측정된 오류를 나타내는 래스터 레이어를 얻게
됩니다.
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이 강의의 시작 부분에서 설명한 대로, Random selection 알고리듬 실행 시 랜덤 이라는 요소가 관여하므로
사용자의 결과는 앞의 그림과 다를 수도 있습니다.

17.23 알고리듬 반복 실행

주석: 이 강의에서는 입력 벡터 레이어에 있는 피처에 대해 반복적으로 실행해서, 벡터 레이어를 사용하는
알고리듬을 실행하는 다른 방법에 대해 설명합니다.

우리는 처리 과정 작업을 자동화 하는 방법 가운데 하나인 도표 모델 작성자에 대해 벌써 알고 있습니다.
하지만 어떤 상황에서는 모델 작성자가 주어진 작업을 자동화하는 데 필요한 도구가 아닐 수도 있습니다.
그런 상황 가운데 하나를 살펴보고, 다른 기능을 이용해 해당 상황을 쉽게 해결할 수 있는 방법을
배워보겠습니다. 바로 알고리듬의 반복 실행입니다.

이 강의에 해당하는 데이터를 불러오십시오. 다음과 같이 보일 것입니다.
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이전 강의들에서 사용했던 DEM 및 해당 DEM 에서 추출한 유역들의 집합인 것을 알 수 있습니다. 이
DEM 을 각 레이어가 한 유역에 상응하는 표고 데이터만 담고 있는 몇 개의 작은 레이어들로 잘라야 한다고
가정합시다. 향후 평균 표고 또는 고도분포 곡선 (hypsographic curve) 과 같은 각 유역과 관련된 어떤
파라미터를 계산하고자 할 때 유용할 것입니다.

이 작업은, 특히 유역의 개수가 많을 경우, 시간도 오래 걸리고 따분한 일이 될 수도 있습니다. 하지만 곧
설명할 바와 같이, 이 작업을 쉽게 자동화할 수 있습니다.

폴리곤 레이어로 래스터 레이어를 클리핑하는 데 쓰이는 알고리듬을 Clip grid with polygons 라고 하며, 그
파라미터 대화 창은 다음과 같습니다.
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유역 레이어와 DEM 을 입력물로 써서 실행하면, 다음과 같은 결과를 얻게 됩니다.

모든 유역 폴리곤이 커버하는 영역을 클리핑한 것을 볼 수 있습니다.

원하는 유역을 선택한 다음 방금처럼 알고리듬을 실행하면 DEM 에서 유역 하나만 클리핑할 수 있습니다.
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선택한 피처만 사용하므로, 래스터 레이어에서 선택한 폴리곤의 영역만 잘라낼 것입니다.

모든 유역에 대해 이 작업을 반복하면 원하는 결과를 얻을 수 있겠지만, 그렇게 실용적인 방법은 아닌 것
같습니다. 그 대신, 이 선택하기 및 잘라내기 루틴을 자동화할 수 있는 방법을 살펴보겠습니다.

먼저 이전에 선택한 폴리곤을 해제해서 다시 모든 폴리곤을 쓸 수 있게 하십시오. 이제 Clip grid with
polygon 알고리듬을 열고 이전과 동일한 입력물을 선택하는데, 이번에는 유역 레이어를 선택한 벡터 레이어
입력 항목의 오른쪽에 있는 버튼을 클릭하십시오.
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이 버튼을 클릭하면 선택한 입력 레이어를 각 피처 당 한 레이어로 나누어, 각 레이어가 폴리곤 하나를 담게
됩니다. 그 다음 알고리듬을 반복적으로 호출해서, 한 번에 이 단일 폴리곤 레이어 하나씩을 사용합니다.
이 경우, 알고리듬이 래스터 레이어 하나가 아니라 알고리듬 실행 시 생성한 각각의 래스터 레이어 집합을
산출합니다.

사용자가 설명대로 클리핑 알고리듬을 실행했을 경우의 결과물은 다음과 같습니다.
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각 레이어의 흑백 색상표 (또는 사용자의 색상표) 의 최소 및 최대값은 서로 다르게 조정됩니다. 레이어
사이의 경계에서 색이 일치하지 않아 각각의 레이어를 구별할 수 있는 이유입니다. 하지만 값은 일치합니다.

산출물 파일명을 입력했다면, 결과물 파일은 그 파일명 뒤에 각 반복 작업에 해당하는 숫자를 붙여
명명됩니다.

17.24 알고리듬 심화 반복 실행

주석: 이강의에서자동화를더심화시킬수있도록모델작성자와알고리듬의반복실행을결합하는방법을
살펴보겠습니다.

내장된 알고리듬에서만이 아니라, 사용자가 직접 생성할 수 있는 알고리듬, 즉 모델에서도 알고리듬을 반복
실행할 수 있습니다. 더 복잡한 결과물을 더 쉽게 얻을 수 있도록, 모델과 알고리듬의 반복 실행을 결합하는
방법을 살펴보겠습니다.

이강의에서사용할데이터는직전강의에서사용했던것과동일합니다. 이경우 DEM을각유역폴리곤으로
클리핑만하는것이아니라,유역안에서표고가어떻게분포되어있는지연구하기위해몇몇단계를추가해서
클리핑된 각 레이어에 대해 고도분포 곡선을 계산할 것입니다.

Since we have a workflow that involves several stapes (clipping + computing the hypsometric curve), we
shouldgo to the modeler and create the corresponding model for that workflow.

이강의를위한데이터폴더에이미모델이생성되어있지만, 먼저사용자가직접생성해보는편이좋습니다.
이 경우 고도분포 곡선에 흥미가 있기 때문에, 클리핑된 레이어가 최종 결과물이 아닙니다. 즉 이 모델은
어떤 레이어도 생성하지 않습니다. 곡선 데이터를 담은 테이블을 생성할 뿐입니다.

모델이 다음과 같이 보여야 합니다.
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이 모델을 사용자의 models 폴더에 추가, 툴박스에서 사용할 수 있도록 한 다음 실행하십시오.

DEM 과 유역 분지 레이어를 선택하십시오. 물론 알고리듬을 반복적으로 실행해야 한다는 사실을 알리는
버튼을 클릭하는 일도 잊지 마십시오.

알고리듬이 몇 번 실행된 후, 상응하는 테이블들이 생성되어 QGIS 프로젝트에 열릴 것입니다.
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모델을 확장해서 경사도 통계를 계산하도록 해서 이 예제를 더 복잡하게 만들 수 있습니다. 모델에 Slope,
aspect, curvatures 알고리듬을 추가한 다음, 경사도 산출물만 입력에 사용해야 하는 Raster statistics
알고리듬을 추가하십시오.

If you now run the model, apart from the tables you will get a set of pages with statistics. These pages
will be available in the results dialog

17.25 배치 처리 과정 인터페이스

주석: 이 강의에서 여러 개의 서로 다른 입력값들로 단일 알고리듬을 실행할 수 있게 해주는 배치 (batch)
처리 과정 인터페이스를 소개합니다.
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가끔주어진알고리듬을서로다른입력들을사용해서몇번이고실행해야할때가있습니다. 이를테면입력
파일 한 무리를 기존 포맷에서 다른 포맷으로 변환해야 하는 경우입니다. 또는 주어진 투영체를 사용하는
레이어 몇 개를 다른 투영체로 변환해야 하는 경우도 있겠죠.

In that case, calling the algorithm repeatedly on the toolbox is not the best option. Instead, the batch
processing interface should be used, which greatly simplifies performing a multiple execution of a given
algorithm. To run an algorithm as a batch process, find it in the toolbox, and instead of double–clicking
on it, right–click on it and select Run as batch process

이 예제에서는 Reproject algorithm 을 사용하겠습니다. 앞에서 설명한 대로 시작하십시오. 다음 대화 창이
나타날 것입니다.

If you have a look at the data fo this lesson, you will see that it contains a set of three shapefiles, but
no QGIS project file. This is because, when an algorithm is run as a batch process, laye inputs are not
selected from the current QGIS project, but from files instead. that makes it easier to process large
amounts of layers, such as, for instance, all the layers in a given folder.

배치 처리 과정 대화 창에 있는 테이블의 각 행은 해당 알고리듬의 각 실행을 나타냅니다. 각 행의 셀들은
알고리듬이필요로하는파라미터에해당합니다. 이파라미터들은일반적인단일실행대화창처럼위아래로
배열되어 있는 것이 아니라 각 행에 나란히 배열되어 있습니다.

이 테이블을 상응하는 값들로 채워 실행할 배치 처리 과정을 정의하십시오. 대화 창에 이 작업을 쉽게 할 수
있는 몇몇 도구들이 있습니다.

각 필드를 하나씩 채워봅시다. 첫 번째 열이 Input layer 필드입니다. 처리하고자 하는 각 레이어의 이름을
입력하는 대신, 모든 레이어를 선택해서 대화 창이 각 행에 채워넣도록 할 수 있습니다. 좌상단의 셀 옆에
있는 버튼을 클릭하면 파일 선택 대화 창이 뜹니다. 재투영할 파일 세 개를 선택하십시오. 각 행에 파일
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하나씩 필요하기 때문에, 다른 두 개를 아래 행들에 채울 것입니다.

행의 기본적인 개수는 3 개로, 변환해야 할 레이어들의 숫자와 일치합니다. 그러나 더 많은 레이어를 선택할
경우, 자동적으로 새 행이 추가될 것입니다. 각 항목을 수동으로 추가하고자 할 경우, Add row 버튼을
사용해서 더 많은 행을 추가할 수 있습니다.

모든 레이어를 EPSG:23029 CRS 로 변환할 것이기 때문에, 두 번째 필드에 해당 CRS 를 선택해야 합니다.
모든 행에 동일한 CRS 를 선택할 것이지만 각 행마다 해당 CRS 를 선택할 필요는 없습니다. 그 대신
(맨 위에 있는) 첫 번째 행의 해당 셀 옆에 있는 버튼을 클릭해서 CRS 를 설정한 다음, 해당 열의 헤더를
더블클릭하십시오. 해당 열의 모든 셀을 맨 위 셀의 값으로 채울 것입니다.
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마지막으로 각 실행에 해당하는 재투영된 레이어를 담고 있는 산출물 파일을 선택해야 합니다. 다시 한 번
첫 번째 셀만 선택하십시오. 맨 위 셀 옆의 버튼을 클릭한 다음, 산출물 파일을 저장하고자 하는 폴더에
파일명을 (예를 들면 reprojected.shp) 입력하십시오.

이제 파일 선택 대화 창의 OK 를 클릭하면, 셀에 파일명이 자동적으로 채워지는 것이 아니라 다음과 같은
입력 대화 창이 대신 나타납니다.

첫번째옵션을선택할경우현재셀만채워질것입니다. 다른옵션을선택한다면,아래쪽의모든행을주어진
패턴으로 채울 것입니다. 이 경우 Fill with parameter value 옵션을 선택한 다음 그 아래 있는 드롭다운
메뉴에서 Input Layer 옵션을 선택하십시오. 이렇게 하면 Input Layer (즉 레이어명) 값을 우리가 설정했던
파일명에 추가해서 각 산출물의 파일명을 서로 다르게 만들 것입니다. 이제 배치 처리 과정 테이블이 다음과
같이 보여야 합니다.
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마지막열은결과물레이어를현재 QGIS프로젝트에추가할것인지아닌지를설정합니다. 이예제의결과를
볼 수 있도록 기본값인 Yes 옵션을 변경하지 마십시오.

OK 를 클릭해서 배치 처리 과정을 실행합니다. 오류가 발생하지 않았다면, 모든 레이어가 처리되어 새
레이어 3 개가 생성되었을 것입니다.

17.26 배치 처리 과정 인터페이스에서의 모델

경고: 이 강의는 제대로 검증되지 않았으므로 주의하십시오. 어떤 문제라도 알려주십시오. 그림이 뜨지
않을 수도 있습니다.

주석: 이 강의에서 배치 처리 과정 인터페이스의 또다른 예를 살펴보겠습니다. 다만 이번에는 내장
알고리듬이 아니라 모델을 사용할 것입니다.

모델을 알고리듬과 동일하게 사용할 수 있으므로, 배치 처리 과정 인터페이스에서도 사용할 수 있습니다.
이를 시연해보려면, 우리에게 벌써 익숙한 수문학적 모델을 통해 해볼 수 있는 간단한 예제가 있습니다.

사용자의 툴박스에 모델이 추가되어 있는지 확인한 다음, 배치 모드로 실행하십시오. 배치 처리 과정 대화
창이 다음과 같아야 합니다.

행을 추가해서 5 행으로 만드십시오. 모든 행의 입력 열에 이 강의에 해당하는 DEM 파일을 선택한 다음,
다음과 같은 5 개의 서로 다른 임계값을 입력하십시오.

서로다른데이터셋에대해동일한처리를수행하는것만이아니라,동일한데이터셋에서로다른파라미터를
적용해서 배치 처리 과정 인터페이스를 실행할 수도 있다는 사실을 알 수 있습니다.

OK 를 클릭하면, 설정한 5 개의 임계값에 상응하는 5 개의 새로운 유역 레이어를 얻게 됩니다.
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17.27 다른 프로그램들

이 모듈은 Faunalia 의 파올로 카발리니 (Paolo Cavallini) 가 제공해주었습니다.

주석: 이 강의에서 처리 과정 내부에서 추가적인 프로그램을 사용하는 방법을 살펴볼 것입니다. 이 강의의
내용을 수료하려면, 사용자의 OS 도구와 함께 관련 소프트웨어 패키지를 설치해야만 합니다.

17.27.1 GRASS

GRASS is a free and open source GIS software suite for geospatial data management and analysis, image
processing, graphics and maps production, spatial modeling, and visualization

OSGeo4W독립실행형인스톨러 (32및 64bit)를통해윈도우에기본설치되며, 모든주요리눅스배포판을
위한 패키지도 있습니다.

17.27.2 R

R 은 통계 계산 및 도표를 위한 무료 오픈소스 소프트웨어 환경입니다.

개별적으로 설치해야 하며, 몇몇 필수적인 라이브러리 ( 목록 필요 ) 를 함께 설치해야 합니다.

Processing 실행 시 사용자 자신의 스크립트를, 단순하든 복잡하든 추가할 수 있고, 어떤 다른 알고리듬과도
마찬가지로 더 복잡한 작업 흐름 내부에 삽입해서 사용할 수도 있습니다.

17.27.3 OTB

OTB (또는 Orfeo ToolBox) 는 이미지 처리 알고리듬의 무료 오픈소스 라이브러리입니다. OSGeo4W 독립
실행형 인스톨러 (32bit) 를 통해 윈도우에 기본 설치됩니다. Processing 에서 경로를 설정해줘야 합니다.

OSgeo4W 표준 윈도우 설치의 경우, 경로는 다음과 같을 것입니다.

OTB application folder C:\OSGeo4W\apps\orfeotoolbox\applications
OTB command line tools folder C:\OSGeo4W\bin

데비안이나 그 변형판에서의 경로는 /usr/bin 이 될 것입니다.

17.27.4 기타

TauDEM 은 수문학적 정보의 추출 및 분석을 위한 수치 표고 모델 (DEM) 도구 묶음입니다. 어떤 OS 에서
사용할 수 있는지는 여러 OS 에 따라 달라집니다.

LASTools 는 LiDAR 데이터를 처리하고 분석할 수 있는, 상표권이 등록된 무료 복합 명령어 묶음입니다.
어떤 OS 에서 사용할 수 있는지는 여러 OS 에 따라 달라집니다.

추가적인 플러그인을 통해 사용할 수 있는 다음과 같은 도구들이 더 있습니다.

• LecoS : 토지 피복 통계 및 경관 생태학을 위한 묶음입니다.

• lwgeom : PostGIS의일부였던이라이브러리는도형정리를위한몇가지유용한도구를제공합니다.

• Animove : 동물들의 서식지 범위를 분석할 수 있는 도구입니다.

더 많은 도구가 추가될 예정입니다.
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17.27.5 말단 도구들의 비교

버퍼와 거리

points.shp 를 로드하고 툴박스의 검색 란에 buf 라고 입력한 후, 다음 알고리듬들을 더블클릭해보십시오.

• Fixed distance buffer : 거리 10000

• Variable distance buffer : 거리 필드의 SIZE

• v.buffer.distance : 거리 10000

• v.buffer.column : bufcolumn 의 SIZE

• Shapes Buffer : (디졸브 여부에 상관없이) 고정값 10000, (축척 조정된) 속성 필드

속도가 얼마나 다른지, 그리고 어떤 서로 다른 옵션들을 사용할 수 있는지 살펴보십시오.

사용자를 위한 예제 : 서로 다른 방법으로 산출한 도형들이 어떻게 다른지 알아보십시오.

다음은 래스터의 버퍼 및 거리에 관한 내용입니다.

• first, load and rasterize the vector rivers.shp with GRASS → v.to.rast.value; beware: cell size
must be set to 100 m, otherwise the computation time will be enormous; resulting map will have
1 and NULLs

• SAGA → Shapes to Grid → COUNT 를 통해 동일한 작업을 하십시오. (결과물 맵은 6 개에서 60 개
사이입니다.)

• 마지막으로 (GRASS 에서는 value = 1, SAGA 에서는 rivers ID 목록으로) proximity 를, 파라미터 값
1000, 2000, 3000 으로 r.buffer 를, (두 맵 가운데 첫 번째 맵으로) r.grow.distance 를 실행해보십시오.

디졸브

일반 속성에 기반해서 피처를 디졸브해보십시오.

• municipalities.shp 의 PROVINCIA 속성에 대해 GRASS → v.dissolve 를 실행하십시오.

• municipalities.shp 의 PROVINCIA 속성에 대해 QGIS → Dissolve 를 실행하십시오.

• municipalities.shp 의 PROVINCIA 속성에 대해 SAGA → Polygon Dissolve 를 실행하십시오.
(주석 : 동일한 속성을 3 번 선택해야 합니다.)

경고: SAGA 2.10 이하 버전에서는 마지막 메뉴 항목이 작동하지 않습니다.

사용자를 위한 예제 : 서로 다른 방법을 통한 산출물 (도형 및 속성) 들이 어떻게 다른지 알아보십시오.

17.28 보간법 및 등고선 형성

이 모듈은 Faunalia 의 파올로 카발리니 (Paolo Cavallini) 가 제공해주었습니다.

주석: 이 강의에서는 서로 다른 말단 도구들을 통한 서로 다른 보간 계산법을 배울 것입니다.

17.28.1 보간법

이 강의를 위한 프로젝트는 남북 방향의 강수량 그래디언트를 보여줍니다. 모두 동일하게 points.shp 의
RAIN 파라미터에 기반한 서로 다른 보간 법들을 사용해봅시다.

경고: 셀 크기를 500 으로 설정해야 합니다.

17.28. 보간법 및 등고선 형성 551
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• GRASS → v.surf.rst

• SAGA → Multilevel B-Spline Interpolation

• SAGA → Inverse Distance Weighted [제곱 지수: 4; 검색 범위: 전 세계]

• GDAL → Grid (Inverse Distance to a power) [제곱 지수: 4]

• GDAL → Grid (Moving average) [Radius1 및 Radius2: 50000]

17.28.2 등고선

Various methods to draw contour lines [always step= 10]:

• GRASS → r.contour.step

• SAGA → Contour Lines from Grid

• GDAL → Contour
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CHAPTER 18

Module: QGIS 에서 공간 데이터베이스 사용

이 강의에서 QGIS 에서 공간 데이터베이스를 사용하여 데이터베이스의 데이터를 관리, 표출, 조작하는
방법은 물론쿼리를 통해 분석을 수행하는 방법을배울것입니다. 주로 (이전강의에서다뤘던) PostgreSQL
과 PostGIS 를 이용하겠지만, spatialite 를 포함하는 기타 공간 데이터베이스 실행 시에도 동일한 개념을
적용할 수 있습니다.

18.1 Lesson: QGIS 브라우저에서 데이터베이스 작업

이전 2 번의 강의를 통해 관계형 데이터베이스의 기능 및 함수는 물론 관계형 데이터베이스에서 공간
데이터를저장,관리,쿼리,조작할수있게해주는확장프로그램에대해서도살펴보았습니다. 이강의에서는
QGIS 에서 어떻게 공간 데이터베이스를 효율적으로 사용할 수 있는지에 대해 더 심도 있게 다룰 것입니다.

이강의의목표: QGIS브라우저인터페이스를이용해공간데이터베이스와상호작용을하는방법을배우기.

18.1.1 Follow Along: 브라우저를 사용해 QGIS 에 데이터베이스 테이블 추가

데이터베이스 테이블을 QGIS 레이어로 추가하는 방법에 대해서는 벌써 간단하게 다루었지만, 이제 좀 더
상세한 내용을 살펴보고 어떻게 QGIS 에서 동일한 작업을 다른 방식으로 할 수 있는지 배워보겠습니다.
새로운 브라우저 인터페이스부터 시작합시다.

• QGIS 에서 비어 있는 새 맵을 생성하십시오.

• Layer Panel 맨 밑에 있는 Browser 탭을 클릭해서 브라우저를 여십시오.

• 메뉴 트리에서 PostGIS 부분을 열면 이전에 설정했던 연결을 그대로 사용할 수 있다는 사실을 알 수
있을 것입니다. (브라우저 창 상단의 Refresh 버튼을 클릭해야 할 수도 있습니다.)
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• 여기 나열된 테이블이나 레이어를 더블클릭하면 맵 캔버스에 추가될 것입니다.

• 테이블이나 레이어를 오른쪽 클릭하면 몇 가지 옵션이 나타납니다. Properties 항목을 클릭해서 해당
레이어의 속성을 살펴보십시오.
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주석: 물론 이 인터페이스를 통해 사용자 시스템 외부에 있는 서버가 호스팅하고 있는 PostGIS
데이터베이스에 접속할 수도 있습니다. 메뉴 트리의 PostGIS 항목을 오른쪽 클릭하면 새 연결을 위한
접속 파라미터를 설정할 수 있습니다.

18.1.2 Follow Along: 필터링된 레코드 집합을 레이어로 추가

테이블 전체를 QGIS 레이어로 추가하는 방법은 이미 알고 있습니다. 이제 테이블에서 필터링된 레코드
집합을 이전 강의들에서 배운 대로 쿼리를 통해 레이어로 추가하는 방법을 배울 차례입니다.

• 아무 레이어도 없는 비어 있는 새 맵을 시작하십시오.

• Add PostGIS Layers 버튼을 클릭하거나, 메뉴에서 Layer → Add PostGIS Layers 항목을
선택하십시오.

• Add PostGIS Table(s) 대화 창이 뜨면, postgis_demo 연결에 접속하십시오.

• public schema 를 확장하면 이전에 작업했던 테이블 세 개를 볼 수 있을 것입니다.

• lines 레이어를 클릭해서 선택하십시오. 그러나 그대로 추가하는 대신, Set Filter 버튼을 클릭해서
Query Builder 대화 창을 여십시오.

• 버튼을 사용하거나 직접 입력해서 다음 표현식을 작성하십시오.

"roadtype" = 'major'

18.1. Lesson: QGIS 브라우저에서 데이터베이스 작업 555



QGIS Training Manual, 출시 2.2

• OK 를 클릭해서 필터 편집을 종료한 다음, Add 를 클릭해서 필터링된 레이어를 사용자 맵에
추가하십시오.

• 트리에 있는 lines 레이어의 명칭을 roads_primary 로 변경하십시오.

전체 레이어가 아니라 ‘주요 도로’ 만 맵에 추가된 것을 알 수 있을 것입니다.

18.1.3 In Conclusion

QGIS브라우저를통해공간데이터베이스와상호작용을하는방법및쿼리필터를기반으로맵에레이어를
추가하는 방법을 배웠습니다.

18.1.4 What’s Next?

다음 강의에서 좀 더 완전한 데이터베이스 관리 작업들을 위해 QGIS 의 DB 관리자 인터페이스를 사용하는
방법을 배울 것입니다.

18.2 Lesson: QGIS 에서 DB 관리자를 통해 공간 데이터베이스 사용

벌써 QGIS 는 물론 다른 도구들을 통해 여러 가지 데이터베이스 작업을 수행하는 방법을 살펴보았습니다.
그러나 이제 그와 동일한 기능은 물론 관리 지향 도구들을 더 많이 제공하는 DB 관리자 도구에 대해 배워볼
때입니다.

이 강의의 목표: QGIS DB 관리자를 이용해서 공간 데이터베이스와 상호 작용을 하는 방법을 배우기.

18.2.1 Follow Along: DB 관리자를 통해 PostGIS 데이터베이스 관리

먼저 메뉴에서 Database → DB Manager → DB Manager 항목을 선택하거나 툴바에서 다음 DB 관리자
아이콘을 클릭해서 DB 관리자 인터페이스를 실행해야 합니다.

이전에 설정한 연결에서 myPG 부분의 public 스키마를 확장하면 이전 강의에서 작업했던 테이블을 볼 수
있어야 합니다.

사용자 데이터베이스가 담고 있는 스키마에 대한 몇몇 메타데이터를 볼 수 있다는 사실을 알 수 있습니다.
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Schemas are a way of grouping data tables and other objects in a PostgreSQL database and a container
for permissions and other constraints. Managing PostgreSQL schemas is beyond the scope of this manual,
but you can find more information about them in the PostgreSQL documentation. You can use the DB
Manager to create new Schemas, but will need to use a tool like pgAdmin III or the command line
interface to manage them effectively.

사용자 데이터베이스 내부의 테이블을 관리하는 데에도 DB 관리자를 사용할 수 있습니다. 벌써
커맨드라인에서 테이블을 생성하고 관리하는 다양한 방법을 배웠지만, 이제 DB 관리자에서 이런 작업을
하는 방법을 배워보겠습니다.

먼저 트리에서 테이블명을 클릭한 다음, Info 탭에서 테이블의 메타데이터를 살펴보면 도움이 됩니다.

18.2. Lesson: QGIS 에서 DB 관리자를 통해 공간 데이터베이스 사용 557
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이 패널에서 테이블에 대한 General Info 는 물론 PostGIS 확장 프로그램이 도형 및 공간 참조 시스템에
대해 유지관리하고 있는 정보를 볼 수 있습니다.

Info 탭을 스크롤다운할 경우, 현재 보고 있는 테이블의 Fields, Constraints, Indexes 에 대한 자세한 정보를
볼 수 있습니다.
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DB 관리자를 사용하면 레이어 트리에 있는 레이어의 속성 테이블을 보는 것과 동일한 방식으로 간단히
데이터베이스 내부의 레코드를 볼 수 있다는 것도 도움이 됩니다. Table 탭을 선택하면 데이터를 둘러볼 수
있습니다.

18.2. Lesson: QGIS 에서 DB 관리자를 통해 공간 데이터베이스 사용 559
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레이어의 데이터를 맵 프리뷰로 보여주는 Preview 탭도 있습니다.

트리에 있는 레이어를 오른쪽 클릭한 다음 Add to Canvas 를 선택하면 해당 레이어를 사용자 맵에 추가할
것입니다.

지금까지 데이터베이스의 스키마와 테이블의 메타데이터를 살펴보기만 했지만, 테이블을 수정하거나 새
열을 추가하려면 어떻게 해야 할까요? DB 관리자에서 직접 이런 작업을 할 수 있습니다.

• 트리에서 편집하고자 하는 테이블을 선택하십시오.

• 메뉴에서 Table → Edit Table 항목을 선택해서 Table Properties 대화 창을 여십시오.

이 대화 창에서 열을 추가하고, 도형 열을 추가하고, 기존 열을 편집하거나 완전히 삭제할 수 있습니다.

Constraints 탭에서 어떤 필드를 기본 키로 사용할지 관리하거나 기존 제약을 드롭할 수도 있습니다.
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Indexes 탭에서 공간 및 일반 인덱스 모두를 추가하거나 삭제할 수 있습니다.

18.2. Lesson: QGIS 에서 DB 관리자를 통해 공간 데이터베이스 사용 561
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18.2.2 Follow Along: 새 테이블 생성

이제 데이터베이스에 있는 기존 테이블을 작업하는 과정을 배웠으니, DB 관리자를 이용해서 새 테이블을
생성해봅시다.

• DB 관리자를 닫았을 경우 다시 DB 관리자 창을 열고, 사용자 데이터베이스에 이미 존재하는 테이블
목록이 보일 때까지 트리를 확장하십시오.

• 메뉴의 Table → Create Table 항목을 선택해서 Create Table 대화 창을 여십시오.

• 기본값인 Public 스키마를 이용하고, 테이블명을 places 라고 설정하십시오.

• id, place_name, elevation 필드를 다음과 같이 추가하십시오.

• id 항목을 기본 키로 설정했는지 확인하십시오.

• Create geometry column 항목의체크박스를체크한다음 POINT유형으로, Name 을 geom으로, SRID
를 4326 으로 설정하도록 하십시오.

• Create spatial index 항목의 체크박스를 체크한 다음, Create 를 클릭해서 테이블을 생성합니다.

562 Chapter 18. Module: QGIS 에서 공간 데이터베이스 사용



QGIS Training Manual, 출시 2.2

• 테이블이 생성되었다고 알려주는 대화 창을 닫고, Close 를 클릭해서 Create Table 대화 창을
닫으십시오.

이제 DB 관리자에서 새 테이블을 검사해보면 물론 어떤 데이터도 없다는 사실을 알게 될 겁니다. 이때
레이어 메뉴의 Toggle Editing 을 통해 해당 테이블에 places 데이터를 추가할 수 있습니다.

18.2.3 Follow Along: 기본적인 데이터베이스 관리

DB 관리자를 통해 몇몇 기본적인 데이터베이스 관리 작업을 할 수도 있습니다. 좀 더 완전한 데이터베이스
관리도구의대체제로사용할수는분명없지만, 사용자데이터베이스를유지관리하는데쓸수있는몇가지
기능들을 제공하고 있습니다.

종종 데이터베이스 테이블이 아주 커질 수도 있고 자주 수정되는 테이블의 경우 PostgreSQL 이 더 이상
필요로 하지 않는 레코드 찌꺼기가 남게 될 수도 있습니다. VACUUM 명령어는 일종의 쓰레기 정리 작업을
수행하며, 또 좀 더 나은 퍼포먼스를 위해 사용자 테이블을 분석하는 옵션도 갖추고 있습니다.

DB 관리자 내부에서 VACUUM ANALYZE 명령어를 실행할 수 있는 방법을 알아보겠습니다.

• DB 관리자의 트리에서 사용자 테이블 가운데 하나를 선택하십시오.

• 메뉴에서 Table → Run Vacuum Analyze 항목을 선택하십시오.

끝입니다! PostgreSQL 이 해당 작업을 수행할 것입니다. 사용자 테이블의 크기에 따라 완료하는 데 시간이
걸릴 수도 있습니다.
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You can find more information about the VACUUM ANALYZE process in the PostgreSQL Documenta-
tion

18.2.4 Follow Along: DB 관리자에서 SQL 쿼리 실행

DB 관리자는 사용자 데이터베이스에 대해 쿼리를 작성하고 그 결과를 살펴볼 수 있는 방법도 제공합니다.
이미 Browser 패널에서 이런 유형의 기능을 배웠지만, DB 관리자에서도 다시 살펴보도록 하겠습니다.

• 트리에서 lines 테이블을 선택하십시오.

• DB 관리자 툴바에서 다음 SQL window 버튼을 선택하십시오.

• 쿼리 작성 공간에 다음 SQL query 를 작성하십시오.

select * from lines where roadtype = 'major';

• Execute (F5) 버튼을 클릭해서 쿼리를 실행하십시오.

• 이제 Result 패널에서 쿼리와 일치하는 레코드를 볼 수 있을 겁니다.

• 이 결과를 사용자 맵에 추가하려면 Load as new layer 항목의 체크박스를 체크하십시오.

• Column with unique integer values 에 id 열을, Geometry column 에 geom 열을 선택하십시오.

• Layer name (prefix) 텍스트 란에 roads_primary 라고 입력하십시오.

• Load now! 를 클릭하십시오. 이 결과가 사용자 맵에 새 레이어로 뜰 것입니다.
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이제 사용자 쿼리와 일치하는 레이어가 사용자 맵에 나타났습니다. 물론 이 쿼리 도구를 사용해서 이전
강의들에서 살펴보았던 많은 명령어를 포함하는 어떤 임의의 SQL 명령어라도 실행할 수 있습니다.

18.2.5 데이터베이스에 DB 관리자를 통해 데이터 임포트

커맨드라인을 이용해 공간 데이터베이스에 데이터를 임포트하는 방법을 벌써 배웠고 SPIT 플러그인
사용법도 배웠으므로, 이제 DB 관리자를 통해 임포트하는 방법을 배워보겠습니다.

• DB 관리자 툴바에서 다음 Import layer/file 버튼을 클릭하십시오.

• exercise_data/projected_data 경로에 있는 urban_33S.shp 파일을 입력 데이터셋으로
선택하십시오.

• Update Options 버튼을 클릭해서 일부 서식값을 미리 채우십시오.

• Create new table 옵션을 반드시 선택하도록 하십시오.

• Source SRID 를 32722 로, Target SRID 를 4326 으로 설정하십시오.

• Create Spatial Index 항목의 체크박스를 체크하십시오.

• :guilabel:‘OK‘를 클릭해서 임포트를 수행하십시오.
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• 임포트가 성공했다고 알려주는 대화 창을 닫으십시오.

• DB 관리자 툴바에서 Refresh 버튼을 선택하십시오.

이제 트리에서 사용자 데이터베이스의 해당 테이블을 클릭해서 검사할 수 있습니다. Spatial ref: 항목의
값이 WGS 84 (4326) 인지 확인해서 데이터가 재투영되었는지 확인하십시오.
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트리에 있는 해당 테이블을 오른쪽 클릭한 다음 Add to Canvas 를 선택하면 해당 레이어를 사용자 맵에
추가할 것입니다.

18.2.6 데이터베이스에서 DB 관리자를 통해 데이터 익스포트

DB 관리자는 물론 사용자의 공간 데이터베이스에서 데이터를 익스포트할 수도 있으므로, 그 방법을
배워보겠습니다.

• 트리에서 lines 레이어를 선택한 다음 툴바에 있는 Export to File 버튼을 클릭해서 Export to vector
file 대화 창을 여십시오.

• Output file 항목의 오른쪽에 있는 ... 버튼을 클릭해서 해당 데이터를 exercise_data 디렉터리에
urban_4326 라는 파일명으로 저장하도록 설정합니다.

• Target SRID 를 4326 으로 설정하십시오.

• :guilabel:‘OK‘를 클릭해서 익스포트를 시작하십시오.
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• 임포트가 성공했다고 알려주는 대화 창을 닫고, DB 관리자 창도 닫으십시오.

이제 브라우저 패널에서 방금 생성한 shapefile 을 검사할 수 있습니다.
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18.2.7 In Conclusion

이제 QGIS 에서 DB 관리자 인터페이스를 통해 사용자의 공간 데이터베이스를 관리하는 방법, 사용자
데이터에 대해 SQL 쿼리를 실행하는 방법, 그리고 데이터를 임포트하고 익스포트하는 방법을 배웠습니다.

18.2.8 What’s Next?

다음 강의에서 spatialite 데이터베이스에 대해 이런 동일한 기술들을 사용하는 방법을 살펴보겠습니다.

18.3 Lesson: QGIS 에서 spatialite 데이터베이스 작업

서버에서 복수의 사용자에게 동시에 공간 데이터베이스 기능을 제공하는 데 일반적으로 PostGIS 를 쓰기는
하지만, QGIS는공간데이터베이스를통째로파일하나에저장할수있는가볍고이동하기쉬운 *spatialite*
이라는 파일 포맷도 지원하고 있습니다. 이 2 가지 유형의 공간 데이터베이스는 서로 다른 목적으로 쓰여야
하는 것이 당연하지만, 2 가지 모두 동일한 원칙 및 기술이 적용됩니다. 새 spatialite 데이터베이스를
생성하고 QGIS 가 이 데이터베이스 작업에 제공하는 기능들을 탐구해봅시다.

이 강의의 목표: QGIS 브라우저 인터페이스를 이용해 spatialite 데이터베이스와 상호 작용을 하는 방법을
배우기.

18.3.1 Follow Along: 브라우저를 통해 Spatialite 데이터베이스 생성

브라우저 패널을 사용하면 새 spatialite 데이터베이스를 생성하고 QGIS 에서 사용하기 위해 설정할 수
있습니다.

• 브라우저 트리에서 Spatialite 항목을 오른쪽 클릭한 다음 Create Database 를 선택하십시오.

• 사용자 시스템에서 파일을 저장하고자 하는 경로를 설정하고 파일명을 qgis-sl.db 라고
입력하십시오.

• 브라우저 트리에서 다시 Spatialite 항목을 오른쪽 클릭한 다음, 이번에는 New Connection 항목을
선택하십시오. 이전 단계에서 생성했던 파일을 찾아서 열어보십시오.

이제 새 데이터베이스를 생성했지만, 브라우저 트리에 있는 해당 항목 아래 아무것도 없으며 이 시점에서
사용자가 할 수 있는 일이라곤 연결을 삭제하는 것뿐이라는 사실을 알게 될 것입니다. 물론 이
데이터베이스에 아무 테이블도 추가하지 않았기 때문입니다. 테이블을 추가해보겠습니다.

• 새 레이어를 생성하는 다음 버튼을 클릭하고 드롭다운 메뉴에서 새 Spatialite 레이어를 생성하는
항목을 선택하거나, 또는 메뉴에서 Layer → New → New Spatialite Layer 항목을 선택하십시오.

• 드롭다운 메뉴에서 이전 단계에서 생성했던 데이터베이스를 선택하십시오.

• 레이어명을 places 라고 설정하십시오.

• Create an auto-incrementing primary key 항목의 체크박스를 체크하십시오.

• 다음 그림과 같이 2 가지 속성을 추가하십시오.

• :guilabel:‘OK‘를 클릭해서 테이블을 생성하십시오.
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• 브라우저 상단의 새로고침 버튼을 클릭하면, 이제 사용자의 places 테이블을 볼 수 있습니다.
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해당 테이블을 오른쪽 클릭하면, 이전 예제들에서와 마찬가지로 테이블의 속성을 살펴볼 수 있습니다.

이제 편집 세션을 시작해서 사용자의 새 데이터베이스에 직접 데이터를 추가할 수 있습니다.

데이터베이스에 DB 관리자를 통해 데이터를 임포트하는 방법도 배웠으므로, 동일한 기술을 사용해서
사용자의 새 데이터베이스에 데이터를 임포트할 수 있습니다.

18.3.2 In Conclusion

spatialite데이터베이스를생성하고, 테이블을추가하고, QGIS에서이테이블을레이어로사용하는방법을
배웠습니다.
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CHAPTER 19

부록 : 이 교재에 공헌하기

이 강의에 자료를 추가하려면, 이 부록에 명시된 지침을 따라야 합니다. 이 부록에 있는 조건들을, 좀 더
명확히하려는 목적이 아니라면, 수정해서는 안 됩니다. 이 교재의 질과 일관성을 유지하기 위해서입니다.

19.1 리소스 다운로드

이 문서의 소스를 GitHub 에서 구할 수 있습니다. Git 버전 컨트롤 시스템 이용법에 대해서는 GitHub.com
에 문의하십시오.

19.2 교재 서식

이 교재는 reStructuredText 마크업 언어를 사용하는 파이썬 문서 생성자인 Sphinx 를 이용해서
작성됐습니다. 이 도구들의 사용법은 각 해당 사이트에서 알 수 있습니다.

19.3 모듈 추가

• 새 강의를 추가하려면 먼저 새 강의의 명칭으로 (최상위 qgis-training-manual 디렉터리 바로
아래에) 새 디렉터리를 생성하십시오.

• 이 새 디렉터리에 index.rst 라는 파일을 생성합니다. 빈 파일인 채로 놔두십시오.

• 최상위 디렉터리에 있는 index.rst 파일을 여십시오. 첫 부분은 다음과 같습니다.
.. toctree::

:maxdepth: 2

foreword/index
introduction/index

/index 가 뒤에 붙는 디렉터리명 목록이라는 것을 알 수 있습니다. 이 목록이 최상위 인덱스 파일을 각
디렉터리의 인덱스 파일에 연결합니다. 이 목록의 순서가 문서 내부의 강의 순서를 결정합니다.

• 이 목록의 사용자가 원하는 순서에 새 강의 명칭 (예를 들면 새 디렉터리에 부여한 명칭) 을 추가하고,
뒤에 /index 를 붙이십시오.

• 뒤에 오는 강의는 이전 강의에서 배운 지식을 기반으로 하는 것과 같이 강의 순서가 논리적이어야
한다는 사실을 기억하십시오.

• 사용자의 새 강의의 인덱스 파일 ( [강의 명칭]/index.rst ) 을 여십시오.

• 페이지 맨 위에 별표 ( * ) 80 개를 쓰십시오. 강의 제목을 나타냅니다.

• 이 라인 다음 줄에 (“module” 을 뜻하는) |MOD| 마크업 구문으로 시작하는 강의명을 작성하십시오.
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• 다음 줄에 다시 별표 80 개를 쓰십시오.

• 그 다음 줄은 빈 줄로 남겨두십시오.

• 강의의 목적 및 내용을 설명하는 짧은 글을 작성하십시오.

• 한 줄을 띄운 다음, 다음 텍스트를 추가하십시오.
.. toctree::

:maxdepth: 2

lesson1
lesson2

... lesson1, lesson2 등은 사용자가 계획한 강의 제목들입니다.

모듈 수준의 인덱스 파일은 다음과 같이 보일 것입니다.
*******************************************************************************
|MOD| Module Name
*******************************************************************************

Short paragraph describing the module.

.. toctree::
:maxdepth: 2

lesson1
lesson2

19.4 강의 추가

새 모듈 또는 기존 모듈에 강의를 추가하려면,

• 모듈 디렉터리를 여십시오.

• (새 모듈인 경우, 앞에서 생성했던) index.rst 파일을 여십시오.

• 계획한 강의 명칭들이 앞에서와 같이 toctree 지시문 아래 나열되어 있는지 확인하십시오.

• 모듈 디렉터리에 새 파일을 생성하십시오.

• 해당 파일명을 모듈의 index.rst 에 적은 강의 명칭과 정확히 동일하게 명명한 다음, 확장자 .rst 를
추가하십시오.

주석: 편집 목적을 위해, .rst 파일은 일반 텍스트 파일 ( .txt ) 과 정확히 동일하게 동작합니다.

• 강의를 작성하기 전에 |LS| 마크업 구문으로 시작하는 강의명을 작성하십시오.

• 다음 줄에 등호 기호 ( = ) 80 개를 쓰십시오.

• 그 다음 줄은 빈 줄로 남겨두십시오.

• 강의의 목적을 간단히 설명하십시오.

• 주제에 대한 일반적인 소개를 포함시키십시오. 이 교재의 기존 강의를 참고하십시오.

• 그 아래에 다음 구문으로 시작하는 새 문장을 작성하십시오.

**The goal for this lesson:**

• 이 강의를 완료하면 얻을 수 있는 결과를 간단히 설명하십시오.

• 강의의 목적을 문장 하나 또는 두 개로 설명할 수 없을 경우, 해당 주제를 여러 개의 강의로 나누는
것이 좋습니다.
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각 강의는 다음 단계에서 설명하는 것처럼 여러 섹션으로 세분화됩니다.

19.5 섹션 추가

섹션에는 “따라 하기 (follow along)” 및 “직접 해보기 (try yourself)” 두 가지 유형이 있습니다.

• “따라 하기” 섹션은 사용자에게 QGIS 의 주어진 측면을 사용하는 방법을 가르치기 위한 상세한
지침들로 이루어집니다. 일반적으로 중간 중간 스크린샷이 들어가는 가능한 한 명확한 단계별
지침들을 제공합니다.

• “직접 해보기” 섹션은 사용자가 직접 시연해볼 수 있는 간단한 과제들을 부여합니다. 이 과제는 보통
과제를 완수 하는 방법을 보여주거나 설명하는, 또는 가능한 경우 예상되는 산출물을 보여주는, 이
문서 마지막의 답안지에 있는 항목과 연결됩니다.

각 섹션은 난이도에 따라 분류됩니다. 쉬운 섹션은 |basic|, 중급은 |moderate|, 고급은 |hard| 로
표시합니다.

19.5.1 “따라 하기” 섹션 추가

• 이 섹션을 시작하려면, (앞에서 설명한 대로) 의도한 난이도를 나타내는 마크업 구문을 적으십시오.

• 한 칸 띄운 다음 (“따라 하기” 를 나타내는) |FA| 라고 쓰십시오.

• 다시 한 칸 띄운 다음 섹션 명칭을 쓰십시오. (맨 첫글자만 대문자로 적고, 합당한 명사일 경우에도 첫
글자를 대문자로 적습니다.)

• 다음 줄에 빼기/대시 ( - ) 기호를 80 개 쓰십시오. 사용자의 텍스트 편집기가 기본 빼기/대시 문자를
긴 대시 또는 다른 문자로 대체하지 않는지 확인하십시오.

• 섹션의 목적을 설명하는 간단한 소개문을 작성하십시오. 그 다음 시연할 과정에 대한 자세한 (클릭
단계별) 지침을 작성하십시오.

• 각 섹션에 필요한 만큼 내부 링크, 외부 링크 및 스크린샷을 첨부하십시오.

• 가능하다면, 결론을 내리는 동시에 자연스럽게 다음 섹션으로 이어지는 문단으로 각 섹션을 끝내도록
합니다.

19.5.2 “직접 해보기” 섹션 추가

• 이 섹션을 시작하려면, (앞에서 설명한 대로) 의도한 난이도를 나타내는 마크업 구문을 적으십시오.

• 의도한 난이도를 나타내는 마크업 구문을 쓴 다음, 한 칸 띄고 (“직접 해보기” 를 나타내는) |TY| 라고
쓰십시오.

• 다음 줄에 빼기/대시 ( - ) 기호를 80 개 쓰십시오. 사용자의 텍스트 편집기가 기본 빼기/대시 문자를
긴 대시 또는 다른 문자로 대체하지 않는지 확인하십시오.

• 사용자가 완수하길 바라는 예제를 설명하십시오. 필요할 경우 이전 섹션, 강의, 또는 모듈을
언급하십시오.

• 텍스트만으로 이루어진 설명이 명확하지 않을 경우, 요구 사항을 명확하게 하는 스크린샷을
첨부하십시오.

대부분의경우해당섹션이할당하는과제를완수하는방법에대한답안을제공하고자할것입니다. 그러려면
답안지에 해당 항목을 추가해야 합니다.

• 먼저 답안에 대해 유일한 명칭을 결정하십시오. 이 명칭에 강의 명칭과 함께 순차적인 숫자를 붙이는
것이 이상적입니다.

• 다음과 같이 이 답안에 대한 링크를 생성하십시오.

:ref:`Check your results <answer-name>`
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• 답안지 ( answers/answers.rst ) 를 여십시오.

• 다음 라인을 작성해서 “직접 해보기” 섹션으로 연결되는 링크를 생성하십시오.
.. _answer-name:

• 필요한 경우 링크 및 이미지를 사용해서 해당 과제를 완수하는 방법에 대한 지침을 작성하십시오.

• 다시 “직접 해보기” 섹션으로 돌아가는 링크를 다음과 같이 첨부해서 답안을 완성하십시오.

:ref:`Back to text <backlink-answer-name>`

• 이 링크가 동작하게 하려면, “직접 해보기” 섹션의 제목 위에 다음 라인을 추가해야 합니다.

.. _backlink-answer-name:

지금까지 살펴본 모든 라인들의 위아래가 빈줄이어야 한다는 사실을 기억하십시오. 그렇지 않다면 문서
생성 시 오류가 발생할 수 있습니다.

19.6 결론 추가

• 강의를 끝내려면 “결론을 내리면 (in conclusion)” 을 나타내는 |IC| 구문을 작성하고, 다음 줄에
빼기/대시 ( - ) 80 개를 쓰십시오. 이 강의에서 어떤 개념을 배웠는지 설명하는 강의의 결론을
작성하십시오.

19.7 참고 문헌 섹션 추가

• 이 섹션이 꼭 필요한 것은 아닙니다.

• “참고 문헌 (further reading)” 을 나타내는 |FR| 구문을 작성하고, 다음 줄에 빼기/대시 ( - ) 80 개를
쓰십시오.

• 적합한 외부 웹사이트로 연결되는 링크를 첨부하십시오.

19.8 다음 주제 섹션 추가

• “다음 주제 (what’s next)” 를 나타내는 |WN| 구문을 작성하고, 다음 줄에 빼기/대시 ( - ) 80 개를
쓰십시오.

• 현재 강의가 어떻게 다음 강의 또는 모듈을 위해 사용자를 준비시켰는지 설명하십시오.

• 필요할 경우 이전 강의의 “다음 주제” 섹션이 새 강의를 언급하도록 변경하는 일을 잊지 마십시오.
기존 강의들 사이에 또는 기존 강의 마지막에 새 강의를 삽입하는 경우 필요한 작업입니다.

19.9 마크업 사용

이 문서의 표준을 준수하려면, 사용자의 텍스트에 표준 마크업을 추가해야 합니다.

19.9.1 새로운 개념

• 새로운 개념을 설명할 경우, 해당 개념의 명칭을 별표 ( * ) 로 둘러싸 이탤릭체로 만들어야 합니다.

This sample text shows how to introduce a *new concept*.
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19.9.2 강조

• 새로운 개념이 아닌 중요한 용어를 강조하려면, 쌍별표 ( ** ) 로 둘러싸 볼드체로 만들어야 합니다.

• 사용에 주의하십시오! 강조를 너무 많이 사용할 경우 독자에게 소리를 지르거나 잘난 체하는 것으로
보일 수 있습니다.

This sample text shows how to use **emphasis** in a sentence. Include the
punctuation mark if it is followed by a **comma,** or at the **end of the
sentence.**

19.9.3 이미지

• 이미지 추가 시 _static/강의 _ 명칭/ 폴더를 만들고 저장하십시오.

• 문서에 다음과 같이 이미지를 추가하십시오.

.. image:: /static/training_manual/lesson_name/image_file.extension
:align: center

• 이미지 마크업 위아래에 빈 줄을 삽입하는 것을 잊지 마십시오.

19.9.4 내부 링크

• 링크를 위한 앵커 (anchor) 를 생성하려면, 사용자가 링크가 가리키게 하고자 하는 곳 윗 줄에 다음과
같은 라인을 작성하십시오.

.. _link-name:

• 다음과 같은 라인을 추가해서 링크를 생성하십시오.

:ref:`Descriptive link text <link-name>`

• 이 라인 위아래에 빈 줄을 삽입하는 것을 잊지 마십시오.

19.9.5 외부 링크

• 외부 링크를 생성하려면 다음과 같이 작성하십시오.

`Descriptive link text <link-url>`_

• 이 라인 위아래에 빈 줄을 삽입하는 것을 잊지 마십시오.

19.9.6 고정폭 텍스트 사용

• 사용자가입력해야하는텍스트,경로명,테이블이나열명칭같은데이터베이스요소명등을텍스트로
작성할 때, 다음과 같이 monospaced text 로 써야 합니다.

Enter the following path in the text box: :kbd:`path/to/file`.

19.9.7 GUI 항목 라벨링

• 버튼 같은 GUI 항목을 언급하는 경우, 그 명칭을 다음과 같이 the GUI label format 으로 써야 합니다.

To access this tool, click on the :guilabel:`Tool Name` button.

• 사용자가 버튼을 클릭할 필요 없이, 도구명만을 언급할 경우에도 역시 적용됩니다.
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19.9.8 메뉴 선택

• 사용자에게 메뉴를 안내할 경우, 그 명칭을 다음과 같이 menu → selection → format 으로 써야
합니다.

To use the :guilabel:`Tool Name` tool, go to :menuselection:`Plugins -->
Tool Type --> Tool Name`.

19.9.9 주석 추가

• 텍스트 안에 강의의 흐름의 일부로 쉽게 녹아들지 못 하는 추가적인 세부 사항을 설명하는 주석이
필요할 수도 있습니다. 해당 마크업은 다음과 같습니다.

[Normal paragraph.]

.. note:: Note text.
New line within note.

New paragraph within note.

[Unindented text resumes normal paragraph.]

19.9.10 스폰서/작성자 주석 추가

스폰서를 대신해서 새 모듈, 강의 또는 섹션을 작성하는 경우, 스폰서가 선택한 간단한 스폰서의 메시지를
첨부해야 합니다. 이 메시지는 독자들에게 스폰서의 명칭을 알려야 하며, 스폰서가 후원하는 모듈, 강의
또는 섹션 제목 아래에 위치해야 합니다. 하지만, 꼭 스폰서 회사를 위한 광고일 필요는 없습니다.

스폰서를 대신하는 것이 아니라 스스로 모듈, 강의 또는 섹션을 작성하는 데 자원했다면, 작성한 모듈, 강의
또는섹션제목아래에작성자주석을삽입할수있습니다. This [module/lesson/section] contributed
by [author name]. 이라는 서식을 지켜야만 합니다. 다른 문장이나 연락처 등을 추가하지 마십시오. 그런
세부 정보는 추가한 부분 (들) 의 명칭 (들) 과 함께 서문의 “개인 공헌자 (Contributors)” 섹션에 추가될
것입니다. 내용을 업데이트하거나 수정하거나 추가하기만 했다면 편집자 목록에 이름을 추가하십시오.

19.10 감사합니다!

이프로젝트에공헌해주셔서감사합니다! 당신덕분에 QGIS의접근성을향상시키고전체 QGIS프로젝트에
가치를 더할 수 있습니다.
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CHAPTER 20

답안지

20.1 Results For 첫 레이어 추가

20.1.1 준비

도로를 심볼화하는 많은 라인들이 보여야 합니다. 이 모든 라인들은 사용자가 방금 기본 맵을 생성하기 위해
불러들인 벡터 레이어가 담고 있습니다.

돌아가기

20.2 Results For 인터페이스 개요

20.2.1 개요 (Part 1)

인터페이스 레이아웃을 보여주는 이미지를 다시 참조하고, 스크린에 나타난 요소들의 명칭과 기능을
기억하는지 확인하십시오.

돌아가기

20.2.2 개요 (Part 2)

1. Save as

2. Zoom to layer

3. Help

4. Rendering on/off

5. Measure line

돌아가기
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20.3 Results For 벡터 데이터 작업

20.3.1 Shapefile

사용자 맵에 다음 5 개 레이어가 있어야 합니다.

• places

• water

• buildings

• rivers

• roads

돌아가기

20.3.2 데이터베이스

맵에 모든 벡터 레이어를 불러와야 합니다. 아직 보기 좋지 않을 수도 있습니다. (다음 단계에서 보기 싫은
색상을 수정할 것입니다.)

돌아가기

20.4 Results For 심볼

20.4.1 색상

• 사용자가 예상한 대로 색상이 바뀌었는지 확인하십시오.

• 이 시점에서는 water 레이어만 변경해도 충분합니다. 다음 예시는 사용자가 선택한 색상에 따라 달라
보일 수도 있습니다.
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주석: 한 번에 레이어 하나만 작업하고자 하고 다른 레이어들을 신경 쓰고 싶지 않다면, 레이어 목록에
있는 레이어명 옆에 있는 체크박스를 클릭해서 레이어를 숨길 수 있습니다. 체크박스를 해제하면 레이어가
보이지 않습니다.

돌아가기

20.4.2 심볼 구조

이제 사용자 맵이 이렇게 보여야 합니다.
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초급 수준 사용자일 경우, 이 단계에서 멈춰도 됩니다.

• 앞에서 언급한 방법을 이용해서 나머지 모든 레이어들의 색상 및 스타일을 변경하십시오.

• 오브젝트의 자연스러운 색상을 이용해보십시오. 예를 들어 도로는 빨강이나 파랑이 아니라 회색이나
검정이어야 합니다.

• 또한 폴리곤에 대해 서로 다른 Fill Style 및 Border Style 설정을 마음대로 시험해보십시오.

돌아가기

20.4.3 심볼 레이어

• 사용자가원하는대로 buildings 레이어를사용자지정하십시오. 그러나맵상에서서로다른레이어를
쉽게 구별할 수 있어야 한다는 사실을 기억하십시오.

다음은 그 예시입니다.
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돌아가기

20.4.4 심볼 수준

필요한 심볼을 만들려면, 다음 2 개의 심볼 레이어가 필요합니다.

20.4. Results For 심볼 583
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아래에있는심볼레이어는넓은노란색라인입니다. 그위의심볼레이어는좀더가느다란회색라인입니다.

• 사용자의심볼레이어가앞의그림과비슷하지만원하는결과를얻지못할경우,사용자의심볼수준이
다음과 같은지 확인하십시오.
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• 이제 사용자 맵이 이렇게 보여야 합니다.
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돌아가기

20.4.5 심볼 수준

• 사용자의 심볼 수준을 다음 값으로 조정하십시오.

• 다른 결과를 얻으려면 다른 값들을 시험해보십시오.

• 다음 예제를 해보기 전에 다시 원래 맵을 여십시오.

돌아가기

20.5 Results For 속성 데이터

20.5.1 속성 데이터

라벨을 보여주는 데 NAME 필드가 가장 유용합니다. NAME 값이 모든 오브젝트에 대해 유일하며 NULL
값을 담고 있을 가능성이 거의 없기 때문입니다. 사용자 데이터가 몇 개의 NULL 값을 담고 있을 경우,
사용자의 places 대부분이 명칭을 갖추고 있으므로 걱정하지 마십시오.
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돌아가기

20.6 Results For 라벨 도구

20.6.1 사용자 지정 라벨 (Part 1)

이제 사용자 맵에 마커 포인트가 나타나고 라벨은 2.0 mm 만큼 오프셋되어 있어야 합니다. 마커와 라벨의
스타일이 맵 상에서 둘 다 명확히 보이도록 해야 합니다.

돌아가기

20.6.2 사용자 지정 라벨 (Part 2)

다음 최종 산출물을 생산하는 해법이 있습니다.
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이 결과물을 산출하려면,

• 폰트 크기를 10, Label distance 를 1,5 mm, Symbol width 및 Symbol size 를 3.0 mm 로 설정하십시오.

• 그리고 이 예시에서 다음 Wrap label on character 옵션을 사용합니다.
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• 이항목에공백을입력한다음 Apply 를클릭해서동일한효과를내십시오. 이경우, 일부지명이매우
길어 사용자가 식별하기 어려운 여러 줄로 나타날 수도 있습니다. 사용자 맵에 대해서는 이 설정이 더
적합할 수도 있습니다.

돌아가기

20.6.3 데이터 정의 설정 사용

• 편집 모드에서 FONT_SIZE 값을 마음대로 설정하십시오. 이 예시는 도시에 16, 교외에 14, 주거지에
12, 마을에 10 값을 사용하고 있습니다.

• 변경 사항을 저장하고 편집 모드를 끄도록 하십시오.

• places 레이어의 Text 서식 옵션으로 돌아가 폰트 크기 오버라이드 드롭다운 메뉴의 Attribute field 에
있는 FONT_SIZE 를 선택하십시오.
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앞에서 설정한 값을 사용할 경우, 결과물이 다음과 같아야 합니다.

돌아가기
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20.7 Results For 범주화

20.7.1 범주화 개선

• 이 강의의 첫 번째 예제에서와 동일한 방법으로 다음과 같이 경계선을 제거하십시오.

사용자의 설정이 동일하지 않을 수도 있지만, Classes = 6 그리고 Mode = Natural Breaks (Jenks) 값을
설정하면 (그리고 물론 동일한 색상을 사용하면) 맵이 다음과 같이 보일 것입니다.
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돌아가기

20.8 Results For 새 벡터 데이터셋 생성

20.8.1 디지타이징

심볼과 상관 없이, 결과물이 다음과 비슷하게 보여야 합니다.

돌아가기

20.8.2 위상 : 고리 추가 도구

정확한 모양에 상관 없이, 사용자 피처 가운데에 다음과 같이 구멍이 생겨야 합니다.
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• 다음 도구에 대한 예제를 해보기 전에 편집 내용을 되돌리십시오.

돌아가기

20.8.3 위상 : 부분 추가 도구

• 먼저 Bontebok National Part 를 선택하십시오.
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• 새 부분을 추가하십시오.

• 다음 도구에 대한 예제를 해보기 전에 편집 내용을 되돌리십시오.

돌아가기

20.8.4 피처 합치기

• Merge Selected Features 도구를 이용, 먼저 사용자가 합치고자 하는 폴리곤을 둘 다 선택하도록
하십시오.

• 사용자 속성의 소스로 OGC_FID 를 1 로 설정해서 피처를 사용하십시오. (대화 창에서 해당 항목을
클릭한 다음, Take attributes from selected feature 버튼을 클릭하십시오.)

주석:
다른 데이터셋을 사용할 경우, 사용자의원래폴리곤의 OGC_FID값이 1이아닐가능성이높습니다. 그냥

OGC_FID 항목을 갖추고 있는 피처를 선택하십시오.

주석: Merge Attributes of Selected Features 도구를 사용하면 계속 도형들을 구분할 수 있지만, 동일한
속성을 부여할 것입니다.

돌아가기

20.8.5 서식

TYPE 의 경우, 도로가 가질 수 있는 유형은 분명히 제한되어 있습니다. 이 레이어의 속성 테이블을
확인해보면, 이미 유형이 정의되어 있다는 사실을 알 수 있습니다.

• 위젯을 Value Map 으로 설정하고 Load Data from Layer 를 클릭하십시오.

• Label 드롭다운 메뉴에서 roads 를 선택하고, Value 및 Description 에 대해 모두 highway 를
선택하십시오.
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• OK 를 세 번 클릭합니다.

• 이제 편집 모드에 들어간 상태에서 도로에 대해 Identify 도구를 사용해보면, 다음과 같은 대화 창이
나타날 것입니다.

돌아가기
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20.9 Results For 벡터 분석

20.9.1 OSM 데이터에서 사용자 레이어 추출

이 예제의 목적에 걸맞는, 우리가 흥미를 가지고 있는 OSM 레이어는 multipolygons 와 lines 입니다.
multipolygons 레이어는 houses, schools 그리고 restaurants 레이어를 생산하는 데 필요한 데이터를
담고 있습니다. lines 레이어는 도로 데이터셋을 담고 있습니다.

레이어 속성에 다음 Query Builder 가 있습니다.

multipolygon 레이어에 대해 Query Builder 를 사용해서 houses, schools, restaurants 그리고
residential 레이어를 위한 다음 쿼리들을 작성하십시오.
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각각의쿼리를입력한다음 OK 를클릭하십시오. 맵이업데이트되면서사용자가선택한데이터만나타내는
것을 볼 수 있습니다. 이 시점에서 OSM 데이터셋으로부터 multipolygon 데이터를 다시 사용해야 하므로,
다음 방법들 가운데 하나를 쓸 수 있습니다.

• 필터링된 OSM 레이어의 명칭을 변경하고 osm_data.osm 으로부터 레이어를 다시 임포트하거나,

• 필터링된 레이어를 복사해서 복사본의 명칭을 변경한 다음, Query Builder 에서 쿼리를 삭제하고 새
쿼리를 작성하십시오.

주석: OSM 의 building 필드가 house 값을 담고 있기는 하지만, 사용자 지역의 - 우리 지역과 마찬가지로
- 커버리지가 완전하지 않을 수도 있습니다. 따라서 예제 지역에서 house 가 아닌 다른 값으로 정의된 모든
건물들을 제외 하는 것이 더 정확합니다. 또는 house 로 정의된 건물들과 함께 yes 처럼 의미가 명확하지
않은 값들을 모두 포함시킬 수도 있습니다.

roads 레이어를 생성하려면, OSM 의 lines 레이어에 대해 다음 쿼리를 작성하십시오.
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다음과 비슷하게 보이는 맵이 생성될 것입니다.

돌아가기
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20.9.2 고등학교로부터의 거리

• 버퍼 대화 창이 다음과 같이 보여야 합니다.

Buffer distance 는 1000 미터 (즉 1 킬로미터) 입니다.

• Segments to approximate 값을 20 으로 설정하십시오. 필수적인 사항은 아니지만, 산출물 버퍼를 더
부드럽게 보이게 하기 때문에 추천합니다. 다음 그림을,
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이 그림과 비교해 보십시오.

첫 번째 이미지는 Segments to approximate 값을 5 로 설정한 버퍼이며, 두 번째 이미지는 20 으로 설정한
버퍼입니다. 이번 예시에서는 차이점이 뚜렷하지 않지만, 값이 높을수록 버퍼의 경계가 더 매끈하다는
사실을 알 수 있습니다.

돌아가기
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20.9.3 식당으로부터의 거리

새 houses_restaurants_500m 레이어를 생성하려면, 다음 두 단계의 과정을 거쳐야 합니다.

• 먼저, 다음과 같이 식당 주위에 500 미터의 버퍼를 생성하고 레이어를 맵에 추가합니다.
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• 그 다음, 해당 버퍼 영역 내부에 있는 건물들을 선택하십시오.

• 이제 그 선택 집합을 새 houses_restaurants_500m 레이어로 저장하십시오.
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이제 사용자 맵에 도로에서 50 미터, 학교에서 1 킬로미터, 식당에서 500 미터 이내에 있는 건물들만 나타날
것입니다.
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돌아가기

20.10 Results For 레스터 분석

20.10.1 향 계산

• DEM (Terrain analysis) 대화 창을 다음과 같이 설정하십시오.
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결과 :

돌아가기

20.10.2 경사도 계산 (2 도, 5 도 미만)

• Raster calculator 대화 창을 다음과 같이 설정하십시오.
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• 5 도 미만을 계산하려면 표현식 및 파일명의 2 를 5 로 바꾸십시오.

결과 :

• 2 도 :
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• 5 도 :
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돌아가기

20.11 Results For 분석의 완성

20.11.1 래스터를 벡터화

• Layers list 에서 all_terrain 레이어를 오른쪽 클릭해서 Query Builder 를 열고, General 탭을
선택하십시오.

• 그 다음 "suitable" = 1 이라는 쿼리를 작성하십시오.

• OK 를 클릭해서 이 기준을 만족하지 못 하는 모든 폴리곤을 필터링하십시오.

원래 래스터 위에 겹쳐보면, 다음과 같이 영역들이 완전히 일치해야 합니다.

• Layers list 에서 all_terrain 레이어를오른쪽클릭한다음 Save As... 를선택하면이레이어를저장할
수 있습니다. 그 후 지침에 따라 진행하십시오.

돌아가기

20.11.2 결과 점검

Intersect 도구가 사용자의 new_solution 레이어에 있는 건물들 가운데 일부를 “잘라” 냈을지도 모릅니다.
즉 건물의 일부만 - 따라서 부지의 일부만 - 이 적합한 지역에 들어가 있다는 사실을 보여줍니다. 따라서
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당연히 데이터셋에서 이런 건물들을 제거할 수 있습니다.

돌아가기

20.11.3 분석 개선

이 시점에서, 사용자의 분석이 이렇게 보여야 합니다.

모든 방향으로 100 미터씩 이어지는 원형 영역을 떠올려보십시오.
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해당 영역의 반경이 100 미터 이상일 경우, (모든 방향으로부터) 크기를 100 미터 줄이면 다음과 같이
가운데에 영역의 일부가 남게 됩니다.

따라서, 기존 suitable_terrain 벡터 레이어에 대해 100 미터 크기의 내부 버퍼 (interior buffer) 를 실행할
수 있습니다. 이 버퍼 기능의 산출물에서, 원래 레이어로부터 남은 모든 영역이 100 미터를 넘어서는 적합한
지역이 있는 영역을 나타내게 됩니다.

시연 :

• 메뉴에서 Vector → Geoprocessing Tools → Buffer(s) 도구를 클릭해서 Buffer(s) 대화 창을
띄우십시오.

• 다음과 같이 설정하십시오.
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• suitable_terrain 레이어에 대해 분할 (segment) 값을 10 으로, 버퍼 거리를 -100 으로 설정하십시오.
(사용자 맵이 투영된 CRS 를 사용하고 있으므로 거리 단위가 자동적으로 미터가 됩니다.)

• 산출물의 경로를 exercise_data/residential_development/, 파일명을
suitable_terrain_continuous100m.shp 으로 저장하십시오.

• 필요할 경우 새 레이어를 원래 suitable_terrain 레이어 위로 옮기십시오.

결과물이 다음과 같이 보일 것입니다.
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• 이제 Select by Location 도구를 실행하십시오. (Vector → Research Tools → Select by location)

• 다음과 같이 설정하십시오.

• suitable_terrain_continuous100m.shp 가 담고 있는 피처와 교차 (intersect) 하는 new_solution 의
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피처를 선택하십시오.

결과물은 다음과 같습니다.

선택된건물들은노란색입니다. 몇몇건물들이새로운 suitable_terrain_continuous100m레이어바깥에
걸치기는하지만,원래 suitable_terrain레이어내부에들어있기때문에모든요구사항들을만족합니다.

• 이 선택 집합을 exercise_data/residential_development/ 경로의 final_answer.shp
파일명으로 저장하십시오.

돌아가기

20.12 Results For WMS

20.12.1 또다른 WMS 레이어 추가

사용자 맵이 다음처럼 보여야 합니다. (레이어 순서를 변경해야 할 수도 있습니다.)
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돌아가기

20.12.2 새 WMS 서버 추가

• 이전과 동일한 방법으로 새 서버 및 해당 서버가 호스팅하고 있는 적합한 레이어를 추가하십시오.
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• Swellendam 지역으로 줌인할 경우, 이 데이터셋의 해상도가 낮다는 사실을 알 수 있습니다.

따라서, 현재 맵에서 이 데이터를 사용하지 않는 편이 좋습니다. Blue Marble 데이터는 전 세계 또는 국가
단위 수준에 적합합니다.

돌아가기

20.12.3 WMS 서버 찾기

많은WMS서버가항상사용가능한 상태는아니라는사실을 알아차렸을지도모르겠군요. 일시적인경우도
있고, 영원히 사용할 수 없게 됐을 수도 있습니다. 이 교재를 작성하는 시점에서 작동하는 WMS 서버의
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예를 들자면, http://apps1.gdr.nrcan.gc.ca/cgi-bin/worldmin_en-ca_ows 주소의 World Mineral
Deposits WMS 가 있습니다. 사용료나 접속 제약도 없으며, 전 세계에서 사용할 수 있습니다. 따라서 요구
사항을 만족합니다. 하지만 한 예에 불과하다는 사실을 기억하십시오. 선택할 수 있는 다른 많은 WMS
서버들이 있습니다.

돌아가기

20.13 Results For 데이터베이스 개념들

20.13.1 주소 테이블 속성

우리의 이론적인 address 테이블의 경우, 다음 속성들을 저장하고자 할 수도 있습니다.

House Number
Street Name
Suburb Name
City Name
Postcode
Country

주소 오브젝트를 나타내는 테이블을 생성할 때, 이 속성들을 하나하나 나타내는 열을 생성하고 SQL 을
준수하며 가능한 경우 축약된 명칭을 부여할 것입니다.

house_number
street_name
suburb
city
postcode
country

돌아가기

20.13.2 인물 테이블 정규화

people 테이블의 큰 문제는 한 인물의 주소 전체를 담고 있는 주소 필드가 하나뿐이라는 사실입니다. 이
강의이전단계의이론적인 address테이블을생각해보면,우리는주소가서로다른여러속성으로이루어져
있다는 것을 알고 있습니다. 이 모든 속성들을 필드 하나에 저장한다면, 데이터를 업데이트하거나 쿼리하는
작업이 더욱 힘들어집니다. 따라서 주소 필드를 다양한 속성들로 나누어 다음과 같은 구조의 테이블을
생성해야 할 것입니다.

id | name | house_no | street_name | city | phone_no
--+---------------+----------+----------------+------------+-----------------
1 | Tim Sutton | 3 | Buirski Plein | Swellendam | 071 123 123
2 | Horst Duester | 4 | Avenue du Roix | Geneva | 072 121 122

주석: 다음 섹션에서, 이 예제의 데이터베이스 구조를 더욱 향상시킬 수 있는 외래 키 관계에 대해 배울
것입니다.

돌아가기

20.13.3 인물 테이블 심화 정규화

현재 people 테이블은 다음과 같이 보입니다.
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id | name | house_no | street_id | phone_no
---+--------------+----------+-----------+-------------
1 | Horst Duster | 4 | 1 | 072 121 122

street_id 열은 ‘people’ 오브젝트 및 관련 ‘street’ 오브젝트 사이의 ‘일대다’ 관계를 나타냅니다. 이때
‘street’ 오브젝트는 streets 테이블에 있습니다.

테이블을 심도 있게 정규화하는 방법 가운데 하나는 명칭 필드를 다음과 같이 first_name 과 last_name
으로 나누는 것입니다.

id | first_name | last_name | house_no | street_id | phone_no
---+------------+------------+----------+-----------+------------
1 | Horst | Duster | 4 | 1 | 072 121 122

또한 마을이나 도시 명칭 및 국가를 위한 개별 테이블을 생성하고, 이들을 ‘일대다’ 관계를 통해 people
테이블에 연결할 수도 있습니다.

id | first_name | last_name | house_no | street_id | town_id | country_id
---+------------+-----------+----------+-----------+---------+------------
1 | Horst | Duster | 4 | 1 | 2 | 1

이에 대한 ER 도표를 그린다면 다음과 같이 보일 것입니다.

돌아가기

20.13.4 인물 테이블 생성

정확한 people 테이블을 생성하기 위해 필요한 SQL 은 다음과 같습니다.

create table people (id serial not null primary key,
name varchar(50),
house_no int not null,
street_id int not null,
phone_no varchar null );

이 테이블의 스키마는 다음과 같습니다. (:kbd:‘ d people‘ 입력)
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Table "public.people"

Column | Type | Modifiers
-----------+-----------------------+-------------------------------------
id | integer | not null default

| | nextval('people_id_seq'::regclass)
name | character varying(50) |
house_no | integer | not null
street_id | integer | not null
phone_no | character varying |
Indexes:
"people_pkey" PRIMARY KEY, btree (id)

주석: 보기 쉽게 하기 위해, 일부러 외래 키 제약을 제외했습니다.

돌아가기

20.13.5 DROP 명령어

이 경우 DROP 명령어가 먹히지 않는 이유는 people 테이블이 streets 테이블에 외래 키 제약을 갖추고
있기때문입니다. 즉 streets테이블을드롭하면 (또는삭제하면) people테이블이존재하지않는 streets
데이터를 참조하게 됩니다.

주석: CASCADE 명령어를 사용하면 streets 테이블을 ‘강제로’ 삭제할 수 있지만, 동시에 people 테이블은
물론 streets 테이블과 관계가 있는 모든 테이블을 삭제하게 됩니다. 조심해서 사용하세요!

돌아가기

20.13.6 새 도로 삽입

The SQL command you should use looks like this (you can replace the street name with a name of your
choice):

insert into streets (name) values ('Low Road');

돌아가기

20.13.7 외래 키 관계를 가진 새 인물 추가

정확한 SQL 선언문은 다음과 같습니다.

insert into streets (name) values('Main Road');
insert into people (name,house_no, street_id, phone_no)
values ('Joe Smith',55,2,'072 882 33 21');

다시 (이전과 동일한 선택 선언문을 써서) streets 테이블을 보면, Main Road 항목에 대한 id 값이 2 라는
것을 알 수 있습니다.

이것이 앞에서 단순히 숫자 2 만 입력해도 됐던 이유입니다. 앞의 선언문에서 Main Road 라고 전부 풀어
쓰지 않아도, 데이터베이스가 street_id 값이 2 인 레코드들을 모두 연결할 수 있습니다.

주석: If you have already added a new street object, you might find

that the new Main Road has an ID of 3 not 2.

20.13. Results For 데이터베이스 개념들 621



QGIS Training Manual, 출시 2.2

돌아가기

20.13.8 도로명 반환

사용자가 사용해야 할 정확한 SQL 선언문은 다음과 같습니다.

select count(people.name), streets.name
from people, streets
where people.street_id=streets.id
group by streets.name;

결과 :

count | name
------+-------------

1 | Low Street
2 | High street
1 | Main Road

(3 rows)

주석: You will notice that we have prefixed field names with table names

(e.g. people.name and streets.name). This needs to be done whenever the field name is am-
biguous (i.e. not unique across all tables in the database).

돌아가기

20.14 Results For 공간 쿼리

20.14.1 공간 쿼리에 사용되는 단위들

예제쿼리가사용하는단위는도 (degree)입니다. 해당레이어가사용하는 CRS가WGS84이기때문입니다.
WGS84 는 지리 CRS 로, 지리 CRS 는 도를 단위로 사용합니다. UTM 투영체와 같은 투영 CRS 는 미터를
단위로 사용합니다.

쿼리 작성 시 레이어의 CRS 가 사용하는 단위를 알아야 한다는 사실을 기억하십시오. 그래야만 사용자가
예상하는 결과를 반환하는 쿼리를 작성할 수 있습니다.

돌아가기

20.14.2 공간 인덱스 생성

CREATE INDEX cities_geo_idx
ON cities
USING gist (the_geom);

돌아가기
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20.15 Results For 도형 구성

20.15.1 라인스트링 생성

alter table streets add column the_geom geometry;
alter table streets add constraint streets_geom_point_chk check

(st_geometrytype(the_geom) = 'ST_LineString'::text OR the_geom IS NULL);
insert into geometry_columns values ('','public','streets','the_geom',2,4326,

'LINESTRING');
create index streets_geo_idx
on streets
using gist
(the_geom);

돌아가기

20.15.2 테이블 연결

delete from people;
alter table people add column city_id int not null references cities(id);

(QGIS 에서 도시를 캡처하십시오.)

insert into people (name,house_no, street_id, phone_no, city_id, the_geom)
values ('Faulty Towers',

34,
3,
'072 812 31 28',
1,
'SRID=4326;POINT(33 33)');

insert into people (name,house_no, street_id, phone_no, city_id, the_geom)
values ('IP Knightly',

32,
1,
'071 812 31 28',
1,
'SRID=4326;POINT(32 -34)');

insert into people (name,house_no, street_id, phone_no, city_id, the_geom)
values ('Rusty Bedsprings',

39,
1,
'071 822 31 28',
1,
'SRID=4326;POINT(34 -34)');

다음 오류 메시지를 반환받을 경우,

ERROR: insert or update on table "people" violates foreign key constraint
"people_city_id_fkey"

DETAIL: Key (city_id)=(1) is not present in table "cities".

cities 테이블에 대해 폴리곤을 생성하려 하는 동안 일부를 삭제하고 다시 시작해야 한다는 의미입니다.
사용자의 cities 테이블에 있는 항목들을 확인하고 존재하는 id 를 사용하십시오.

돌아가기
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20.16 Results For 단순 피처 모델

20.16.1 테이블에 값 채우기

create table cities (id serial not null primary key,
name varchar(50),
the_geom geometry not null);

alter table cities
add constraint cities_geom_point_chk
check (st_geometrytype(the_geom) = 'ST_Polygon'::text );

돌아가기

20.16.2 ‘geometry_columns’ 테이블 채우기

insert into geometry_columns values
('','public','cities','the_geom',2,4326,'POLYGON');

돌아가기

20.16.3 도형 추가

select people.name,
streets.name as street_name,
st_astext(people.the_geom) as geometry

from streets, people
where people.street_id=streets.id;

결과 :

name | street_name | geometry
--------------+-------------+---------------
Roger Jones | High street |
Sally Norman | High street |
Jane Smith | Main Road |
Joe Bloggs | Low Street |
Fault Towers | Main Road | POINT(33 -33)

(5 rows)

제약 조건 덕분에 데이터베이스에 Null 값을 추가할 수 있다는 사실을 알 수 있습니다.

돌아가기
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색인 및 차례

• genindex

• modindex

• search
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